Jump to content
Sign in to follow this  
Valmar

A16 Valmod Pack

Recommended Posts

I have Valmod Overhaul installed. I have a lot of aspects of valmod, but i only seem to have vanilla prefabs. Aren't there supposed to be special prefabs with valmod? If so, what info can I provide to determine whther I have the full overhaul working or not? Thanks.

 

its not hard to install compopack after installed valmod it makes a world of difference in random gen, i went two steps further and added gnamod into compopack and installed it into valmod and could not be more happy with random gen now, just takes a bit of work beyond just install and go like normal valmod installs

 

EDIT~

wont steal valmar's thread on howto but if you are intrested how to get gnamod + compopack into the game i have no issue explaining in PM

 

REEdit ~ hey val any chance of sdx coming ?

Edited by SavageArsenal (see edit history)

Share this post


Link to post
Share on other sites
Hi, I've installed the overhaul pack and found some random flour but I've been running around everywhere trying to find wheat, does it grow only in certain biomes? Or can you only grow from seeds found? Apologies if this has been asked and answered I tried to search past posts but didn't see anything.

 

You just need a "seedpack" to craft 1 wheat seed. If you find more seedpacks, you can craft all other seeds in the game and in Valmod.

Share this post


Link to post
Share on other sites
hey maybe this already got answered, but is there going to be a mod pack for a16

 

I do plan on updating to work with the A16 standard whenever that time comes.

 

(I replied in this thread last week but it did not show up. I think it maybe stuck somewhere.)

 

Good mod Mr Valmar. I enjoy your work very much.

 

In my base, I have huge farm and orchard (of apple) for food production.

I harvest my apple tree with a steel axe, which turn harvestable trees into harvested trees.

Normally, a harvested tree will grow back into a harvestable tree at around 1 game day.

But if you hit the harvested tree once more without cutting it all down before it changes into a harvestable tree, the damaged harvested tree turn into a harvestable tree with 0/40 HP that cannot be broken down by fist or by axe (no apple yield too).

I have a couple of these apple trees in my orchard and that really annoys me.

I even tried to dig around and below and try to make it fall but it just float there.

 

I wonder if there is any way to get rid of these bugged tree by some XML edit.

 

On the other hand I think these bugged trees can be used as some undestructible fence for my base...

 

There may not be a way to get rid of the trees already bugged but there is a simple xml edit to fix future trees. blocks.xml find the appleTreeEmpty block and then add this to it:

<property name="MaxDamage" value="40" />

 

 

Hello Sir Valmar! I and my wife and friends (8 or 9 of us) thank you and those whom helped you with ValMod :) Excellent work and many thanks to all of 'you!' Y'all made a very good game GREAT!

 

 

"We" were wondering if it would be possible to be able to steer the minibike with the mouse instead of the keys in one of your mods? Cause it's hard enough to keep our left hands - especially my pinky finger - held down on the keyboard for long periods of time; while our mouse isn't doing anything.

 

Again - thank yall for all the hard work!

 

Greetings. Glad you and the gang enjoy the mod. Unfortunately the controls for the minibike are not something I can touch. My mod is XML-driven which is afancy way of saying its nothing but some little notepad tweaks to text. Something like minibike controls I assume is more in-depth and requires modifying the game engine. Either way, not something I can do. For whatever its worth, I hate the minibike controls too.

 

Hey there, was wondering if you could add some more bladed weapons into the game such as battle axes, katanas, or even some great swords XD I know you added a couple of new ones in your mod but they just don't feel that accurate or even as fun as something like a katana or a great sword would be >:3

 

I loved true survivals weapons but there is some bug in that game that resets my character for daring to change the game speed for night times. I just can't play like that, not even backing up my character will save it from the reset :/

 

I also loved how the retical for the crossbow stayed up even when aiming down sights in that mod. Any chance it would be coming over here too? It's soooo helping for shooting with the crossbow seeing as aiming with it normally is janky as hell

 

Do you know any mods that I could download ontop of yours that would give me that? Thanks a bunch man

 

My mod is XML-only and I do not mess with SDX modding which is what would be required to add new models to the game. Sure I could make an item that has the icon of a katana and give it the same length and good damage... but in your hand it will still look like a machete. No point to that, imo.

 

Thank you so much for the help with setting up valmod on my mac. I have been trying to do it for over 6 months now, and was beginning to give up hope!

 

I just got it 6 hours ago, and was playing 6 hours straight (to make up for lost time of course :p) the only downside is the UI bug. I really wish there was a way to fix it, or at least implement another UI over the top/instead. As it is surprisingly quite difficult with no knowledge of your stamina. Please reply with any answers, but either way I want you to know how much i appreciate your efforts.

 

To get the UI to work on MAC you need to edit the xui files. Within the files you will see comments for "Online Mac: @link" use these links instead of the texture address.

 

OR you can change the texture address of these images (where the comments are) to use / instead of \.

Wrong:

@file:Mods\SMX\Textures\Misc\valmodhat.png

Right:

@file:Mods/SMX/Textures/Misc/valmodhat.png

 

Or so I've been told anyway.

Share this post


Link to post
Share on other sites
I have Valmod Overhaul installed. I have a lot of aspects of valmod, but i only seem to have vanilla prefabs. Aren't there supposed to be special prefabs with valmod? If so, what info can I provide to determine whther I have the full overhaul working or not? Thanks.

 

To clarify for future reference Valmod does not add any prefabs or modify the rwgmixer.xml in anyway. It does have a few edited prefab xml files but these are purely to add a few unique zombie spawners to vanilla prefabs like the graveyard. Not really important in the grand scheme of things.

 

Is it possible to install just the GUI and not all the new skill points or extra stuff?

 

This was the reason I am attracted to this GUI I just don't want all the extra stuff

 

My UI is based off of Sirilions's work. You can find his original UI here: Sirillion's SMX UI Mod.

 

 

REEdit ~ hey val any chance of sdx coming ?

 

No, I have no plans on supporting SDX. Outside my league.

Share this post


Link to post
Share on other sites

@AI109

 

Had this issue too and there is an obvious way to get rid of it. Lucky my farm was on open land and took no time at all.

 

Dig under the tree in order to collapse it. Note you also need to remove any blocks around an invulnerable tree and may also need to remove a dirt block adjacent. If you built an underground farm you'd also need to remove any blocks directly below said tree and let gravity take are of the rest. This issue is indeed rare and why I antipate this by using double layer of soil in order to collapse it.

Share this post


Link to post
Share on other sites

Thanks Valmar for the answer.

I will add this to the block.xml file and try it on an apple tree far away from my base.

 

@AI109

 

Had this issue too and there is an obvious way to get rid of it. Lucky my farm was on open land and took no time at all.

 

Dig under the tree in order to collapse it. Note you also need to remove any blocks around an invulnerable tree and may also need to remove a dirt block adjacent. If you built an underground farm you'd also need to remove any blocks directly below said tree and let gravity take are of the rest. This issue is indeed rare and why I antipate this by using double layer of soil in order to collapse it.

 

I tried this on my first bugged tree. I dug around and 2 or 3 block below but it doesn't fall. I will try again and report back here.

Share this post


Link to post
Share on other sites

 

I loved true survivals weapons but there is some bug in that game that resets my character for daring to change the game speed for night times. I just can't play like that, not even backing up my character will save it from the reset :/

 

 

Just letting you know the reset issue is fixed in case you want to try TS again.

Share this post


Link to post
Share on other sites

The force is strong with this tree! Weird how something works for some people - as it helps some friends too - but not the next but thankfully Valmar has provided a little fix :)

 

You may need to recalculate physics in vain as it seems 'stuck' in place:

- Press F1 then once console menu appears type "dm" without quotations.

- Now press Esc button (menu) and to the right press "recalc stability".

- Give it a 5 - 10 seconds to finish and press Esc again to close the side panel. An OCD measure would be to exit and restart the game, my logic being that it fixes bikes when stuck in terrain or they run off.

 

If it didn't work it's an issue with the engine, occurs with hovering rocks etc during excavations. Remember to type "dm" in again to exit debug menu.

 

When I had this issue with the apple tree I recall I accidently punched it before tree was ripe and once it was ready it showed zero health and remained unpickable. Probably a superstition but I always 'pick' apples by hitting it with an axe instead of punching.

Share this post


Link to post
Share on other sites
how do i find/make assorted vegetables?

 

Scrap vegetables like Corn :)

Share this post


Link to post
Share on other sites

Hey Val. Went to drop the overhaul onto a new dedicated. Saw you updated the post for 15.2 so it should be all good to go? Are the extra files like the bag mod required now? Looks like some things have changed since I used it last. Thanks.

Share this post


Link to post
Share on other sites
Hey Val. Went to drop the overhaul onto a new dedicated. Saw you updated the post for 15.2 so it should be all good to go? Are the extra files like the bag mod required now? Looks like some things have changed since I used it last. Thanks.

 

Valmod is currently updated for the latest version, yes. No extra files are required. Infact vanilla mechanics now make the old bag mod trick redundant as zombie loot now passes down to the goreblock if you don't loot them in time.

Share this post


Link to post
Share on other sites

Valmod Expansion on Mac

 

1. locate the 7DTD.app: /Users/Username/Library/Application\ Support/Steam/steamapps/common/7\ Days\ To\ Die/7DaysToDie.app

On Mac, App's are a container, like a folder. (Backslash is for covering spaces. May on an English system the path is slightly different)

 

2. Right-Click on the 7DaysToDie.app and choose "open package" (I have the German version, so I don't know exactly how it's called)

 

3. Now you see two folders, Contents and Data. Go to Data an open it. In a second window open Valmod-Folder. Now drag all files from Valmod-Data-Config into the 7DaysToDie.app/Data/Config and overwrite. Same with Prefabs. (7DaysToDie.app/Data/Prefabs)

 

4. Now go back to: /Users/Username/Library/Application\ Support/Steam/steamapps/common/7\ Days\ To\ Die

That is the folder which the app is in. Now drag the Valmod-MOD-Folder into this folder. The MOD-Folder should be next to the .app now.

This is different to the Win-method!

5. Do the same with the Valmod-SMX-Folder

Now you should have next to the .app the MOD and SMX-Folder

At this point you will see after open the game just white fields in the UI, because the SMX-Links doesn't work so you have to edit the three files in the Data/Config/XUI folder

6. Download the attachment and drag the content of the zip into Data/Config (overwrite) [ATTACH]18374[/ATTACH]

7. Bigger Backpack Mod doesn't work. May someone find out how to get it to work on a Mac (and no, it has nothing to do with EAC...)

 

I changed all "@file..." against "@http..."-Links, so I think you need internet-connection and the site has to be online...

 

I hope it helps, it's just a trail and error-method, because I'm not a modder :)

 

 

PS: if someone will tell me how to post big pictures here and how to make spoilers I will upload screenshots

 

 

While this post for Mac was very helpful, its still not working for me. Can anyone that has made it work on mac post a screenshot or explain the file structure? The mod seems to be working, but the icons and UI textures still arent loading, depsite copying over the Mac XUI files from above. Man I want this to work sooo bad!

Share this post


Link to post
Share on other sites
Thank you so much for the help with setting up valmod on my mac. I have been trying to do it for over 6 months now, and was beginning to give up hope!

 

I just got it 6 hours ago, and was playing 6 hours straight (to make up for lost time of course :p) the only downside is the UI bug. I really wish there was a way to fix it, or at least implement another UI over the top/instead. As it is surprisingly quite difficult with no knowledge of your stamina. Please reply with any answers, but either way I want you to know how much i appreciate your efforts.

 

Yeah, I can't get the UI to work either, much like the poster above. If anyone actually has Valmod 100% working on Mac, please come back and help us out!

Share this post


Link to post
Share on other sites

Missing icons for new items, how to apply them?

 

Yeah, I can't get the UI to work either, much like the poster above. If anyone actually has Valmod 100% working on Mac, please come back and help us out!

 

So, I got everything working pretty well, the UI works completely except i have no stamina or health bar. I have noticed those were added in with the icons, but I am also not sure of where I put the icons to apply them. Currently I am playing the game with no icons for the valid exclusive items and the few vanilla ones that were changed, like the cotton and chrysanthemum. If You were able to apply the icons, which file folder to put them in and see them in-game, it would be much appreciated. Thanks

Share this post


Link to post
Share on other sites
So, I got everything working pretty well, the UI works completely except i have no stamina or health bar. I have noticed those were added in with the icons, but I am also not sure of where I put the icons to apply them. Currently I am playing the game with no icons for the valid exclusive items and the few vanilla ones that were changed, like the cotton and chrysanthemum. If You were able to apply the icons, which file folder to put them in and see them in-game, it would be much appreciated. Thanks

 

How did you change the links in the 3 UI files to work? Did you change them to the HTTP links? If so, could you attach a screenshot of an example of the text?

Share this post


Link to post
Share on other sites
How did you change the links in the 3 UI files to work? Did you change them to the HTTP links? If so, could you attach a screenshot of an example of the text?

 

The three XUI-specific files you need to worry about already have comments in them to tell you what needs to be changed and what to change it too. View the files in notepad++ so the comments stand out more in green.

 

Example of what it looks like in notepad++:

 

<texture name="Valmod" depth="0" size="53,35" texture="@file:Mods\SMX\Textures\Misc\valmodhat.png" material="Materials/Transparent Colored" pos="-160,-6" /> <!-- Online Mac: @http://i.imgur.com/41Ldkxq.png -->

 

Thus you would turn into this for MAC:

 

<texture name="Valmod" depth="0" size="53,35" texture="@http://i.imgur.com/41Ldkxq.png" material="Materials/Transparent Colored" pos="-160,-6" />

 

 

 

Alternatively you could change the \ into / for the texture addresses where commented.

 

 

MAC wrong:

 

<texture name="Valmod" depth="0" size="53,35" texture="@file:Mods\SMX\Textures\Misc\valmodhat.png" material="Materials/Transparent Colored" pos="-160,-6" />

 

MAC right:

<texture name="Valmod" depth="0" size="53,35" texture="@file:Mods/SMX/Textures/Misc/valmodhat.png" material="Materials/Transparent Colored" pos="-160,-6" />

Share this post


Link to post
Share on other sites

This work on 15.2 b8? i used it on my Multiplayer server but i have some image problems i cant see the new stuff and everywhere is a red "?".... i just use the data folder and extrakt it into my 7daystodie data folder with FileZilla

Share this post


Link to post
Share on other sites
The three XUI-specific files you need to worry about already have comments in them to tell you what needs to be changed and what to change it too. View the files in notepad++ so the comments stand out more in green.

 

Example of what it looks like in notepad++:

 

<texture name="Valmod" depth="0" size="53,35" texture="@file:Mods\SMX\Textures\Misc\valmodhat.png" material="Materials/Transparent Colored" pos="-160,-6" /> <!-- Online Mac: @http://i.imgur.com/41Ldkxq.png -->

 

Thus you would turn into this for MAC:

 

<texture name="Valmod" depth="0" size="53,35" texture="@http://i.imgur.com/41Ldkxq.png" material="Materials/Transparent Colored" pos="-160,-6" />

 

 

 

Alternatively you could change the \ into / for the texture addresses where commented.

 

 

MAC wrong:

 

<texture name="Valmod" depth="0" size="53,35" texture="@file:Mods\SMX\Textures\Misc\valmodhat.png" material="Materials/Transparent Colored" pos="-160,-6" />

 

MAC right:

<texture name="Valmod" depth="0" size="53,35" texture="@file:Mods/SMX/Textures/Misc/valmodhat.png" material="Materials/Transparent Colored" pos="-160,-6" />

 

 

The thing is, I did exactly what was shown to do to install valmod on mac, but I can't seem to figure out how to apply all of the valid item icons, as of now I am playing the game with no icons for all of the objects with valmod icons. Any idea how to fix this?

Share this post


Link to post
Share on other sites

Alpaha 16

 

Once the update releases will the current version of Valmod work with it or will we have to wait for a update to the mod. And how long before maybe we get the updated mod?

Share this post


Link to post
Share on other sites

variable amount of crops going "poof" when planted, any fix? Saw the fix gazz posted a while ago though that looks to be already implemented.

Crops1a.thumb.jpg.60f6cd272b39799a122711c1abcc3ed5.jpg

 

more than 75% went invis (as in when i go to plant a new seed it says cannot be placed there (spot that "appears" open to plant))

Edited by Syrex (see edit history)

Share this post


Link to post
Share on other sites
This work on 15.2 b8? i used it on my Multiplayer server but i have some image problems i cant see the new stuff and everywhere is a red "?".... i just use the data folder and extrakt it into my 7daystodie data folder with FileZilla

 

You need the mod installed locally, not just on the server.

 

The thing is, I did exactly what was shown to do to install valmod on mac, but I can't seem to figure out how to apply all of the valid item icons, as of now I am playing the game with no icons for all of the objects with valmod icons. Any idea how to fix this?

 

I don't know, I've never used a MAC before. I know its possible, as others have, but I don't know the process. This may help:

 

MAC INSTALL INSTRCTIONS:

https://7daystodie.com/forums/showthread.php?31730-Valmod-Pack&p=556496&viewfull=1#post556496

 

Once the update releases will the current version of Valmod work with it or will we have to wait for a update to the mod. And how long before maybe we get the updated mod?

 

It absolutely, positively will NOT work as-is with the next update. I will have to update it to make it work with the new setup. I do not know how long it might take for me to do that. It depends on how much they changed. I won't know till I have my hands on it.

 

variable amount of crops going "poof" when planted, any fix? Saw the fix gazz posted a while ago though that looks to be already implemented.

[ATTACH=CONFIG]20143[/ATTACH]

 

more than 75% went invis (as in when i go to plant a new seed it says cannot be placed there (spot that "appears" open to plant))

 

Specfically what plants are doing it? I'm not sure what the issue could be as it is not one I've experienced in my testing.

Share this post


Link to post
Share on other sites

its all plants. corn, potatoes, yellow/red flower, cotton. If you see the picture, the are 3 lines of plants (34 spaces long) that was 2 lines of corn, 1 line of potatoes and 90% went poof (weren't there, though, when i went to replant in their place I kept getting the "can't plant here" text as if they were still there).

 

Wondering if it might be the planting method. This farm is above the ground in "planters".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...