Jump to content
Sign in to follow this  
Valmar

A16 Valmod Pack

Recommended Posts

Cement is an ingredient of Concrete Mix. Not exactly sure what you're asking, can you give an example of what you're stuck on in more detail?

Share this post


Link to post
Share on other sites
Cement is an ingredient of Concrete Mix. Not exactly sure what you're asking, can you give an example of what you're stuck on in more detail?

 

Sorry if I wasn't clear:

 

I want to make concrete mix, for that I need cement, sand and stones.

For cement I need rocks.

For rocks I need cement, sand and stones (and now I'm realizing that the recipe might be the same as concrete mix(can check later)). So obviously I'm stuck in a circle where I need cement which needs rocks which needs cement...

So either I'm missing something big, or the recipe is broken, just on my side probably. If that's the case I'd appreciate if someone can give me the original recipe so I can modify it.

Share this post


Link to post
Share on other sites

Hi Val and thanks for your great work on 7dtd.. i would to ask to you if you could implement a sllep mode so we dont have to wait for minght gone and if you would to implement electricty and gas in future updates..

 

thanks for your time

Share this post


Link to post
Share on other sites

After checking recipes.xml I realized I forgot one crafting interface...The forge... Anyway that's embarassing ^^ Thanks anyway

Share this post


Link to post
Share on other sites
I dont know if anyone has experiencing this or not.

 

I am playin in Asian country, my friends are playing in the Europe.

 

We open a game, hosted by Europe, then play, it was ok, horde nights were terrible on the sync but still acceptable.

 

But for some how, up to Day 36, it suddenly not working, as the time keeps going forward and backwards with no reason, really cant figure out why, sometimes the time gap is like 2-3 hours, it seems strange, does anyone has similar situation and know how to solve it.

 

I know that horde nights are worst, but in normal days and nights, with the ping of less than 1000, this wasnt even happening before.

 

Thanks for the helping in advance.

 

Sounds like an issue with the server. Nothing I can do about that.

 

Bigger backpack mod doesn't save the last fifth inventory line and I loose all items in the line when I leave the server.

 

Ensure the server has it installed correctly and EAC turned off (if the server has EAC on then it isn't installed). You may also need to install bigger backpack mod locally. If the bigger backpack mod was added to the server after your character had already joined you may also need to die once for it to register the new larger backpack on your character.

 

Hi Val and thanks for your great work on 7dtd.. i would to ask to you if you could implement a sllep mode so we dont have to wait for minght gone and if you would to implement electricty and gas in future updates..

 

thanks for your time

 

Adding a feature like sleep is impossible to do with XML modding. Electricity and gas are also impossible to do with XML modding - though they are coming in A16 officially anyway.

 

If you want to skip ahead to nighttime you could use the console to command the game to jump to night.

 

settime night should work, if I recall correctly.

Share this post


Link to post
Share on other sites

I am having some issues running this mod. In my Windows system everything is great. On my Linux system I am having some graphical issues. Not sure if i am missing something or if the mod is not fully compatible with Linux. Not having an issue playing the game. Just graphics.

 

7d.jpg.2b8a53a443195e6a05f7fa7322bf1a95.jpg

 

 

Is there something I am missing? I have tried downloading the package. Reinstalling the mod did not seem to help either.

Share this post


Link to post
Share on other sites

I have tried to adapt the texts for the German but somehow he does not take anything from it.

 

What surprised me is the 7 should be for the German description?

Or where is my mistake in there

 

Property times 2 examples indicated

 

Localization file
classKey,items,Item Tool,,Class Key,,Klassenschlüssel,,

classMinerDesc,blocks,Block Building,,"The Miner starts off with an pickaxe and pistol. Skilled in masonry, mining tools, forge and explosives.",,"The Miner starts off with an pickaxe and pistol. Skilled in masonry, mining tools, forge and explosives.",,

Key,Source,Context,Changes,English,French,German,Klingon,Spanish

 

Can give me a help where my thinker is here XD.

 

Use Notepad++ to edit

 

thanks Fanai PS: Translate with google :chuncky:

Edited by Fanai (see edit history)

Share this post


Link to post
Share on other sites
I am having some issues running this mod. In my Windows system everything is great. On my Linux system I am having some graphical issues. Not sure if i am missing something or if the mod is not fully compatible with Linux. Not having an issue playing the game. Just graphics.

 

[ATTACH=CONFIG]19476[/ATTACH]

 

 

Is there something I am missing? I have tried downloading the package. Reinstalling the mod did not seem to help either.

 

The UI elements dont work correctly as-is on Linux and Mac systems. You'd have to open the XUi folder inside the config folder and edit the related XUi files within.

 

Example:

 

<texture name="Valmod" depth="0" size="53,35" texture="@file:Mods\SMX\Textures\Misc\valmodhat.png" material="Materials/Transparent Colored" pos="-160,-6" /> <!-- Online Mac: @http://i.imgur.com/41Ldkxq.png -->

 

Replace:

"@file:Mods\SMX\Textures\Misc\valmodhat.png"

 

Replace with:

"@http://i.imgur.com/41Ldkxq.png"

 

Another option could be to swap the \ with /

 

Mods/SMX/Textures/Misc/valmodhat.png

 

I have tried to adapt the texts for the German but somehow he does not take anything from it.

 

What surprised me is the 7 should be for the German description?

Or where is my mistake in there

 

Property times 2 examples indicated

 

Localization file
classKey,items,Item Tool,,Class Key,,Klassenschlüssel,,

classMinerDesc,blocks,Block Building,,"The Miner starts off with an pickaxe and pistol. Skilled in masonry, mining tools, forge and explosives.",,"The Miner starts off with an pickaxe and pistol. Skilled in masonry, mining tools, forge and explosives.",,

Key,Source,Context,Changes,English,French,German,Klingon,Spanish

 

Can give me a help where my thinker is here XD.

 

Use Notepad++ to edit

 

thanks Fanai PS: Translate with google :chuncky:

 

Is it on singleplayer? Just pointing out tha the localization does not push to clients, so it has to be done locally.

 

I'm not sure why it doesn't work for you. I never really tried other languages. Does the vanilla stuff translate properly?

Share this post


Link to post
Share on other sites
The UI elements dont work correctly as-is on Linux and Mac systems. You'd have to open the XUi folder inside the config folder and edit the related XUi files within.

 

Example:

 

<texture name="Valmod" depth="0" size="53,35" texture="@file:Mods\SMX\Textures\Misc\valmodhat.png" material="Materials/Transparent Colored" pos="-160,-6" /> <!-- Online Mac: @http://i.imgur.com/41Ldkxq.png -->

 

Replace:

"@file:Mods\SMX\Textures\Misc\valmodhat.png"

 

Replace with:

"@http://i.imgur.com/41Ldkxq.png"

 

Another option could be to swap the \ with /

 

Mods/SMX/Textures/Misc/valmodhat.png

 

 

Thanks Valmar, I will do some edits and see how it goes. Appreciate the mod and the help by the way ! :cheerful:

Share this post


Link to post
Share on other sites

AppleYoung misses the picture

 

I've been searching, I redownloaded both the packs to check and it looks like there's no picture (icon) for AppleYoung. I don't know, maybe I'm wrong but I haven't found one :frown-new: or is it supposed to not have an icon?

Share this post


Link to post
Share on other sites
I've been searching, I redownloaded both the packs to check and it looks like there's no picture (icon) for AppleYoung. I don't know, maybe I'm wrong but I haven't found one :frown-new: or is it supposed to not have an icon?

 

Nah, no icon. It isn't a block the player can ever get outside of the creative menu so I never bothered to give it an icon.

Share this post


Link to post
Share on other sites

Tools needed for crafting stations

 

Is there, or can someone put together a list of the various crafting stations and the tools that go in them? For example, The workbench uses handsaw, blow torch, and ? (I still haven't figured it out. lol) It would be nice to have a list of such things or a tool tip balloon that tells you the name of the tool (instead of playing, What do you see in this inkblot. hehe) but I don't know if that is possible with just XML

 

Otherwise, I'm loving the Overhaul. Great work Valmar!

You may want to look at suspicious stumps though. I've only found 1 so far but have 12 survivors combinations. Increase the spawn of suspicious stumps? Make the combinations scrapable for something useful? IDK, just sayin. :)

Share this post


Link to post
Share on other sites
Is there, or can someone put together a list of the various crafting stations and the tools that go in them? For example, The workbench uses handsaw, blow torch, and ? (I still haven't figured it out. lol) It would be nice to have a list of such things or a tool tip balloon that tells you the name of the tool (instead of playing, What do you see in this inkblot. hehe) but I don't know if that is possible with just XML

 

Otherwise, I'm loving the Overhaul. Great work Valmar!

You may want to look at suspicious stumps though. I've only found 1 so far but have 12 survivors combinations. Increase the spawn of suspicious stumps? Make the combinations scrapable for something useful? IDK, just sayin. :)

 

Unfortunately at this time the game does not like it when you make custom tooltips so I avoid doing that. However if you search through your recipes within the workstation you will see what recipe takes what tool. If you do not have the tool you need the recipe will give you a red message in the corner saying "X Required"

 

Such "Bowl of Water Required" or something along those lines.

 

Anyway, the tools for the workbench are:

Handsaw, Welding Torch, Paper Rack

 

Tool for the decor station are:

Handsaw, Welding Torch, Electrical Toolkit

 

 

 

Stumps are purely random. Sometimes you get lucky and get several. Sometimes you get none. Just have to keep an eye out.

 

Also you can actually scrap the combination to get survivor notes. Or you should be able to, anyway.

Share this post


Link to post
Share on other sites
Unfortunately at this time the game does not like it when you make custom tooltips so I avoid doing that. However if you search through your recipes within the workstation you will see what recipe takes what tool. If you do not have the tool you need the recipe will give you a red message in the corner saying "X Required"

 

Such "Bowl of Water Required" or something along those lines.

 

Anyway, the tools for the workbench are:

Handsaw, Welding Torch, Paper Rack

 

Tool for the decor station are:

Handsaw, Welding Torch, Electrical Toolkit

 

 

 

Stumps are purely random. Sometimes you get lucky and get several. Sometimes you get none. Just have to keep an eye out.

 

Also you can actually scrap the combination to get survivor notes. Or you should be able to, anyway.

 

Awesome, Never even thought about trying to scrap a combination. I tried searching thru recipes in the workstation didn't find anything though. Of course, I don't have ALL the recipes yet. :) Thanks for the info and keep up the great work.

Share this post


Link to post
Share on other sites

Crafting anything and it has 0 durability

 

I am just gonna provide a link to the reddit thread i put up for it. I did go on creative mode and replicate the issue. a stone axe came out with zero durability .

 

Share this post


Link to post
Share on other sites

Valmod Mac Textures Missing in MP

 

When I load the game in SP, everything works perfectly fine but when I connect to a MP server, the textures go missing from the hud.

 

3.thumb.jpg.48e03fccf2d11f56767831dfa0a09f18.jpg

 

Any idea whats causing this?

Share this post


Link to post
Share on other sites

Can't figure out what I did wrong

 

I've followed the directions to install everything and I only play single player when trying a new Mod for me. It seems that somewhere something went wrong and I did look for a fix before resorting to asking for help.

 

20170323110546_1.thumb.jpg.dfee7025ac4a7f08def8cd5fb2ee1f83.jpg

 

thanks for any help

 

EDIT: I'm working with Overhaul

Edited by Stillintus (see edit history)

Share this post


Link to post
Share on other sites
I am just gonna provide a link to the reddit thread i put up for it. I did go on creative mode and replicate the issue. a stone axe came out with zero durability .

 

 

Overhaul or Expansion? What version is the mod?

 

How are you replicating the bug? I maxed out my tool crafting and my stone axes still crafted fine on both overhaul and expansion.

 

 

Valmar, any info on what you're gonna do for A16?

 

Not really. I don't know what kind of opportunities A16 will actually bring. Will need to actually get my hands on it first to even know where to begin.

 

 

When I load the game in SP, everything works perfectly fine but when I connect to a MP server, the textures go missing from the hud.

 

[ATTACH=CONFIG]19607[/ATTACH]

 

Any idea whats causing this?

 

Are you playing on a Mac/Linux by chance?

 

 

I've followed the directions to install everything and I only play single player when trying a new Mod for me. It seems that somewhere something went wrong and I did look for a fix before resorting to asking for help.

 

[ATTACH=CONFIG]19609[/ATTACH]

 

thanks for any help

 

EDIT: I'm working with Overhaul

 

 

It looks like you don't have enough vram on your graphics card to support all the extra icons, if I had to guess. I've only seen this kind of issue on very low-end PCs.

Share this post


Link to post
Share on other sites

It looks like you don't have enough vram on your graphics card to support all the extra icons, if I had to guess. I've only seen this kind of issue on very low-end PCs.

 

 

The one thing I didn't figure but yes I'm unfortunately playing on a laptop that's a few years old for now. Thanks anyway.

Share this post


Link to post
Share on other sites
this may have been posted before but any idea why i cant get workbench

 

IIRC you need construction to be level 20 (check Skills for level) and you craft in your Inventory, if you have trouble finding nails hammer wooden blocks, ie houses. You could also wrench one from a Gas Station. FYI the other benches (Combine, Merchant, Quest) are crafted in the Workbench.

Share this post


Link to post
Share on other sites
this may have been posted before but any idea why i cant get workbench

 

Valmod Overhaul does not have a workbench perk, it is a free recipe. Valmod Expansion /does/, however. If you're playing on a server make sure you have the correct version installed locally - the version needs to be the same as the one used by the server. You can't criss-cross.

Share this post


Link to post
Share on other sites

Thank you for the great mod.

 

Is there a way I can modify the chance on hit of a burning club setting the enemy on fire? It seems hugely overpowered for a weapon I can get on day 1. With a 1 quality club lit at a campfire I am taking down bloated zombies with ease thanks to the burning effect, was even able to chase and 1 hit a deer leaving the rest of the damage to the burning effect. I am also taking down hordes of zombies in the day just by hitting them till they alight, then move onto the next.

 

I know I can just not use the item, but Id rather remove the temptation ;)

 

Thank you.

Share this post


Link to post
Share on other sites
Thank you for the great mod.

 

Is there a way I can modify the chance on hit of a burning club setting the enemy on fire? It seems hugely overpowered for a weapon I can get on day 1. With a 1 quality club lit at a campfire I am taking down bloated zombies with ease thanks to the burning effect, was even able to chase and 1 hit a deer leaving the rest of the damage to the burning effect. I am also taking down hordes of zombies in the day just by hitting them till they alight, then move onto the next.

 

I know I can just not use the item, but Id rather remove the temptation ;)

 

Thank you.

 

Had a quick check of items.xml (item ID to search for: 1623) and adjust Buff_chance, currently on 0.6. Change to 0.1, 0.01, or even 0 to disable, test the change for suitability to your preferences.

 

		<property name="Buff" value="burning" />
	<property name="Buff_chance" value="0.6" />

 

Items.xml file is located: \7 Days To Die\Data\Config.

 

Chance seems a little high, maybe it could be better if buffs weren't so effective until say level 20 for a particular weapon class.

 

The buff "burning" is used for other items/entities - plus your only issue is damage dealt - which is why I suggested the above option as the best option, changing the buff effect though is possible but would unbalance aspects of the game. Within buffs.xml look for ID "burning", health drops a fixed amount of "-10" and rate is normal.

 

<buff id="burning" debuffif="+water > 1" duration="15" ffcheck="true" actions="debuff(burningSmall);attach(ParticleEffects/p_onFire, @impact);damage(0,1,0,1);damage(0,3,0,0)" icon="ui_game_symbol_fire" name_key="burning" description_key="burningDesc" tooltip_key="burningTooltip" cures="canBoiledWater,bottledWater,goldenRodTea,redTea">
<modify id="1" stat="health" amount="-10" rate="1"/>
</buff>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...