Jump to content

Linux Vulkan doesn't launch

Recommended Posts

Hello! As the title says, if I choose Vulkan inside 7 days to die launcher, it fails to launch, I just get a small window of EAC, it loads, then screen flashes briefly and game closes. I am using steam game version A21.2 (b30). I am also on Ubuntu 23.10, I play on AMD RX 7600 using default Mesa 23.2.1. I also tried updating to latest Mesa git (24.0) issue persists.

Recorded a short video of the problem: 

Mono path[0] = '/mnt/1a209b4d-ac29-454d-a706-d078214a9c68/Games/steamapps/common/7 Days To Die/7DaysToDie_Data/Managed'
Mono config path = '/mnt/1a209b4d-ac29-454d-a706-d078214a9c68/Games/steamapps/common/7 Days To Die/7DaysToDie_Data/MonoBleedingEdge/etc'
Preloaded 'libEOSSDK-Linux-Shipping.so'
Preloaded 'libMagick.so'
Preloaded 'lib_burst_generated.so'
Preloaded 'libgetrss.so'
Preloaded 'libsteam_api.so'
Preloaded 'steamclient.so'
Unable to preload the following plugins:
Display 0 'PHL 243V7 24"': 1920x1080 (primary device).
Loading player data from /mnt/1a209b4d-ac29-454d-a706-d078214a9c68/Games/steamapps/common/7 Days To Die/7DaysToDie_Data/data.unity3d
Desktop is 1920 x 1080 @ 60 Hz
[Vulkan init] extensions: count=23
[Vulkan init] extensions: name=VK_KHR_device_group_creation, enabled=0
[Vulkan init] extensions: name=VK_KHR_external_fence_capabilities, enabled=0
[Vulkan init] extensions: name=VK_KHR_external_memory_capabilities, enabled=0
[Vulkan init] extensions: name=VK_KHR_external_semaphore_capabilities, enabled=0
[Vulkan init] extensions: name=VK_KHR_get_physical_device_properties2, enabled=1
[Vulkan init] extensions: name=VK_KHR_get_surface_capabilities2, enabled=0
[Vulkan init] extensions: name=VK_KHR_surface, enabled=1
[Vulkan init] extensions: name=VK_KHR_surface_protected_capabilities, enabled=0
[Vulkan init] extensions: name=VK_KHR_wayland_surface, enabled=1
[Vulkan init] extensions: name=VK_KHR_xcb_surface, enabled=0
[Vulkan init] extensions: name=VK_KHR_xlib_surface, enabled=1
[Vulkan init] extensions: name=VK_EXT_debug_report, enabled=0
[Vulkan init] extensions: name=VK_EXT_debug_utils, enabled=0
[Vulkan init] extensions: name=VK_KHR_display, enabled=1
[Vulkan init] extensions: name=VK_KHR_get_display_properties2, enabled=0
[Vulkan init] extensions: name=VK_EXT_acquire_drm_display, enabled=0
[Vulkan init] extensions: name=VK_EXT_acquire_xlib_display, enabled=0
[Vulkan init] extensions: name=VK_EXT_direct_mode_display, enabled=0
[Vulkan init] extensions: name=VK_EXT_display_surface_counter, enabled=0
[Vulkan init] extensions: name=VK_EXT_surface_maintenance1, enabled=0
[Vulkan init] extensions: name=VK_EXT_swapchain_colorspace, enabled=1
[Vulkan init] extensions: name=VK_KHR_portability_enumeration, enabled=0
[Vulkan init] extensions: name=VK_LUNARG_direct_driver_loading, enabled=0
Shutdown handler: initialize.
vkBasalt info:  config file: /home/eima/.config/vkBasalt/vkBasalt.conf
vkBasalt info:  effects = dls:smaa
vkBasalt info:  enableOnLaunch = True
vkBasalt info:  dlsSharpness = 0.6
vkBasalt info:  dlsDenoise = 0.15
[2023-11-17 22:14:00.115] [MANGOHUD] [info] [config.cpp:118] skipping config: '/mnt/1a209b4d-ac29-454d-a706-d078214a9c68/Games/steamapps/common/7 Days To Die/MangoHud.conf' [ not found ]
[2023-11-17 22:14:00.115] [MANGOHUD] [info] [config.cpp:118] skipping config: '/home/eima/.config/MangoHud/7DaysToDie.x86_64.conf' [ not found ]
[2023-11-17 22:14:00.115] [MANGOHUD] [info] [config.cpp:123] parsing config: '/home/eima/.config/MangoHud/MangoHud.conf'
Caught fatal signal - signo:11 code:2 errno:0 addr:0x7f7551c5cbd0
Obtained 4 stack frames.
#0  0x007f762a042910 in __sigaction
#1  0x007f7551c5cbd0 in std::__cxx11::basic_stringstream<wchar_t, std::char_traits<wchar_t>, std::allocator<wchar_t> >::str() const &
#2  0x007f75500be55a in (Unknown)
#3  0x007f762c54af50 in (Unknown)


Link to comment
Share on other sites

12 hours ago, Jugginator said:

Vulkan support isn't all there yet, it's still highly unstable. Does GLcore work?

Oh yes GLcore works but it has issues, colors seem washed out, some textures flickering(which makes me quite dizzy), I used to play Alpha 20 on Vulkan smoothly and really loved the experience, colors were more vivid, fps higher in intensive areas, kinda got used to the experience! I was aware that Vulkan support wasn't fully implemented but I haven't encountered any issues over 100+ hours on Alpha 20. That's why I was wondering if there was something I can do to make it run?

A lot has changed since I played Alpha 20. Like new Ubuntu release, I also migrated from older AMD card to latest line they released. I tested Alpha 21.2 on secondary laptop which has windows 11 and Vulkan runs there too, it's just that the hardware is not up to par.

Edited by Strengthinside (see edit history)
Link to comment
Share on other sites

* My 21.2(b30) runs perfectly on vulkan. With a 6700 amd card. I use latest Ubuntu LTS. I could check out 23.10 as well on a laptop if necessary.


* Here in the forum some people report their game crashing with EAC **on Windows** with the newests versions


This does suggest a different culprit, doesn't it?


@Strengthinside   : Have you tested without EAC?


@Jugginator : Can't be that unstable. Since A16 or A17 I have been continually playing with vulkan except for a few months in A17 I think and a few weeks in A21.0. Though I had to disable Reflections or something similar for the earlier alphas.


Edited by meganoth (see edit history)
Link to comment
Share on other sites

Ah yeah it's definitely weird as different machines/cards have different results, and depends on how chaotic Linux updates/packages decide to be now a days it seems. Works fine for some not for others, sometimes it works for a month then it doesn't.


My secondary rig had that with Linux. Vulkan didn't like my rx580, and after giving up I ran it just fine with the ryzen apu. I reinstalled the OS and suddenly the apu crashed on vulkan and the 580 ran it fine. 580 is dead now though so no more science for it heh. But I'll take a look into it, there are some Linux power users that may have advice including Meganoth. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...