Jump to content

Why is my vehicle floating in-game and throwing tons of errors?

Recommended Posts

Hey there fellow survivors!

Today, I was working on my mod for 7 Days To Die Alpha 21, and I hit a snag. When I tried making my own vehicle, I got everything set up and ready to go. It properly renders in game, it has it's own item, and everything seems fine. That is until I actually spawn it in. The second I do, I get spammed by it saying:


NullReferenceException: Object reference not set to an instance of an object
  at EntityVehicle.CheckForOutOfWorld () [0x00171] in <d7dcfa4979674f179c13273f8b30b551>:0
  at EntityVehicle.PhysicsFixedUpdate () [0x0032a] in <d7dcfa4979674f179c13273f8b30b551>:0
  at EntityVehicle.FixedUpdate () [0x00000] in <d7dcfa4979674f179c13273f8b30b551>:0 

I can only assume that something may be wrong with the physics, or somehow the vehicle is not working properly. So, if anyone knows how to fix this, please help me. I've been stuck on this for weeks now. Nothing I've done has fixed it so far.

Link to comment
Share on other sites

Can be several things, such as a typo in your hierarchy in Unity or something else. A pic of the fully expanded hierarchy in Unity would help, as well as your xml from items, entityclasses, and vehicles.xml.


Also, if you use Discord, you can join Gup's server to get help. Makes sorting these kinds of issues easier. You can find it here:


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...