Jump to content

Overhaul mod not working properly and I'm getting repeated Null errors.


Arez

Recommended Posts

I'm using the Romero Mod. 

 

The Blood Moon is supposed to be disabled but on the 7th day it happened (I'm on day 9 now). It has a lockable inventory slot option but it keeps resetting every time I relaunch the game. Traders are supposed to be accessible at all times, but pressing E on them after 21:50 hours does nothing. I can go into their compounds, I just can't interact with them until 6:05am. The suspense music when fighting zombies randomly cuts in and out. I get repeated Null errors while in the Wasteland. And when exiting to menu, I get an endless string of console errors. 

 

I've checked around and I haven't seen anyone report issues like this with this mod, so I'm fearing that my game is corrupted in some way. I played a little on one of my vanilla saves and it was seemingly ok.

 

Here's the log for when I last played on the Romero Mod. I had to split it up into two links.

https://pastebin.com/embed_js/mKSUzqdu

https://pastebin.com/embed_js/nX9tQfcL

 

Any help would be greatly appreciated. 

Link to comment
Share on other sites

Yeah. I can point to an issue though, had a few moments and took at look at the log. 

 

ArgumentException: Type cannot be null.
at (wrapper managed-to-native) UnityEngine.GameObject.GetComponent(UnityEngine.GameObject,System.Type)
at EModelBase.createAvatarController (EntityClass _ec) [0x000e0] in <d7dcfa4979674f179c13273f8b30b551>:0
at (wrapper dynamic-method) EModelBase.DMD<EModelBase::Init>(EModelBase,World,Entity)
at Entity.InitEModel () [0x00061] in <d7dcfa4979674f179c13273f8b30b551>:0
at Entity.Init (System.Int32 _entityClass) [0x0000d] in <d7dcfa4979674f179c13273f8b30b551>:0
at EntityAlive.Init (System.Int32 _entityClass) [0x00000] in <d7dcfa4979674f179c13273f8b30b551>:0
at EntityEnemy.Init (System.Int32 _entityClass) [0x00000] in <d7dcfa4979674f179c13273f8b30b551>:0
at EntityZombieCop.Init (System.Int32 _entityClass) [0x00000] in <d7dcfa4979674f179c13273f8b30b551>:0
at EntityFactory.CreateEntity (EntityCreationData _ecd) [0x004c2] in <d7dcfa4979674f179c13273f8b30b551>:0
at EntityFactory.CreateEntity (System.Int32 _et, System.Int32 _id, ItemValue _itemValue, System.Int32 _count, UnityEngine.Vector3 _transformPos, UnityEngine.Vector3 _transformRot, System.Single _lifetime, System.Int32 _playerId, System.String _skinName, System.Int32 _spawnById, System.String _spawnByName) [0x0001b] in <d7dcfa4979674f179c13273f8b30b551>:0
at EntityFactory.CreateEntity (System.Int32 _et, System.Int32 _id, UnityEngine.Vector3 _transformPos, UnityEngine.Vector3 _rotation) [0x0000c] in <d7dcfa4979674f179c13273f8b30b551>:0
at EntityFactory.CreateEntity (System.Int32 _et, UnityEngine.Vector3 _transformPos) [0x00014] in <d7dcfa4979674f179c13273f8b30b551>:0
at SpawnManagerBiomes.SpawnUpdate (System.String _spawnerName, System.Boolean _isSpawnEnemy, ChunkAreaBiomeSpawnData _chunkBiomeSpawnData) [0x0043f] in <d7dcfa4979674f179c13273f8b30b551>:0
at (wrapper dynamic-method) SpawnManagerBiomes.DMD<SpawnManagerBiomes::Update>(SpawnManagerBiomes,string,bool,object)
at World.OnUpdateTick (System.Single _partialTicks, System.ArraySegment`1[T] _activeChunks) [0x001e6] in <d7dcfa4979674f179c13273f8b30b551>:0
at GameManager.UpdateTick () [0x00073] in <d7dcfa4979674f179c13273f8b30b551>:0
at GameManager.gmUpdate () [0x00331] in <d7dcfa4979674f179c13273f8b30b551>:0
at GameManager.Update () [0x00000] in <d7dcfa4979674f179c13273f8b30b551>:0

 

This is complaining about some value being null when it tried to create a zombie cop, in layman's terms. Not sure which mod does what, but I see a bloodmoon speed one. If you set a value that's outside the valid range, you'll get errors like that. You said you removed bloodmoons, maybe some mod referenced it or something. So, that's a general area to look for.

Edited by Jugginator (see edit history)
Link to comment
Share on other sites

If the error was being caused by the zombie cop (I can't access the log links while at work), you might have an older version of the mod.  This was an issue that cropped up, but Khaine fixed it and it seems to have gone away if you have the latest mod file.

Link to comment
Share on other sites

8 hours ago, Jugginator said:

Yeah. I can point to an issue though, had a few moments and took at look at the log. 

 

This is complaining about some value being null when it tried to create a zombie cop, in layman's terms. Not sure which mod does what, but I see see a bloodmoon speed one. If you set a value that's outside the valid range, you'll get errors like that. You said you removed bloodmoons, maybe some mod referenced it or something. So, that's a general area to look for.

Thank you for taking the time to look at this.

 

There's a folder called "Force Bloodmoon and Zombie Move Speed" that's part of the mod pack and the description in the xml says "Sets bloodmoons to off and zombies to always walk for Romero Mod". This is supposed to automatically turn off Blood Moons. I checked the settings and Blood Moons were not set to Disabled but the Blood Moon day count was set to 0. After the Blood Moon happened I manually set it to Disabled. I haven't reached day 14 yet.

 

As for the cop, I believe the mod is supposed to disable cop spit.

 

8 hours ago, BFT2020 said:

If the error was being caused by the zombie cop (I can't access the log links while at work), you might have an older version of the mod.  This was an issue that cropped up, but Khaine fixed it and it seems to have gone away if you have the latest mod file.

I downloaded the A21 version that's in his opening Mod post here on the forum. I'll go through the post again. Maybe he posted the fix later on in the thread. 

 

EDIT: I just went through the thread and someone else posted the same exact issues as I'm having (null and music issues). 

Khaine said he couldn't reproduce the cop null and that was his last post on the subject. 

Edited by Arez (see edit history)
Link to comment
Share on other sites

Someone posted in the mod thread that they removed something relating to the cop and it stopped it from happening. I'm gonna look into that later. 

 

I got a question though. I started playing at the beginning of A21. I have two game saves from before (b16) that I still play. Is there any possibility that could be causing these issues, especially seeing that the mod creator said he couldn't reproduce them? Could keeping those old A21 saves be causing conflicts?  

Link to comment
Share on other sites

17 hours ago, Arez said:

Someone posted in the mod thread that they removed something relating to the cop and it stopped it from happening. I'm gonna look into that later. 

 

I got a question though. I started playing at the beginning of A21. I have two game saves from before (b16) that I still play. Is there any possibility that could be causing these issues, especially seeing that the mod creator said he couldn't reproduce them? Could keeping those old A21 saves be causing conflicts?  

 

Well it's definitely something in the mod causing it. And generally no, that wouldn't cause an issue. The only issue it may cause is a warning popup after game game save list populates, but even if so it won't affect other saves.

Link to comment
Share on other sites

On 10/18/2023 at 12:11 AM, Arez said:

Khaine said he couldn't reproduce the cop null and that was his last post on the subject. 

 

I was going to download the mod last night and see if I can reproduce the issue but didn't have time (my boys got new Ipads so of course, they wanted them to be setup).  I will try to do it tonight.  If I don't have any issues with it, I will provide details on how I got it setup.  If I do have issues, I will provide you a workaround for now.

Link to comment
Share on other sites

44 minutes ago, BFT2020 said:

If I do have issues, I will provide you a workaround for now.

Thank you! 

This has got to be the most helpful community and dev company I've ever engaged with. People like you and @Jugginator are awesome. 

Link to comment
Share on other sites

13 minutes ago, Arez said:

Thank you! 

This has got to be the most helpful community and dev company I've ever engaged with. People like you and @Jugginator are awesome. 

 

Aww thanks! Yeah, this community is amazing, been an honor to be involved in it for like the past 5/6 years now lol, the people here are great.

Link to comment
Share on other sites

On 10/19/2023 at 2:42 PM, BFT2020 said:

 

I was going to download the mod last night and see if I can reproduce the issue but didn't have time (my boys got new Ipads so of course, they wanted them to be setup).  I will try to do it tonight.  If I don't have any issues with it, I will provide details on how I got it setup.  If I do have issues, I will provide you a workaround for now.

 

Hi Khaine we're having the same issue, just as another data point! When zombies spawn (wandering hordes or sleeper volume) I get null reference popups. We weren't having them in the early game so it makes sense if it's the cop.

 

We're also having about 50% of the ferals are clearly jogging and not walking, even though I've also manually set everything to walk in the settings.

Link to comment
Share on other sites

On 10/19/2023 at 3:40 PM, Arez said:

Thank you! 

This has got to be the most helpful community and dev company I've ever engaged with. People like you and @Jugginator are awesome. 

 

Try this, this seemed to fix the issue with the cop spawning and generating null errors.  Replace the existing file in the 0-RomeroModCore folder

 

https://github.com/BFT2020/RomeroModChange.git

 

Let me know if that works

6 hours ago, Feycat said:

 

Hi Khaine we're having the same issue, just as another data point! When zombies spawn (wandering hordes or sleeper volume) I get null reference popups. We weren't having them in the early game so it makes sense if it's the cop.

 

We're also having about 50% of the ferals are clearly jogging and not walking, even though I've also manually set everything to walk in the settings.

 

FYI, I am not Khaine  LOL

Link to comment
Share on other sites

18 hours ago, Feycat said:

We're also having about 50% of the ferals are clearly jogging and not walking, even though I've also manually set everything to walk in the settings.

 

I forgot to mention, it seemed to fix the issue with them running.  At least, when I spawned in both the feral cop and radiated cop, neither of them sprinted at me after I engaged them.

 

Damage reduction if not hit in the head seemed to work fine also.

 

Let me know if you see any issues,  I also spawn in the radiated vulture to make sure no issues and didn't see any.  At least with the limited time I was checking out the changes.

Link to comment
Share on other sites

17 hours ago, BFT2020 said:

Try this, this seemed to fix the issue with the cop spawning and generating null errors.  Replace the existing file in the 0-RomeroModCore folder

Not only did you check out the issue but you created an edited file that fixes it. That's incredible. 

 

I'm gonna check this out later and report back. 

Link to comment
Share on other sites

Can´t really help here, but as a general advice, if you have problems with an overhaul mod, join their discord. Most of them do have one and they usually have channels for troubleshooting.

 

Ofc you also get help here most of the time, but asking in the discord can lead to help directly from the mod author and(or the the team that works on it.

Link to comment
Share on other sites

On 10/22/2023 at 6:30 PM, BFT2020 said:

Try this, this seemed to fix the issue with the cop spawning and generating null errors.  Replace the existing file in the 0-RomeroModCore folder

Thanks for the fix! It worked! No more null errors. The music still cuts in and out and the horde night still happens, even with the removal modlet and manually having it set to disabled and 0 days. I'm actually not mad at it because the zombies don't run. It's a lot of fun actually, so I'm pretty happy with the way everything's running now.

5 hours ago, pApA^LeGBa said:

Can´t really help here, but as a general advice, if you have problems with an overhaul mod, join their discord.

I did. I posted a message a week ago and there were no replies. 

Link to comment
Share on other sites

It really is. Oh and I didn't stop playing though.  I got 5 different A21 saves going and one A16 save (though I'm probably gonna avoid that one until I can get around it resetting my keybinds). 🙂

Link to comment
Share on other sites

16 minutes ago, Arez said:

though I'm probably gonna avoid that one until I can get around it resetting my keybinds. 

 

Ah, yeah those settings changed format so would need to be wiped. You can actually export the registry for the game and put it on your desktop, then you can rename it like "A21settings", then delete the registry, run your  A16 copy, repeat the export process, and then you've got 2 configs ready to go. Just double click them before launching and it'll put all the info in there. I got like 20 of them in a folder lol

Link to comment
Share on other sites

3 hours ago, Jugginator said:

You can actually export the registry for the game and put it on your desktop

Really?! I'm pretty clueless when it comes to something like that, so forgive me for asking, but can you explain how to do that?

A21 is such a massive improvement, but A16 is a vibe.  

Link to comment
Share on other sites

45 minutes ago, Arez said:

Really?! I'm pretty clueless when it comes to something like that, so forgive me for asking, but can you explain how to do that?

A21 is such a massive improvement, but A16 is a vibe.  

I hear you, going back in time is fun for a bit.

 

Yeah it's a quick process. If you open regedit (you can also use the game launcher to open game settings) it's here: Computer\HKEY_CURRENT_USER\Software\The Fun Pimps\7 Days To Die

 

From here, look at the left, you'll see 7 Days to Die under The Fun Pimps:

image.thumb.png.857a1b2b647414b82670b427be82b858.png

 

Right-click that folder, click Export, put it wherever/give it a name. then you can just run it like a program and it'll replace the current reg set with that one. Just make sure you only hit either the fun pimps or 7 days to die folders.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...