Jump to content

Stuck at game loading screen


Recommended Posts

Game Version: (A21.1 & 2)

OS/Version: Windows

CPU Model: Intel(R) Core(TM) i7-10700KF CPU @ 3.80GHz   3.79 GHz

System Memory: 32 GB

GPU Model and VRAM: nVidia GTX 3080

Screen Resolution: 2560x1440 120hz and 160hz

Video Settings: high/ultra

Game mode: SP


Did you wipe old saves? yes


Did you start a new game? Yes


Did you validate your files? Yes


Are you using any mods? No


EAC on or off? tried Both


Status: NEW


Bug Description:


Detailed steps to reproduce the bug:

1) Open Steam, Go to Library, click Play

2) Tried with and with out EAC



Actual result: Gets to main load screen and freezes. does nothing for 30+ minutes


Expected result: the game to load in a few seconds as it had always had done

Link to Pastebin Output Log:


Ive tried everything, uninstalling, verifying, loading with and without eac just gets stuck at loading splash screen. comes up with loading particles and blocks then nothing. Im running in Administrator Mode also. drivers are up to date (version 537.42)

TRying to delete this post but actually it may me of use to others. I found some redundent mod files in the  mod folder that i was unaware of, deleted those and game loads fine

Link to comment
Share on other sites

On 9/29/2023 at 7:56 PM, MrB said:

TRying to delete this post but actually it may me of use to others.


tried to reinstallec ANTICHEAT?

its in the 7days directory EasyAntiCheat ..first click uninstalleac.bat > restart pc, then click installeac.bat

tried newest grafix driver ?


when uninsztalled havce u deleted all old files from the game in USER/APPDATA/ / / 7days ? (u must make files visible, then the directory appdata appears)


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...