Jump to content

Server timeouts on connection attempt

Recommended Posts

Summary: Server timeouts when connecting to dedicated server (server disconnected you, network timeout)


Game Version: A20.7 (b1)

Platform: PC

OS/Version: Windows 

CPU Model: Intel N100 3.4GHz

System Memory:16 GB

Game mode: Client on dedi, NAV)


Did you wipe old saves? Yes

Did you start a new game? Yes

Did you validate your files? Yes

Are you using any mods? No

EAC on or off? Off



Bug Description:   I have set up a dedicated server, first with a world I made in coop through steam with a friend then from scratch to test the issues encountered from the first attempt (same thing happened with blank/new state). I used steamcmd and now the server just through steam itself ran on the batch file, both same issues. I have correctly forwarded all required ports and tested them to make sure they are also open (firewall settings are all set and have tested with both DMZ on and off, again same results). The only way I can connect on my local network is if I disable LiteNetLib as a protocol in the server config however, my friends still cant connect. I have tried each setting for the network protocols too btw, disabling LiteNetLib was the only one that worked but only for my side and not friends on different networks. The server does show up on the server list too, same results trying that or through ip connection, and yep also using correct ip for it, all same msg of the network timeout unless the setting above is set.

The following are the logs of when I couldn't connect and the one where I could with the protocol changed.  Forgot to mention the server is run on a different pc I use specifically for servers not the one I'm playing on. Also second logs where its working are from when I tried with the world I had made with my friend since I was getting the same results no matter what. I do also have the logs of where its ran on the fresh save if that's needed but figured this would do as its the same end result on both.








Edited by GibsonAxe (see edit history)
Link to comment
Share on other sites

It started working, left only steamworks disabled so my other friends could try and they got in, tried myself once I got home and didn't get timed out anymore. Not sure what was going on but glad its working now.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...