Jump to content

Compo-Pack for Random Gen


Magoli

Recommended Posts

Me and 7 friends on a hosted dedicated box we're using were averaging 89-140fps everywhere. After adding this pack, we literally get 1-5 fps around any of the prefabs from the pack, especially the Space Needle.

 

It probably doesn't help that the people who made these got REALLY light happy. In an older version of this pack and the game, we went around a city destroying literally every single electric light we could, and it solved our frame rate issue.

 

That space needle by itself had 6 light bulbs in a row right next to each other at the base, and 20+ lights up the staircase and at the top area. I wouldn't mind a version of the pack without any lights, however, it seems more severe now than it was before, as destroying lights in this version is hardly fixing the frame issue.

 

I have been screaming this for months now the LIGHTS GOT TO GO! In the space needle alone there are over 40 of them and after destroying every single one we had better performance.

 

In my opinion there should be NO light. The game is dark for a reason. I bet Magoli if you removed somehow all of these stick lights and ceiling lights there would be a huge increase in performance.

Link to comment
Share on other sites

I find it odd that I have very little frame drop in the big cities except when there was an issue with which lights to use in prefabs. Think at one point it was lit1 and lit0 and once of them caused issues or something. But this was back in A10 or A11 or so. Mag can verify which it was I don't remember right off.

 

However in A14 I get decent framerates in the city except when there are certain POI's. The space needle causes me zero slow down when I'm playing and it causes very little for anyone on my server so I can't say it's the space needle or the lights for that matter. I do see some odd flickering of lights at times, but when they do I don't lose FPS at all.

 

I am willing to bet it is most likely a buggy POI or a few buggy POIs. I have found a few now including one I made. The one I made has some pipes facing the wrong direction and they occasionally flicker. I will take some screens of it later along with a few other issues I see.

 

Maybe it is something Mag can fix easily or something we can help fix. Either way take note of your frame rates when they drops real low turn different directions and see if you can pinpoint a certain POI causing the issue.

Link to comment
Share on other sites

I'm with JaxTeller718 on this. The lights are the biggest fps killer, though I've noticed that it's more often candles and torches than the regular ceiling lights. Performance gets a lot better after I pull down all the flickering light sources. For that matter, the burning lands are also lag-intensive, likely due to the random flaming bits scattered about.

 

I'm considering going through all the custom prefabs and pulling all the candles and torches to see if it helps. I'm not quite annoyed enough to do that yet, though. ;)

Link to comment
Share on other sites

It's been proven that a lot of lights do cause some FPS drop, but for me they have never caused me to drop to 3fps and when I ran into a lone POI that slowed my FPS down in the open I tend to lean more towards that as I haven't had many fps drops with the CompoPack before until A14 and the lit1 issue I mentioned above.

Link to comment
Share on other sites

Lit2 is what a12 used. Lit1 and lit0 caused major issues. Mag's i am certain replaced all these.

 

My issues with fps dont happen until zs spawn in city. To test turn zs off and traverse the city in a test game.

 

Another fps drop for me is collapsing blocks this freeses the game fps something chronic.

 

Turn ssao off in options and some of the high use options you really dont need also helps.

Link to comment
Share on other sites

My entirely anecdotal evidence leads me to believe that the lights (and/or glass?) can cause some issues. I've noticed my performance dips if my seed happens to spawn something like two Skyscraper prefabs in close proximity. The Skyscraper has over 300 lights (though the majority of them are switched off) and over 4200 glass blocks.

 

In a past Alpha I did what others suggested and replace all the lights with air blocks and noticed an improvement, but things could have changed since that Alpha release. An easy enough test would be to make a hub spawn nothing but Skyscrapers and check the results with the lights set to Lit1/Lit2/Off or removed entirely. Or with the glass in place or swapped out for another block. The ultimate test would be a new prefab with a core of nothing but lights, surrounded by all glass. My computer would either implode or prove that lights/glass don't really matter.

Link to comment
Share on other sites

My entirely anecdotal evidence leads me to believe that the lights (and/or glass?) can cause some issues. I've noticed my performance dips if my seed happens to spawn something like two Skyscraper prefabs in close proximity. The Skyscraper has over 300 lights (though the majority of them are switched off) and over 4200 glass blocks.

 

In a past Alpha I did what others suggested and replace all the lights with air blocks and noticed an improvement, but things could have changed since that Alpha release. An easy enough test would be to make a hub spawn nothing but Skyscrapers and check the results with the lights set to Lit1/Lit2/Off or removed entirely. Or with the glass in place or swapped out for another block. The ultimate test would be a new prefab with a core of nothing but lights, surrounded by all glass. My computer would either implode or prove that lights/glass don't really matter.

 

The glass fps issue is when the shower glass block is used. The businessglass block is fine. Mega city has a sky scraper series in it which adds 21 different sky scrapers. And so far when zs are turned off and no building is collapsing. Fps is ok and doesnt freeze. As soon as i turn zs on bam fps drops to 3 or less and freezes. Or cause a prefab has used terrain filler it starts collapsing bam fps drops and game freezes. Nothing to do with lights or blocks imo

Link to comment
Share on other sites

But ofc it be good to finally rule them out so everyone agrees to. But really i think only tfp can improve fps on the game. Go into navesgane and place 20 skyscraperd or 29 high light placed prefabs and see if the fps tunders. As it simply could be the rwg. But i am more in the side of mags here to with the fact that the issues lay with tfp and only allowing enough space for the handful of prefabs they have in game.

 

And not thinking oh wait there might be a guy named mags who will ride into town on a 3 legged horse making a awesome prefab pack :-)

Link to comment
Share on other sites

Or cause a prefab has used terrain filler it starts collapsing bam fps drops and game freezes.

 

I truly believe that some people have issues with terrain filler, but I have never had an instance of the terrain filler not spawning in and resulting in a collapse. One time I thought I finally had it, but it turned out to be the custom city blocks at a low elevation causing the issue.

Link to comment
Share on other sites

I truly believe that some people have issues with terrain filler, but I have never had an instance of the terrain filler not spawning in and resulting in a collapse. One time I thought I finally had it, but it turned out to be the custom city blocks at a low elevation causing the issue.

 

Terrain filler spawns in as air if placed under a prefab. If it placed outside of prefab border its fine and spawns as spose to. But when the terrain filler is under a prefab spawns air and down comes prefab cradle and all :-D.

 

Most have been fixed/corrected tho so there shouldnt be any old ones still with terrain filler under prefabs lol. But its getting the info to new prefabbers is the key. I think i might collaborate with the great prefabbist in this community and write a how to prefab. And have all the knowledge gained from everyone in one place. And when the game is updated and either new errors come or new work arounds come the thread can be updated to assist new prefabbers.

 

What blocks to use little of like glassshower. Maybe even fewer lights not have none but dont over crowd it. Etc etc etc. Will do this next week.

Link to comment
Share on other sites

I think I found the issue for me it is just one POI that I noticed so far that is causing issues. I found it on a group of 3 buildings and when I looked at it I dropped from 60fps to 3fps when it was not on my screen it went back to 60fps.

 

The POI name is xcostum_Haulier_lg(by_Limodor)a12_v1

 

 

Yeah, that one is bad for me as well. My framerate tanks whenever that POI is in the direction I'm facing. Doesn't matter if it's behind something, either; if it occurs within my sight range, down goes the frame rate. :/

Link to comment
Share on other sites

I think I found the issue for me it is just one POI that I noticed so far that is causing issues. I found it on a group of 3 buildings and when I looked at it I dropped from 60fps to 3fps when it was not on my screen it went back to 60fps.

 

The POI name is xcostum_Haulier_lg(by_Limodor)a12_v1

 

Now there may be others but this is definitely one that is causing me issues.

 

Screen shot of it.

 

If anyone else can verify this one causes fps drops for you too please let me know.

 

This I can confirm as one of the troublesome ones. Can or has anyone looked to see if this one has entities built in (zombies) I am wanting to prove or debunk my theory that it is the built in entities.

Link to comment
Share on other sites

I have to get to bed so I can't test it any further tonight, but this is what I did so far:

 

This is all in RWG

 

Step 1: Disabled zombies spawns.

Results weren't that great, bouncing around from 100+ to 8 fps depending on location in the city.

 

Step 2: Changed all light blocks to air.

Results weren't that great, still bouncing around from 100+ to 8 fps depending on location in the city.

 

Step 3: Changed all glass blocks to wood frames.

Saw a quantum leap in performance.

 

I'll check again to make sure I didn't completely overlook something. If you have the time try this out yourself, it seems to me that something has drastically changed in regard to the glass blocks. The most noticeable change I had was while looking up at the xcostum_TV_Tower_Restaurant prefab as all of its glass blocks are concentrated in one spot.

 

Maybe this is completely hardware dependent and others won't have the same results, but unless it was a complete fluke it definitely helped me. I'll test more later.

Link to comment
Share on other sites

I have to get to bed so I can't test it any further tonight, but this is what I did so far:

 

This is all in RWG

 

Step 1: Disabled zombies spawns.

Results weren't that great, bouncing around from 100+ to 8 fps depending on location in the city.

 

Step 2: Changed all light blocks to air.

Results weren't that great, still bouncing around from 100+ to 8 fps depending on location in the city.

 

Step 3: Changed all glass blocks to wood frames.

Saw a quantum leap in performance.

 

I'll check again to make sure I didn't completely overlook something. If you have the time try this out yourself, it seems to me that something has drastically changed in regard to the glass blocks. The most noticeable change I had was while looking up at the xcostum_TV_Tower_Restaurant prefab as all of its glass blocks are concentrated in one spot.

 

Maybe this is completely hardware dependent and others won't have the same results, but unless it was a complete fluke it definitely helped me. I'll test more later.

 

Thank you curmudgeon please pm me so I can send you TS info and get you invited to the CoGamers Discord so I can help you test this further.

Link to comment
Share on other sites

This I can confirm as one of the troublesome ones. Can or has anyone looked to see if this one has entities built in (zombies) I am wanting to prove or debunk my theory that it is the built in entities.

 

I found the issue with this prefab and several others its the windows. If you look real close at them there are some little dots in the windows where glass should be. I have not tried to open the POI to edit it, but I do see something that isnt right. When I removed these my FPS jumped back up.

 

While the scyscraper did reduce my fps some it was very minor. Maybe a 10fps drop from 65 to 50-55. WIth these POI's with the odd glass I drop to maybe 3 fps. When removed it was back to 55-60.

Link to comment
Share on other sites

It looks like the block is glassCTRsheet in the editor, but I'll confirm this.

 

Looks like The Sect Followers of M has the same issue along with a few others. It looks like the Space Needle has it also. The skyscraper that I can tell doesn't use glassCTRsheet thus why I never lose much FPS with it.

 

xcostum_TheSect_Followers-of-M(by_magoli)a12_v1.jpg.cd703128df2fabcc64226b4f22607b68.jpg

Link to comment
Share on other sites

I found the issue with this prefab and several others its the windows. If you look real close at them there are some little dots in the windows where glass should be. I have not tried to open the POI to edit it, but I do see something that isnt right. When I removed these my FPS jumped back up.

 

While the scyscraper did reduce my fps some it was very minor. Maybe a 10fps drop from 65 to 50-55. WIth these POI's with the odd glass I drop to maybe 3 fps. When removed it was back to 55-60.

 

th single pane glass or the square block glass (Shower glass)

Link to comment
Share on other sites

We uploaded Mags Pack to our test server yesterday, and while we was testing something completely different we stated a massive FPS drop when turning to a single prefab in the wilderness. It was TheSect_Followers-of-M. We teleported to the city, and there we had the same issue with the same prefab...FPS dropped down to 3. The second prefab that dropped our FPS down to 3-5 was the Haulier_lg(by_Limodor).

 

We commented both prefabs out in the mixer and found another prefab that massively dropped our FPS, the Windowfactory(by_magoli). There was also a prefab with gas pumps that dropped our FPS, but we stopped testing due to the late time. Will continue testing later today.

Link to comment
Share on other sites

th single pane glass or the square block glass (Shower glass)

 

Is it possible to replace those glass with something similar, but less straining, in the XML files ?

 

I believe there was a similar patch months ago for some "glass-type" too

Link to comment
Share on other sites

Is it possible to replace those glass with something similar, but less straining, in the XML files ?

 

I believe there was a similar patch months ago for some "glass-type" too

 

Yes using hals editor you can replace all. But i warn you to remove all vanilla tts and xmls first.

 

Or just copy game prefab folder then remove prefabs inside of game folder (not the copied one) then grab the co 18 again and paste into it so as the editor reads only cp prefabs

Link to comment
Share on other sites

Confirmed. Glassctrsheet in all prefabs i replaced with businessglassblock and wallah fps a steady 20. Except had a collapsing building which froze computer

 

Yep, it is this block. When placed out of the creative menu, it has no real texture, it looks like 4 small transparent pieces of broken glass in the center, and it has no hitbox either.

Link to comment
Share on other sites

  • Roland locked this topic

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...