Jump to content

Compo-Pack for Random Gen


Recommended Posts

Know which prefab the piece of is in my crosshairs?

 

The rubble is a large bornes and nobles which collapsed upon game start. It seems it somehow occupied the same space as another prefab and all you see is a side piece with a railing

 

which%20prefab.png

 

 

 

Vote h0tr0d 2016 -- railing against authority

 

 

its "xcostum_collapsed_bldg_01(by_BuLLeTZ)"

it is a pre-collapsed rubble-building.

 

I saw that and somehow loved it :) !!!

So i included it into the CP (since CP10) !!!

I let it appear in wastycities and wastytowns(if u r lucky !!!)

 

So - No bug this time !!! This is supposed to be so !!!

 

 

Mag

Link to post
Share on other sites
its "xcostum_collapsed_bldg_01(by_BuLLeTZ)"

it is a pre-collapsed rubble-building.

 

I saw that and somehow loved it :) !!!

So i included it into the CP (since CP10) !!!

I let it appear in wastycities and wastytowns(if u r lucky !!!)

 

So - No bug this time !!! This is supposed to be so !!!

 

 

Mag

 

The structure looks precisely like the Bornes and Nobles store collapsed, very odd.

 

I measured it and spawned one in behind me, the light post there, the sign is on the left, red cabinets in back.

 

I'll spawn in the one you said to see, thanks!

 

 

 

Vote h0tr0d 2016 -- odd man out

Link to post
Share on other sites

Since 13.6 I get nearly empty town grids like in the image below.

The central city spawns normal with custom prefabs, but in every other biome every grid which is not a city hub looks like this for any seed.

 

Is this normal in 13.6 RWG or have I somehow destroyed my rwgmixer (I use that of 13.5).

 

2015-12-28_00001.thumb.jpg.15c4ec8fee86f8f9f67301522b8c2638.jpg

2015-12-28_00002.thumb.jpg.f3fa73647c3f723e11dfbbe4738f91cd.jpg

Edited by BFC_OGDA (see edit history)
Link to post
Share on other sites
I personally don't play this version 13.6 anymore - It really makes no fun these days !!!!

 

from a chat 10mins ago:

 

"Pure Vanilla-maps ??? - No thank you - too boring !!!!"

"Why u dont play ur own pack ?"

"It makes me disappointed to see that its potential is not supported by the game. Just about to 40% - I could scream and cry !!! This was not I voted for !!!"

 

"things have to change to good first !!!"

"what things ?"

"read my OP !"

 

 

^^and iam serious about that !!!

(the point below zero has reached IMO)

(I not try to say the devs what they have to do !!! They got their strict plan they follow !!! This is absolutly natural and OK !!!)

(more and more i believe the world how I(we) want it to be - is not the world the devs like it to be !!!)

 

 

perhaps i gather all my questions and post them in a open thread - directly asking to the devs !!!

Or I gather them - write them down - burn the paper and eat the ashes !!!

I dont know yet!

 

 

Mag

 

Please, communicate to the DEVS this problems, so they can take a look!

Link to post
Share on other sites

This mod is AMAZING! Thank you SO MUCH for making it super easy to install and use!

I don't think I had a problem with this mod at all with 13.6 unless im not looking at the right spot.

 

So far, most prefab are fun to defend and explore and modify! Thanks again MAG!

Link to post
Share on other sites

Awesome POI pack, sucks about the changes in 13 screwing things up.

 

I made a SP world to test seeds and had a huge wasteland biome (with no real end in sight), so I rerolled with a different seed, and had a huge snow biome.

 

Dug into the rwgmizer.xml (the one with Compopack_13) and saw this for the biome_spawn_rules

 

 

<biome_spawn_rules>
	<biome_spawn_rule name="burnt_forest"/>
	<biome_spawn_rule name="pine_forest"/>
	<biome_spawn_rule name="desert"/>
	<biome_spawn_rule name="wasteland" />
	<biome_spawn_rule name="forest"/>
	<biome_spawn_rule name="plains"/>

	<!--
	<biome_spawn_rule name="snow"/>
	<biome_spawn_rule name="wasteland" />
	<biome_spawn_rule name="wasteland_hub"/>
	<biome_spawn_rule name="radiated"/>
	<biome_spawn_rule name="water"/>-->
</biome_spawn_rules>

 

Shouldn't those have elevation_range values?

Link to post
Share on other sites
No, when you check the vanilla rwg mixer, you will see, elevation values has been removed there too. The RWG is now triggered different.

 

I'm not liking how it's triggered. There isn't any dithering/blending between biomes anymore, and they look to be very large and random.

Link to post
Share on other sites

i got an issue.

I run two Mods. yours first then i run Rongos Complete Mod. ( updated for A-13 ) the problem is i have gotten the prefab building mod to work once. For some reason it causes my game to hang at the entry screen right before it says click to play. then you start playing.

 

It only seams to happen when i use the Prefab Mod. I can hear the birds tweeting but the entry screen refuses to change over to press key to enter part. even though i am actually on my server, the game knows i am in game, ( i use CBSM Server Manager and it shows me as being in game ) but that entry screen refuses to go away. so i never actually get to play the game on my server.

 

Im really not sure whats causing the issue. maybe you can help?

game runs fine with out the prefab mod though.

Link to post
Share on other sites
i got an issue.

I run two Mods. yours first then i run Rongos Complete Mod. ( updated for A-13 ) the problem is i have gotten the prefab building mod to work once. For some reason it causes my game to hang at the entry screen right before it says click to play. then you start playing.

 

It only seams to happen when i use the Prefab Mod. I can hear the birds tweeting but the entry screen refuses to change over to press key to enter part. even though i am actually on my server, the game knows i am in game, ( i use CBSM Server Manager and it shows me as being in game ) but that entry screen refuses to go away. so i never actually get to play the game on my server.

 

Im really not sure whats causing the issue. maybe you can help?

game runs fine with out the prefab mod though.

 

You should post the game LOGS to see the problem

Link to post
Share on other sites
i got an issue.

I run two Mods. yours first then i run Rongos Complete Mod. ( updated for A-13 ) the problem is i have gotten the prefab building mod to work once. For some reason it causes my game to hang at the entry screen right before it says click to play. then you start playing.

 

It only seams to happen when i use the Prefab Mod. I can hear the birds tweeting but the entry screen refuses to change over to press key to enter part. even though i am actually on my server, the game knows i am in game, ( i use CBSM Server Manager and it shows me as being in game ) but that entry screen refuses to go away. so i never actually get to play the game on my server.

 

Im really not sure whats causing the issue. maybe you can help?

game runs fine with out the prefab mod though.

 

Please go to common/7daystodie/7daystodie_data and upload here your output.log and we can have a look

Link to post
Share on other sites
Since 13.6 I get nearly empty town grids like in the image below.

The central city spawns normal with custom prefabs, but in every other biome every grid which is not a city hub looks like this for any seed.

 

Is this normal in 13.6 RWG or have I somehow destroyed my rwgmixer (I use that of 13.5).

 

[ATTACH=CONFIG]12639[/ATTACH]

[ATTACH=CONFIG]12640[/ATTACH]

 

Sorry for reposting, but can anyone confirm if this normal behaviour for 13.6 or if this might be a corrupt installation (running a dedicated server)?

Link to post
Share on other sites
Sorry for reposting, but can anyone confirm if this normal behaviour for 13.6 or if this might be a corrupt installation (running a dedicated server)?

 

I have not had this issue with 13.6, with or without the compopack. Running Linux dedicated server.

 

With the compopack, I've had to edit rwgmixer.xml a little. For example, I changed the prob for the custom hubs in the vanilla ruleset to 0.01. I realize that people are saying prob isn't what we think it is, but simple fact is: I see none of those custom hubs unless I change this from 0 to at least 0.01. Even if they're spawning in the wrong places, I'd rather see them then not at all.

 

I also lowered probability for pools, asylums and zoos. I end up with them all over the place, disproportionate to other buildings.

 

I think I might have increased the size for townSmall and townLarge also. I like lots of buildings.

 

Other then that, I usually see a good mixture of cities, towns, wilderness POIs with the pack. Everything's fine with the vanilla files. Sometimes buildings spawn wrong (broken or whatnot), but that doesn't bug me personally.

Link to post
Share on other sites
Sorry for reposting, but can anyone confirm if this normal behaviour for 13.6 or if this might be a corrupt installation (running a dedicated server)?

 

We have the same kind of town cities too: lots of empty spaces all around

Link to post
Share on other sites

UPDATE-TIME !!! :)

 

 

COMPOPACK 14 (for alpha13.6) IS OUT NOW !!!

 

 

I have rolled up the complete Spawning-Sitiuation - to adjust the world to the given handycaps (A13.6)

It looks pretty well now again and its also pretty playable and exciting.

But what iam saying? - Check it out Yourselfes !!!

 

to get it go to the OpeningPost

 

 

 

detailed changes:

 

COMMON CHANGES:

 

- changed misrotations on tubehalfmetal1-blocks in "xcostum_Car_Dealership_old(by_P1ut0nium)a13_v1"

- added wasteland to all necessary prefab.xml's

- checked the prefab's xml's - and tweaked them a bit (and removed unneeded lines)

 

 

- RWGMIXER-CHANGES:

 

+ changed: cell_size="1600" cell_offset="0.6" generation_distance="12000"

+ removed towntype: townLarge from map

+ removed all rurals from map

+ removed AsiaHub from map

+ removed LimodurHospitalHub from map

+ removed nationalparkHub from map

+ removed TWD_PrisonHub from map

+ removed SS_StadiumHub from map

+ removed IndustrialHub from map

+ tweaked the balance of all the remaining town- and city- types

+ reduced and tweaked the wilderness-Spawning (now its a way better prefab-mix !!! And wilderness-POI's are more rare !!!)

- added a few new screenshots

 

 

2015-dec-29

Magoli

Link to post
Share on other sites

Hi All! Having lots of fun with this combo pack. I was wondering if anyone new how to make a giant city with this? My idea for a MP game is a Giant City (representing Raccoon City from Resident Evil) no loot respawns and highest zed count possible. I am trying to make something around 1000x1000 block city so the idea is escape to safety, and you can only last in one area for so long. Thanks in advance.

Link to post
Share on other sites
Hi All! Having lots of fun with this combo pack. I was wondering if anyone new how to make a giant city with this? My idea for a MP game is a Giant City (representing Raccoon City from Resident Evil) no loot respawns and highest zed count possible. I am trying to make something around 1000x1000 block city so the idea is escape to safety, and you can only last in one area for so long. Thanks in advance.

 

OR... A world that only generates the central hub city forever all directions.

Link to post
Share on other sites
Why did you remove so many hubs? I found the asia town it looks pretty cool to me. Or the other ones? I still have not found TWD prison yet in any version as well, really wanted to see that one.

 

The hubs with multiple prefabs r screwup to much.

We work on that. The hubs with rotated prefabs didnt wanna show in the right direction.

I havent figured out yet how to handle the rotations.

The new coordsystem in hubs is strange enough to work with.

 

And i really guess that the mainpoint for prefabs in hubs will change another time soon.

 

When Stalli and Laz have repaired their creations, I will ofc add them back to pack.

 

Back Pack

Mack

LoL

Link to post
Share on other sites
Well, that's it for me then. I never found this in previous versions. Maybe I'll try again if it ever gets put back in.

 

I know laz man is redoing twd prison so it shouldn't be to long for that 1. The ss stadium may take a bit got to get in touch with stompynz and work on it.

Link to post
Share on other sites
  • Roland locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...