Jump to content

Compo-Pack for Random Gen


Recommended Posts

As this will be the 'last' version I release of them, you are more than welcome to include them if you want at this stage mag. I still think they largely come down to a matter of taste for the person interested. Even if they remain a 'stand-alone' add-on to the compo pack they are simple enough to add manually if desired.

 

either way, the new versions should be done some point this weekend

Link to post
Share on other sites

there already was a pack for NAVA (https://7daystodie.com/forums/showthread.php?30553-The-Navezhattan-Project)

 

but Urziel havent been around since months.

 

 

The NAVA-pack was very cool too. It was based on my RWG-COMPOPACK-prefabs.

 

IMO it should still work with the COMPOPACK12 content - when the new names are edited in the prefabs.xml !!!

 

 

Hm - perhaps I give it a glimpse

 

 

 

Mag

Link to post
Share on other sites
Hey Magoli,

 

I'm not sure if this is your stuff, a bug with the game, or a prefab having static spawns of old zombies. But.....I was fighting the silver surfer zombies in Laz Manz Prison today .

[ATTACH=CONFIG]12118[/ATTACH][ATTACH=CONFIG]12119[/ATTACH]

 

Your pack is working well though. And it's awesome as always, just wanted to let you know .

 

Bahahaha lol Zombie world is in deep trouble now lol. But why did you kill the silver surfer lol he would a been the second choice to chuck norris lol :-D in Zombie fighting

Link to post
Share on other sites
Hey Magoli,

 

I'm not sure if this is your stuff, a bug with the game, or a prefab having static spawns of old zombies. But.....I was fighting the silver surfer zombies in Laz Manz Prison today .

[ATTACH=CONFIG]12118[/ATTACH][ATTACH=CONFIG]12119[/ATTACH]

 

Your pack is working well though. And it's awesome as always, just wanted to let you know .

 

very much LOL !!!

 

how u could kill the silversurfer - and where is his board now - lol

 

very very cool and funny screenshot - it has something to do with a wrong zed-texture.

Or have u installed a unknown Terminater T1000-MOD ??? :)

 

 

I believe I know what it is:

 

There is a static entity-zombietyp choosen in the prefabs tts-file. He has choosen much static-zeds inside i saw ;)

The problem: This choosen one doesnt excist anymore in A13. Better said: the texture for the zed is missing in A13 !!

 

If my guess is right -then its in fact the COMPO-PACK's fault.

I already told Hal about that "old"-"new" ZOMBIE-PROBLEM with the prefabs own static Zombies - that may cause some kind of Issue.

And now its fact !!!

 

 

We (Hal and I) are on that !!!

When the editor is updated - then we will c - what is the best solution for fixing this Issue.

(lol - on the other hand: looks really spacy - like made from Pacco :)

 

 

good night - good fight

Mag

Link to post
Share on other sites
very much LOL !!!

 

how u could kill the silversurfer - and where is his board now - lol

 

very very cool and funny screenshot - it has something to do with a wrong zed-texture.

Or have u installed a unknown Terminater T1000-MOD ??? :)

 

 

I believe I know what it is:

 

There is a static entity-zombietyp choosen in the prefabs tts-file. He has choosen much static-zeds inside i saw ;)

The problem: This choosen one doesnt excist anymore in A13. Better said: the texture for the zed is missing in A13 !!

 

If my guess is right -then its in fact the COMPO-PACK's fault.

I already told Hal about that "old"-"new" ZOMBIE-PROBLEM with the prefabs own static Zombies - that may cause some kind of Issue.

And now its fact !!!

 

 

We (Hal and I) are on that !!!

When the editor is updated - then we will c - what is the best solution for fixing this Issue.

(lol - on the other hand: looks really spacy - like made from Pacco :)

 

 

good night - good fight

Mag

 

Yeah its the original classic zombie from

the game.. The bald guy in the green shirt

only he is missing a texture.. Speaking of

old / original zombies..

 

Do you think there is a chance that after

ALPHA 13 is out for a bit longer you could

make a mod that adds in the old zombies

as well as keeps the new ones?

Link to post
Share on other sites
I have a gentleman-agreement with Slaan for that:

 

The sewer & subway isn't part of the COMPOPACK !!!!

 

It is - and stays and extension to the pack !!!

 

But Slaan and me are working together to keep up the Sewers-pack compatible to the COMPOPACK !!!

 

I dont know the state of it right now- and if its already ready to use !!!!

(I believe Slaan said its working yesterday in chat !?!)

 

Mag

 

Please disregard my question. Slaan's sewer & subway prefabs were left over from an A12.5 installation that I failed to remove completely from my computer when I upgraded 7D2D to A13.2.

Link to post
Share on other sites

Regarding changes in update 13.3: (as far as I can see)

 

- rwgmixer.xml is a new version

- army_camp_01_burnt / grass / snow changed into army_camp_01 / 02 / 03 (6 files total, old ones are deleted)

 

I want to use my Savegame from 13.2. So I wonder if I should go back to A13.2 or replace the rwgmixer und use the 13.2 Prefab folder.

 

Edit: Just saw that there is no option in the Betas tab for going back to any 13.x version.

Edited by Apocalypticus (see edit history)
Link to post
Share on other sites

wow - didnt noticed that 13.3 is out

 

Iam at work right now !!!!

 

@SylenThunder: thx for the pic. But this is OK. 1 just took the 2nd bed 1 block aside. To be more natural. Just a little thingy.

 

@vaustein: OK :)

 

@The Last Survivor: I cant do that - I havent the knowledge to do this. But there are other guys here who could do that

 

@ScubaSteve3465: Thx - yes pls make screenshots of the misrotations - then I will fix them !!!

 

 

Mag

Link to post
Share on other sites

Hey guys

 

like u allready know: Alpha 13.3 is out !!!

 

The update has installed a new rwgmixer !!!

 

This means u guys have to exchange the COMPOPACK's rwgmixer.xml again with new installed one.

In the prefabs-folder we dont have to do anything.

The 3 new/changed prefabs are in fact just has renamed.

But since last COPMPOPACK i have seperated the pack from the Vanilla prefabs !!!

So changes in Vanilla-Prefabs dont have a impact to the COMPOPACK :)

 

 

COMPOPACK 12 is still combatible to Alpha 13 , 13.1 , 13.2 , and 13.3 !!!

 

And u can also use the savegames from Alpha 13.2 , 13.1 and 13.0

in Alpha 13.3 (said ba the FunPimp)

 

 

Thank you Apocalypticus for the infos on that. So i could do a controlled check for that very quickly.

 

 

btw:

beds (and all other blocks) are IMO only bugged when they clipped into walls or surfaces - or fly in midair.

No matter how it looks(for now). Aslong no other block is confused by another one, its OK for me at this point right now.

Its like in a real apocalypse - there would be also some furnitures not placed on their given places anymore.

Don't u think so too guys ???

 

 

Mag

Edited by Magoli (see edit history)
Link to post
Share on other sites

Hey Mag, been using your pack since A12 and love it, but with A13 now I am noticing that the towns are super spread out, almost none on my server and the little we do find are towns that are empty. Maybe 4-10 houses and about 15-30 empty lots.

 

Even the hub city is a bit lame IMO.

 

I can post screenshots if you'd like. Just making you aware and or trying to find out if this may not be an issue with your pack.

Link to post
Share on other sites
Hey Magoli,

 

I'm not sure if this is your stuff, a bug with the game, or a prefab having static spawns of old zombies. But.....I was fighting the silver surfer zombies in Laz Manz Prison today .

[ATTACH=CONFIG]12118[/ATTACH][ATTACH=CONFIG]12119[/ATTACH]

 

Your pack is working well though. And it's awesome as always, just wanted to let you know .

 

Lol.....you found the secret mob i inserted. Jking...

 

As a side note, egad that fencing is super old looking. Once the a13 editor and converter is out i will be releasing a new version of the prison (new fencing). I will need to redo all of the pipe blocks and add in the new blocks as well (power console, dumpster, etc.)

Link to post
Share on other sites

Also, on a side note: I have noticed lots more issues with the random gen.

 

Desert is the only place towns are found really.

 

Every single city is a destroyed city with few prefabs

 

as mentioned above every single town is a large yet empty town

 

 

Starting to make the game not fun and hard to survive as the towns are few and far between and when found, nothing worth while is in it.

Link to post
Share on other sites
Hey Mag, been using your pack since A12 and love it, but with A13 now I am noticing that the towns are super spread out, almost none on my server and the little we do find are towns that are empty. Maybe 4-10 houses and about 15-30 empty lots.

 

Even the hub city is a bit lame IMO.

 

I can post screenshots if you'd like. Just making you aware and or trying to find out if this may not be an issue with your pack.

 

 

the Issue with the lame towns is known (see the OP). The amount is OK IMO - but the filling is very bad.

But hadnt time to test if its the pack or the game.

I have a few guesses what it could be. But first i need the new editor-version working.

 

The hub-city (middle-city) can be 3 city-types: Common,Wasty and Coronadocity.

Coronado is always 2by2(=16 prefbas) Cityblocks. Wastycities are about 3by4 Cityblocks(=48 prefabs).

And the Commoncity can have a max-size 5by6 Cityblocks(=120 prefabs).

Try another seed. Sometimes the map and streets are really wierd.

 

 

Iam on that town-Issue. I wanna have nice and well filled towns again too !!!

 

 

@ScubaSteve3465:

 

It truly can be - that i have missed some beds. Pls post the pics - then they will be fixed.

 

Overall:

I have to go throw each prefab - let it spawn - check everything !!!

But wanna do the big overhaul when all the rotation-bugs are finally gone.

I hoped for that in A13 - but nope !!!

 

Mag

Link to post
Share on other sites

Try another seed. Sometimes the map and streets are really wierd.

 

2015-12-17_00002.thumb.jpg.ce9fa7ffbd80d6adab3854ce0a7b0bce.jpg

 

 

These are a selection of pics of the wastland hub from maybe 15 seeds so far, each one very similar. Trying to get the 8x8 cityblock size city back i had in 12.5 and get nothing but this.

 

<hub_rule name="bigCity">  <!-- EDIT-->
		<hub_type value="city"/>
		<width value="824, 824" />
		<height value="824, 824" />
		<path_material value="asphalt" /> 
		<path_radius value="7" />
		<prefab_rule name="bigCityPrefabs" prob="1"/>
	</hub_rule>

 

I've rolled cities all the way up to 1648,1648 and its always the same. After this happened 3-4 times with the modified compo pack mixer I burned that and started a fresh vanilla one with just the wasteland hub cell and the above code as its hub rule and getting the same problem.

 

2015-12-17_00001.thumb.jpg.0cbe4bedc99dbf67517c730b0303475e.jpg

 

this one is over a massive area, map is fully zoomed out...

2015-12-17_00006.thumb.jpg.ecda8d3e5679215093002550b5abbe28.jpg

2015-12-17_00005.thumb.jpg.1a2644a43b6260313631c656569316e2.jpg

Link to post
Share on other sites

Magoli, it's not just your pack man. In vanilla there's empty cities lots everywhere, the cities seem to spawn correctly (albeit alot less of them), but they are not filled out at all. Your pack seems to help a little, but there are still huge areas empty in cities. but again it's like that in vanilla, so i would bet it's a RGW thing that has to be ironed out by TFP. Just my .02

Link to post
Share on other sites
Magoli, it's not just your pack man. In vanilla there's empty cities lots everywhere, the cities seem to spawn correctly (albeit alot less of them), but they are not filled out at all. Your pack seems to help a little, but there are still huge areas empty in cities. but again it's like that in vanilla, so i would bet it's a RGW thing that has to be ironed out by TFP. Just my .02

 

Yeah Kinyajuu addressed it in the hub_layout thread.

 

I asked him about that issue here and he replied the next post here.

 

I believe it's on his radar.

 

 

 

Vote h0tr0d 2016 -- the grid...

Link to post
Share on other sites
  • Roland locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...