Jump to content
Magoli

Compo-Pack for Random Gen

Recommended Posts

Known issue... Huge/big prefab smoke all ram... You can't deal with... Best thing to do is to remove oversized prefabs from the pack... Or rent a dedi with over 32Go Ram in it...

 

:eagerness:

 

I'm sure the number of people playing on the server have something to do with it. I run a small server with rarely more than 4-5 online at the same time and while we get some slowdowns at time, never enough to be unplayable.

 

Of course maybe that's why they charge more for larger servers. More people requires more ram. I'm sure my $12 a month for a 10 person server has less ram allocated vs a 50 person server.

Share this post


Link to post
Share on other sites

Can confirm the FPS issue is present in some prefabs, hospital is one of them.

 

There are also still some very broken prefabs causing the world to stop loading. I'm not sure if Magoli has isolated any further causes for these errors.

Share this post


Link to post
Share on other sites
Can confirm the FPS issue is present in some prefabs, hospital is one of them.

 

There are also still some very broken prefabs causing the world to stop loading. I'm not sure if Magoli has isolated any further causes for these errors.

 

Hospital will be out - in the next release. Till then pls remove its entry from the prefabs.xml manually !!!

 

Can u name the broken prefabs or send me a screenshot of them. This would make the Issue-search much easier.

We need to identify it !!!

 

Is that prob with broken prefabs only in MP or in a local game too ???

 

And what means broken ??? - Collapsed?? Misroratated?? a big one again??? PLS gimme a little bit more details.

 

I couldn't find any Issuues in a localgame. In Biomes with much grass,trees my fps goes down to 40. Everywhere Else: 60fps - no matter if iam in town or in desert.

The prefabs dont causes any differences to the fps-rate - when i walk in a town/City !!!

And i can't join my own rent server - because of technical problems of them !!! (gotta quit that host !!!)

 

Mag out

Share this post


Link to post
Share on other sites

Hi Mag,

 

Just wanted to say thanks for the good work on this so far, I installed it over the weekend after checking in here (page 3-4 I believe) and it is like a completely new game to me, it's brilliant. Looking forward to future releases of this and hopefully the devs sort out some of the back end issues which are limiting/hampering your efforts i.e. block rotation.

 

Keep up the good work! :congratulatory:

Share this post


Link to post
Share on other sites
Hospital will be out - in the next release. Till then pls remove its entry from the prefabs.xml manually !!!

 

Can u name the broken prefabs or send me a screenshot of them. This would make the Issue-search much easier.

We need to identify it !!!

 

Is that prob with broken prefabs only in MP or in a local game too ???

 

And what means broken ??? - Collapsed?? Misroratated?? a big one again??? PLS gimme a little bit more details.

 

I couldn't find any Issuues in a localgame. In Biomes with much grass,trees my fps goes down to 40. Everywhere Else: 60fps - no matter if iam in town or in desert.

The prefabs dont causes any differences to the fps-rate - when i walk in a town/City !!!

And i can't join my own rent server - because of technical problems of them !!! (gotta quit that host !!!)

 

Mag out

 

I've asked my players on US and AU servers to start collecting screenshots of all broken buildings, whether it be FPS, problems with blocks, etc.

 

Two reported so far are Banks and Hospitals.

 

I will provide you with a full server free, in US or Australia, whichever is better for you, to use for testing as long as you like. You can drop that host.

Share this post


Link to post
Share on other sites
I've asked my players on US and AU servers to start collecting screenshots of all broken buildings, whether it be FPS, problems with blocks, etc.

 

Two reported so far are Banks and Hospitals.

 

I will provide you with a full server free, in US or Australia, whichever is better for you, to use for testing as long as you like. You can drop that host.

 

That sounds fantastic

thx ahead

Lets talk about that later - iam at work now :(

 

Yes - the Bank looks displaced in the wilderness - no matter if error or not !!! Bank will be out too for wilderness-spawning !!!

(also all Malls, Supermarkets, Prefabs with driveways in it - perhaps even the Prisons :Cry::Cry::Cry: )

 

I wanted a cool big Pool of prefabs for a nice mix -

 

But function comes over estetic !!!

 

Weekend i will release a testversion with no big wilderness-spawners !!!

 

Mag out

Share this post


Link to post
Share on other sites
That sounds fantastic

thx ahead

Lets talk about that later - iam at work now :(

 

Yes - the Bank looks displaced in the wilderness - no matter if error or not !!! Bank will be out too for wilderness-spawning !!!

(also all Malls, Supermarkets, Prefabs with driveways in it - perhaps even the Prisons :Cry::Cry::Cry: )

 

I wanted a cool big Pool of prefabs for a nice mix -

 

But function comes over estetic !!!

 

Weekend i will release a testversion with no big wilderness-spawners !!!

 

Mag out

 

No problem, contact me on steam when you want to chat.

 

What I am seeing on two servers is that even though wilderness POIs are more interesting, the towns are becoming very bland. With very few of the stores spawning and mostly just green houses and red brick 2 story commercial buildings.

 

On top of this I've experienced world corruption again on the Australian server and it lost progress. There are two possible causes - a POI, or the RWGMixer I am using.

 

The funny thing is I already tested just the POIs, and then just the RWGMixer, and both worked fine. As soon as I concluded testing and told the players this was the permanent world, errors appeared. Quite evil.

Share this post


Link to post
Share on other sites

Hello Mag,

 

Your rwgmixer delivred with the v3 pack is wrong... Pls change value to POI min / max for 3/4 instead of your 1/6 in each case...

 

1/6 value (especially 6) causing issues... Building collisions most of the time...

 

I tested your v3 pack with this value & all work fine... Except shop spawning in town... So I change theses values too in each xml prefab files...

 

Removing bookstore to wilderness... Adding some of them (when missing) in city/town or rural...

 

Testing it ATM on my dedi just patched 11.5 : [FR-RP-PVP] ZombieLand

 

Bull out...

Share this post


Link to post
Share on other sites
Hello Mag,

 

Your rwgmixer delivred with the v3 pack is wrong... Pls change value to POI min / max for 3/4 instead of your 1/6 in each case...

 

1/6 value (especially 6) causing issues... Building collisions most of the time...

 

I tested your v3 pack with this value & all work fine... Except shop spawning in town... So I change theses values too in each xml prefab files...

 

Removing bookstore to wilderness... Adding some of them (when missing) in city/town or rural...

 

Testing it ATM on my dedi just patched 11.5 : [FR-RP-PVP] ZombieLand

 

Bull out...

 

NO - this is not MY rwgmixer.xml i delivered with v3 !!!

I got wilderness-min 3 and wilderness-max 6 in my modded .xml !!!!

(but i will decrease the max-amount in the next release - thx :) )

 

Which shop that spawns in town do u mean ????

 

What is with the Bookstore ??? - and most important: Which bookstore do u mean ????

 

However:

 

-The Spawning-mix is NOT 100% finetuned yet. To be seriously it is just finished and how i like it to 60% !!!

(Especially with the new Problem with big Prefabs and dedi-maps)

 

-Feel free to modify, remove or add what ur personal favors are !!!

 

-This weekend i release a new update. It contains following changes:

 

* a lot of big-prefabs will be removed from the .xml (not from the Pack!)

* the rwgmixer.xml will be not the same like in v3

* perhaps the spawning-mix will be overdone (when i get the Componist-tool repaired !!!)

 

 

Did Alpha 11.5 fixed the big-prefab-framedrop-prob perhaps. Or the Region-Errors that belongs to them ???

 

 

Mag out

Share this post


Link to post
Share on other sites
Did Alpha 11.5 fixed the big-prefab-framedrop-prob perhaps. Or the Region-Errors that belongs to them ???

 

 

Mag out

 

Nope, so I removed all big prefab : prison, twd prison, bank, malls, recycling, shop malls, wullf town CD, office & everything looks fine...

 

For the book store, I mean the big one : store_book_lg, you allowed it to spawn in wilderness... Breakin' immersion...

 

Bull out... ;)

Share this post


Link to post
Share on other sites

I've had to remove the pack from one of my servers as it was shutting down the chunk loading and killing the world.

 

This is the third day of stability running without it so I am sad to say that on large dedicated servers with random gen the pack causes major problems, or at least some of the POIs have a chance to do so. Everything will run fine and then when a player enters an area and it chooses a random prefab to populate the chunk one or more of the POIs is causing the chunk to fail with an exception error.

 

For now I'm afraid I can't make use of custom POIs safely while running busy servers. :/

Share this post


Link to post
Share on other sites

sorry to hear that LT. (iam sure u used ur rwgmixer - don't u?)

 

It seems Bullrott got it get working (by removing the big ones)

 

I constantly work on the pack guys

 

I hope the next version will work on dedi-servers too.

I will test it - before i release it !!!

Share this post


Link to post
Share on other sites
sorry to hear that LT. (iam sure u used ur rwgmixer - don't u?)

 

It seems Bullrott got it get working (by removing the big ones)

 

Yep D10 on my dedi... 64 slots... No fps drop... No crash at all...

 

BUT

 

Still some buildings collasping... Have to identify'em one by one... Like the top of the junkyard when walking on it...

 

& little things like bad offset when building spawning in wilderness onto an hill for example... World collision... I assume that we cannot do something for prevent this to happen...

 

Anyway, the world looks far better now then ever... The price to pay is lesser than the pleasure u can grab when playing in it...

 

:triumphant:

Share this post


Link to post
Share on other sites
Yep D10 on my dedi... 64 slots... No fps drop... No crash at all...

 

BUT

 

Still some buildings collasping... Have to identify'em one by one... Like the top of the junkyard when walking on it...

 

& little things like bad offset when building spawning in wilderness onto an hill for example... World collision... I assume that we cannot do something for prevent this to happen...

 

Anyway, the world looks far better now then ever... The price to pay is lesser than the pleasure u can grab when playing in it...

 

:triumphant:

 

 

wonderful :)

 

Thx for ur feedback

 

I think i got an idea now - what i could do against the collapsing-Issue.

They collapse - because they got air under - right ???

Tommorrow i start a little test on this - to solve that problem !!!

 

Yes - there are some few cosmetical things: where they allowed to spawn and some disrotations

 

good night Mag out

Share this post


Link to post
Share on other sites

Must be a RWG issue. I added only the prefabs and not a single problem so far. no fps drop, no falling buildings, no map crashing.

Share this post


Link to post
Share on other sites
Must be a RWG issue. I added only the prefabs and not a single problem so far. no fps drop, no falling buildings, no map crashing.

 

did u try it local - or on a server too ??? Because local there no probs reported so far

 

The only change in my modded rwgmixer.xml is set the minimum-wilderness-spawning to 3 instead of 1

(but it will change in the next release)

 

 

But OK - if it work for u - then iam happy too.

 

Mag out

Share this post


Link to post
Share on other sites

Hey guys

 

In my research of finding old lost and forgotten Prefabs - I found a special one.

 

But i feel like i have to ask u guys - if we should add this Prefab to the Pack.

 

It is one of the towers of the WORLD-TRADE-CENTER !!!!

(here is the origanal post with some screenshots !!!)

 

I come from europe - for me its no problem to see that on map - but i want to know how u US-guys think of it !!!

 

I really don't want to start a discussion of it !!!!!!!!!!!!!!!

I just want to know if: WTC should be in or not !!!

 

 

If we choose to add it - it will be a City-spawner.

And if we just see the architectical part - it will be one of the nicest POI's in the CITY

 

 

For that reason I started a POLL here.

The voting will run exactly 1 week (till now) !!!

 

 

I WANT YOU TO VOTE !!!

 

 

here u can see the temporary voting-result

 

Mag out

Edited by Magoli (see edit history)

Share this post


Link to post
Share on other sites

Why not only call it tower, and remove the wtc tag? So Nobody should be pissed off! It's a real great prefab!!!! And didn't wanted some guys towers?

Share this post


Link to post
Share on other sites
Why not only call it tower, and remove the wtc tag? So Nobody should be pissed off! It's a real great prefab!!!! And didn't wanted some guys towers?

 

Yes - good idea !!!

 

If it gets in - i will exactly do this !!!

 

And yes - its a very nice building (from the creators point of view)

(just needs a little bit of repairing and pimping work - but this just 1h work for me - so no prob :) )

Share this post


Link to post
Share on other sites

Mag,

 

Does this work with A11.5 on dedi servers currently or are you still having the issues discussed on the last page or two of posts?

Share this post


Link to post
Share on other sites
Mag,

 

Does this work with A11.5 on dedi servers currently or are you still having the issues discussed on the last page or two of posts?

 

i don't tested it by myself yet. But it seems it works fine (look post #88 from Bullrott here !!!)

(just remove the big prefabs Bull has mentioned and use the vanilla rwgmixer.xml !)

 

I work on the update right now

Share this post


Link to post
Share on other sites
i don't tested it by myself yet. But it seems it works fine (look post #88 from Bullrott here !!!)

(just remove the big prefabs Bull has mentioned and use the vanilla rwgmixer.xml !)

 

I work on the update right now

 

Ok I will try this in a little while...

 

Any idea if the Steel Marauders mod works with it too?

Share this post


Link to post
Share on other sites

Hey Mag,

 

We are testing the pack on a friends server, so far it is responding fairly well. We have some ground flaws (regions joining together and causing this gigantic volcanic eruption type of ground) and we have found quite a few mods that are collapsing, one of them Im sorry to say is your Mag10 store (my god that's an amazing mod by the way, I was able to look around and I LOVE it, (other than the big writing on it). Here's a screenie

Mag10.thumb.jpg.153bacf870cde4c8811d56fffce45dbd.jpg

 

But the amount of PoI's and the variation is PERFECT!! I am itching to load it on my own server now

Share this post


Link to post
Share on other sites

Oh and this is another weird one I've run into. I've been in two of these now and both are completely empty. I've been in them before and they had desks and filing cabinets and other items to loot, but the two (that I've run into so far) on this server we are testing are empty

 

inside.jpg.18ede606f6ff06fd1904281c83866384.jpg

 

and a few of these

 

flying.jpg.baef949e8d747b5cd631264e003e846c.jpg

copshop.jpg.eac21189678058d018d0efaece8f3f86.jpg

Edited by Tahoenvy (see edit history)

Share this post


Link to post
Share on other sites

@Tahoenvy:

 

thx for ur feedback :)

 

The way u did the post was perfect (with screenshots !)

 

So i can exactly take stand:

 

1. I know about the little collapsing Issue in "Mag10". IMO it belongs only a few barrel-roof-plates.

But i decided to add it anyway. (In sad - because in A10 everything was holding in place)

 

2. all other Pics looks like the known Gamebugs. The game has problems to position all prefabs 100% probably

(this means errors on: Hight,rotation,position)

 

3. as i said: A few Prefabs needs a little bit love (Lootcontainers , looking , excitement)

But this is the next step. Iam glad the pack is living now. And soon 100% errorfree - i hope !!!

 

 

btw:

The ornament-building has 3 versions - they almost look like the same (just a window-row more each one)

 

 

As always - iam on it - thx for your help guys

Mag out

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...