Jump to content

Compo-Pack for Random Gen


Recommended Posts

LOL - thanks for making that fun with ma little guessing-game ;)

 

Ok - SylenThunder is nearest ;)

 

COMPO means:

 

C = Collection

O = Of

M = Magoli's

P = Prefab

O = Overdoings

 

 

 

btw:

 

I have started the work on Pack v8.

 

Perhaps we have a release this month ;)

 

From the next update on - the Prefabs in the Pack will have a Scoresystem for Lootcontainer-amount in association with the Prefabs.

 

 

Mag

Link to post
Share on other sites
will this work with the new A12.5?

 

As far I read from the A12.5 update-notes: YES !!!

 

there are no changes that belongs to my work!

 

 

Will test it soon today - then i give full report!

 

 

Mag

Link to post
Share on other sites

But what i like to see ist.

 

C = Collection

O = Of

M = Magoli's

P = Prefab

O = Overdoings

I = Is

I = In

T = The

M = Main

G = Game

I = Implemented

 

;)

 

Otherwise ith would make me happy if TFP implement an better poi integration.

 

@ Magoli

 

Danke für deine Stete Arbeit.

Link to post
Share on other sites
Mag, is it posible to put in the new one you came out with without wiping my world? I'm using V6 at the moment. Also another important question is: Did you remove Working Stiffs and if so is there a way to get it back in?

 

 

Yes - just install the pack - delete the regions u want to be written new. Dont delete the regions u want to keep.

 

 

The small and big workingstiffs spawns in Packv7 !!!

 

The small workingstiff spawns in Packv6 !!!

 

The big workingstiff DONT spawns in Packv6 - because the vanilla-version of it is to big to spawn in towns/cities !!!

 

I made a smaller version of it for Packv5 !!!

But as u perhaps know - the vanilla-prefabs are protected by eac since a12 (=Compopackv6).

This means all my changes to the vanilla-Prefabs are no longer supported by the game !!!

If I make .tts-changes to the vanilla-prefab i have to rename them now.

 

This is what iam doing right now in this moment ;)

Iam about to check, repair and rename all Vanilla-Prefabs - that have Issues or strangers right now !!

 

I found many many bugs as i calculated and determined the Scores for the Scoresystem.

So i decided to make the general vanilla-Repair at first.

 

Some bugs just causes the Prefab to not spawn. But I also found some Nasty Issues in some Prefabs (Vanilla and Customs)

(Prefabs with Air above or below !!! Nasyty unreal stair-rotation-Issues - Errors or missing entries in the .xml-file, ...)

 

 

OK - u see guys - iam straight on the work for the next Pack

stay tuned

Mag

Edited by Magoli (see edit history)
Link to post
Share on other sites

I know this might sound like a bit of a daft question but what you don`t know you question I guess. Ok if i add this to a dedicated server will all my players be able to see all the new buildings etc or will they each have to install this to their clients?

Link to post
Share on other sites
I know this might sound like a bit of a daft question but what you don`t know you question I guess. Ok if i add this to a dedicated server will all my players be able to see all the new buildings etc or will they each have to install this to their clients?

 

Just install on serverside.

 

Only the host needs to install it. All other Players dont have todo nothing !

 

 

Mag

Link to post
Share on other sites

hey bigc

 

I saw that thread too.

 

But he only said: "my favorite server"

 

1. I dont know which mods they are using

2. Don't know which Prefab-Set they are using

 

 

Here i got no report that something is wrong now.

 

And in the Update-notes are also no changes listed - that belongs to my Pack

 

Mag

Link to post
Share on other sites

Hey Magoli, I can confirm the weird log light poles. I am running the latest live free or die mod and your prefab pack w/mixer. I saw a couple in the hub city last night . I'm thinking TFP may have made a change and not put it in the change log. It's not really an issue gameplay wise, just looks really weird haha.

Link to post
Share on other sites

Block IDs has not been changed with A12.5, but some blocks got new properties, e.g., block 921 (material is wood) got it's shape property changed and also the model type has changed, maybe these are the bugged poles, wrong rotation maybe?

 

I run Magolis Pack 6 on my main server and Pack 7 on the test server, and the only strange lamp posts I found are the ones at the Car Dealership. They have Corrugated Metal texture, and 3 lamp poles outside the city version of the Zombie Zoo, where are only concrete poles, with no lamp on the top.

Link to post
Share on other sites

hey people

 

The Picture with the missroted tubehalfwoodpoles is "gas_station1" (vanilla prefab) !!!

 

In Alpha 12.4 this Prefab don't have this bug !!! - I tested it right now !!!

 

But i can't make a test in 12.5 right now - because iam in alpha12.4 because i need the editor fully working !!!

 

 

As long I get no negative report of a purly COMPO-PACK WITHOUT OTHER MODS INSTALLED - i don't feel to react !

(read the first Sentence of the Pack releasenotes !!!)

 

 

@Puschpa:

 

The streetlights of the Dealership are fine too.

The direction is like always (lamps directed to inside!)

And the material is also ok like in 1995 ;) - ( <block id="923" name="tubeHalfMetal2NoDistort"> )

 

With the Zombie-Zoo u r right !!! Only the Poles are there - the lights are missing !!!

(It seems i cuttet them by accident - when i was making the city-version from it)

 

Thx for the Info on that. I will re-add the lights for the next release !!!

 

 

Strange:

They also said nothing about texture-changes in the a12.5-game-releasenotes !?!?!?!

 

anyhow

 

As long it dont belongs my latest Pack-version: no matter to me !!!

 

 

Mag

Link to post
Share on other sites

No other mods installed and I am getting some issues with this Compo-Pack, I have narrowed it down to this pack which is causing my issue. No idea what else it could be as nothing else has changed, What is weird is this Block ID with value 640 and 630 are rockresources. No idea whats going on.

 

Getting Spammed on my server with these line.

Block on position 6082, 109, -7688 with value id=640 px=1 py=0 pz=-1 should be a parent but is not! (3)
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 65)

Block on position 6074, 109, -7699 with value id=630 px=-1 py=0 pz=1 should be a parent but is not! (5)
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 65)

Block on position 1925, 114, -6760 with value id=640 px=2 py=0 pz=0 should be a parent but is not! (3)
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 65)

Block on position -2298, 133, -7391 with value id=640 px=2 py=0 pz=0 should be a parent but is not! (3)
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 65)

 

And these as well.

 

IndexOutOfRangeException: Array index is out of range.
 at ItemValue.Read (System.IO.BinaryReader _br) [0x00000] in <filename unknown>:0 
 at ItemValue.Read (System.IO.BinaryReader _br) [0x00000] in <filename unknown>:0 
 at ItemValue.Read (System.IO.BinaryReader _br) [0x00000] in <filename unknown>:0 
 at ItemValue.Read (System.IO.BinaryReader _br) [0x00000] in <filename unknown>:0 
 at ItemValue.Read (System.IO.BinaryReader _br) [0x00000] in <filename unknown>:0 
 at ItemValue.Read (System.IO.BinaryReader _br) [0x00000] in <filename unknown>:0 
 at ItemValue.Read (System.IO.BinaryReader _br) [0x00000] in <filename unknown>:0 
 at ItemValue.Read (System.IO.BinaryReader _br) [0x00000] in <filename unknown>:0 
 at ItemValue.Read (System.IO.BinaryReader _br) [0x00000] in <filename unknown>:0 
 at ItemValue.Read (System.IO.BinaryReader _br) [0x00000] in <filename unknown>:0 
 at ItemValue.Read (System.IO.BinaryReader _br) [0x00000] in <filename unknown>:0 
 at ItemValue.Read (System.IO.BinaryReader _br) [0x00000] in <filename unknown>:0 
 at ItemValue.Read (System.IO.BinaryReader _br) [0x00000] in <filename unknown>:0 

Edited by Lordicon (see edit history)
Link to post
Share on other sites

If you teleport to the coordinates, you will find there one of the large boulders. On my server I found them, following the errors in logfiles, on the areal of the xcostum_Citymix_02(gunst_sm-kuldlargeh-bunk)a12_v1 and the xcostum_Citymix_09(grocery_sm-barn01-medclinic_sm)a12_v1 prefabs.

Link to post
Share on other sites

Finally found a prefab with flipped over lamp poles - it is the xcostum_Car_Dealership_old(by_P1ut0nium)a12_v1. Also the pole that supports the signboard is now made of horizontally flipped tubeHalfMetall (Block ID 922).

Link to post
Share on other sites
  • Roland locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...