Jump to content

Compo-Pack for Random Gen


Magoli

Recommended Posts

hotfix01 for CP45 is out now !!!

because of the NullRef-error some of us is getting when they try to continue their saved games I decided to deliver a hotfix01 for CP45

We still dont know what exactly is causing these NullRef-errors, but we are working on in and hope this hotfix01 will help against it.

We suggest it could have something to do with corrupted/older player-profiles and/or also with corrupted SleeperVolumes

We still working on that and try to figure out what causes this.

We recommend to choose/create a new player-profile before starting a new A19-game and delete/cleanup all the older profiles !!!

 

further to that I decided to remove all the xvanilla-prefabs and use the original vanilla-prefabs instead again (for the prefablist.txt for Nitrogen)

 

pls let me know if you are still getting errors after using this hotfix01

 

to get the hotfix01 pls go to the openingpost

-COMPOPACK_45(for Alpha19stable_built180)  has been exchanged with COMPOPACK_45hotfix01(for Alpha19stable_built180)

-COMPOPACK_45(for Alpha19stable_built180) is not available anymore !!!

-actual version is now COMPOPACK_45hotfix01(for Alpha19stable_built180)

 

here is the CHANGELOG for COMPOPACK_45hotfix01(for Alpha19stable_built180) :

 

xcostum_Bank(by_Guppycur) checked / checked/cleanup xml
xcostum_Cabin(by_Sudo) fixed missing waterblocks / reworked SLvolumes / checked/cleanup xml
xcostum_Cantine(by_Limodor) checked / checked/cleanup xml
xcostum_CityPark(by_Spider) fixed missing waterblocks / reworked SLvolumes / checked/cleanup xml
xcostum_CountyJail(by_Volar) reworked SLvolumes / checked/cleanup xml
xcostum_exfarmstead(by_owl79) checked / checked/cleanup xml
xcostum_Haulier_lg(by_Limodor) reworked SLvolumes / checked/cleanup xml
xcostum_Hobbit(by_Limodor) checked / checked/cleanup xml
xcostum_Motel(by_Limodor) checked / checked/cleanup xml
xcostum_Prison(by_Limodor) fixed overlapping SLvolumes / checked/cleanup xml
xcostum_PublicPool(by_Warsaken) fixed missing waterblocks / checked/cleanup xml
xcostum_Recycling(by_Limodor) reworked SLvolumes / checked/cleanup xml
xcostum_RedCatDiner(by_Najax) checked / checked/cleanup xml
xcostum_ScienceLab(by_kinklade) reworked SLvolumes / checked/cleanup xml
xcostum_SeafoodShop(by_Guppycur) reworked SLvolumes / checked/cleanup xml
xcostum_WulftownA(by_WereWulfen) checked / checked/cleanup xml
xcostum_Dark_Mausoleum32(by_LuckyStar) reset gamestageadjust / checked/cleanup xml
xcostum_homestead(by_Mana) reworked SLvolumes / checked/cleanup xml
xcostum_house_number14(by_Kam) reworked SLvolumes / reset gamestageadjust / checked/cleanup xml
xcostum_house3(by_Curbolt) checked / checked/cleanup xml
xcostum_modernvilla(by_owl79) reworked SLvolumes / checked/cleanup xml
xcostum_Plant(by_Wsiegel) reworked SLvolumes / checked/cleanup xml

 

removed xcostum_H0bbit(by_Limodor) (duplicate)

 

xcostum_Firedepartment(by_Guppycur) fixed POI-size
xcostum_fp_house_medium_002(by_Frank_Souza) reworked SLvolumes

 

removed all xvanilla-prefabs and use the original vanilla-prefabs instead
(I removed the xvanilla-prefabs because it seems it is not needed anymore to take care of the corrupted waterblocks (ID256)
the waterblocks in the vanilla-prefabs are still corrupted (rotation/metavalue) but it seems the game can handle this now since built180
and there is no negative impact on spawning, missing waterblocks and game-performance anymore)

 

 

 

 

 

 

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

1 hour ago, NSHGaming said:

And i generated 2 maps with water going across the middle of map about 30 blocks high

 

Hi NSHGaming

 

You would not have installed the CompoPack hotfix, it was just in case you had NullRef-error, there are some who have had that, for them it is the hotfix.

Link to comment
Share on other sites

33 minutes ago, Gouki said:

 

Hi NSHGaming

 

You would not have installed the CompoPack hotfix, it was just in case you had NullRef-error, there are some who have had that, for them it is the hotfix.

But you added new stuff that wasn't in 44 or did you add it to 44 as well

Link to comment
Share on other sites

6 minutes ago, NSHGaming said:

It says 45 is no longer available. just the 45hotfix

 

Yes, it is the 45hotfix, it could be a fault of the Nitrogen generator or something of the prefabs, I don't know, just my assumptions.

Link to comment
Share on other sites

1 minute ago, Gouki said:

 

Yes, it is the 45hotfix, it could be a fault of the Nitrogen generator or something of the prefabs, I don't know, just my assumptions.

3 maps in a row with the wall of water. Will go back to 44 until someone figures out what is causing it.

Link to comment
Share on other sites

8 minutes ago, NSHGaming said:

3 maps in a row with the wall of water. Will go back to 44 until someone figures out what is causing it.

 

I suppose people will go back to version 44 if the problem persists even with the Hotfix, my suspicions of what is causing the NullRef-error in the Prefabs and maybe the generation, it may be that they have added the new development block that emits the smoke It's just my guess.

Link to comment
Share on other sites

7 hours ago, Gouki said:

 

I suppose people will go back to version 44 if the problem persists even with the Hotfix, my suspicions of what is causing the NullRef-error in the Prefabs and maybe the generation, it may be that they have added the new development block that emits the smoke It's just my guess.

not the smoke blocks. the null ref we got was from a new prefab we got that had a bad sleeper volume. Vanilla has it's own null refs as well. I believe there are also smoke blocks in some vanilla prefabs as well

Link to comment
Share on other sites

7 hours ago, Gouki said:

 

I suppose people will go back to version 44 if the problem persists even with the Hotfix, my suspicions of what is causing the NullRef-error in the Prefabs and maybe the generation, it may be that they have added the new development block that emits the smoke It's just my guess.

Nothing to do with smoke blocks at all.

Link to comment
Share on other sites

2 hours ago, wolfbain5 said:

ok, now that is weird. prefab placement has nothing to do with the water and lakes. you are using nitrogen? and making sure to use vanilla prefab list?

I replaced prefab.txt list with with cp45 prefab list as video explained and chose vanilla. the last 3 maps did the water wall

Link to comment
Share on other sites

I have a logistical question. In the video showing how to use cp45 when the prefab list was copied from the cp45 folder and paste in 7d2d prefab folder the video showed 4485 files. When i do it it only shows 2351. Did prefab file just delete 2100 files on its own since video was made.

Link to comment
Share on other sites

7 minutes ago, NSHGaming said:

I have a logistical question. In the video showing how to use cp45 when the prefab list was copied from the cp45 folder and paste in 7d2d prefab folder the video showed 4485 files. When i do it it only shows 2351. Did prefab file just delete 2100 files on its own since video was made.

we were using copies of the vanilla prefabs that had a few corrections on them. but since they were updated and changed by tfp, we removed the copies. so the files size and amounts dropped.

 

the water pics you are showing I do not think is a cp error. prefab xmls do not affect anything outside of a prefab. the prefab files also do not affect anything outside a prefab. the water in your world is above the ground level. that is not a prefab error. I have no clue what is causing your problem.

Link to comment
Share on other sites

  • Roland locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...