Jump to content
Magoli

Compo-Pack for Random Gen

Recommended Posts

Next editor update will have a feature to create this line automatically (or copies the line to the clipboard):

 

PrefabName,none,3,-3,84,38,104,alone

Edited by Pille (see edit history)

Share this post


Link to post
Share on other sites
Next editor update will have a feature to create this line automatically (or copies the line to the clipboard):

 

PrefabName,none,3,-3,84,38,104,alone

 

thats a good idea^^

(I should have doublechecked it - that was my fault)

 

to your first question:

the lowest negative yoffset for cities,towns,farms,alone is -35

 

because bedrock is 3 Layers thick and starts at 0 - so it goes from 0 to 3

the common Level where towns spawn is about 36-40 above 0

so u can go 35 blocks deep with ur POI's (1 block stays for safetyreason)

 

when the prefab is deeper just assign it to Mountain in Nitrogen-prefablist

for rwg its almost impossible to implement

Share this post


Link to post
Share on other sites
Confused.

 

I'd like to experience the new "CompoPack 43" on a new Nitrogen map.

 

- Copied the new prefabs to my 7DaysToDie folder

- Replaced the "rwgmixer" file … per "Farket" YouTube tutorial

- Found and Replaced the "configUI" and "prefablist" in the Nitrogen "resources" folder

 

Run Nitrogen:

… but in the Advanced section in the top right-hand corner … the "Prefab list" still only offers "Vanilla" / "CompoPack 42" / "Custom"

 

If I click on "CompoPack 42" … will I actually get "CompoPack 43" content?

 

Thanks.

 

when u have overwritten the default Nitrogen-prefablist with the CP43-prefablist, the CP43-prefablist has become the standard-prefablist Nitrogen is watching at when u choose "vanilla" in the box !

 

In other words:

U have done everything right! Just choose "vanilla" in the Advanced section, and u r fine

Dont care about the options for earlier Compopacks

  • Like 1

Share this post


Link to post
Share on other sites
thats a good idea^^

(I should have doublechecked it - that was my fault)

 

to your first question:

the lowest negative yoffset for cities,towns,farms,alone is -35

 

because bedrock is 3 Layers thick and starts at 0 - so it goes from 0 to 3

the common Level where towns spawn is about 36-40 above 0

so u can go 35 blocks deep with ur POI's (1 block stays for safetyreason)

 

when the prefab is deeper just assign it to Mountain in Nitrogen-prefablist

for rwg its almost impossible to implement

 

I meant for the ingame random world generator. :) But thanks, I didn't know that Nitrogen also has limitations.

Share this post


Link to post
Share on other sites

I use Nitrogen and I need a bit of a hand , I cant seem to get both compopack and the vanillas at same time , plus Im not even sure its getting the full compopack Any advice?

Share this post


Link to post
Share on other sites
I use Nitrogen and I need a bit of a hand , I cant seem to get both compopack and the vanillas at same time , plus Im not even sure its getting the full compopack Any advice?

 

COMPOPACK has all vanilla-prefabs included when installed (and used) right

 

so where u stuck ?

where u got problems ?

Share this post


Link to post
Share on other sites
COMPOPACK has all vanilla-prefabs included when installed (and used) right

 

so where u stuck ?

where u got problems ?

 

I read somewhere this evening on the forum there have been some issues with Nitrogen since the recent patch. I've not tested it since before that so might be an individual experience for that person. Just something to be aware of. Guess I will go check it and see. It's worked flawlessly up til now at least.

Share this post


Link to post
Share on other sites
I read somewhere this evening on the forum there have been some issues with Nitrogen since the recent patch. I've not tested it since before that so might be an individual experience for that person. Just something to be aware of. Guess I will go check it and see. It's worked flawlessly up til now at least.

 

Any player.log reports cosole errors. Whats it doing no one can help if you dont give all info lol.

Share this post


Link to post
Share on other sites
Any player.log reports cosole errors. Whats it doing no one can help if you dont give all info lol.

 

Stallion, I’m not having any issue whatsoever. Just responding to the post. I read in the Nitrogen thread there might be an issue but have not tested creating anything new.

 

Think I’ll test a map after I have my morning coffee to see if anything has changed. :fat:

Share this post


Link to post
Share on other sites

Im trying a 4k map with nitrogen using compopack right now and my nitro settings are all mega and lots and what not and Im running compo43 the map part works fine its when I place the campfire. Meaning when I look at the list it shows that it should generate and gives the cords. But once I get in game I get the error once getting to the trader part. Seems like nothing is really spawning in. Is there a way to do this with Nitrogen while keeping your vanilla game pure. Although if I merge it or keep it pure same issue. I need major help. I can follow the directions and nothing is wrong in the map creations. its something connected to the trader.

 

 

Edit, Lowered it to the option below Mega and still the error persists and the Traders are seen in the prefablist of the map so not sure whats happening.

 

Edit - I don't know if this has an impact either but I created an instance of the game to keep vanilla pure.

 

Edit - Combined in the vanilla game or not not seeing a difference.

Share this post


Link to post
Share on other sites
Im trying a 4k map with nitrogen using compopack right now and my nitro settings are all mega and lots and what not and Im running compo43 the map part works fine its when I place the campfire. Meaning when I look at the list it shows that it should generate and gives the cords. But once I get in game I get the error once getting to the trader part. Seems like nothing is really spawning in. Is there a way to do this with Nitrogen while keeping your vanilla game pure. Although if I merge it or keep it pure same issue. I need major help. I can follow the directions and nothing is wrong in the map creations. its something connected to the trader.

 

 

Edit, Lowered it to the option below Mega and still the error persists and the Traders are seen in the prefablist of the map so not sure whats happening.

 

Edit - I don't know if this has an impact either but I created an instance of the game to keep vanilla pure.

 

Edit - Combined in the vanilla game or not not seeing a difference.

 

I ran a 10 k map today and it runs fine with the compopack. I went through the trader and completed it without issue but I did not create the map with “mega” anything. Most settings are mid or slightly over default. What’s your memory usage during play?

Share this post


Link to post
Share on other sites

Not sure but I don't have problem until I try compopack

and I would really love to keep compo separate to keep my vanilla game pure

Share this post


Link to post
Share on other sites
Not sure but I don't have problem until I try compopack

and I would really love to keep compo separate to keep my vanilla game pure

 

COMPOPACK does not corrupt the default prefabfiles and also CP has no impact on any existing gamesave !!!

(when u just use Nitrogen for generating maps u wouldn't even have to change the rwgmixer.xml)

So all stays vanilla until u play on a Nitrogenmap generated with the COMPOPACK-prefablist_for_Nitrogen

 

In the Nitrogen-tool there is no option for COMPOPACK43 available

And because Damocles has freezed down the development atm, I decided to always use the vanilla-setting, which means when generating a map Nitrogen searches the file "prefablist.txt" instead of any other file (e.g. prefablist_CompoPack_39) !!!

Thats all !!! Its just called "vanilla" even if its not the default Nitrogen-prefablist !!!

 

to the traderproblem:

 

I cant imagine what u mean with "empty inside" - a screenshot or vid would be awesome

Is there any msg in the console about it? - If u could upload the output.log that would help much

 

do u encounter the same trader-Issue when u start a new game with the COMPOPACK43-Examplemap (included in CP43-dl-folder) ???

 

Is this Issue is still here when u use the configUI from the CP43-dl-folder ???

Share this post


Link to post
Share on other sites
your welcome, if I come across more, I will vid them. better info than pics, thanks for the great work

 

also bavarianbowseshop

 

where is the quest marker?

 

Its not there where it should be - thats a fact ;)

 

thx for the headsup mate - I will fix it in the next update (which will come soon - it will be mainly a hotfix-update-version i guess)

Share this post


Link to post
Share on other sites

You edit the txt file in nigirgen to use combopack 43. Thats what i did and made a 10k map with 43, works without issue. also ussing several modlets with no issues.

Share this post


Link to post
Share on other sites

My issue is the buildings don't seem to be generating , which causes an error when I get to the trader part of the quest..

The funny issue though is the prefabs.xml in the map folder shows what & where yet nothing marks :(

 

Edit- Is there a way that isn't copying the files into the vanilla list because I wanna be able to have both Vanilla maps and CP maps Can someone give me any advice on how to achieve this

Edited by AmethystLainey (see edit history)

Share this post


Link to post
Share on other sites

go to you nitrogen resources folder and open the configprefablist.txt edit like so,

 

//listing of prefabslists

//lists must be present in the resources folder

//filename ; description

 

prefablist.txt; Vanilla (default)

prefablist_CompoPack42_b5.txt; Compo Pack 42

prefablist_Combopack_43.txt; Compo Pack 43 This is the edited line. Just add any combo pack or prefablist you want to this list like this line.

 

ensure you add the Combopack_43.txt to this directory as well. the file above with the edit txt line tells nitrogen where to load the prefablist from. So the prefablist you get in the conmbo pack will be copied to the resources directory in nitrogen, then edit the last line like shown.

Run nitrogen and you will see the option for combo43. I renamed mine to make it shorter. So if you copy the prefablist from the combo pack make sure when you add the line in the configprefab txt you write it exactly as the combo pack prefablist is named.

Share this post


Link to post
Share on other sites

Are you sure you copied the prefabs to your prefabs folder?

 

Also as he already explained, COMPOPACK does not mess with Vanilla, you can play Vanilla saves and CP saves on the same install.

Share this post


Link to post
Share on other sites

I understand that, but having all the prefabs list mess with being able to make vanilla or compo maps in future or is that the point of the .txt’s ? It tells it which ones to draw from ?

Share this post


Link to post
Share on other sites

I think I may have solved my problem like a goof I was going thru my modded game but I had the prefabs in my vanilla game LOL so that part is solved. I just need to figure out how to get it to draw from the COMPO POI and VANILLA POI would that be as simple as adding the info in the vanilla .txt to the compos .txt?

Share this post


Link to post
Share on other sites

If you use Nitrogen with Compopack, it draws from both Vanilla and Compopack without having to do anything else short of the clearly laid out directions in regard to the directory and copying the RGWmixer and adding the prefabs. The Nitrogen tool is laid out quite clearly as to how to use the Compopack. It will be listed in the tool. It will always draw from the vanilla as well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...