Jump to content
Magoli

Compo-Pack for Random Gen

Recommended Posts

UPDATE-TIME

 

COMPOPACK_41(for Alpha18.2_built2) is out now !!!

 

COMPOAPCK now supports NITROGEN-maps and rwgmixer-maps

 

 

to get it go to the OPENINGPOST

 

 

here are the detailed Changes:

 

CHANGELOG CP41:

 

-fixed typo in rwgmixer.xml: renamed xcostum_DriveIn(by_DuffyDuck) to xcostum_DriveIn(by_NAGG_Genosis) in rwgmixer (also in nitrogen prefablist)

-fixed xcostum_AmityvilleHorrorHouse(by_Swolk) (removed useless air above POI / redone SleeperVolumes / changed POI-height in prefabslist from 46 to 24)

-fixed xcostum_research_vessel(by_Pille) (removed useless air above POI / changed POI-height in prefabslist from 50 to 39)

-fixed xcostum_Tavern(by_Limodor) (exchanged snowky blocks to common biome-universal Ones / removed useless air above POI / added POI to prefabslist / redone SleeperVolumes)

-fixed xcostum_spanish_mission(by_The_Cure) (exchanged dessert blocks to common biome-universal Ones)

-fixed xcostum_simpsonshouse(by_magoli) (removed floating tree high above)

-completely redecorated and repainted xcostum_storeset1(by_Guppycur)

 

-fixed gap between POI and landscape when a shapeblock is in surface-Layer position (done in all prefabs)

 

-added a new customtown with 25 POI's - DESTROYED TOWN

 

-removed xcostum_RestArea_Desert(by_Guppycur) from spawning (out for bigger plans)

 

-exchanged hatch-elevator to a simple ladder in xcostum_SkyDiner(by_Tom) (improvised Solution until Creator Releases new version)

-exchanged hatch-elevator to a simple ladder in xcostum_Spirallibrary(by_Tom) (improvised Solution until Creator Releases new version)

 

-made some new screenshots for several POI's

 

-made new meshfiles for:

xcostum_Asia_Restaurant(by_Redlotus)

xcostum_InsaneAsylum(by_Genosis)

xcostum_TV_Tower_Restaurant(by_magoli)

 

 

-New Prefabs (and which Nitrogen-zones they assigned to)

(added to Nitrogen-CP41-prefablist and rwgmixer.xml):

 

xcostum_airport_rundown(by_gt) (custom_outback_size_1) (has many Sleepers - quest-tier5)

xcostum_airport1(by_ouch) (custom_outback_size_2) (has many Sleepers)

xcostum_airport2(by_ouch) (custom_settlement_size_3) (has many Sleepers - quest-tier5)

xcostum_Canyon_Cave(by_War3zuk) (farm) (has a bunch of Sleepers - quest-tier3)

xcostum_Coronado_barn_lg(by_Slaan) (farm) (has a few Sleepers - quest-tier2)

xcostum_Coronado_cornfield_crash(by_Slaan) (farm) (has Sleepers)

xcostum_Coronado_cornfield_missle_silo(by_Slaan) (farm) (has many Sleepers - quest-tier5)

xcostum_Coronado_farm_lake(by_Slaan) (farm) (no Sleepers - no quest)

xcostum_Coronado_farmedField(by_Slaan) (farm) (no Sleepers - no quest)

xcostum_Coronado_farmSheds(by_Slaan) (farm) (has some Sleepers - quest-tier2)

xcostum_Coronado_shamway_plant(by_Slaan) (farm) (has Sleepers - quest-tier4)

xcostum_Multi_Trader_02(by_War3zuk) (trader) (no Sleepers - no quest)

xcostum_simplehouse(by_hernan) (houses,smalltown) (no Sleepers - no quest)

 

 

Magoli

2019-11-27

 

Amazing sir magoli...... gonna try it out next couple days. You sir are awesome.

 

Btw i found 2 issues with another poi. Every time they spawn they have dirt where air should be.

 

1. The hobbit house inside the house .

 

2. The farmer joes prefab by that stallionsden. has dirt inside and out where air should be.. (oh wait this is mine lol..... 'DOH' will fix it lol

Share this post


Link to post
Share on other sites
Amazing sir magoli...... gonna try it out next couple days. You sir are awesome.

 

Btw i found 2 issues with another poi. Every time they spawn they have dirt where air should be.

 

1. The hobbit house inside the house .

 

2. The farmer joes prefab by that stallionsden. has dirt inside and out where air should be.. (oh wait this is mine lol..... 'DOH' will fix it lol

 

thx sir Stalli ;)

 

I have noticed the Issue u r talking about in many other POI's since A18 - last time just 30 mins ago in xcostum_pagoda_sm(by_Magoli) in my newest survival world testing gameplay

 

Also saw this terrain-Pillar in skyscaper(by_Peppino) and in Volars Superstore

 

ofc I checked the prefabs in every case - but I really saw no Issues in Pilles editor

And on another place these prefabs just spawn fine (within the same map !)

 

IMO there is something wrong with the rwg-world-generation at all !!!

(It also happens when I use Nitrogen-maps)

 

 

oh - btw: I play the examplemap right now - and really love how the landscape, streets and towns looks like - very amazing

 

I spawned near an Asia-town - It looks very realistic and natural - absolutely great

 

Damocles is a magician - Nitrogen is a very superb tool !

 

IMO COMPOPACK41 has the best looking world I ever saw (when generated with Nitrogen and with my configUI) - even better than A15 !!!

Edited by Magoli (see edit history)

Share this post


Link to post
Share on other sites
thx sir Stalli ;)

 

I have noticed the Issue u r talking about in many other POI's since A18 - last time just 30 mins ago in xcostum_pagoda_sm(by_Magoli) in my newest survival world testing gameplay

 

Also saw this terrain-Pillar in skyscaper(by_Peppino) and in Volars Superstore

 

ofc I checked the prefabs in every case - but I really saw no Issues in Pilles editor

And on another place these prefabs just spawn fine (within the same map !)

 

IMO there is something wrong with the rwg-world-generation at all !!!

(It also happens when I use Nitrogen-maps)

 

 

oh - btw: I play the examplemap right now - and really love how the landscape, streets and towns looks like - very amazing

 

I spawned near an Asia-town - It looks very realistic and natural - absolutely great

 

Damocles is a magician - Nitrogen is a very superb tool !

 

IMO COMPOPACK41 has the best looking world I ever saw (when generated with Nitrogen and with my configUI) - even better than A15 !!!

 

Yeh and doesn't look like a19 is going to fix any rwg either at this stage either.

 

But yes compopack + nitrogen = AMAZING being able to customise your world like nitrogen allows you and being able to use the compopack makes the world so much better

Share this post


Link to post
Share on other sites

First of all I love Nitrogen and Compopack,. thank you guys!

Just one thing, let me know if I understund if right, because in Install-Instructions there is no word about it.

I ask, because if I simply follow Instructions, the server says: "could not find a file "xvanilla..." bla bla bla"... - this is of course because there is no xvanilla files in game (server) folder.

 

So, if I want to use the vanilla and new prefabs, should I rename all "xvanilla" to "vanilla" in rwgmixer and prefablist files?

Or should I generate all xvanilla files in the Prefabs game (server) folder by renaming all the files?

Share this post


Link to post
Share on other sites
First of all I love Nitrogen and Compopack,. thank you guys!

Just one thing, let me know if I understund if right, because in Install-Instructions there is no word about it.

I ask, because if I simply follow Instructions, the server says: "could not find a file "xvanilla..." bla bla bla"... - this is of course because there is no xvanilla files in game (server) folder.

 

So, if I want to use the vanilla and new prefabs, should I rename all "xvanilla" to "vanilla" in rwgmixer and prefablist files?

Or should I generate all xvanilla files in the Prefabs game (server) folder by renaming all the files?

 

Yeah. I just noticed this as well, with generating a new map, there are a TON of empty spaces. Your prefablist.txt file has all of the xvanilla_..... files listed, but in the prefab folder, you only have the xcustom_....... prefabs in there.

 

I assume copying all of the xvanilla files from the CP40 zip file into prefabs folder will work in the meantime, or is it better to manually edit the prefablist file to remove all of the "xvanilla_" prefixes, so that it is using the actual vanilla prefabs instead.

 

Just curious.

Share this post


Link to post
Share on other sites
First of all I love Nitrogen and Compopack,. thank you guys!

Just one thing, let me know if I understund if right, because in Install-Instructions there is no word about it.

I ask, because if I simply follow Instructions, the server says: "could not find a file "xvanilla..." bla bla bla"... - this is of course because there is no xvanilla files in game (server) folder.

 

So, if I want to use the vanilla and new prefabs, should I rename all "xvanilla" to "vanilla" in rwgmixer and prefablist files?

Or should I generate all xvanilla files in the Prefabs game (server) folder by renaming all the files?

 

Yeah. I just noticed this as well, with generating a new map, there are a TON of empty spaces. Your prefablist.txt file has all of the xvanilla_..... files listed, but in the prefab folder, you only have the xcustom_....... prefabs in there.

 

I assume copying all of the xvanilla files from the CP40 zip file into prefabs folder will work in the meantime, or is it better to manually edit the prefablist file to remove all of the "xvanilla_" prefixes, so that it is using the actual vanilla prefabs instead.

 

Just curious.

 

Simply go to cp40 and grab the xvanilla prefabs as I doubt mags did any work on them he hasn't already done. And also what one Is and all is good

Share this post


Link to post
Share on other sites

ooookkk.... who the fu... did this "rave club" (old brewery?) with lots of blinking lights from spotlights ? Which sadistic , psychopathic POI builder did that?

 

Was exploring a short cut back to my base and came across it in the middle of the dessert. Started looting outside and noticed i'm hungry. Ok, just found some blueberry pie.... yeah... RNG hit and i lost nearly all health and stamina.

 

No problem, that one zombie in front of me i can shoot with a gun.

 

Long story short, 150 7.62mm and around 100 shotgun shells later i was done final.

 

Holy crap, first time in A18 that i panicked!! You Sir , who ever build that, deserve a huge slap and a big thank you.

 

Just one thing, did i miss some big loot boxes in there or are there none?

Share this post


Link to post
Share on other sites

god damn - whats wrong with me XD

 

sry guys - u r right

 

I forgot to put the xvanillafiles into the dl-folder

 

I will fix this in a minute

 

sry

Share this post


Link to post
Share on other sites

i have linked the pack in the NitroGen thread.

I can add the CompoPack 41 prefabslists to the dropdown soon, so it has the most current official one.

Share this post


Link to post
Share on other sites

OK - I have fixed the pack and Released a new version

 

so again its UPDATE-TIME

 

COMPOPACK_42(for Alpha18.2_built5) is out now

 

I just added the missing xvanilla-files to the dl-prefabsfolder

 

thx for the feedback 83ZGvoMhSvGI and Sullen Skulls

 

 

to get the new version go to the OPENINGPOST or download it directly HERE

 

sthx and sry again

Share this post


Link to post
Share on other sites
ooookkk.... who the fu... did this "rave club" (old brewery?) with lots of blinking lights from spotlights ? Which sadistic , psychopathic POI builder did that?

 

Was exploring a short cut back to my base and came across it in the middle of the dessert. Started looting outside and noticed i'm hungry. Ok, just found some blueberry pie.... yeah... RNG hit and i lost nearly all health and stamina.

 

No problem, that one zombie in front of me i can shoot with a gun.

 

Long story short, 150 7.62mm and around 100 shotgun shells later i was done final.

 

Holy crap, first time in A18 that i panicked!! You Sir , who ever build that, deserve a huge slap and a big thank you.

 

Just one thing, did i miss some big loot boxes in there or are there none?

 

this guy is called orak and tbh I never had a conversation with him/her

 

I also very like this POI - when I firstly saw this lightshow I was totally blown away

 

And yes - some of the CP-POI's are very challenging ;)

 

 

anyway thx for the feedback

 

have fun

 

- - - Updated - - -

 

i have linked the pack in the NitroGen thread.

I can add the CompoPack 41 prefabslists to the dropdown soon, so it has the most current official one.

 

thx Damocles - the actual version is COMPOPACK42 now

(somebody has stolen the xvanilla-files from ma COMPOPACK41-folder LOL - damn NSA XD)

 

cheers

Share this post


Link to post
Share on other sites
Simply go to cp40 and grab the xvanilla prefabs as I doubt mags did any work on them he hasn't already done. And also what one Is and all is good

 

Thanks, all works now, as expected :-)

Share this post


Link to post
Share on other sites

Good Day Maqolis ..

 

Question .. Can your " CompoPack 42 " be Added on top of COMPOPACK 40 ? and just let it overwrite any existing files.

 

I using your 40 right now and not having any issues with it .. other than the normal rotation maybe in the wrong direction, but not on that many.

I asked Damocles .. since I use " Nitrogen " for All my map making .. but Damocles said to check with you.

 

Just wondering .. the Old Gamer …

 

And as always .. Have Fun and Enjoy

Share this post


Link to post
Share on other sites
Good Day Maqolis ..

 

Question .. Can your " CompoPack 42 " be Added on top of COMPOPACK 40 ? and just let it overwrite any existing files.

 

I using your 40 right now and not having any issues with it .. other than the normal rotation maybe in the wrong direction, but not on that many.

I asked Damocles .. since I use " Nitrogen " for All my map making .. but Damocles said to check with you.

 

Just wondering .. the Old Gamer …

 

And as always .. Have Fun and Enjoy

 

yes - u can overwrite the existing prefabs with the CP42-prefabs and still be able to play ur CP40-map

 

The new Prefabs ofc will not show up then

 

The prefabs that already has been spawned will stay like they are

 

In unexamined regions the newcopied prefabs will spawn

Share this post


Link to post
Share on other sites
yes - u can overwrite the existing prefabs with the CP42-prefabs and still be able to play ur CP40-map

 

The new Prefabs ofc will not show up then

 

The prefabs that already has been spawned will stay like they are

 

In unexamined regions the newcopied prefabs will spawn

 

Thank you for the Reply .. I was thinking, while playing on my existing map .. would it be better to Start on a Fresh Map with the update files .. I have NO problem starting a New Game, do it all the time.

 

Thank you and have a great weekend .. the Old Gamer … :02.47-tranquillity:

 

edit: PS .. I just deleted all my world maps .. except current 10k that I have been playing and updated prefab files with CompoPack 42 and rwgmixer file. (Only have explored maybe 5% of current map, so should be good) .. if I have an issue _ I will just start a new one .. Thank you for all your hard work putting this together _ I haven't seen some of these building in ages.

Edited by gpcstargate (see edit history)

Share this post


Link to post
Share on other sites
thx sir Stalli ;)

 

I have noticed the Issue u r talking about in many other POI's since A18 - last time just 30 mins ago in xcostum_pagoda_sm(by_Magoli) in my newest survival world testing gameplay

 

Also saw this terrain-Pillar in skyscaper(by_Peppino) and in Volars Superstore

 

ofc I checked the prefabs in every case - but I really saw no Issues in Pilles editor

And on another place these prefabs just spawn fine (within the same map !)

 

IMO there is something wrong with the rwg-world-generation at all !!!

(It also happens when I use Nitrogen-maps)

 

 

oh - btw: I play the examplemap right now - and really love how the landscape, streets and towns looks like - very amazing

 

I spawned near an Asia-town - It looks very realistic and natural - absolutely great

 

Damocles is a magician - Nitrogen is a very superb tool !

 

IMO COMPOPACK41 has the best looking world I ever saw (when generated with Nitrogen and with my configUI) - even better than A15 !!!

 

Congrats Mags!!!! Hopefully Nitrogen is helping you realize your world vision with the compo pack. 😎👍

Share this post


Link to post
Share on other sites
i have linked the pack in the NitroGen thread.

I can add the CompoPack 41 prefabslists to the dropdown soon, so it has the most current official one.

 

Hi, love the work you both do! One question and I apologize if I missed a step or thread... Has adding 42 been done to Nitrogen? I do the pull down and see 39 as the pack I can choose... I downloaded the latest NitroGen this am... I may be jumping the gun and if so, my bad.. :)

Share this post


Link to post
Share on other sites

I will add the CompoPack 42 list natively to NitroGen in the next update.

You can just drop the one from CompoPack into NitroGens resources folder for now.

Share this post


Link to post
Share on other sites
Hi, love the work you both do! One question and I apologize if I missed a step or thread... Has adding 42 been done to Nitrogen? I do the pull down and see 39 as the pack I can choose... I downloaded the latest NitroGen this am... I may be jumping the gun and if so, my bad.. :)

 

Hasn't been added to nitrogen yet. Simply copy the contents of cp42 and past over the cp section in nitrogen/resources/prefablist_compopack.txt then rename to prefablist.txt

Share this post


Link to post
Share on other sites

Ok, the newest CompoPack prefabslist is now in NitroGen v0.474

 

Still check for future changes to CompoPack to have the most up to date version, and replace it if necessary.

Share this post


Link to post
Share on other sites
I will add the CompoPack 42 list natively to NitroGen in the next update.

You can just drop the one from CompoPack into NitroGens resources folder for now.

 

Thanks everyone for the info!

Share this post


Link to post
Share on other sites

Damocles, I love ur work and have been using it in my server

 

unfortunately today I updated as I'm about to wipe my server, and I can't generate a map with "border biome : none"

 

can you check this later, please?

Share this post


Link to post
Share on other sites
Damocles, I love ur work and have been using it in my server

 

unfortunately today I updated as I'm about to wipe my server, and I can't generate a map with "border biome : none"

 

can you check this later, please?

 

Just checked version 0.474 , border biomes 'none' worked fine for me.

It just skips adding a specific biome around the border, keeping the original biomes.

 

What part is not working for you?

Share this post


Link to post
Share on other sites

just got that bug you where talking about with earth instead of air tiles in one prefab.... actualy, not sure if bug, the whole Prefab looks wired, so could be intentional :D

 

Screen of the prefab:

20191201135453_1.thumb.jpg.84ea55ef4290c425b2f96108226dec5d.jpg

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...