Jump to content

Compo-Pack for Random Gen


Magoli

Recommended Posts

I just tested and it still works P2P. The only thing I noticed was that LOD distant models aren't present. If you have your view distance set to high, you'll rarely notice. I had to back up pretty far before seeing the buildings pop out of existence. This may be happening on a dedicated server too and I may never have noticed, because I do keep my view distance set to maximum. Even so, I feel it's worth it to have the added variety of prefabs. A couple years ago, the game didn't even have LOD models and we all got along just fine :)

Link to comment
Share on other sites

I recon this will take some serious time & effort as I got the old version to run without errors but its messy as I dont have the time to spend sorting out each prefab so I cheated & loaded up each file saving it after it errors, replacing all dodgy blocks lol.. Cant play this game without the Magoli pack..... Just not happening haha

Link to comment
Share on other sites

UPDATE-TIME :)

 

COMPOPACK_39(for Alpha18_exp_built143) is out now !!!

 

 

after 10 days working on it its done - CP has arrived A18 now

 

mainthing was to bring the prefabs from A17 to A18 and do the blockconverting.

But I have made some cool improvements that makes the variety and the look of the towns even better

 

to get it go to the FIRST-POST

 

here are the Changes in detail:

 

changelog CP39:

 

A17 work:

 

- repaired xcostum_CityPark(by_Spider) changed cabinettextures to stonetextures

- repaired xcostum_nepa_base(by_Eihwaz) (changed yoffset to -2 and copyairblocks=True)

 

*********************************************************************************************************************************************

 

- EXECUTED CONVERTION FROM A17 to A18 !!!

(62 blocks has changed/namechanged or removed - thx Pille for the whole work on the Conversation)

 

 

***********************************************************************************************************************************************

 

A18 work:

 

(work in build 139):

 

- removed prefab: xvanilla_cornfield_md

- removed prefab: xvanilla_cornfield_sm

- removed prefab: xvanilla_potatofield1

- renamed xvanilla_army_camp(universal) to xcostum_army_camp(universal)

- renamed xvanilla_Trailerhousemix01 to xcostum_Trailerhousemix01

- renamed xvanilla_Trailerhousemix02 to xcostum_Trailerhousemix02

- renamed xvanilla_Trailerhousemix03 to xcostum_Trailerhousemix03

- renamed xvanilla_Trailerhousemix04 to xcostum_Trailerhousemix04

 

- took over all relevant A18-Vanilla-Prefabs that can spawn in RWG (amount of 335) - new prefix: xvanilla_

(because of nasty waterblock-bug and xml-modifications that are needed for better spawning (Allowed Township / Allowed Zone / Allowed Biome)

 

- changed block257 : waterMovingBucket to block 256 : terrWaterPOI (in all prefabs)

- changed block258 : waterMovingBucket to block 256 : terrWaterPOI (in all prefabs)

- changed block259 : waterMovingBucket to block 256 : terrWaterPOI (in all prefabs)

- changed block260 : waterMovingBucket to block 256 : terrWaterPOI (in all prefabs)

 

replaced missing waterblock (id256) in following prefabs:

"vanilla_abandoned_house_08.tts"

"vanilla_cabin_11.tts"

"vanilla_cave_01.tts"

"vanilla_cave_02.tts"

"vanilla_factory_lg_02.tts"

"vanilla_hotel_new_01.tts"

"vanilla_hotel_roadside_02.tts"

"vanilla_house_modern_04.tts"

"vanilla_house_old_ranch_03.tts"

"vanilla_oldwest_business_04.tts"

"vanilla_oldwest_watertower.tts"

"vanilla_remnant_house_02.tts"

"vanilla_school_k6.tts"

"vanilla_skyscraper_01.tts"

"vanilla_utility_waterworks_01.tts"

"vanilla_water_tower_01.tts"

"vanilla_water_tower_02.tts"

"vanilla_water_tower_03.tts"

 

 

(work in build 143):

 

- exchanged all old xvanilla_ xml's with the new better b143-versions

- exchanged prefab xvanilla_house_old_pyramid_02 with better new b143-version

- exchanged prefab xvanilla_settlement_trader_04 with better new b143-version

 

- generated the new stats xml-entry for every CP-prefab

 

- fixed b143vanilla bug in xvanilla_bombshelter_lg_01.xml (removed ""-Sleeper-Entries) (vanillab143bug!)

 

- repaired block256 : terrWaterPOI - reset Rotation and Meta to 0 (in all Prefabs) (vanillab143bug!)

- repaired block1 : terrStone - reset Rotation and Meta to 0 (in all Prefabs)

- repaired block2 : terrainFiller - reset Rotation and Meta to 0 (in all Prefabs)

- repaired block5 : terrDirt - reset Rotation and Meta to 0 (in all Prefabs)

- repaired block6 : terrForestGround - reset Rotation and Meta to 0 (in all Prefabs)

- repaired block7 : terrBurntForestGround - reset Rotation and Meta to 0 (in all Prefabs)

- repaired block15 : terrDestroyedStone - reset Rotation and Meta to 0 (in all Prefabs)

- repaired block17 : terrGravel - reset Rotation and Meta to 0 (in all Prefabs)

- repaired block18 : terrAsphalt - reset Rotation and Meta to 0 (in all Prefabs)

- repaired block19 : terrConcrete - reset Rotation and Meta to 0 (in all Prefabs)

- repaired block0 : air - reset Rotation and Meta to 0 (in all Prefabs)

 

- exchanged block2065 : cntShoppingBasketEmpty to block2067 : cntShoppingBasketRandomLootHelper (in all Prefabs)

- exchanged block2066 : cntShoppingBasket to block2067 : cntShoppingBasketRandomLootHelper (in all Prefabs)

- exchanged block2062 : cntShoppingCartEmpty to block2064 : cntShoppingCartRandomLootHelper (in all Prefabs)

- exchanged block2063 : cntShoppingCart to block2064 : cntShoppingCartRandomLootHelper (in all Prefabs)

- exchanged block2091 : cntBackpack01 to block2111 : cntBagsRandomLootHelper (in all Prefabs)

- exchanged block2093 : cntBackpack03 to block2111 : cntBagsRandomLootHelper (in all Prefabs)

- exchanged block2094 : cntDuffle01 to block2111 : cntBagsRandomLootHelper (in all Prefabs)

- exchanged block2095 : cntSportsBag01 to block2111 : cntBagsRandomLootHelper (in all Prefabs)

- exchanged block2096 : cntSportsBag02 to block2111 : cntBagsRandomLootHelper (in all Prefabs)

- exchanged block2097 : cntPurse01 to block2111 : cntBagsRandomLootHelper (in all Prefabs)

- exchanged block2098 : cntSuitcase to block2111 : cntBagsRandomLootHelper (in all Prefabs)

 

- removed file from prefabsfolder: xvanilla_hospital_02.ins (vanillab143bug!)

- removed file from prefabsfolder: xvanilla_house_new_mansion_03.xml (vanillab143bug!)

 

- added new prefabs:

xcostum_7EndStore(by_Jackelmyer)

xcostum_Adam_House_Z1(by_DMC)

xcostum_CanucksCoffee(by_Genosis)

xcostum_Dave_Home_2(by_DMC)

xcostum_InsaneAsylum(by_Genosis)

xcostum_IZEA_market(by_Genosis)

xcostum_Lost_Joels(pseudo-trader)(by_DMC)

xcostum_QuietPinesSpecial(by_hernan)

 

- reworked all xvanilla-xml's again

 

 

rwgmixer:

 

in principe the structure of the CP-RWGMIXER is still the same like CP38

there is still the multiple-township-system with 9 different townships i brought to the CP in A17 - but its much more improved now

And the mainpoint is that A18-RWG generaly seems to work like it should (very less errors or wierd creations)

As you know the A18-RWG-maps are generated as Islands now. So also the CP39-RWG-maps will spawn as Islands !

 

 

- removed/renamed the old xvanilla_ - poi's

- implemented all vanilla-pois to be xvanilla_-poi's now (also the new A18-prefabs)

- made all relevant changes on the wilderness-traders (min_repeat_distance="500" so about every 500blocks should be a trader now)

- set sizes to all several townships (but seems to not work - it has simply no effect - the towns are as big like they would, totally randomly

IMO its not possible to bind a specific township to a specific size !!! this is bad !!!

this means that sometimes townships with a low amount of prefabs (e.g. Asiatown) are suddenly forced to spawn in a hub that is to big to get all sockets filled ==> empty spots in towns)

- changed waterlevel from 43 to 45

 

 

thats all - have fun - give feedback!

 

Magoli

2019-10-16

  • Like 1
Link to comment
Share on other sites

Might be me but server spewing errors:

2019-10-17T06:54:31 1757.572 ERR Prefab loading failed. Prefab 'xvanilla_snowy_ski_lodge' does not exist!

2019-10-17T06:54:31 1757.576 ERR Prefab loading failed. Prefab 'xvanilla_oldwest_graveyard' does not exist!

 

And again! Thank you Magoli!!!!!!!!!!!

Link to comment
Share on other sites

Might be me but server spewing errors:

2019-10-17T06:54:31 1757.572 ERR Prefab loading failed. Prefab 'xvanilla_snowy_ski_lodge' does not exist!

2019-10-17T06:54:31 1757.576 ERR Prefab loading failed. Prefab 'xvanilla_oldwest_graveyard' does not exist!

 

And again! Thank you Magoli!!!!!!!!!!!

 

Opps! Looks like TFP changed a tonne of prefabs, or at least the naming of them:

house_new_02

house_new_03

house_new_04

house_new_06

houseburnt1

houseburnt2

houseburnt3

houseburnt5

houseburnt3b

house_new_mansion_01

Are missing in this RWG.

 

Then these are apparently missing:

xvanilla_Trailerhousemix01

xvanilla_Trailerhousemix02

xvanilla_Trailerhousemix03

xvanilla_Trailerhousemix04

 

Imgur link

 

MY BAD! I think I was trying to do too much! Might have had the wrong rwgmixer lol

Edited by Cadamier (see edit history)
Link to comment
Share on other sites

Is anyone else getting islands?!?

 

like Guppy said: Its the A18-RWG

 

 

@all:

I really Recommend to read the OP and maybe also the CP-Changelogs ;)

 

Once again I have to say Iam ok with the Idea of the Island, because of 2 reasons:

1. The world itself looks good and there is still a plenty of space to play around with.

2. If there must be a border somewhere I really dont care how it looks like (as long its not invisible wall - that would suck!).

(a beach to the endless ocean or an area that nobody can do something with and suddenly begins invisibly ??? Choose urself fellas!)

 

what do you guys think about the new CP-RWG ? (except the bordering ! Are there no other much more important topics atm ???)

 

3 things I have say about CP-RWG since I had some serious gameplay:

 

1. There are some bridges across Rivers in A18-RWG right now - thats amazing

2. There is still a problem with the wilderness-POI's - some of the wilderness-paths ends in empty slots (no POI is spawned!)

Could be the big Prefabs that have problems to spawn - gonna have an eye on this.

3. I saw some block-Issues in some of the old-CP-prefabs (misrotated blocks / Lootcabinets in corners / wrong materials for walls and surfaces) They are noticed and I will fix them in the next update

 

 

thats all for now

cheers

 

 

btw: the "Mild Anemia"-Bug sucks !!! I hope the 0.0 buff disappears when I respawn after death !!

Link to comment
Share on other sites

Hey Magoli,

 

 

Love the pack, however I'm getting some strange behavior on generations, willing to admit this could be something I'm doing or have done wrong.

 

Using a Dedicated server hosted through bluefang

 

Completely wiped the server files and rebuilt the library,

 

Added the compo pack prefabs to the folder and replaced the RWG mixer.

 

the world is generating fine, however every building appears to be STUFFED completely full of black wool like blocks that break in huge sections with 1 attack see attached:

 

20191020021827_1.thumb.jpg.9eb92d8d009feb3ce0c4302305bad7ca.jpg

 

20191020021759_1.thumb.jpg.a280d2f9bd2d6440ec2e17bb39dd2bc7.jpg

 

20191020021812_1.thumb.jpg.e31764203451fd00b419a7690c248e9d.jpg

 

 

 

Quite weird behavior, not sure if anyone else has gotten this?

'

Link to comment
Share on other sites

Magoli, have you tried the Nitrogen world generator tool? The worlds and cities are so much better than vanilla. Someone had your pack working with it in A17 and it was amazing

 

Hi - sry for the late answere, but i was so in love playing the new A18-CP-RWG ;)

 

yeah - ofc I tried Nitrogen in A18 and yes, ofc I played around with it.

But I dicided to go with the RWGMIXER instead of NITROGEN in A18 !!!

 

I seriously thought back and forth and back and forth which generator would generate the better world for CP !?

 

Every Generator has its own pro's and con's - non of them is really perfekt !!!

(best would be a mix between both of them - LOL)

 

yes u are right, the towns look amazing in Nitrogen - but there is only this one township over and over across the map

With RWGMIXER I have the ability to make different towntypes that surely differs from each other.

 

the rural farms in Nitrogen are also looking very nice and I really love them - but these also every time look alike the same.

 

 

There are much more points to tell about, but I will finish here...

 

 

...finally I decided to use the RWGMIXER, because I really have more control over the Generation. The biggest decision-point for me was the Ability to use the multiple-township-system I wrote for the RWGMIXER. My goal was (and will ever be) to deliver a world in which every town differs to each other. Also my goal is to have every single POI just one single time on the map and also some towns that follow a speciffic Theming (like Asiatown, HillBillyVillage, big City with huge buildings and skyscrapers, or just a common OR modern town ... )

 

If these points are fullfilled not only one town is looking amazing, but also all towns and POI's on the whole map do.

And with RWGMIXER Iam actally closer to that concept of "The perfect map" IMO

 

but maybe when there will be more functions and features in NITROGEN in future I decide its better to use that for COMPOPACK.

 

 

I didnt scratched the surface - there so much more to talk about when it comes to world-Generation, but I hope u understand now y it is like it is

Edited by Magoli (see edit history)
Link to comment
Share on other sites

Hey Magoli,

 

 

Love the pack, however I'm getting some strange behavior on generations, willing to admit this could be something I'm doing or have done wrong.

 

Using a Dedicated server hosted through bluefang

 

Completely wiped the server files and rebuilt the library,

 

Added the compo pack prefabs to the folder and replaced the RWG mixer.

 

the world is generating fine, however every building appears to be STUFFED completely full of black wool like blocks that break in huge sections with 1 attack see attached:

 

[ATTACH=CONFIG]29939[/ATTACH]

 

[ATTACH=CONFIG]29940[/ATTACH]

 

[ATTACH=CONFIG]29941[/ATTACH]

 

 

 

Quite weird behavior, not sure if anyone else has gotten this?

'

 

"...every building..." ????

 

Have u installed other mods ?

Do u have a modified blocks.xml ?

 

The first screenshot is the one of the new Custom-POI's: the 7end-store

 

Sadly I have made no serious gameplay-test with all of the new Custom-prefabs.

I just quick flew over and through the POI's to check for any visuall strangers.

All I know is that the blocks are regular and they are spawning fine in RWG and dont give Redmsgs in the console.

 

 

So technically they are all fine - but I didnt do any material checks for the new customPOIs and also dont know how they behave in real survival.

 

It looks like these blackwoolblocks in the bottom-pics are awning-blocks with some black texture IMO - but not sure

 

 

thx for the feedback

actual Iam doing a serious RWG-survival myself atm and ALL Prefabs I met are working fine and behave like they should.

I havent meet the 7end-POI in my actual gameplay. But when I will check out whats all about these blackwoolblocks.

Link to comment
Share on other sites

hi guys

 

just a few quick infos:

 

COMPOPACK_39(for Alpha18_exp_built143) is also compatiple with built_152 !!!

 

 

During my gameplay I saw some POI's that seems to spawned 180 degrees misrotated

this means they are facing with the back to the street

I will follow that and will give a report when I know more.

 

 

Also I think the traders could have more distance between them

Actually they have a minimum-repeat-distance of 500m

(and it seems the rwg-engine will use that as a guide! - so EVERY 500m in every direction RWGengine tries to place a trader in wilderness)

 

In the next tests I will increase the minimum-distance of traders from 500m to lets say 700m !!!

 

what do u guys think about the density of traderposts on the CP-RWG-world ???

Edited by Magoli (see edit history)
Link to comment
Share on other sites

"...every building..." ????

 

Have u installed other mods ?

Do u have a modified blocks.xml ?

 

The first screenshot is the one of the new Custom-POI's: the 7end-store

 

Sadly I have made no serious gameplay-test with all of the new Custom-prefabs.

I just quick flew over and through the POI's to check for any visuall strangers.

All I know is that the blocks are regular and they are spawning fine in RWG and dont give Redmsgs in the console.

 

 

So technically they are all fine - but I didnt do any material checks for the new customPOIs and also dont know how they behave in real survival.

 

It looks like these blackwoolblocks in the bottom-pics are awning-blocks with some black texture IMO - but not sure

 

 

thx for the feedback

actual Iam doing a serious RWG-survival myself atm and ALL Prefabs I met are working fine and behave like they should.

I havent meet the 7end-POI in my actual gameplay. But when I will check out whats all about these blackwoolblocks.

 

Aye it appears to be all POI's I thought it was maybe just the custom at first, then I checked a default mansion that spawned as well as a Dishong tower, filled, to the brim, with the blocks.

 

As I said new server wipe, 3 experimental builds had passed since I updated so I decided it was time.

 

Wiped everything but the server config file, re added my mods folder with currently only 1active mod currently, which is the smart stash buttons mod for A18 qs a quality of life, then the compo pack.

 

Server loaded up and generated fine, tried a few seeds to get a good world gen, then decided to check out a couple POI's before re opening yo the public which is when I noticed the odd behavior.

Link to comment
Share on other sites

Nuked the server installation and am rebuilding again, will let you know if I experience the issue again.

 

Same issue, full re install, simply modified my Config XML and Progression XML.

 

Did notice that I had generated 1 world prior with no issues but had forgot to switch the RWG Mixer file, the next time after I deleted the save and switched the file, it generated with the black block issue again.

Link to comment
Share on other sites

Silly question - I am new to playing anything outside vanilla. I added the combo pack and it is great - however a couple things I noticed and wondering if I can change.

 

1) I have a street with about 8-10 7 End stores in a row. Can you change the number that will spawn in each location?

 

2) some POI’s are really imbalanced- anyone know how/which can be removed that are too imbalances? One was very amazingly built and beautiful - but it had all the needed tables, saw, mixers, etc plus enough concrete/rocks to get you through - just a bit to good if you want a challenge.

Link to comment
Share on other sites

Silly question - I am new to playing anything outside vanilla. I added the combo pack and it is great - however a couple things I noticed and wondering if I can change.

 

1) I have a street with about 8-10 7 End stores in a row. Can you change the number that will spawn in each location?

 

2) some POI’s are really imbalanced- anyone know how/which can be removed that are too imbalances? One was very amazingly built and beautiful - but it had all the needed tables, saw, mixers, etc plus enough concrete/rocks to get you through - just a bit to good if you want a challenge.

 

to 1:

this should not happen - maybe u had a very bad seed or something went wrong during rwg-generation

 

to 2:

I need the name or a discribtion of the prefab or even better picture pls

 

- - - Updated - - -

 

Nuked the server installation and am rebuilding again, will let you know if I experience the issue again.

 

I have checked now the 7end-store in 2 different locations

I dont see any blackwoolblocks in none of the prefabs.

 

must be somewhere on ur side with the server-config or the other mod

Link to comment
Share on other sites

Silly question - I am new to playing anything outside vanilla. I added the combo pack and it is great - however a couple things I noticed and wondering if I can change.

 

1) I have a street with about 8-10 7 End stores in a row. Can you change the number that will spawn in each location?

 

2) some POI’s are really imbalanced- anyone know how/which can be removed that are too imbalances? One was very amazingly built and beautiful - but it had all the needed tables, saw, mixers, etc plus enough concrete/rocks to get you through - just a bit to good if you want a challenge.

 

Farmer joes maybe lol. Does it look like a landscaping business glass walls etc

Link to comment
Share on other sites

to 1:

this should not happen - maybe u had a very bad seed or something went wrong during rwg-generation

 

to 2:

I need the name or a discribtion of the prefab or even better picture pls

 

- - - Updated - - -

 

 

 

I have checked now the 7end-store in 2 different locations

I dont see any blackwoolblocks in none of the prefabs.

 

must be somewhere on ur side with the server-config or the other mod

 

 

 

I don't really know what to say, simply changing the server settings for static Zombies or Progresson points in the XML to 2 per level 9isn't going to cause that.

 

I rebuilt from a fresh install 4 times, I'm running no other mods.

 

The last time I rebuilt it did it again with the RWG Mixer, I took the RWG back out and used the default and regenerated and it didn't happen. It wasn't simply the 7 end POI, it was every POI with available space inside filled to the brim.

 

For now, I'm not sure why but it doesn't work correctly on my dedicated server. I'd be happy to give you info off a fresh generation and let you run around and see what I'm talking about at some point.

Link to comment
Share on other sites

  • Roland locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...