Jump to content

Compo-Pack for Random Gen


Recommended Posts

There is no download link available? IS this collection no longer available? I can change or add the textures myself, but I can't do anything if I can't download the files. I will have to see if compopack31 will work and what changes I need to make to get it to work...

 

EDIT after tinkering with available files.

I kind of got it working...

First I downlaoded and installed COMPOPACK_31(for_alpha16.4)

 

Then I downlaoded and installed...

https://www.dropbox.com/s/nr9eu8ac6z...12-15.zip?dl=0

 

It's working but with the errors that SandyBeaches modlet was supposed to fix. The modlet is not changing anything that I can tell.

 

For the SandyBeaches fix I downloaded and installed the modlet from https://drive.google.com/file/d/1d04...ew?usp=sharing

to fix the fridge problem, and downloaded and installed

https://github.com/Sandy-Beaches/ComboPack

 

But still I am getting the errors on the trash compactor and fridge... Works, but the fridge and trash compactor are just standard metal gray blocks.

 

[ATTACH=CONFIG]26454[/ATTACH]

 

Edit - Last for dec, 20.

 

Ran out of time to try to change the references in the mod or try to get the mod to work. If nothing is done by tomorrow, I will try to fix them then. Was really hoping to play tonight, but just not going to happen with the constant red-line errors.

 

Because mags is currently updating the mod. It takes time and once he is done there be a dl link available. But with any mod that don't work dl link is removed

Edited by stallionsden (see edit history)
Link to post
Share on other sites
Because mags is currently updating the mod. It takes time and once he is done there be a dl link available. But with any mod that don't work dl link is removed

 

Are you sure about that? Considering he said -

 

I have to do about 30 blocks to texturechange with all prefabs

this will take a while - i think 2-3 days

 

I think that means he won't be uploading anything until the 23rd. Though, it is Christmas time and I would hope that he would be enjoying his holidays rather than busting his butt to fix his awesome prefab pack. I wouldn't expect it until January 3rd at the earliest. Which is fine, he shouldn't have to feel like he has to get it done sooner, or at all for that matter.

 

He has a section with links to old versions of the files, but it stops at 31. I'm just saying... he could add the 34 to the old versions downloads and just go off and enjoy his holidays and New Year, then come back to it when he's refreshed and relaxed. But, since I posted the previous info, people can get close to the 34 version and just tinker with the files and textures themselves to fix the errors.

Link to post
Share on other sites
Are you sure about that? Considering he said -

 

 

 

I think that means he won't be uploading anything until the 23rd. Though, it is Christmas time and I would hope that he would be enjoying his holidays rather than busting his butt to fix his awesome prefab pack. I wouldn't expect it until January 3rd at the earliest. Which is fine, he shouldn't have to feel like he has to get it done sooner, or at all for that matter.

 

He has a section with links to old versions of the files, but it stops at 31. I'm just saying... he could add the 34 to the old versions downloads and just go off and enjoy his holidays and New Year, then come back to it when he's refreshed and relaxed. But, since I posted the previous info, people can get close to the 34 version and just tinker with the files and textures themselves to fix the errors.

 

You don't know mags lol. He is dedicated and I near guarantee he will have the next version out when he states. Known mags a long time he don't know what a break is haha. So yes I am sure of it

Link to post
Share on other sites

yes - ur right guys its time for a update

 

COMPOPACK_35(for Alpha17exp_b233) is out now !!!

 

this Release is just a hotfix for b233 - everythings works now fine again

 

to get it go to the OP

 

here are the changes in detail:

 

CHANGELOG COMPOPACK_35:

 

changed block 1551 : cntFridgeBottom to 1549 : cntRetroFridgeRandomLootHelper

changed block 1550 : cntFridgeTop to 0 : air

 

changed texture 76 to 0 on block 508 : rWoodMetalWedgeTipStairs

changed texture 75 to 0 on block 362 : woodHalf

changed texture 76 to 0 on block 2158 : rConcretePillar50

changed texture 75 to 0 on block 2097 : rConcreteHalf

changed texture 75 to 0 on block 2099 : steelHalf

changed texture 76 to 0 on block 1509 : cntCabinetBottomRandomLootHelper

changed texture 76 to 0 on block 1508 : cntCabinetBottomFiller

changed texture 76 to 0 on block 777 : stainlessSteelWedgeStairs

changed texture 76 to 0 on block 1027 : stainlessSteelBlock

changed texture 75 to 0 on block 1027 : stainlessSteelBlock

changed texture 75 to 0 on block 468 : stainlessSteelHalf

changed texture 76 to 0 on block 468 : stainlessSteelHalf

changed texture 76 to 0 on block 1513 : cntGraniteSink

changed texture 76 to 0 on block 956 : rConcreteCTRpole

changed texture 76 to 0 on block 2107 : rConcretePillar100

changed texture 76 to 0 on block 1714 : cntMorticianDrawer

changed texture 75 to 0 on block 1718 : cntGreenDrawer

changed texture 76 to 0 on block 1718 : cntGreenDrawer

changed texture 75 to 0 on block 1508 : cntCabinetBottomFiller

changed texture 76 to 0 on block 508 : rWoodMetalWedgeTipStairs

changed texture 76 to 0 on block 952 : concreteCTRpole

changed texture 76 to 0 on block 1557 : cntTrashCompactor

 

repaired xcostum_Trailerhousemix03(by_SandyBeaches)

removed xcostum_Shoppingcenter(by_Tom) (out for Repair)

added CP35-prefabs to vanilla rwgmixer.xml (b233)

 

have fun

... and Merry Christmas

 

Magoli

2018-12-21

Edited by Magoli (see edit history)
Link to post
Share on other sites

Just generated a world, and its not compatible. BUT, seems like an easy fix as the only error I got was:

 

ERR Loading prefab "xcostum_storeset1(by_Guppycur)" failed: Block name to ID mapping file missing.

 

Unless it didnt use all prefabs in that worldgen of course.

Link to post
Share on other sites
Is this compatible with b238.........?

Merry Christmas :)

 

YES !!!

 

CP35 works also on build238

 

I could start a RWG-world without any Issues

 

- - - Updated - - -

 

Just generated a world, and its not compatible. BUT, seems like an easy fix as the only error I got was:

 

ERR Loading prefab "xcostum_storeset1(by_Guppycur)" failed: Block name to ID mapping file missing.

 

Unless it didnt use all prefabs in that worldgen of course.

 

ups - u are right - iam fixing it right now

 

pls do another dl in about 10 mins

Link to post
Share on other sites

I can post the ones that generated in the world i tried if you want, as those are apparently working atleast.

 

Edit: Just saw your post, so then that wouldnt be necessary :)

Edit2: Do you update the rwgmixer to the b238 one? It has some fixes to the excessive amount of rubble buildings being generated.

Edited by Quasimiyao (see edit history)
Link to post
Share on other sites
I can post the ones that generated in the world i tried if you want, as those are apparently working atleast.

 

Edit: Just saw your post, so then that wouldnt be necessary :)

Edit2: Do you update the rwgmixer to the b238 one? It has some fixes to the excessive amount of rubble buildings being generated.

 

yes - in a further update

 

for now its OK

the industrial-changes arent that powerful and overall there are the CP-prefabs excluded into the industrial-zone-spawning

so its ok for now

Link to post
Share on other sites

First of all, thx a ton for the updates to the pack, keeping it alive through the a17 builds :D

But I went through the b238 rwgmixer.xml comparing all of the vanilla stuff with yours and found a few changes from the b233 file in your pack. Nothing major, was the rubble changes, plus a few others (not just in industrial) had got new prob, count and min/max values. So I went ahead and made those changes to your rwgmixer.xml.

But as you said, it shouldnt make that much difference. I just know it would keep bugging me anyway lol :p

I'll share it here incase others want it too. Hope thats okay :)

 

[ATTACH]26496[/ATTACH]

rwgmixer_C35_b238.zip

Link to post
Share on other sites

Thanks for your work and for adding my prefab! You are doing a lot for the community.

 

I've done some modifications (V 1.2)

- the light show was way too agressive, even dangerous for epyleptics I guess... It should be alright now

- removed the zombie bear, a bit too much

- xml modifications (isolated spawn, on the good side of the road and in the forest biome)

 

You can download it in my thread when you want.

https://7daystodie.com/forums/showthread.php?99280-Rave-party-in-an-abandoned-factory

 

Cheers!

Link to post
Share on other sites
I've got a bug with randomgen, in the rwgmixer "max_count" is set to 1, but I've got 4 Notre-Dame next to each other in the same town...

Anyway to fix that?

 

its not my fault

 

we have this Issue during the whole complete alpha since rwg was introduced to the game.

Its a well known bug, but TFP don't react to that

 

fact is the engine that generates RWG dont follow the rules from the rwgmixer.xml most times

 

In addition to that IMO the prob-command also seems to not work probably

IMO it is very difficult to aim the right value for getting the wished effect

actual it was so in A16 - didnt have time to test this in A17 yet

 

the only chance I see atm is to increase the variety of possible prefabs to spawn (adding more prefabs to the CP)

 

I want u to remember that the rwgmixer.xml is still version 3.0

maybe the engine behind grew up a littlebit - but is still halfbaked

 

ok - case closed (again)

 

next topic:

 

what the hell TFP did with the RWG-world ???

The RWG-world looked so cute in b208 and now this ?????????????

since b233 the world-generation is a mess - esp. the street-generation and superespecially the density of POI's in the towns.

IMO it has something to do how they handled the problem with the floating Prefabs.

(btw. the Floating-Prefab-Issue is still not fixed in b238 !!!)

Since b238 the Town-prefabs are resting now on kinda even mounds (like the wilderness-POI's in A16)

This eats important spawning-space and causes prefabs to NOT spawn next to each other.

And overall it looks bad - check this out:

[ATTACH=CONFIG]26500[/ATTACH]

[ATTACH=CONFIG]26501[/ATTACH]

[ATTACH=CONFIG]26502[/ATTACH]

 

LOL

Link to post
Share on other sites
its not my fault

 

we have this Issue during the whole complete alpha since rwg was introduced to the game.

Its a well known bug, but TFP don't react to that

 

fact is the engine that generates RWG dont follow the rules from the rwgmixer.xml most times

 

In addition to that IMO the prob-command also seems to not work probably

IMO it is very difficult to aim the right value for getting the wished effect

actual it was so in A16 - didnt have time to test this in A17 yet

 

the only chance I see atm is to increase the variety of possible prefabs to spawn (adding more prefabs to the CP)

 

I want u to remember that the rwgmixer.xml is still version 3.0

maybe the engine behind grew up a littlebit - but is still halfbaked

 

ok - case closed (again)

 

next topic:

 

what the hell TFP did with the RWG-world ???

The RWG-world looked so cute in b208 and now this ?????????????

since b233 the world-generation is a mess - esp. the street-generation and superespecially the density of POI's in the towns.

IMO it has something to do how they handled the problem with the floating Prefabs.

(btw. the Floating-Prefab-Issue is still not fixed in b238 !!!)

Since b238 the Town-prefabs are resting now on kinda even mounds (like the wilderness-POI's in A16)

This eats important spawning-space and causes prefabs to NOT spawn next to each other.

And overall it looks bad - check this out:

[ATTACH=CONFIG]26500[/ATTACH]

[ATTACH=CONFIG]26501[/ATTACH]

[ATTACH=CONFIG]26502[/ATTACH]

 

LOL

 

Yes this issues have been around for ages as mags said. You can use max="1" remove all probs and min_counts from the rwgmixer and it should temp fix it.

 

MAGS

 

Maybe copy the rwgmixer of B208 with the roads and paste it in b238 rwgmixer paste over b238 road stuff see if that helps.

Link to post
Share on other sites
While walking around i saw alot less prefabs with this then i did without it.

 

Well except for the 5 traders in one area :)

 

I have the same issue, 8 traders within one kilometer of eachother, city/town gen seems fine, its just the rural roads with probably 95% vacant space, 4% that does generate are traders, the other 1% a mix between vanilla and comp mod poi's.

Link to post
Share on other sites
I have the same issue, 8 traders within one kilometer of eachother, city/town gen seems fine, its just the rural roads with probably 95% vacant space, 4% that does generate are traders, the other 1% a mix between vanilla and comp mod poi's.

 

Had the same problem you are describing before the mod. Cluster of traders in center and not much else.

Link to post
Share on other sites
  • Roland locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...