Jump to content

Compo-Pack for Random Gen


Magoli

Recommended Posts

I don't know if it's due to the pack but i can't enter the random gen world a second time it crashes when i load it.

 

idk what that could be

 

I don't think this has something to do with the pack

do u have other mods installed?

 

have u changed anything after ur last session?

 

dont forget the game is still experimental and still has tons of bugs atm

 

i recommend to reinstall game and pack again and then try if u can join the map

Link to comment
Share on other sites

Well it just seems i cannot play on RWG. But maybe i couldn't play RWG at all before installing the pack. I can't remember if i tried using RWG when it first cam out.

 

when you put the prefabs folder stuff in to game prefabs did you simply overwrite prefabs folder or did you open both up and copy compo pack prefabs to the game prefab folder. The latter one is what you needed to do. If you did the first one you will get errors and unable to enter the game due to the rwgmixer looking for prefabs that arent in the prefab folder anymore.

Link to comment
Share on other sites

please tell me if it works errorfree and without Issues for u guys !!!

 

have fun

Mag

 

It looks like there is xcostum_TheEstate(by_Ekk0) in the rwgmixer file, but your notes state "removed prefab xcostum_TheEstate(by_Ekk0) -(out of order for Rapairings)"

 

The file(s) is not present in the prefabs folder and it gives an error on server load "ERR Loading prefab "xcostum_TheEstate(by_Ekk0)" failed: Block name to ID mapping file missing."

 

server continues to run.

Link to comment
Share on other sites

All thanks and respects to ya, Mag, for doing the work of bringing this over to A17. Did not expect to see that happen so soon.

My impression after some quick fly-bys and fly-thrus: It sure is a messy business. Looks like even after doing conversions and whatever automated processes you come up with, there's still going to be some need for manual restauration. I'm up for doing some of that, when A17 has gone stable.

Link to comment
Share on other sites

It looks like there is xcostum_TheEstate(by_Ekk0) in the rwgmixer file, but your notes state "removed prefab xcostum_TheEstate(by_Ekk0) -(out of order for Rapairings)"

 

The file(s) is not present in the prefabs folder and it gives an error on server load "ERR Loading prefab "xcostum_TheEstate(by_Ekk0)" failed: Block name to ID mapping file missing."

 

server continues to run.

 

thx for this important bug-report - I will fix it and Release a new version soon

 

 

@Stallionsden:

thx for the Response and help - Iam looking forward to it

Link to comment
Share on other sites

UPDATETIME !!!

 

COMPOPACK_33(for Alpha17exp_b208) is out now !!!

 

to get it go to the OPENING-POST

 

I have fixed just 1 bug - but it was a nasty bug:

 

 

Changelog COMPOPACK_33:

 

removed line 664 in rwgmixer.xml:

<prefab name="xcostum_TheEstate(by_Ekk0)" max_count="1" prob="0.3" />

 

this caused a redMsg in Console because prefab is currently not in the pack (thx to Dracos99)

 

 

 

!!!! PLEASE DONT USE COMPOPACK32 ANYMORE !!!!

Link to comment
Share on other sites

All thanks and respects to ya, Mag, for doing the work of bringing this over to A17. Did not expect to see that happen so soon.

My impression after some quick fly-bys and fly-thrus: It sure is a messy business. Looks like even after doing conversions and whatever automated processes you come up with, there's still going to be some need for manual restauration. I'm up for doing some of that, when A17 has gone stable.

 

yes - ur right

thanks for the help - i really appreciate that

maybe u could grab the Ones u have made first to make them great again

Link to comment
Share on other sites

IMPORTANT!

 

You have marked prefabs as able to do quests (clear,fetch,hidden_cache) without adding the necessary blocks to support them, causing any quests that spawn to be bugged and unable to be completed.

 

All 3 NEED a 'QUESTRALLYMARKER' to exist somewhere in the prefab (the big ! that starts the quest)

fetch and hidden_cache NEED at least one '= Quest Loot = Random Helper' to exist somewhere in the prefab. It doesn't matter where, you could stick it on the roof or outside. If multiples exist (the preferred option going by funpimp prefabs), the extras will be swapped for normal loot.

 

 

They also need other things to work and I don't know what yet.

 

 

Possible values of QuestTags (from the .dll) are: none, quest, trader, clear, fetch, hidden_cache

Edited by SandyBeaches
removed false information. whoops (see edit history)
Link to comment
Share on other sites

I apologise for the double post but I have redone xcostum_Firestation(by_Slick50)

 

xcostum_Firestation(by_Slick50).jpg.2968694a0f56498a73b058b285819b90.jpg

All windows updated to new blocks!

Loot Redone!

New decorations!

All prefab painted!

New sleeper volumes, including rooftop vultures and loot room boss!

Sarcastic anarchic post apocalyptic art installation!

Water! (Now with pipes!)

Retracting front doors!

Minor dungeon path!

Meditent on roof with Fun and Games!

Jumpscares!

and more.

 

Download now - >[ATTACH]26139[/ATTACH]

xcostum_Firestation(by_Slick50).zip

Link to comment
Share on other sites

I apologise for the double post but I have redone xcostum_Firestation(by_Slick50)

 

[ATTACH=CONFIG]26138[/ATTACH]

All windows updated to new blocks!

Loot Redone!

New decorations!

All prefab painted!

New sleeper volumes, including rooftop vultures and loot room boss!

Sarcastic anarchic post apocalyptic art installation!

Water! (Now with pipes!)

Retracting front doors!

Minor dungeon path!

Meditent on roof with Fun and Games!

Jumpscares!

and more.

 

Download now - >[ATTACH]26139[/ATTACH]

 

thanks

It looks very nice - I will take a walkthrough soon and add this to the next Release

 

to ur previous post:

yes - ur right - thanks for the tipps how to do it - I didn't watched for it in detail yet. But I knew POI-quests have to be balanced in some way.

Next COMPOPACK will have full support of POI-quests.

 

IMO its just fetch that is broken because of the target-bag not added.

burried chest and clear area should be fine. Iam gonna test this next.

 

thx for the feedback

Link to comment
Share on other sites

I apologise for the double post but I have redone xcostum_Firestation(by_Slick50)

 

[ATTACH=CONFIG]26138[/ATTACH]

All windows updated to new blocks!

Loot Redone!

New decorations!

All prefab painted!

New sleeper volumes, including rooftop vultures and loot room boss!

Sarcastic anarchic post apocalyptic art installation!

Water! (Now with pipes!)

Retracting front doors!

Minor dungeon path!

Meditent on roof with Fun and Games!

Jumpscares!

and more.

 

Download now - >[ATTACH]26139[/ATTACH]

 

It does not load in the ingame-POI-editor. I just get this REDMSG when I try to load it:

https://steamcommunity.com/sharedfiles/filedetails/?id=1586853132

 

this is strange because I had the same problems when I tried to load the ShoppingCenter from TopMinder.

 

It must to have something to do with the blocks.xml (or prefabs .min-file)

I use a clean unmodified vanilla blocks.xml - Vanilla-Prefabs loading fine - Cp-Prefabs loading fing fine

I also have trouble to load these Prefabs in Pille's editor - it just shows air-blocks with some textures

 

Something is really strange here - But I don't know whats the solution here

 

Question to U and TopMinder:

 

Do u use a modified blocks.xml ???

From where have u got the origin-prefabs?? (from CP32 or somewhere else??)

have u converted the prefabs in any way??? (have u used the console's mapping-command ???)

have u loaded and saved the prefabs with Pille's editor or just loaded,build,and saved ingame ???

 

If we all use the same (vanilla-)blocks.xml it has something to do with the .nim-files !!!

Link to comment
Share on other sites

O.k, just removed all mods and tested it. Worked fine. Saved again with no mods and reupload.

 

btw, my next revival project will be that big empty plain building with the underground carpark, security check, the court rooms, and rooftop military.

[ATTACH]26150[/ATTACH]

 

as for the questions:

 

1) only by mods and am not including any mod blocks on the build.

(btw, *.nim stands for Name In Mapping, and if you open with a hex editor is literally just the block's name, and a 5 byte designation. It doesn't care what the blocks can do.)

2) CP33

3) Nope

4) Ingame.

xcostum_Firestation(by_Slick50).zip

Edited by SandyBeaches
answered the questions. (see edit history)
Link to comment
Share on other sites

O.k, just removed all mods and tested it. Worked fine. Saved again with no mods and reupload.

 

btw, my next revival project will be that big empty plain building with the underground carpark, security check, the court rooms, and rooftop military.

[ATTACH]26150[/ATTACH]

 

as for the questions:

 

1) only by mods and am not including any mod blocks on the build.

(btw, *.nim stands for Name In Mapping, and if you open with a hex editor is literally just the block's name, and a 5 byte designation. It doesn't care what the blocks can do.)

2) CP33

3) Nope

4) Ingame.

 

hi - thx for response

 

Ur prefab seems to be OK because others can load it without no problems - but not on my PC here

It seems the error is on my side here but I don't know what it could be.

 

I can load all Vanilla-prefabs without problems

I can load all CP-prefabs without no problems

But I can't load other new Prefabs (except I reinstall the game it seems)

 

I have to make a few tests to figure out whats going on here.

 

I have the slight opinion it has something to do with the ingame-editor and the way the prefabs are loaded and saved !

Something is secretly modifying and changing prefabs (.nim-file ?? / .ins-file ?? / maybe even blocks.xml ??) during the loading (maybe saving to) of prefabs in the ingame-POI-editor !!

Link to comment
Share on other sites

I just hope it isn't a localization issue.

 

 

 

 

Unfortunately, as of now prefabs can't be included in a modlet, just like localization.txt. We await the day...

 

I have no proper idea about how the modlets thing works, but I'd assume the prefabs.xml could be a modlet, while the prefab files still need to be added manually? Afaik they could remain in the folder no matter if the modlet is loaded or a different one or none at all?

Link to comment
Share on other sites

  • Roland locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...