Jump to content

Alpha 20.4 Stable


Recommended Posts

Hello everyone!

While the majority of the team is heavy at work on Alpha 21, we are excited to give you A20.4 b42 stable today!

 

Server owners will need to add/modify these 2 new properties in the serverconfig.xml. These filters will help players find your server.
 

<property name="Region"  value="NorthAmericaEast" />
Values must be one of the following:
NorthAmericaEast, NorthAmericaWest, CentralAmerica, SouthAmerica, Europe, Russia, Asia, MiddleEast, Africa, Oceania

<property name="Language" value="English" />
Values: Use any language name that your players would expect to search for. Should be the English name of the language, e.g. not "Deutsch" but "German". This is a filter name only and DOES NOT SET the language for players.

 

 If no region is entered on the server end, you will not be able to find the server.

 

For everyone who played EXP:

There is no change between b41 and b42, we just had to adjust the buildnumber.

 

A20.4 b42 changelog:

 

Added 

  • Language selection under Video > UI. Defaults to the platform's language (on Steam the language that is selected in Steam for the game, otherwise the host system's language)
  • EOS P2P networking for cross platform P2P games
  • Destroy area attacks partial blocks it moves into 
  • AI ApproachAndAttackTarget decreases path update rate at farther distances 
  • Path generation canceling on a new path request 
  • Cr console command u, utimed and ue parameters 
     

Changed 

  • Launcher on Windows now stores log files in %APPDATA%/7DaysToDie/logs folder
  • Screenshots are stored in <UserDataFolder>/Screenshots (i.e. the folder that also stores saves, e.g. on Windows %APPDATA%/7DaysToDie/Screenshots) 
  • Mods are now loaded from <UserDataFolder>/Mods (i.e. the folder that also stores saves, e.g. on Windows %APPDATA%/7DaysToDie/Mods) in addition to <game folder>/Mods. In a future build this will change to only load from that new location so no data is written/changed in the program folder at any time. 
  • Reduced sleeper volume attack target time 
  • Changed SkyManager to explicitly set shadowCustomResolution for the moon and sun lights based on the ingame "Shadow Distance" setting: 1k for Low/Medium, 2k for High, and 4k for Ultra/Ultra+. This gives more consistent results in terms of performance and fidelity when changing the setting, regardless of the user's output screen resolution. 
  • MacOS builds target x86_64 only for now until third party code supports M1 you can still run the game on M1 Macs with Rosetta, but you no longer manually have to enable it 
  • Reduced achievement goals for: Dying, PvP kills, game stage, and staying alive 
  • Favorite and history servers are now stored independently of Steam 
  • Removed display name from non-lootable produce baskets 
  • Improved path generation state switching and aborting 
  • Optimised SpeedTree shaders by multicompiling a version without FadeOut behaviour and automatically swapping to it whenever the FadeOut value is set to 1 (fully opaque). 

 

Fixed 

  • Giving the same command line argument to the dedi multiple times causes exception but no startup abort 
  • Errors in dedi config does not cause the server to immediately shut down after the errors are logged 
  • Client side NRE spam after kicking a player with ESC menu open 
  • Opening the map on a controller attempts to open On Screen Keyboard 
  • Vulture sleepers flapping when spawned 
  • Cases of falling into ground if chunk colliders reallocated during baking 
  • Rare invisible chunk colliders if changed and cleared during baking 
  • Drone's light doesn't affect player stealth 
  • Junk drone dye not applying to all tint parts 
  • Drone dye displays differently between clients and hosts  Dedi and P2P issues 
  • Only the first Drone Cargo Mod can be added by drag and drop 
  • Ranged actions doing tool belt notifies more than once per execute 
  • Sporadically vehicles can reload underground and get moved (IsChunkAreaCollidersLoaded check) 
  • Silly votes and actions conflict with each other. 
  • Activating quest marker at POI can reset adjacent POI 
  • Robotic turrets stop working when placed higher than where the player is standing 
  • Removed Unity Screen Selector option from game launcher as Unity does no longer support this 
  • 2 wheeled vehicles are very good at climbing vertical walls 
  • Zombie pathing/digging can fail/struggle when the player is too far underground 
  • Fixed shadow clipping bug in the SpeedTree8 shader by implementing Unity's SHADOW_CASTER macros to correctly handle shadow pancaking. 
  • Server list not updating the table when new data for an existing entry comes in 
  • Changing server list sorting did not apply until filters are changed or a new server shown 
  • Resetting filters in the server browser causes any filter fields that are min/max input only (like game days) to fail 
  • Playing doctor achievement triggers without proper requirements 
  • Billboard shapes had inconsistent harvest events 
  • Players can be damaged and rag dolled by vehicles on log in 
  • Treasure chest appears in the same spot as previously looted treasure chest. 
  • Occasional NullRef's when decapitating wolves, mountain lions and deer as client on dedicated server 
  • Typo with some repair lists using forged iron could not be repaired 
Edited by Hated (see edit history)
  • Like 1
  • Sad 1
  • Dislike 3
Link to comment
Share on other sites

3 hours ago, Hated said:

Changed 

  • Launcher on Windows now stores log files in %APPDATA%/7DaysToDie/logs folder
  • Screenshots are stored in <UserDataFolder>/Screenshots (i.e. the folder that also stores saves, e.g. on Windows %APPDATA%/7DaysToDie/Screenshots) 
  • Mods are now loaded from <UserDataFolder>/Mods (i.e. the folder that also stores saves, e.g. on Windows %APPDATA%/7DaysToDie/Mods) in addition to <game folder>/Mods. In a future build this will change to only load from that new location so no data is written/changed in the program folder at any time. 

Updates are always appreciated, but these changes are a tad concerning...

 

How do these changes impact running multiple dedicated servers on the same PC?

Are the logs and screenshots combined in the same folder?

Can I run multiple live servers with different mod sets?

  • Like 4
  • Afraid 1
Link to comment
Share on other sites

Quote

Server owners will need to add/modify these 2 new properties in the serverconfig.xml. These filters will help players find your server.
 

<property name="Region"  value="NorthAmericaEast" />
Values must be one of the following:
NorthAmericaEast, NorthAmericaWest, CentralAmerica, SouthAmerica, Europe, Russia, Asia, MiddleEast, Africa, Oceania

<property name="Language" value="English" />
Values: Use any language name that your players would expect to search for. Should be the English name of the language, e.g. not "Deutsch" but "German". This is a filter name only and DOES NOT SET the language for players.

 

Ive done this and my server goes to Pid=0 start error. yes, ive updated the server.

Link to comment
Share on other sites

Also, what changed in the Localization.txt file? I have several mods that make updates to that file and each of them is throwing an error:

ERR [MODS] Failing loading localization from mod: LocalizationChangesA20

EXC Value cannot be null

 

What does the EXC value represent? I looked over the new Localization.txt file and I was unable to determine what changed.

  • Like 1
Link to comment
Share on other sites

If I add the lines to my serverconfig.xml I get a segmentation fault. If I remove those two lines it starts, but doesn't show up in the list (expected). I've updated the server. Dedicated server running on Linux.

Link to comment
Share on other sites

8 minutes ago, MikeTWB said:

If I add the lines to my serverconfig.xml I get a segmentation fault. If I remove those two lines it starts, but doesn't show up in the list (expected). I've updated the server. Dedicated server running on Linux.

I too am getting this error. Server is updated to the latest version, but these 2 lines cause an almost immediate segmentation fault on Linux.

Link to comment
Share on other sites

I just keep getting timed out when trying to join my own server. Server has loaded fine, I can find it in the list but times out and cannot connect. The error box says could not retrieve server information. Was fine until this update

Edited by jenniann (see edit history)
  • Like 1
Link to comment
Share on other sites

Is there a page somewhere I could read a glossary or explanation of terms like "sleeper volume attack target time" and so forth, please? 6000 hours into the client end of 7DTD and I am still mystified by some patch notes.

  • Like 1
Link to comment
Share on other sites

There you done it! Officially messed the game up for a whole load of people! Moving the Mods folder was THE greatest lamest stupidest thing to do. You don't realize that MOST people don't have much space on drive C:\ . Especially for Modpacks that are 2-9 GB in size. Yes there ARE modpacks that are that huge. The other thing is, what now we have to go and mess about with the folders there every time we want to play a different modpack? You know, some of us are playing a different modpack every several hours a day or different one every other day of the week. So we had 1-2 Terrabyte space on secondary drives, but barely 15GB on drive c:\ and windows and stuff need 10+ GB free or it starts freaking out because Microsoft, so now you come along and mess with the delicate balance some of us have to juggle with. You know some of us had up to 8 different copies of the game on secondary drive each with a different set of Mods/Modpacks/Mods in the making and now all that going to be f-ed with. You do realize that MANY people buy your game because of the great Modding support it had till now and you just tossed the mother of all wrenches into those delicate clockwork? Also, the server searching thing you guys made sux. BIG time! This update first felt like a late April's Fool's joke. But then I realized you are not Blizzard... No, you guys are seriously think that this is something good.... THIS is the update that SHOULD NOT have been. I'm sure you'll see many many many many more comments like this... Some may be worded more nicely, some may not be worded as nicely. But there will be plenty more from loads of people.... I would hate to leave this game. I have nearly 5500 hours in this game. I have spent many many hours creating modlets for this game. I have genuine love for this game.... I would really hate to loose it because you felt like moving the Mods folder out of the game folder was a good idea..... You are cutting off support for mods....

  • Like 13
  • Haha 2
  • Dislike 1
Link to comment
Share on other sites

I updated our dedicated server (Win10) and can't connect: I'm getting the message "Server is still initializing, please try again later"  (Linux client)

 

Looking in the log file, there's a couple of NullReferenceExceptions being generated when I try to logon. The tail end of the log can be found here:

 

https://www.dropbox.com/sh/ltd3axner5bjd3p/AABbx6Z7V_YpG_Fh12lAHZiAa?dl=0

 

Link to comment
Share on other sites

3 minutes ago, MikeTWB said:

@rxvt08 how did you fix the Segmentation fault? (Other than just removing the two lines, which makes it not seg fault, but also makes it unreachable).

 

Back up your config file, run steamcmd again and update it again, there was a second update for it and it gave a whole new config file. It fixed the segfault.

  • Like 1
Link to comment
Share on other sites

I updated my server and like some others, it is no longer visible on the server list and it says it couldn't retrieve server info when I try to join as some others have experienced. I've tried updating multiple times. However, I have figured out why it is happening but as of now I can't fix it. I rent from Bluefang and they set the server port to 26332 and do not allow me to change that. I can see my server when I view servers from Steam server list and it is showing my server port as 26334. So for some reason 7 Days changed my port from 26332 to 26334 and I have no idea how to fix this. I'm going to have to roll back to 20.3 until this gets fixed unless someone here has discovered a workaround.

 

EDIT: Fixed. Bluefang needed to change parameters in the command line pointing to the World gen folder

Edited by Star69 (see edit history)
Link to comment
Share on other sites

What is up with the WEST and EAST regions for the US?  Where is North America - Central?  What about us in the middle of the country running our servers in Dallas so we are on the prime fiber junction for best bandwidth across our player base?

 

Splitting up the US doesn't make much sense on the face of it since it makes it much harder to find a server now.  I put us in the WEST region and half our players couldn't find us because they didn't go check our Discord to find out where we were placed and they were very confused.  I do understand moving your cheese takes a bit of getting used to, and it is a pain trying to find a server now.

 

It would really help if you explained the outcome you expect with the new regions and how that will benefit everyone.

 

A global server name search would be nice since we have hundreds of players from around the world on our four servers and it is hard enough helping the find the servers with a shared name space.

14 minutes ago, vasti said:

You wiped my server config file back to defaults.  I've lost everything.

Every update over-writes the serverconfig.xml.

 

That is why you update the serverconfig.xml file similar to this, and then move it into the "Saves" folder that you hand create.  Update your launch command line to point to the new serverconfig and you are golden.

 

	<property name="UserDataFolder"					value="C:\Game Server\7DaysToDie\Saves\Worlds" />	<!-- Use this to override where the server stores all generated data, including RWG generated worlds. Do not forget to uncomment the entry! -->
	<property name="SaveGameFolder"					value="C:\Game Server\7DaysToDie\Saves" />	<!-- Use this to only override the save game path. Do not forget to uncomment the entry! -->

 

  • Like 1
Link to comment
Share on other sites

22 minutes ago, bob the big blob of goo said:

Every update over-writes the serverconfig.xml.

 

That is why you update the serverconfig.xml file similar to this, and then move it into the "Saves" folder that you hand create.  Update your launch command line to point to the new serverconfig and you are golden.

 

	<property name="UserDataFolder"					value="C:\Game Server\7DaysToDie\Saves\Worlds" />	<!-- Use this to override where the server stores all generated data, including RWG generated worlds. Do not forget to uncomment the entry! -->
	<property name="SaveGameFolder"					value="C:\Game Server\7DaysToDie\Saves" />	<!-- Use this to only override the save game path. Do not forget to uncomment the entry! -->

 

 

To your knowledge, is there any way to recover my world?  I've noticed the name of my server and the seed name are still located in appdata\Roaming\7daystodie\saves

Link to comment
Share on other sites

I got my server all updated, added the extra lines to the config & got it showing in the list. HOWEVER, now where it is supposed to show my server name & what map it's running, it literally just says "Server Name" & "World". Am I doing something wrong here?? 

Link to comment
Share on other sites

  • Roland unpinned and locked this topic
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...