Jump to content

making arrows more visible


Recommended Posts

I'm trying to make arrows easier to find after shooting them and so far I'm not having much luck doing anything very useful. I've tried adding a NavObject to them using the spear and supply_drop nav objects classes. I've tried adjusting their sticky values and the only one that seems to do anything is StickyOffset. I even tried adding a StickyMaterial to them that also did nothing that I could tell ingame. My current code looks like 

<configs>
	<append xpath="/items/item[@name='ammoArrowStone']">
		<property name="StickyOffset" value=".75"/>
		<property name="NavObject" value="spear"/>
	</append>	
</configs>	

Again the StickyOffset does work but the NavObject part does nothing that I can tell ingame. If anyone has any suggestions to what I can do or corrections to my code please let me know.

 

Edit: Forgot to mention I have tried this with A20 b238 and b6.

Edited by omegaflames (see edit history)
Link to comment
Share on other sites

you could try 

	<append xpath="/items/item[@name='ammoArrowStone']">
		<property name="StickyMaterial" value="#Entities/Zombies?Zombies/Materials/rad_eye.mat"/>
	</append>

have not tested

Link to comment
Share on other sites

Ok something is off here because that is still not working for me. I'm downloading the A19 version from https://7daystodiemods.com/glowing-arrows-bolts-spears/ The code I have in full for it is 

<configs>

	<!--Glowing Arrows, Bolts & Spears-->
	<append xpath="/items/item[@name='ammoArrowStone']">
		<property name="StickyOffset" value=".75"/>
		<property name="StickyMaterial" value="#Entities/Zombies?Zombies/Materials/feral_radiated.mat"/>
	</append>	
	
	<append xpath="/items/item[@name='ammoCrossbowBoltStone']">
		<property name="StickyOffset" value=".75"/>
		<property name="StickyMaterial" value="#Entities/Zombies?Zombies/Materials/feral_radiated.mat"/>
	</append>
	
	<append xpath="/items/item[@name='ammoCrossbowBoltIron']">
		<property name="StickyOffset" value=".75"/>
		<property name="StickyMaterial" value="#Entities/Zombies?Zombies/Materials/feral_radiated.mat"/>
	</append>
	
	<append xpath="/items/item[@name='meleeWpnSpearT0StoneSpear']">
		<property name="StickyMaterial" value="#Entities/Zombies?Zombies/Materials/feral_radiated.mat"/>
	</append>
	
	<append xpath="/items/item[@name='meleeWpnSpearT1IronSpear']">
		<property name="StickyMaterial" value="#Entities/Zombies?Zombies/Materials/feral_radiated.mat"/>
	</append>

	<append xpath="/items/item[@name='meleeWpnSpearT3SteelSpear']">
		<property name="StickyMaterial" value="#Entities/Zombies?Zombies/Materials/feral_radiated.mat"/>
	</append>
	
</configs>	

and what I see in game is spacer.png

Link to comment
Share on other sites

That is strange. I literally had just downloaded it and added it to my game and tested it and it worked.  You may have another mod that is counteracting it. Try adding a z to the name of the mod so it is the last mod in your list.

 

zO92 Glowing Arrows, Bolts and Spears

 

That should make sure it is the last to load if I recall.

Link to comment
Share on other sites

In you mods folder, does the structure look like this...
 

image.png.9d2337064a0fed1961c400429fe4e2fc.png

 

or is it more like this

 

image.png.d24a975dda3b47a4b85056261c3fae50.png

 

because sometimes when extracted the extra folder gets added and it won't work that way. It has to be like the first pic.

Link to comment
Share on other sites

That's why I added the line for increasing the StickyOffset to the code and picture to show that the mod is loading and is increasing the StickyOffset correctly. For some reason though the lines for the StickyMaterial are not working. I had assumed that in A20 feral_radiated.mat was removed since that mod wasn't working for me and it now looks like the radiated zombies now get a unique .mat but you are saying that it's working for you so I don't know anymore. I'm using the steam version (b6 was pushed as stable yesterday so it forced me to update but I started this testing a couple of days ago when I was still on b238) and have validated my files (all files were successfully validated) just now and created a completely fresh test world. The arrows I'm using were crafted in game and they are still not showing the green glow from the radiated effect but are showing as being offset correctly. This last test was done just now. If it makes a difference these are my video settings. If there is a radiated glow on that arrow I am unable to see it.

spacer.pngspacer.pngspacer.png

Edited by omegaflames (see edit history)
Link to comment
Share on other sites

I was unable to get the texture to change either. However, if I change the stone arrow mesh to that of the flame arrow then the material changed to the radiated.

 

Not sure why it was working for Gamida and not you or me. Stranger still that changing the mesh made it work. If it wasn't for the change working for Gamida I would think that hard-coded it to ignore material changes on the normal stick-able arrows.

Link to comment
Share on other sites

A few minutes ago when fighting a Darlene I had a few arrows in her and got up close during the fight when I switched to melee and for a split second noticed one of my stone arrows had the radiated effect. So the effect is being applied but for some reason getting cut out of the final image for the 2 of us. Did a bit more testing and if you get super close to it then it will show the radiated effect on a stone arrow. Same thing for iron and steel arrows. I'm thinking this might be a video settings issue but my testing isn't panning out to what setting gets me the intended result. I've tried raising all the settings to the highest possible value (started with the ultra preset and then individually raised everything that wasn't by default at max, also noted I'm getting 60 fps with that so I guess A20 made some fps fixes) but got the same result. Repeated with the lowest settings possible or turned off and the effect wouldn't show unless you put the arrow into your eyeball. After all settings changes I restarted the game before testing and did the changes from the menu not in game just in case that mattered. @GamidaCould you please let me know what your video settings are so I can repeat with your settings?

Link to comment
Share on other sites

I can give you my settings but mine is only partially working now. I redownloaded the stable version and it reset all my settings. I put it back about to what I think it was but now only the spear works. It flashed red (on then off), but the arrow doesn't seem to anymore. So I may have to fiddle around with it myself.

 

image.thumb.png.c28ed116b8ceb03efbfa30a65b43a8a2.png

Link to comment
Share on other sites

For absolutely no reason that I can think of (as in I have no idea what I changed to make it work or if it's even my fault) the feral_radiated.mat is working now. However the location that you have to have the mouse pointed at to pickup the arrow is no longer at the location of the arrow but moved about half a block down from where the arrow lands so I was forced to increase the radius to compensate for that. My current implementation is to just replace the normal versions with the flaming one and just use the fact it's a small fire to make it visible. I don't consider this the ideal situation but since nothing else I've tried is working as intended I'm just going to stop here until I figure out more about how all this works. The code I'm using and current video settings are 

<configs>
	<!--Glowing Arrows, Bolts & Spears-->
	<append xpath="/items/item[@name='ammoArrowStone']">
		<property name="Meshfile" value="#Other/Items?Weapons/Ranged/Bows/Arrows/arrow_flamingPrefab.prefab"/>
		<property name="StickyMaterial" value="#Entities/Zombies?Zombies/Materials/feral_radiated.mat"/>
		<property name="StickyOffset" value=".75"/>
		<property name="StickyColliderRadius" value="1"/>
	</append>
	<append xpath="/items/item[@name='ammoArrowIron']">
		<property name="Meshfile" value="#Other/Items?Weapons/Ranged/Bows/Arrows/arrow_flamingPrefab.prefab"/>
	</append>
	<append xpath="/items/item[@name='ammoArrowSteelAP']">
		<property name="Meshfile" value="#Other/Items?Weapons/Ranged/Bows/Arrows/arrow_flamingPrefab.prefab"/>
		<property name="StickyOffset" value=".75"/>
		<property name="StickyColliderRadius" value="1"/>
	</append>
	<append xpath="/items/item[@name='ammoCrossbowBoltStone']">
		<property name="Meshfile" value="#Other/Items?Weapons/Ranged/Bows/Arrows/bolt_flamingPrefab.prefab"/>
		<property name="StickyMaterial" value="#Entities/Zombies?Zombies/Materials/feral_radiated.mat"/>
		<property name="StickyOffset" value=".75"/>
		<property name="StickyColliderRadius" value="1"/>
	</append>
	<append xpath="/items/item[@name='ammoCrossbowBoltIron']">
		<property name="Meshfile" value="#Other/Items?Weapons/Ranged/Bows/Arrows/bolt_flamingPrefab.prefab"/>
		<property name="StickyMaterial" value="#Entities/Zombies?Zombies/Materials/feral_radiated.mat"/>
		<property name="StickyOffset" value=".75"/>
		<property name="StickyColliderRadius" value="1"/>
	</append>
	<append xpath="/items/item[@name='ammoCrossbowBoltSteelAP']">
		<property name="Meshfile" value="#Other/Items?Weapons/Ranged/Bows/Arrows/bolt_flamingPrefab.prefab"/>
		<property name="StickyMaterial" value="#Entities/Zombies?Zombies/Materials/feral_radiated.mat"/>
		<property name="StickyOffset" value=".75"/>
		<property name="StickyColliderRadius" value="1"/>
	</append>
</configs>

spacer.png

Link to comment
Share on other sites

I am a dunce lol. In the example I gave above of how the mod structure should look I added the wrong way to show how it shouldn't be and I forgot to correct it...doh. Any how the thing is when I did that the spear did a red pulsating thing that showed the full spear that was way easier to see. I liked it and am thinking I may try to see what was doing it. If I do find out I will let you know.

  • Thanks 1
Link to comment
Share on other sites

On 2/2/2022 at 10:40 AM, omegaflames said:

That's odd because I tried that one before trying to write my own and it didn't work for me. I'll test it again.

 

On 2/2/2022 at 5:26 AM, omegaflames said:

I'm trying to make arrows easier to find after shooting them and so far I'm not having much luck doing anything very useful. I've tried adding a NavObject to them using the spear and supply_drop nav objects classes. I've tried adjusting their sticky values and the only one that seems to do anything is StickyOffset. I even tried adding a StickyMaterial to them that also did nothing that I could tell ingame. My current code looks like 

<configs>
	<append xpath="/items/item[@name='ammoArrowStone']">
		<property name="StickyOffset" value=".75"/>
		<property name="NavObject" value="spear"/>
	</append>	
</configs>	

Again the StickyOffset does work but the NavObject part does nothing that I can tell ingame. If anyone has any suggestions to what I can do or corrections to my code please let me know.

 

Edit: Forgot to mention I have tried this with A20 b238 and b6.

What is the function of "stickyoffset" in the game?

Link to comment
Share on other sites

#Entities/Zombies?Zombies/Materials/feral_radiated.mat"

was removed from game.

the rad  is all a pefab mesh of each zombie

 

like   <property name="Mesh" value="#Entities/Zombies?Prefabs/ZArleneRadiated.prefab"/>

Link to comment
Share on other sites

6 hours ago, jk958 said:
#Entities/Zombies?Zombies/Materials/feral_radiated.mat"

was removed from game.

the rad  is all a pefab mesh of each zombie

 

like   <property name="Mesh" value="#Entities/Zombies?Prefabs/ZArleneRadiated.prefab"/>

That's clearly not true since we are seeing it in the game. There are even screenshots above showing you that.

Link to comment
Share on other sites

On 2/5/2022 at 5:24 PM, omegaflames said:

It moves the arrow a distance backwards from where it is embedded into. So if the arrows are so deep into the block that you can't see them then increase stickyoffset until you can.

 

On 2/10/2022 at 7:39 AM, jk958 said:

the green on rads is random now  from last 19 version so is like 50 50 chance to see green

Thank you, very helpful.

Link to comment
Share on other sites

  • 4 months later...
On 6/24/2022 at 8:42 PM, Worrun said:

Did you ever get this to work?

I never got the radiated effect to apply consistently enough to be worth doing it. Ultimately I just used the flaming arrow graphics instead.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...