Jump to content

help with game crashes


tedt129302926
 Share

Recommended Posts

My game crashes about once every 20 minutes, i also have stutters and when i check my disk usage its very high while the game is active or shortly after it crashes. this never happened in A19 i first played in january 2021 and never had any issues with this using the same PC. when i played A20 this month it started, i constantly stutter and used to crash every hour or so now i cannot play more than 15-20 mins without crashing. i have reinstalled, verified files, reset OS, i have tried playing on all lowest graphic settings but it makes 0 difference whether im on medium or lowest the same exact stutters and crash still happens. the "bugfix" patch and the A20 stable release didnt make anything worse. i looked at alot of forum posts and best i can find is that its "memory leak" and the game is using insane amounts of RAM but have not seen any fix. dont tell me to try previous builds of the game, any other potential solution to stop this issue would help. the crashes happens randomly but 90% of the time its when im opening a container/loot/inventory and if im in a server it sometimes just gives me network timeout and i cannot reconnect until i restart my game. i have played on 6k and 10k maps and the same issue occurs on either. thx

Link to comment
Share on other sites

we have the same problem with a friend joining us

he has windows 10...game crashes after 20min..then after other 20min after 2x crashes it runs hours...in some days it will run fine without crashes

- it crashes ofter when u open loot (when the game must "think" wats in the loot)

 

the problem was: windows 10 update checks somethings in the background...the cpu goes 100% usage and 7days say goodbye...

perhaps i coud help...(no, we tried to start the computer 3hours before..but no changes)

 

on win7 we dont have this problem.

we recommend a fresh restart before gaming

Link to comment
Share on other sites

I have the some problem like tedt129302926.

After A20 my 7d2d was stable, after update to A20, after few minutes 7d2d always crash. I will try reinstall 7D2D and my graphic drivers. Run 7d2d without use Discord, switch sound off (0 %) and nothing was help. I already had played 1600 hours in 7d2d and now it is total unstablet. I´m playing on dedicated server of my friend and I´m only one who has problem with stability.
Every time server disconect me with information "Network timeout". 

(sorry my English :-))

Link to comment
Share on other sites

First of all same symptoms don't necessarily mean it is the same cause. Secondly Star69 already said what is needed, read the pinned thread in this forum section

https://community.7daystodie.com/topic/3956-how-to-report-an-issue-please-read-before-creating-new-threads/?do=findComment&comment=3956

and it will explain how to post your logfile.

Edited by meganoth (see edit history)
  • Thanks 1
Link to comment
Share on other sites

This is from DED server when I have Network Timeout during login.


https://pastebin.com/EPwTAkmf

 

And last info fro DED server, after 5 minutes in game

2021-12-26T18:25:40 30266.075 INF NET: LiteNetLib: Client disconnect from: 213.195.233.131:5169 (Timeout)
2021-12-26T18:25:40 30266.076 INF [NET] PlayerDisconnected EntityID=171, PltfmId='Steam_76561198044995342', CrossId='EOS_0002f143a8374d8984b3928290c4007b', OwnerID='Steam_76561198044995342', PlayerName='Kamikadze'
2021-12-26T18:25:40 30266.076 INF DynamicMusic: 171 successfully removed from Bloodmoon state cache
2021-12-26T18:25:40 30266.076 WRN Client disconnected from dy mesh: Id: 171 Total: 2
2021-12-26T18:25:40 30266.076 WRN Client disconnect complete for 171 Total: 1
2021-12-26T18:25:40 30266.076 INF Player disconnected: EntityID=171, PltfmId='Steam_76561198044995342', CrossId='EOS_0002f143a8374d8984b3928290c4007b', OwnerID='Steam_76561198044995342', PlayerName='Kamikadze'
2021-12-26T18:25:40 30266.084 INF GMSG: Player 'Kamikadze' left the game
2021-12-26T18:25:40 30266.085 INF Exited thread NCS_Writer_0_0
2021-12-26T18:25:40 30266.085 INF Exited thread NCS_Reader_0_0
2021-12-26T18:25:40 30266.085 INF Exited thread NCS_Reader_0_1
2021-12-26T18:25:40 30266.085 INF Exited thread NCS_Writer_0_1

Edited by Kamikadze (see edit history)
Link to comment
Share on other sites

3 hours ago, Kamikadze said:

Can you join any other, random server? If you can, it narrows it down to something between you and your server. If you cannot join any server then there’s something up with your machine. I noticed that you have EAC disabled on your computer….is EAC enabled on the server?

Link to comment
Share on other sites

So it sounds like a connection issue on your pc. I can offer a couple of options to try. Log out of friends, join the server and once connected properly then you can log back in. Why? The server is logging you in via steamnetworking because you have friends on the server then you get litenetlib timeout. The other option is in the server config, disable steamnetworking thereby forcing the litenetlib connection. Finally, if neither of those things work, you can try to disable IPv6 on the server machine. These are solutions I’ve found by searching the forums for litenetlib timeout.

 

How is your internet set up? Pc wired to modem to internet or is there a router in ther or are you running on a vpn?

Link to comment
Share on other sites

29 minutes ago, Blonanjo said:

Hi there, is my log, i hope you can help me.

 

https://pastebin.com/CeehyiQW

 

Thanks!!

 

You have mods installed and many warnings related to mods. First thing I would do is remove all mods and make sure that the game works as expected. Then add one mod at a time until you begin having trouble again then you will know which mod is causing the problem. At that point you contact the mod author to see if they can advise you how to get that mod to work properly.

Link to comment
Share on other sites

21 hours ago, Star69 said:

You have mods installed and many warnings related to mods. First thing I would do is remove all mods and make sure that the game works as expected. Then add one mod at a time until you begin having trouble again then you will know which mod is causing the problem. At that point you contact the mod author to see if they can advise you how to get that mod to work properly.

OK, i will try this, Thanks!

2 minutes ago, Blonanjo said:

OK, i will try this, Thanks!

 I dont see any mod installed....is another place where the mods can be instaled? I check in this place: E...\steamapps\common\7 Days To Die

Link to comment
Share on other sites

46 minutes ago, Blonanjo said:

OK, i will try this, Thanks!

 I dont see any mod installed....is another place where the mods can be instaled? I check in this place: E...\steamapps\common\7 Days To Die

Usually there is a folder named Mods in that 7 Days to Die folder but I’m not familiar with how all mods are loaded. This is from your log so you definitely have mods installed somewhere:

 

  1. 2022-01-03T18:38:53 24.104 INF [MODS] Start loading
  2. 2022-01-03T18:38:53 24.110 INF [MODS] Initializing mod code
  3. 2022-01-03T18:38:53 24.111 INF [MODS] Loading done
Link to comment
Share on other sites

21 hours ago, Star69 said:

Usually there is a folder named Mods in that 7 Days to Die folder but I’m not familiar with how all mods are loaded. This is from your log so you definitely have mods installed somewhere:

 

  1. 2022-01-03T18:38:53 24.104 INF [MODS] Start loading
  2. 2022-01-03T18:38:53 24.110 INF [MODS] Initializing mod code
  3. 2022-01-03T18:38:53 24.111 INF [MODS] Loading done

Well, the folder "MODS" is totally empty, is in "...\steamapps\common\7 Days To Die\Mods". And the another folder that i know for the game is in: "C:\Users\Usuario\AppData\Roaming\7DaysToDie". No Mods there.....so if there is a mod folder in another place i dont know it....No mods intallled! :(

Link to comment
Share on other sites

Have you used mods in A20? If not, you may have residual files from A19 or even earlier A20 experimental. My first suggestion, delete the mods folder. Click on the blue banner at the top of the forum and follow the instructions to clean out all your old saves and files then do an uninstall/reinstall. If that doesn’t fix your problem, post back. Unfortunately, just removing mod files from the mod folder doesn’t always fix issues because some mods will modify game files so cleaning, uninstall/reinstall is the only option to fix certain problems.

Link to comment
Share on other sites

On 1/5/2022 at 6:23 PM, Star69 said:

Have you used mods in A20? If not, you may have residual files from A19 or even earlier A20 experimental. My first suggestion, delete the mods folder. Click on the blue banner at the top of the forum and follow the instructions to clean out all your old saves and files then do an uninstall/reinstall. If that doesn’t fix your problem, post back. Unfortunately, just removing mod files from the mod folder doesn’t always fix issues because some mods will modify game files so cleaning, uninstall/reinstall is the only option to fix certain problems.

Hi there. Well, i made all this suggestions: Delete «Mods» folder, clean all the old files (A good clean as show the video that Jugginator sent me), uninstall and eliminate the folder of game, delete all the folder «7DaysToDie» in "C:\Users\Usuario\AppData\Roaming\7DaysToDie", restart the pc, then reinstall the game. The game works better, less small loaded pauses, more fluid game. But then the game kick me out to the menu again....and again in 10 minutes mores, and again in another 10 minutes (not exactly 10 minutes, but was close i guess)....

 

So i made a new paste in pastebin: https://pastebin.com/mLZJzR9h

 

Thanks for all, i dont know what more to do.

Link to comment
Share on other sites

Why are you running this so frequently? INF Executing command 'xui close trader'

 

Honestly this may be a issue of an antivirus not excluding the game completely or something(s) running in the background causing a delay in the game. A disconnect from a server usually is a loss of communications between client -> server.

Link to comment
Share on other sites

It looks like you are disconnecting from your own internet which is disconnected you from the server. Are you able to load a web page during this disconnect? I know it sounds ridiculous, but worth considering. Having multiple file pathways will be an issue when trying to load the game. If the server has to search through your computer in order to locate your 7 Days to die game files, it very well might not be able to locate the files. You should ensure that the pathway the server has to use is a simple path without many barriers to entry, or the opposite of how you would want a zombie base.

Link to comment
Share on other sites

Hi there, i set the graphics low, and i have been played better, the game kick me with more time in a first time, but now i have the same problem, every 6 minutes (more or less) the server kick me to the principal menu. I play music on youtube at the same time and the music dont stop never, so i suppose there is no problem with my internet, otherwise i dont have any problem with another games onlines. Just with this game i cant playa fliud in online mode.

Link to comment
Share on other sites

This is a strange potential solution but can you check YouTube stats for nerds during this 6 minute time frame? Just out of curiosity I would run a scan of task manager performance monitor as well. Might contact server last ditch effort

Link to comment
Share on other sites

23 hours ago, Shnoz said:

This is a strange potential solution but can you check YouTube stats for nerds during this 6 minute time frame? Just out of curiosity I would run a scan of task manager performance monitor as well. Might contact server last ditch effort

i font know how to do this.....but if you tell me i will try

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...