Jump to content

Recipe not working


Zyamaia
 Share

Recommended Posts

Ok after looking at several examples I'm stumped as to why this recipe I've made does not work.

 

Here's what it says:

<Zyamaia>

    <append xpath="/recipes">
    
        <recipe name="resourceAcid" count="1" craft_area="chemistryStation"  craft_time="20"  tags="chemStationCrafting">
            <ingredient name="resourceScrapBrass" count="2"/>
            <ingredient name="resourceScrapLead" count="2"/>
            <ingredient name="drinkJarRiverWater" count="1"/>
        </recipe>
        
    </append>

</Zyamaia>

Link to comment
Share on other sites

Does it have a ModInfo.xml with it?

What does the Player.log show? i.e. there should be a few lines like this somewhere: these are the mod loading lines from my last session last night, and the mod I use is called "Red20"   Lines 70 to 79. . . . . 

021-12-21T17:55:16 6.787 INF [MODS] Start loading
2021-12-21T17:55:16 6.791 INF [MODS] Trying to load from folder: Red20
2021-12-21T17:55:16 6.818 INF [MODS] Loaded Mod: Red20 (0.0.0)
2021-12-21T17:55:16 6.818 INF [MODS] Initializing mod code
2021-12-21T17:55:16 6.818 INF [MODS] Loading done
2021-12-21T17:55:16 6.945 INF Pack 60465 us
2021-12-21T17:55:17 7.010 INF Pack 19146 us
2021-12-21T17:55:17 7.011 INF [MODS] Loading localization from mod: Red20
2021-12-21T17:55:17 7.019 INF Loading permissions file at 'C:\Users\pj\AppData\Roaming/7DaysToDie/Saves/serveradmin.xml'
2021-12-21T17:55:17 7.032 INF Loading permissions file done.

 

Your mod name should appear as INF [MODS] Loaded Mod: Zyamaia

(This is a Steam version, A20 b238, with the lo located at C:\Users\pj\AppData\LocalLow\The Fun Pimps\7 Days To Die\Player.log)

Edited by paulj_3 (see edit history)
Link to comment
Share on other sites

2021-12-22T09:54:37 7.096 INF [MODS] Start loading
2021-12-22T09:54:37 7.099 INF [MODS] Trying to load from folder: Acid
2021-12-22T09:54:38 7.126 INF [MODS] Loaded Mod: Acid (1.0)

 

Shows the mod loaded but when I search the chemistry station for Acid nothing comes up.

Link to comment
Share on other sites

I copied your code into my own recipies xml, Zy, and it showed up and worked without issue. . 

 


Acid1.thumb.JPG.5d8386b5e4de9532832f71d05f201327.JPG

 

Before Brass, Lead,and Murky stuff. . .

Acid2.JPG

 

Added the bits. . .

Acid3.JPG

 

Ran it, and and got my bottle.

Acid4.JPG


So I have no clue as to why it won't work..
Sorry. . . something is missing in your setup. Can you post the recipe.xml somewhere?

Edited by paulj_3 (see edit history)
Link to comment
Share on other sites

I tried to make it a mod and I THINK I followed the format but not 100% certain.  LOL and have no clue where I can upload this so you can actually see the mod.

 

 

edit:  I put the recipe physically in recipe.xml and it works fine just not when I try to make it into a mod LOL

Edited by Zyamaia (see edit history)
Link to comment
Share on other sites

On 12/22/2021 at 10:17 PM, BFT2020 said:

Umm, should this <Zyamaia> actually be <config> and </Zyamaia> be </config>?

Not sure what's wrong.  Here's the google drive link for the mod. https://drive.google.com/drive/folders/1QL2BA33H1aUpcZMiSQvuA8nGo4UkJVIn?usp=sharingusp=sharing

 

Edited by Zyamaia (see edit history)
Link to comment
Share on other sites

Good Morning Zy...  unfortunately the recipes.xmll is only a link to yout game installation on your C:.

The Modinfo looks ok, as long as the folder structure is like this below it should be ok. but we/I need to see your actual recipes.xml.

The recipes.xml should look like this:-
 

<configs>

    <append xpath="/recipes">
    
        <recipe name="resourceAcid" count="1" craft_area="chemistryStation"  craft_time="20"  tags="chemStationCrafting">
            <ingredient name="resourceScrapBrass" count="2"/>
            <ingredient name="resourceScrapLead" count="2"/>
            <ingredient name="drinkJarRiverWater" count="1"/>
        </recipe>
        
    </append>

</configs>


This is a shot of my file structure: the Mod name is Red20, and contains a Configs file, where the recipes.xml sits, and you can see the ModInfo listed there too.
(Ignore the Assets-Resources-Sounds folders, etcc - they are parts of the much bigger Red20 mod)

#3_Level.JPG

 

Yours should look like this.

Zyamaia.JPG

Edited by paulj_3 (see edit history)
Link to comment
Share on other sites

Nup - still comes as a link to the file. Don't worry about it, Zy:  the info above will make it work, provided no syntax or spelling errors . . . .    Just make it like the pics.
I'll be around here all day, so ask away if you still have problems.  👍
 

Link to comment
Share on other sites

On 12/22/2021 at 9:17 PM, BFT2020 said:

Umm, should this <Zyamaia> actually be <config> and </Zyamaia> be </config>?

Apparently the "toplevel" XML tags in a modlet XML file can be anything as long as the top and bottom one are identical (and the last has the slash in it). <config></config> is just what TFP has in all their files.  I use <Doughs></Doughs>, because that's how I learned to do it when i was learning by looking at other peoples mods.

Link to comment
Share on other sites

1 hour ago, doughphunghus said:

Apparently the "toplevel" XML tags in a modlet XML file can be anything as long as the top and bottom one are identical (and the last has the slash in it). <config></config> is just what TFP has in all their files.  I use <Doughs></Doughs>, because that's how I learned to do it when i was learning by looking at other peoples mods.

Learning something new everyday.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...