Jump to content

Prefab Problem: Shelter gets placed in the skys


Mistwraith

Recommended Posts

Hello.

 

I created a little prefab with a cellar and tryed to place that into a world. When I place it, everything seems to be alright. But when loading my game, it sits atop a high pillar of earth and concrete.

 

Within the editor, I have set the ground level to the right height, and in play testing, it IS correctly placed on the ground. As soon as I start a game, however, it sits atop its pillar again.

 

I tryed editing the y offset in the prefabs .xml file, but this doesnt change a thing. Also, when placing it within the editor, the prefab seem to be handled by the engine as if the ground level is the floor of the cellar. It has to be manualy lowered, so that it appears to be on ground level, otherwise its to high.

Lowering it by any amount, however, doesnt do a thing. Ground level is block 60 in this chunk, but it gets placed at lvl 144 no matter how high or low I place it within the editor.

 

Please help me out here, I tryed the whole afternoon and evening to figure this out and found no solution yet.

 


World-Editor.png

Ingame.png

Link to comment
Share on other sites

50 minutes ago, stallionsden said:

Check the yoffset on the prefab and make sure the ground level is correct

 

If you mean within the .xml, then I did that already. There is no visible difference between  an offset of -10, -84 or +100.

If there are other means to manipulate the y offset, I would be happy to hear about them.

 

EDIT:

I just discovered, that when enabling "Show ground level" within the world editor, there is a floating copy of the asset at the height where it gets (wrongly) placed in the game.

The options to move it are grayed out, however.

 

Floating-Copy.png

 

Link to comment
Share on other sites

That didnt do the trick. After deleting everything and starting without the prefab into the game, just to see what happens, the prefab was still there.

 

So I figured, that I just create a new map (Stallion Island) and try it again. And it finaly worked. Thank you for trying to help me out, but I messed something up in the world editor most likely. Still no idea what i was, but at least its working now.

 

Fixed.png

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...