Jump to content

Game Crashes on start up menu...tried all posted guidance


Codog
 Share

Recommended Posts

New to 7 Days to Die and very excited to play.  I have multiple other Steam games, Valheim being most recent and never an issue. I understand this is pre-release, but am hoping to find help here.  My system isn't new, but it is above Minimum specs and Recommended specs: Windows 10, i5-6600k processor, 3.5GHz, 16Gig Memory, 64 bit Op sys, GeForce GTX 980 graphics. I use ESET virus software.  Steam is located on my primary Solid State drive C:\.  I am trying run  Alpha 19.6 (b8)

Game launches to menu screen and I get the Main Menu ( New Game, Continue Game...etc.) 

Game repeatedly crashes with no message and exits out after less than 30 seconds.  Again no issues at all with Valheim.  

I have verified the file, video drivers are up to date, restarted the computer, uninstalled and reinstalled multiple times, excluded steam from Virus and Performance on ESET, Shut off ESET altogether, tried to run as Admin.  Nothing seems to have any effect at all. 

I have found many YouTubes, but they seem to be from 2016-2018....not as much current posts having this issue.  

 

Maybe Alpha 20 will fix....but would really appreciate any advice.  Thanks in advance!

 

Ps...If I have left out any pertinent tech specs of my machine, please let me know. 

 

Link to comment
Share on other sites

Does the game crash when you are trying to start / join a world (i.e. it would create an output log) or is it crashing while in the menu screen?  Based on your post, it sounds like you are crashing after the game starts, but before you start going into a world.

Link to comment
Share on other sites

Thanks for the replies. Here is the latest log.  https://pastebin.com/EBbYkHRu

 

To the question of a corrupted save...I have not been able to get in-game to get to a save point...if by save you mean a corrupted save file.

 

I have verified the game file multiple times.

 

The sequence of the crash is that it gets to the main menu and crashes out in about 20 seconds. I can get to the settings if I move quick, as I have seen that Motion Blur setting can cause issues. I see that mine is defaulted to Simple.  But I cant get actually in game to any World before I crash out.  And note, there is no message or warning....it is as if I just closed out the X on a browser Tab.  

 

Thanks

 

Link to comment
Share on other sites

I tried to enter the game quickly to see if it would generate a log error. 

I think it did....... here is the most current log with what I see as a possible error.

 

Fallback handler could not load library C:/Program Files (x86)/Steam/steamapps/common/7 Days To Die/7daystodie_Data/Mono/libc

 

Here is the current log after trying to enter a game.....still times out at about 20-30 sec

https://pastebin.com/bC88riMA

Link to comment
Share on other sites

That’s interesting, no errors at all. Makes me wonder if it’s not a 7 Days issue causing the crash??? Have you done some of the basic things like excluding Steam from your antivirus software, making sure your graphics drivers, chipset drivers, audio drivers are up to date as well as Windows? In my old rig, I ran the game just fine with a gtx 980m so I don’t think it’s your videocard. Hopefully someone else can give you additional ideas.

Link to comment
Share on other sites

Ya, I have excluded Steam both on Performance and Virus from Steam. I have also tried running with ESET(anti-virus closed). Drivers and Windows up to date.  

 

I am not sure what the log entry "Fallback handler could not load library" means.

 

I have restarted my PC with nothing else open (Outlook, any browser tabs, etc)  with no diff results.

 

At a loss for now.  Come on Team Community, I have faith in you! :)

Link to comment
Share on other sites

Fallback handler message is fine, the log generally is fine.

 

Have you changed the cache handling in the operating system? 7D2D is or was sensitive to this. 

 

There might be crash infos in the windows system log, https://www.cyberlink.com/support/faq-content.do?id=10449 describes how to access it

 

 

Edited by meganoth (see edit history)
Link to comment
Share on other sites

For the exception code you are getting:

 

https://www.minitool.com/news/0xc0000409.html

 

Also notes I seen point to a Stack Buffer Overflow Error

 

One thing you mentioned is that you uninstalled and reinstalled the game.  One thing you can try is to uninstall everything 7D2D and then check to see if the registry has removed all instances of 7D2D.  If not, those could be causing you an issue.

 

Also should check your system files to make sure none of them are corrupted.  Details on how to do that are in the link I pasted below

 

https://support.microsoft.com/en-us/topic/use-the-system-file-checker-tool-to-repair-missing-or-corrupted-system-files-79aa86cb-ca52-166a-92a3-966e85d4094e

 

That is a start, others will chime in some ideas to check.

 

For the registry, instructions in this link pasted.

 

https://support.microsoft.com/en-us/windows/how-to-open-registry-editor-in-windows-10-deab38e6-91d6-e0aa-4b7c-8878d9e07b11

 

Just check if you see any references to 7D2D after you uninstall the game.  If it doesn't do a clean uninstall, we can walk you through removing them safely and not crashing your OS.

 

Also here is an example of it on my system

 

https://imgur.com/a/EtnQjgd

 

Edited by BFT2020 (see edit history)
Link to comment
Share on other sites

Ok.... soooo much spent with no results.

Have uninstalled.  Done a System Restore to before 7D2D install.

Verified that the 7D2D was no longer in Registry   https://imgur.com/a/KhEaYVZ

Did a system check ( sfc/scannow ) to verify no corrupted files. There were corrupted files but fixed.  

Then ran sfc again....    2nd run " Windows Resource Protection did not find any integrity violations."

Started up Steam again...it updated.

Downloaded  7D2D again  (Currently installing under C;\Program Files (x86)\Steam   an Solid State Drive

 

Still no Chicken Dinner.  :(

Link to comment
Share on other sites

Wow... you are correct. I had checked via the Window Device mgr and said it was current. Today I went to NVIDIA site.

Today I see there was an update that was just over a week ago.  All updated and current now .  

Current Driver   11/26/2021  Driver Ver 30.0.14.9709    (aka  497.09)

 

Still same result and exits out right after the kettle drums, which is like 4 bars of music.  Exact same spot regardless of if I do nothing or try to enter the menu options or start game. 

 

Wife is out of town and was soooo looking forward to a full day of 7D2D :(

 

 

 

 

Link to comment
Share on other sites

This still smells like a Windows issue. It definitely is not a 7 Days problem. The fact that you did need to repair corrupted system files, I still think you have corrupted files even though the scan isn’t finding anything now. I guess it could be a bad sector on your hard drive but I doubt it. As a last resort, I’d suggest either reinstalling or repairing Windows. A clean install is best but you could also reinstall while keeping all your files.  I think you’ve tried just about everything else.

Link to comment
Share on other sites

3 hours ago, Codog said:

And lastly, the latest sfc/scannow verification went perfect.

 

RAM Scan went perfect... no errors.

This is a long shot, but someone recently had crashing caused by bloatware, specifically from Asus. Check for any unnecessary running processes, and any installed programs that you don't actually need. Especially ones that start at boot.  RGB lighting software has specifically been identified as causing issues.

Link to comment
Share on other sites

2 hours ago, Beelzybub said:

This is a long shot, but someone recently had crashing caused by bloatware, specifically from Asus. Check for any unnecessary running processes, and any installed programs that you don't actually need. Especially ones that start at boot.  RGB lighting software has specifically been identified as causing issues.

Suggestion would have Codog use an utility program to scan and export a log so they can post it here for us to assist.  Long ago, I used a program called Hijack This to do that, but I saw that it is not supported anymore.  I got referred to another program called Hijack This Fork, but I have no experience so I don't want to suggest using it at this time.  Do you or anyone else have a good, free process scanning program (I know he can use Task Manager, but the default Microsoft tool doesn't find everything).

 

Another thing to check is page file size

 

https://www.tomshardware.com/news/how-to-manage-virtual-memory-pagefile-windows-10,36929.html

 

My gut is saying something is sapping resources away to run this game.  Sorry this is taking a long time to troubleshoot, but not easy to do through the forums (I rather be sitting in front of the computer working on it instead).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...