Jump to content

The 7D2D Mod Launcher - A Mod Launcher for 7 Days to Die


sphereii
 Share

Recommended Posts

...this stands out...

 

configfile=D:\7D2D\Alpha17\Darkness_Falls\Darkness_Falls\SaveConfig.xml

2019-03-30T09:16:07 35.610 INF Parsing server configfile: D:\7D2D\Alpha17\Darkness_Falls\Darkness_Falls\SaveConfig.xml

2019-03-30T09:16:07 35.726 ERR Error parsing configfile: GameName is empty or contains invalid characters

2019-03-30T09:16:07 35.726 INF Allowed characters: A-Z, a-z, 0-9, dot (.), underscore (_), dash (-) and space ( )

 

- - - Updated - - -

 

...as does this...

 

2019-03-30T09:15:32 0.603 INF [EAC] Not loading, not started from launcher

Could not open file D:/7D2D/Alpha17/Darkness_Falls/Darkness_Falls/7DaysToDie_Data/resources.assets for read

 

- - - Updated - - -

 

...and a few other things.

Link to comment
Share on other sites

...this stands out...

 

configfile=D:\7D2D\Alpha17\Darkness_Falls\Darkness_Falls\SaveConfig.xml

2019-03-30T09:16:07 35.610 INF Parsing server configfile: D:\7D2D\Alpha17\Darkness_Falls\Darkness_Falls\SaveConfig.xml

2019-03-30T09:16:07 35.726 ERR Error parsing configfile: GameName is empty or contains invalid characters

2019-03-30T09:16:07 35.726 INF Allowed characters: A-Z, a-z, 0-9, dot (.), underscore (_), dash (-) and space ( )

 

- - - Updated - - -

 

...as does this...

 

2019-03-30T09:15:32 0.603 INF [EAC] Not loading, not started from launcher

Could not open file D:/7D2D/Alpha17/Darkness_Falls/Darkness_Falls/7DaysToDie_Data/resources.assets for read

 

- - - Updated - - -

 

...and a few other things.

 

Ok Guppycur, any suggestions?

Link to comment
Share on other sites

Maybe your steam install is bad, so every copy you make, is bad. Are you doing a Copy From Local? If so, please re-verify the steam files and re-install the mods

 

I just uninstalled the game and reinstalled it. The same with the Launcher and with the mod.

Still the same.

Can you think of something else?

 

https://pastebin.com/vAwMf8fu

https://pastebin.com/vAwMf8fu

 

Thank you!

Link to comment
Share on other sites

323/5000

I just checked something curious.

If I open the Launcher and run "Steam Version" it works correctly. If I do it after having launched the mod, which gives an error, the same thing happens with the version without mods.

I have done it several times. That is, once I have launched the mod it does not work either with the mod or with the "Steam Version".

Link to comment
Share on other sites

323/5000

I just checked something curious.

If I open the Launcher and run "Steam Version" it works correctly. If I do it after having launched the mod, which gives an error, the same thing happens with the version without mods.

I have done it several times. That is, once I have launched the mod it does not work either with the mod or with the "Steam Version".

 

This does seem like something is detecting the mods as being bad, and nuking it. Bitdefender or something else.

Link to comment
Share on other sites

I finally made it work.

There goes what I did in case something else happens to someone else.

1. uninstall the mods from the Launcher

2. uninstall the Launcher with the Windows uninstaller

3. uninstall the game from Steam

4. Manually delete the LAUNCHER folders of the MODS and 7D2D that were left in "..... \ AppData \ Roaming", "Program Files" and "Program Files (x86)"

5. Manually delete the entries to the programs (LAUNCHER and 7D2D) in the windows registry

Only after doing everything has it returned to funicide me.

 

Thanks to Sphereii for her special interest and the rest of the friends who tried to help me.

Link to comment
Share on other sites

New Update to 2.0.80, to fix a few issues, such as a potential error when opening the Manage Modlet screen, a date and time since last update, and detecting an error when the mod launcher's configuration gets potentially corrupted.

Link to comment
Share on other sites

.NET Framework "Unhandled exception" after running the app, just after it prompts to select mod install location is happening for me.

 

"Unhandled exception has occurred in a component in your application. If you click Continue, the application will ignore this error and attempt to continue. Object reference not set to an instance of an object."

 

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
  at _7D2DLauncher.frmMain.PickModdedFolder() in C:\Users\jkilpatrick\Documents\GitHub\7D2DModLauncher\7D2DLauncher\7D2DLauncher\7D2DLauncher.cs:line 1780
  at _7D2DLauncher.frmMain.txtModdedGameFolder_TextChanged(Object sender, EventArgs e) in C:\Users\jkilpatrick\Documents\GitHub\7D2DModLauncher\7D2DLauncher\7D2DLauncher\7D2DLauncher.cs:line 3065
  at System.Windows.Forms.Control.OnTextChanged(EventArgs e)
  at System.Windows.Forms.TextBoxBase.WmReflectCommand(Message& m)
  at System.Windows.Forms.RichTextBox.WmReflectCommand(Message& m)
  at System.Windows.Forms.RichTextBox.WndProc(Message& m)
  at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
   Assembly Version: 4.0.0.0
   Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
   CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
7D2DLauncher
   Assembly Version: 2.0.80.18955
   Win32 Version: 2.0.80.18955
   CodeBase: file:///C:/Program%20Files/SphereII%20Software/7D2D%20Mod%20Launcher%20Installer/7D2DLauncher.exe
----------------------------------------
System.Windows.Forms
   Assembly Version: 4.0.0.0
   Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
   CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
   Assembly Version: 4.0.0.0
   Win32 Version: 4.7.3353.0 built by: NET472REL1LAST_B
   CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
   Assembly Version: 4.0.0.0
   Win32 Version: 4.7.3056.0 built by: NET472REL1
   CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
log4net
   Assembly Version: 2.0.8.0
   Win32 Version: 2.0.8.0
   CodeBase: file:///C:/Program%20Files/SphereII%20Software/7D2D%20Mod%20Launcher%20Installer/log4net.DLL
----------------------------------------
System.Net.Http
   Assembly Version: 4.1.1.3
   Win32 Version: 4.6.26907.01
   CodeBase: file:///C:/Program%20Files/SphereII%20Software/7D2D%20Mod%20Launcher%20Installer/System.Net.Http.DLL
----------------------------------------
System.Configuration
   Assembly Version: 4.0.0.0
   Win32 Version: 4.7.3056.0 built by: NET472REL1
   CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Core
   Assembly Version: 4.0.0.0
   Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
   CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Xml
   Assembly Version: 4.0.0.0
   Win32 Version: 4.7.3056.0 built by: NET472REL1
   CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Deployment
   Assembly Version: 4.0.0.0
   Win32 Version: 4.7.3056.0 built by: NET472REL1
   CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Deployment/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Deployment.dll
----------------------------------------
AutoUpdater.NET
   Assembly Version: 1.4.11.0
   Win32 Version: 1.4.11.0
   CodeBase: file:///C:/Program%20Files/SphereII%20Software/7D2D%20Mod%20Launcher%20Installer/AutoUpdater.NET.DLL
----------------------------------------
SharpConfig
   Assembly Version: 3.2.7.0
   Win32 Version: 3.2.7.0
   CodeBase: file:///C:/Program%20Files/SphereII%20Software/7D2D%20Mod%20Launcher%20Installer/SharpConfig.DLL
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
   <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

 

Windows 10 x64 fully updated, re-downloaded and re-installed the Mod Launcher just to be sure. Clicking 'Continue' on the error window will allow the app to load properly, and it shows all available mods/modlets. A close/re-launch of the app however makes it re-prompt for the mod install location (it seems it forgets every time it is closed), and the error occurs again.

 

I have reverted the custom mod directory back to the default of C:\7D2D and the prompt for mod location (and error) still happen. Installed mods/modlets appear to work properly when launched, so this may be a launcher-related problem only.

 

Version in use: 2.0.80.18955

7D2D version installed (default Steam directory): 17.2

 

Any suggestions for troubleshooting or getting info for you to debug are welcome.

Link to comment
Share on other sites

Unrelated to mods but to do with the launcher, but how would I go about downloading alphas older than 8.8? I've heard it's possible but cant see a way to do it on there unless i'm being really stupid

 

Thanks in advance if anyone knows how

Link to comment
Share on other sites

Can I just ask when I add new modlets to the Github do they automatically show up in the mod launcher from there original git link....

 

Oh my, I'm so sorry. I did not see your message.

 

They should. Each time you refresh, it crawls and updates the database with all the latest information. Then, each time someone loads the modlet screen, they download the freshest copy of it.

 

Are you not seeing the changes you are expecting?

 

- - - Updated - - -

 

Unrelated to mods but to do with the launcher, but how would I go about downloading alphas older than 8.8? I've heard it's possible but cant see a way to do it on there unless i'm being really stupid

 

Thanks in advance if anyone knows how

 

Sure, take a look here: https://7daystodie.com/forums/showthread.php?106460-Guide-How-To-download-almost-every-past-Steam-version-of-7-Days-To-Die-from-Steam

Link to comment
Share on other sites

When refreshed its showing 20 instead of 22 no scroll bar is it locked to seeing 20 maybe...

 

1.png

 

2.png

 

Could you add this as a separate as its basically all my mods included in 1 modlet folder so its much more stream lined as im able to incorporate lots of changes compared to having them all separate....

 

https://github.com/War3zuk/War3zuk-Modlet-Pack

Edited by Tallon (see edit history)
Link to comment
Share on other sites

When refreshed its showing 20 instead of 22 no scroll bar is it locked to seeing 20 maybe...

 

1.png

 

2.png

 

No, I don't limit the size of the display of results. I just checked; one of your mods is under the user "Tallon" only, so if you filter on War3zuk/Tallon, then you won't see another one ( Tallon's Modedd Extras ). If you look under Installed Modlets, do you have one available?

 

The screen is awkwardly split between Installed vs not Installed modlets, to help people see what's available and what they have. The Available list does not list the mods you already have installed; perhaps that's a design mistake on my part.

Link to comment
Share on other sites

Yeah the modded extras should be removed as its old, everything should ONLY be under war3zuk/Tallon if possible..... read up cos i was editing when you replied... :)

 

All in one IS NOT compatible with the modlets for obvious reasons.....

 

This is my overhaul...

https://github.com/War3zuk/Tallon-Redux-Alpha-17.2-OverHaul

Edited by Tallon (see edit history)
Link to comment
Share on other sites

.NET Framework "Unhandled exception" after running the app, just after it prompts to select mod install location is happening for me.

 

"Unhandled exception has occurred in a component in your application. If you click Continue, the application will ignore this error and attempt to continue. Object reference not set to an instance of an object."

 

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
  at _7D2DLauncher.frmMain.PickModdedFolder() in C:\Users\jkilpatrick\Documents\GitHub\7D2DModLauncher\7D2DLauncher\7D2DLauncher\7D2DLauncher.cs:line 1780
  at _7D2DLauncher.frmMain.txtModdedGameFolder_TextChanged(Object sender, EventArgs e) in C:\Users\jkilpatrick\Documents\GitHub\7D2DModLauncher\7D2DLauncher\7D2DLauncher\7D2DLauncher.cs:line 3065
  at System.Windows.Forms.Control.OnTextChanged(EventArgs e)
  at System.Windows.Forms.TextBoxBase.WmReflectCommand(Message& m)
  at System.Windows.Forms.RichTextBox.WmReflectCommand(Message& m)
  at System.Windows.Forms.RichTextBox.WndProc(Message& m)
  at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
   Assembly Version: 4.0.0.0
   Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
   CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
7D2DLauncher
   Assembly Version: 2.0.80.18955
   Win32 Version: 2.0.80.18955
   CodeBase: file:///C:/Program%20Files/SphereII%20Software/7D2D%20Mod%20Launcher%20Installer/7D2DLauncher.exe
----------------------------------------
System.Windows.Forms
   Assembly Version: 4.0.0.0
   Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
   CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
   Assembly Version: 4.0.0.0
   Win32 Version: 4.7.3353.0 built by: NET472REL1LAST_B
   CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
   Assembly Version: 4.0.0.0
   Win32 Version: 4.7.3056.0 built by: NET472REL1
   CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
log4net
   Assembly Version: 2.0.8.0
   Win32 Version: 2.0.8.0
   CodeBase: file:///C:/Program%20Files/SphereII%20Software/7D2D%20Mod%20Launcher%20Installer/log4net.DLL
----------------------------------------
System.Net.Http
   Assembly Version: 4.1.1.3
   Win32 Version: 4.6.26907.01
   CodeBase: file:///C:/Program%20Files/SphereII%20Software/7D2D%20Mod%20Launcher%20Installer/System.Net.Http.DLL
----------------------------------------
System.Configuration
   Assembly Version: 4.0.0.0
   Win32 Version: 4.7.3056.0 built by: NET472REL1
   CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Core
   Assembly Version: 4.0.0.0
   Win32 Version: 4.7.3324.0 built by: NET472REL1LAST_C
   CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Xml
   Assembly Version: 4.0.0.0
   Win32 Version: 4.7.3056.0 built by: NET472REL1
   CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Deployment
   Assembly Version: 4.0.0.0
   Win32 Version: 4.7.3056.0 built by: NET472REL1
   CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Deployment/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Deployment.dll
----------------------------------------
AutoUpdater.NET
   Assembly Version: 1.4.11.0
   Win32 Version: 1.4.11.0
   CodeBase: file:///C:/Program%20Files/SphereII%20Software/7D2D%20Mod%20Launcher%20Installer/AutoUpdater.NET.DLL
----------------------------------------
SharpConfig
   Assembly Version: 3.2.7.0
   Win32 Version: 3.2.7.0
   CodeBase: file:///C:/Program%20Files/SphereII%20Software/7D2D%20Mod%20Launcher%20Installer/SharpConfig.DLL
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
   <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

 

Windows 10 x64 fully updated, re-downloaded and re-installed the Mod Launcher just to be sure. Clicking 'Continue' on the error window will allow the app to load properly, and it shows all available mods/modlets. A close/re-launch of the app however makes it re-prompt for the mod install location (it seems it forgets every time it is closed), and the error occurs again.

 

I have reverted the custom mod directory back to the default of C:\7D2D and the prompt for mod location (and error) still happen. Installed mods/modlets appear to work properly when launched, so this may be a launcher-related problem only.

 

Version in use: 2.0.80.18955

7D2D version installed (default Steam directory): 17.2

 

Any suggestions for troubleshooting or getting info for you to debug are welcome.

 

Any thoughts on this error spherii? I've run the .net testing tool, and have all necessary versions installed on the machine and registered correctly. I even tried downloading the superseded installers which indicated they couldn't install due to being included in newer versions.

Link to comment
Share on other sites

Any thoughts on this error spherii? I've run the .net testing tool, and have all necessary versions installed on the machine and registered correctly. I even tried downloading the superseded installers which indicated they couldn't install due to being included in newer versions.

 

I'm sorry, I must have missed this earlier.

 

With the mod launcher closed, try going here in Explorer: %appdata%\..\Roaming\7D2DModLauncher

 

and delete everything in the folder. Then restart the mod launcher and see if that helps. I don't think its a missing library thing, but could be a bad setting.

Link to comment
Share on other sites

  • Crater Creator changed the title to The 7D2D Mod Launcher - A Mod Launcher for 7 Days to Die

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...