Jump to content

The 7D2D Mod Launcher - A Mod Launcher for 7 Days to Die


sphereii
 Share

Recommended Posts

The local mod is called "My mods". You can make your own downloadable mods, and use the Launcher to install them. It won't actually generate a mod itself.

 

Ok, so let's rephrase it. How does one make a downloadable mod? :) Also, does it need to be "downloaded", or can it be on the local filesystem? And if needs to be downloaded, is an HTTP link enough, or is there a special format?

 

Or, more simply stated, where can I find information about all of that?

Link to comment
Share on other sites

No worries. You are officially the second one to mention to me that the mod launcher doesn't like spaces in the year and a half that the launcher has been alive
:) The reason is to avoid any possible conflicts when copying files around, regardless of which version of Windows you have. The Launcher can handle them perfectly fine under most circumstances, but I did not want to deal with the corner cases of when it could have been an issue.

All the mods in the Mod Launcher are known to be working, so let's figure out why it's not working for you right now. What seems to be the issue that you are having with it?


For some reason with Starvation mod I am getting:

 

It then launches into what looks like an unmodified version.

Link to comment
Share on other sites



For some reason with Starvation mod I am getting:
INFO 7 _7D2DLauncher.frmMain - Attempting to download: [url]https://github.com/StarvationTeam/StarvationMod/archive/master.zip[/url]
INFO 7 _7D2DLauncher.frmMain - Clone Download Mode Detected. Using libgit2sharp...
INFO 7 _7D2DLauncher.frmMain - Previous sync exists. Refreshing...
INFO 7 _7D2DLauncher.frmMain - Error Downloading: [url]https://github.com/StarvationTeam/StarvationMod/archive/master.zip[/url]
INFO 7 _7D2DLauncher.frmMain - System.InvalidOperationException: Sequence contains no matching element
  at System.Linq.Enumerable.Single[TSource](IEnumerable`1 source, Func`2 predicate)
  at _7D2DLauncher.frmMain.bgWorker_DoWork(Object sender, DoWorkEventArgs e)
INFO 7 _7D2DLauncher.frmMain - Warning: Download attempt failed. Will retry...
INFO 7 _7D2DLauncher.frmMain - System.InvalidOperationException: Sequence contains no matching element
  at System.Linq.Enumerable.Single[TSource](IEnumerable`1 source, Func`2 predicate)
  at _7D2DLauncher.frmMain.bgWorker_DoWork(Object sender, DoWorkEventArgs e)
INFO 7 _7D2DLauncher.frmMain - Detected Bad Git Repos. Attempting to force a refresh...
INFO 1 _7D2DLauncher.frmMain - Background Process completed: Refreshing Mods for StarvationMod16
INFO 1 _7D2DLauncher.frmMain - Updating Registry with IP Address and port: None:None
INFO 1 _7D2DLauncher.frmMain - launching: G:\7_Days_2_Die_-_Mods\StarvationMod\StarvationMod16\7DaysToDie.exe

 

It then launches into what looks like an unmodified version.

 

Try to click on Disable SSL, and try again. Some ISPs seem to be filtering github, but seems to affect Starvation more than others.

 

- - - Updated - - -

 

Ok, so let's rephrase it. How does one make a downloadable mod? :) Also, does it need to be "downloaded", or can it be on the local filesystem? And if needs to be downloaded, is an HTTP link enough, or is there a special format?

 

Or, more simply stated, where can I find information about all of that?

 

I've never tried to get it to download from a local folder, so I'm not sure if that would work.

 

It can download direct links, in the form of .zip files, or it can sync against a github.com / gitlab.com repository. It's expected that the files are in the correct folder structure, such as Data/Config/items.xml.

 

The Mod Launcher can figure out where the files need to go based on filename alone, but it just makes it harder for people to manually install the mod.

Link to comment
Share on other sites

That's by design smile.png

 

I am sorry, but that is not a good design then, spaces are legal in path names.

 

Thank you for your feed back!.

 

That was probably more polite than I would have been. :)

 

 

Don't you know that "Thank you for your feed back" is a Canadians way of saying Screw You :D

 

I am Canadian also.

 

 

 

 

 

 

 

 

 

 

(Thank you for your feed back) :D

Edited by Gamida (see edit history)
Link to comment
Share on other sites

Try to click on Disable SSL, and try again. Some ISPs seem to be filtering github, but seems to affect Starvation more than others.

Tried this, get the same error pretty much, it still says downloading https://..... so I don't know if the disable ssl worked.

 

I can use the link in the log in a browser and it downloads with output a problem.

Link to comment
Share on other sites

Tried this, get the same error pretty much, it still says downloading https://..... so I don't know if the disable ssl worked.

 

I can use the link in the log in a browser and it downloads with output a problem.

 

Yeah, display is still SSL, but tries the connection without SSL. Something is filtering the github calls on your end, or ISP.

 

To get around this for now, click on Direct Download. After the first download, click on the Refresh Mods Automatically to disable it. Periodically check that, and do a play to keep it in sync.

Link to comment
Share on other sites

Yeah, display is still SSL, but tries the connection without SSL. Something is filtering the github calls on your end, or ISP.

 

To get around this for now, click on Direct Download. After the first download, click on the Refresh Mods Automatically to disable it. Periodically check that, and do a play to keep it in sync.

 

Yes, that seems to work. ISP is generally pretty good, I have not noticed them blocking things before. Does the direct download restart from where it left off?

Link to comment
Share on other sites

Yes, that seems to work. ISP is generally pretty good, I have not noticed them blocking things before. Does the direct download restart from where it left off?

 

No, that's the downfall for the direct link.

 

We recently found out that github is on some weird global filter list, and some ISPs are filtering github API traffic, which the mod launcher uses for the faster downloads. We are looking at alternative solutions

Link to comment
Share on other sites

No, that's the downfall for the direct link.

 

We recently found out that github is on some weird global filter list, and some ISPs are filtering github API traffic, which the mod launcher uses for the faster downloads. We are looking at alternative solutions

 

Is this related to the issue I had with broadband shield preventing the launcher from working? If so and you're seeking a solution I'll keep an eye on the thread.

Link to comment
Share on other sites

Is this related to the issue I had with broadband shield preventing the launcher from working? If so and you're seeking a solution I'll keep an eye on the thread.

 

Yes, I believe the Shield is using that filter list. There may be no solution that the Mod Launcher can do, other than encourage a migration to another hosting service, which is a bit extreme.

Link to comment
Share on other sites

No, that's the downfall for the direct link.

 

We recently found out that github is on some weird global filter list, and some ISPs are filtering github API traffic, which the mod launcher uses for the faster downloads. We are looking at alternative solutions

 

Yes, I was able to get Starvation to work using the direct download method.

 

It would be nice if there was a progress indicator of some type, especially since Starvation is so large.

Link to comment
Share on other sites

Yes, I was able to get Starvation to work using the direct download method.

 

It would be nice if there was a progress indicator of some type, especially since Starvation is so large.

 

I agree. It's not exposed by the API, nor is it a relatively simple thing to implement.

Link to comment
Share on other sites

Is there any way, with your tool, of specifying a different save game location (automatically) with out manually creating a config file to do so? I generally like having a different path so that the different mods do not have access to damage, saves that are not there own. I am not sure what happens if you load a game from a different mod. I assume it would depend on the differences between the mods.

Link to comment
Share on other sites

Is there any way, with your tool, of specifying a different save game location (automatically) with out manually creating a config file to do so? I generally like having a different path so that the different mods do not have access to damage, saves that are not there own. I am not sure what happens if you load a game from a different mod. I assume it would depend on the differences between the mods.

 

A few pages back, a user suggested that we can make a client-config file, like the server one, and it'd use its settings for the save game location. I wanted to include it in the last release, but I never had time to test. I'm hoping next release will have the concept of a local saved game.

Link to comment
Share on other sites

Test Mod Sync downloads the Mods into the TempMods folder. The Play button does the same thing, but launches the game right after. Since some people have been having trouble downloading from Github, I recommend pressing Test Mod Sync first, so that they can see the errors, if there are any, before just starting the game.

 

The Refresh Mod Automatically skips re-downloading. This is for people who want to make changes to the mod, without re-downloading fresh ones. If you are limited on bandwidth, or want a consistent play base (streamers, Let's Plays, etc), then you'd also disable this.

 

Thanks for reply, and sorry for late.

But, what I meant is...

 

  1. When I use launcher, I always disable "Refresh Mods Automatically"
  2. I update mod only after I check what is changed.
  3. If I wanna update mod, use "Test Mod Sync"
  4. Disable "Refresh Mods Automatically" + "Test Mod Sync" -> Don't work
  5. Check "Refresh Mods Automatically" + "Test Mod Sync" -> Work

 

The Excludes function is hooked into the Play's Copy task, rather than the download task. So while it will download the excluded files under TempMods, it just won't copy them over.

 

Thanks for advise. This helps a lot. :)

Link to comment
Share on other sites

Thanks for reply, and sorry for late.

But, what I meant is...

 

  1. When I use launcher, I always disable "Refresh Mods Automatically"
  2. I update mod only after I check what is changed.
  3. If I wanna update mod, use "Test Mod Sync"
  4. Disable "Refresh Mods Automatically" + "Test Mod Sync" -> Don't work
  5. Check "Refresh Mods Automatically" + "Test Mod Sync" -> Work

 

 

 

Thanks for advise. This helps a lot. :)

 

So you feel an appropriate expectation is that when you press on Test Mod Sync, it updates, regardless of whether Refresh Mods Automatically is selected? I do agree with you, but am curious about how widespread that thought would be. I am sure the majority of users have Refresh Mods automatically, so it probably has little effect.

 

I'll look into adjusting the code to allow 4 to work as you expect.

Link to comment
Share on other sites

So you feel an appropriate expectation is that when you press on Test Mod Sync, it updates, regardless of whether Refresh Mods Automatically is selected? I do agree with you, but am curious about how widespread that thought would be. I am sure the majority of users have Refresh Mods automatically, so it probably has little effect.

 

I'll look into adjusting the code to allow 4 to work as you expect.

 

If you make that change I would suggest changing the name of the "Test Mod Sync" button. Most people don't expect a button labeled "Test" to make actual changes to their system.

Link to comment
Share on other sites

Problems with Launcher... blank screen

 

I've tried using the launcher several times... everytime I launch something (simple mode, with EAC and "start with steam" turned on and off)... I get the 7D2D splash screen... then the screen goes black. I have a 7D2D cursor, but that's it. The only way to get things back is to use steam to reinstall the main game.

 

Suggestions? I'd love to use the tool, but I play enough 'basic' 7D2D with my friends that I don't want to keep manually fixing my game.

 

Thanks in advance!

Link to comment
Share on other sites

I've tried using the launcher several times... everytime I launch something (simple mode, with EAC and "start with steam" turned on and off)... I get the 7D2D splash screen... then the screen goes black. I have a 7D2D cursor, but that's it. The only way to get things back is to use steam to reinstall the main game.

 

Suggestions? I'd love to use the tool, but I play enough 'basic' 7D2D with my friends that I don't want to keep manually fixing my game.

 

Thanks in advance!

 

I'd recommend against using Simple mode, as it can make a bit of a mess with your files. Clear our your Steam install of 7 days ( delete all the files, then validate), and try using the Advanced Mode.

 

Sounds like some mods may have broken EAC, and is conflicting with your vanilla play.

Link to comment
Share on other sites

So you feel an appropriate expectation is that when you press on Test Mod Sync, it updates, regardless of whether Refresh Mods Automatically is selected? I do agree with you, but am curious about how widespread that thought would be. I am sure the majority of users have Refresh Mods automatically, so it probably has little effect.

 

I'll look into adjusting the code to allow 4 to work as you expect.

 

Yea, you are right.

This may be minor preference, but some of my acquaintances plays this way. So this has a little effect at least.

Thanks for attempt.:)

 

 

BTW, my friend has a trouble recently. He could run the launcher until 2 days ago, but it shows no mods for now.

 

SS is here.

 

BebxfcA.jpg

 

Error log is here.

https://pastebin.com/raw/fqWwaA0Y

 

What we tested is following, but things don't fix the issue.

  • Reboot Launcher
  • Check Disable SSL and Reboot Launcher
  • Load Defaults and Reboot Launcher
  • Use Open URL feature & pasted url for my personal My Mods xml then Reboot Launcher (don't works)
  • Clear Mod History and Reboot Launcher
  • Reboot PC
  • Re-downloaded Launcher via 7d2dmodlauncher.exe (newly downloaded one)

 

Any other idea? Any help is appreciated. :)

Link to comment
Share on other sites

Yea, you are right.

This may be minor preference, but some of my acquaintances plays this way. So this has a little effect at least.

Thanks for attempt.:)

 

 

BTW, my friend has a trouble recently. He could run the launcher until 2 days ago, but it shows no mods for now.

 

SS is here.

 

BebxfcA.jpg

 

Error log is here.

https://pastebin.com/raw/fqWwaA0Y

 

What we tested is following, but things don't fix the issue.

  • Reboot Launcher
  • Check Disable SSL and Reboot Launcher
  • Load Defaults and Reboot Launcher
  • Use Open URL feature & pasted url for my personal My Mods xml then Reboot Launcher (don't works)
  • Clear Mod History and Reboot Launcher
  • Reboot PC
  • Re-downloaded Launcher via 7d2dmodlauncher.exe (newly downloaded one)

 

Any other idea? Any help is appreciated. :)

 

Sorry for the trouble. Typically, when the Mod Listing is blocked, Disabling SSL will help resolve it. Something his blocking it; either a firewall, anti-virus, or his ISP. Sadly, I do not know of any other way to circumvent it, other than Disabling SSL.

Link to comment
Share on other sites

  • Crater Creator changed the title to The 7D2D Mod Launcher - A Mod Launcher for 7 Days to Die

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...