Jump to content

Possible Yellow Note Quest Bug?


Lorri
 Share

Recommended Posts

Hello. I am unsure if this is a bug within the game or just something going wrong on my end. I don't quite remember when it started but sometime in Alpha 19 the yellow notes that give you specific quests (ie. Killing Lumberjacks with an Axe) no longer work for me. I click read and accept the quest but it then shows up as 0m away on my hud. I click on the quest in my quest list to show it on the map and it says that the quest can not be shown on the map. 

 

I have tried looking around the internet to see if this is happening to anyone else and I can not find anything on the subject. I am on the latest version as of today (Alpha 19.6, 10/21/21) and I am playing on a KingGen map if that makes any difference. I am playing plain vanilla (no mods) too. Is this something that other people are experiencing or could it be just me? Any help would be appreciated. Thank you for reading.

Link to comment
Share on other sites

Killing lumberjacks (AFAIK) is a quest without location. You just enter the winter biome and kill Lumberjacks there until you satisfied the required amount

 

Even quests with a location can be finished everywhere and on your own time. That is important in multiplayer as there could be more players doing the quest than zombies are spawned at that location

 

Link to comment
Share on other sites

6 hours ago, Lorri said:

Hello. I am unsure if this is a bug within the game or just something going wrong on my end. I don't quite remember when it started but sometime in Alpha 19 the yellow notes that give you specific quests (ie. Killing Lumberjacks with an Axe) no longer work for me. I click read and accept the quest but it then shows up as 0m away on my hud. I click on the quest in my quest list to show it on the map and it says that the quest can not be shown on the map. 

 

I have tried looking around the internet to see if this is happening to anyone else and I can not find anything on the subject. I am on the latest version as of today (Alpha 19.6, 10/21/21) and I am playing on a KingGen map if that makes any difference. I am playing plain vanilla (no mods) too. Is this something that other people are experiencing or could it be just me? Any help would be appreciated. Thank you for reading.

 

I have had this same bug happen several times with several different area specific quests.  Also on 19.6.

 

 

1 hour ago, meganoth said:

Killing lumberjacks (AFAIK) is a quest without location. You just enter the winter biome and kill Lumberjacks there until you satisfied the required amount

 

Even quests with a location can be finished everywhere and on your own time. That is important in multiplayer as there could be more players doing the quest than zombies are spawned at that location

 

 

"I'm a lumberjack but that's okay" is an area specific quest for sure.

Edited by kaldarprime (see edit history)
Link to comment
Share on other sites

2 hours ago, meganoth said:

Killing lumberjacks (AFAIK) is a quest without location. You just enter the winter biome and kill Lumberjacks there until you satisfied the required amount

 

Even quests with a location can be finished everywhere and on your own time. That is important in multiplayer as there could be more players doing the quest than zombies are spawned at that location

 

How can you complete the quest without activating it though? There isn't a yellow exclamation point at all. It just says the quest is 0m away. That goes for every yellow note quest. I was just using the Lumberjack one as an example.

1 hour ago, Sarakatunga said:

The same thing happens to me, the sign does not appear or it appears underground without working. In several maps I have tried and it happens until one created by the game.

 

 

 

 

asd444.png

 

I have not seen an underground activation point since Alpha 18 I believe. At least it shows up for you lol Is this a common bug? Do you know if it is with every single yellow note quest or just specific ones?

Kaiderprime, I wonder if reverting back to Alpha 19.5 would fix it? As far as I can remember, the only thing 19.6 did was include Twitch integration. I don't stream so it wouldn't bother me to get rid of that feature. I'm not sure when the issue with AP ammunition was fixed though. I'd hate to lose that.

Link to comment
Share on other sites

2 hours ago, kaldarprime said:

 

I have had this same bug happen several times with several different area specific quests.  Also on 19.6.

 

 

 

"I'm a lumberjack but that's okay" is an area specific quest for sure.

 

Then I misremembered it, probably from earlier times.

 

I have seen the bug with invisible exclamation mark a few times, but always in modded games I think. If you can reliably reproduce the bug in vanilla, make a bug report. If not, deleting the quest in the quest log should remove any problems with it.

 

Link to comment
Share on other sites

Thank you for your help. I can reproduce it with no problem. It has happened with every quest like that. Once it is accepted, it is always 0m away (no matter the quest type) with no yellow exclamation point at all anywhere on the map. Deleting the quest does indeed "fix" it but I don't get to do the quest. And sometimes I just feel like killing some rabbits with a nailgun lol 

Link to comment
Share on other sites

On 10/21/2021 at 7:45 AM, kaldarprime said:

"I'm a lumberjack but that's okay" is an area specific quest for sure.

Area specific as in only areas where lumberjacks spawn in, not specific location like Lady Killer where you go to a specific location where they spawn in.

 

These quests have a rally point that starts the quest (so you will see a location and distance in your map / quest log if you haven't started it yet.  Once you accept the quest though, the location disappears):

  • Silence of the Lambs
  • Nurse you back to Health
  • Starving Tourists
  • Dog Days are Over
  • Itsy Bitsy Spider
  • Lady Killer
  • Maneater
  • You're Nothing Special
  • Blitz Defense
  • Give me a Z
  • Dishonorable Discharge
  • Cable Guys never made it
Quote

 

        <objective type="RandomGoto" value="500-800" phase="1">
            <property name="completion_distance" value="50"/>
            <property name="nav_object" value="quest" />
        </objective>

        <objective type="RallyPoint">
            <property name="start_mode" value="Create"/>
            <property name="phase" value="2"/>
            <property name="nav_object" value="rally" />
        </objective>

 

 

These quests can be completed anywhere after accepting the quest (so no quest markers and nothing on your map indicating a location to go to):

  • Drunk and Disorderly
  • I'm a Lumberjack and I'm okay
  • Kill the Rabbit
  • Nail some Chicks
  • That'll Do Pig
  • Stag Party
  • Don't Feed the Bears
  • Buy the Farm

I believe all of them can be completed just by fullfilling the conditions of the quest, none of them have to be done in a specific location (even the ones with rally points can be done at areas outside of original locations - I have done that when I started the Nothing Special quest at low levels and booked it out of there so I wasn't fighting all the specials right there).  These quests are not like the POI quests which has a perimeter you have to stay before you complete the quest

 

Quote

        <objective type="POIStayWithin">
            <property name="phase" value="3"/>
            <property name="radius" value="25"/>
        </objective>

 

Note, this is the area in the Quest.xml file that defines the boundary.  If you want to remove that boundary or expand on it, you would modify this portion of the quest file.

Link to comment
Share on other sites

 

Thanks BFT, so I was right after all.

9 hours ago, Lorri said:

Thank you for your help. I can reproduce it with no problem. It has happened with every quest like that. Once it is accepted, it is always 0m away (no matter the quest type) with no yellow exclamation point at all anywhere on the map. Deleting the quest does indeed "fix" it but I don't get to do the quest. And sometimes I just feel like killing some rabbits with a nailgun lol 

 

If every such quest does this then it isn't a bug but your savegame likely is corrupted. Read the pinned thread in this forum section that tells you to read it and follow its advice on how to post your logfile.

 

Please post the logfile of a session where you accept such a quest and try to solve it.

 

 

 

Edited by meganoth (see edit history)
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...