Jump to content

Asus ROG can't connect to any servers


Recommended Posts

Hello I cannot connect to my friend's hosted server game once I try to join it crashes on her end and I get a server disconnected message. I tried deleting/reinstall, deleting all game save files and file integrity along with disabling Xbox game bar but still same. I tried joining Random peer to peer servers and it seems to do the same to them as I get the same message and when I go back to the server room the hosted game is gone. .I have no mods and I know the system is well beyond basic requirements. Any ideas?


Edited by gnildem (see edit history)
Link to comment
Share on other sites

My apologizes this is the first time I've even had to contact a form or board to solve a technical issue.  


As I stated above I cannot connect to any peer to peer game servers, once I try to join one sometimes I get past the load screen and spawn/sometimes it doesn't make it past loading but either away I get a server disconnected message and taken back to menu. I was told by a first I every time I tried to load into her hosted game it crashes her game/server and I noticed every random server I try to join I get disconnected and when I look back into server lobby the particular game I tried to join has disappeared I believe I crash others hosted games also.  


  • Did you start a new game and re-create the issue?
    • Yes, I went as far as wiping all the game files, uninstalling the game, and using the game launcher tool to clean all the game files.
  • Have you validated your files through Steam?
    • Yes multiple times
  • After validation, did you re-try with a brand new game?
    • Yes, never had an issue starting my local game but still couldn't join servers
  • Run game without anti-cheat
    • started the game from the non -EAC.exe file, made no difference
  • Disabled Xbox game bar per form user suggestion
    • No difference
  • Also turned off motion blur and disabled discord as another form recommended
    • No difference


My Log: https://pastebin.com/jXfh38Ea

Working on collecting logs from someone that crashes out when I join. 


I hope this is more acceptable, also I didn't see your pinned thread on troubleshooting this type of issue. 

18 hours ago, BFT2020 said:

Not sure how people miss the pinned threads

Useless comment not sure why you even felt this was needed to be added. 


Link to comment
Share on other sites

44 minutes ago, Fox said:

Port forwarded at her end? If you or her have a VPN installed, did you disable it (very important)? Have you tried disabling the firewall, her too?

OP said he crashes any computer they join, not just hers


I am not an expert, but this seemed weird to me




Should this be -10-0 instead?  Seems like it was encoded incorrectly (search seems to indicate this is Windows-1252.  Using an online decoder to UTF-8 gave me -10-0


  1. 2021-08-28T18:20:51 7.039 INF Command line arguments: C:\Program Files (x86)\Steam\steamapps\common\7 Days To Die\7daystodie.exe -force-feature-level–10–0 -force-d3d11 -logfile C:\Program Files (x86)\Steam\steamapps\common\7 Days To Die\7DaysToDie_Data\output_log__2021-08-28__18-20-26.txt -eac_executablename 7daystodie.exe
Edited by BFT2020 (see edit history)
Link to comment
Share on other sites

Adding "feature-level..." is one of the suggestions floating around the net if 7D2D is crashing, to force dirextx10. Especially funny when the next parameter is "force-d3d11"


The feature-level paramter can be removed in the launcher I would guess. If the issue still happens it might be a general operating system setting of using the older encoding. 


Alternatively the encoding problem could simply be a result from copy-pasting the string from the browser.


Link to comment
Share on other sites

Posted (edited)

Hi Guys 

Thank you for looking into my issue, I did copy and paste that force -10 into the launcher as recommended in other posts but it seemed to make no difference. There seems to be an issue with this Asus I'll attach all the system info just to help. I use to play on an old outdated alienware and it played mostly flawlessly but ever since I switched to this Asus I have had problems playing this game.  


OS Name    Microsoft Windows 10 Pro
Version    10.0.19042 Build 19042
System Name    LAPTOP-0TI760RI
System Manufacturer    ASUSTeK COMPUTER INC.
System Model    ROG Strix G712LW_G712LW
System Type    x64-based PC
Processor    Intel(R) Core(TM) i7-10750H CPU @ 2.60GHz, 2592 Mhz, 6 Core(s), 12 Logical Processor(s)
BIOS Version/Date    American Megatrends Inc. G712LW.311, 1/8/2021
SMBIOS Version    3.2
Embedded Controller Version    3.10
BaseBoard Manufacturer    ASUSTeK COMPUTER INC.
BaseBoard Product    G712LW
BaseBoard Version    1.0
Platform Role    Mobile
Secure Boot State    On
PCR7 Configuration    Elevation Required to View
Windows Directory    C:\Windows
System Directory    C:\Windows\system32
Boot Device    \Device\HarddiskVolume1
Hardware Abstraction Layer    Version = "10.0.19041.1151"
Installed Physical Memory (RAM)    32.0 GB
Total Physical Memory    31.8 GB
Available Physical Memory    24.3 GB
Total Virtual Memory    36.5 GB
Available Virtual Memory    27.5 GB
Page File Space    4.75 GB
Kernel DMA Protection    On
Virtualization-based security    Not enabled
Device Encryption Support    Elevation Required to View
Hyper-V - VM Monitor Mode Extensions    Yes
Hyper-V - Second Level Address Translation Extensions    Yes
Hyper-V - Virtualization Enabled in Firmware    Yes
Hyper-V - Data Execution Protection    Yes



8 hours ago, Jugginator said:

Would you mind connecting to my client sometime? Can shoot me a dm if you wish.

Heck yeah I'd greatly appreciate it if you could look at the client log maybe something will stand out! 


Edited by gnildem (see edit history)
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...