Jump to content

Friend can't join anymore/high latency


Recommended Posts


 me and a friend have been playing the game without issues since a couple of weeks. (with me as the server host).

Today, during our game session, he started experiencing delays (due to high ping) and now he cannot join my game anymore.
Even starting a new game doesn't work.

We have the same version and no port forwarding/windows firewall has been touched today nor windows updates were downloaded.


 - I've tried disabling everything (firewall and antivirus) 

 - I've tried uninstalling completely the game (clean uninstall) and reinstalling it.

 - I've tried opening custom ports and using them with the dedicated server tool

 - I've tried rebooting my router (Fritz!box 7530) after removing and adding again 7dtd ports

nothing worked.


Even if he manages to join (after a long wait time) he is stuck with a very high ping value (about 190000) 

I checked my connection and i didn't find issues.


We can both join other servers without issues.


These are the opened ports:
UDP: 26900-26902
TCP: 26900


Any suggestion?


Edited by KalaDan (see edit history)
Link to comment
Share on other sites

Almost certainly a low level packet loss somewhere between you two. Usually the only way pings get that high is due to lost packets being retransmitted and the backup packet getting there in time to be "useful" (that being a relative term, if you can't play)


Not sure what your level of network knowledge is. It's clearly above the average gamer from your testing steps so far, but if the follow steps don't make sense, don't worry, it will probably resolve in time.


1. Enable pings to your router. It may be called ICMP

2. Find out what your public IP address is.

3. Have your friend ping your public IP address using "ping x.x.x.x. -t"  where x.x.x.x is your public IP.

4. Give it a decent time. At least a minute, then cancel it with control-c.

5. Look for the summary at the end, and what the loss ratio is. If it's not 0%, there's your answer.


If you want to go further, you can use the command "tracert x.x.x.x" and see where the packet loss/large jumps in latency starts.  Losing all 3 packets on one line of a trace route is normal, and just means that router is refusing to answer. Getting only 1 or 2 of the 3 back indicates that router is where the problem is. If it's not the first or last hop, then it's an ISP problem and nothing you can really do about it.


Finally, if you are really desperate to play and have decent network skills,  your friend can try to VPN somewhere, since the problem only seems to occurring when you are directly connecting to each other. It might change the route taken. Using a VPN with something like Forward Error Correction can help with packet loss by recovering lost packets faster than a retransmit. 


Good luck.

Link to comment
Share on other sites

You need UDP 26903 open for LiteNetLib, which is the protocol responsible for network performance.


Also extremely high ping usually indicates a failure to exclude the client from security software. This is covered in the FAQ thread. Since he has the high ping, it's likely on his system. On your system, just because you disabled firewall and AV, does not necessarily mean they aren't causing an issue. Windows Defender and Norton both are notorious for this.

Link to comment
Share on other sites

Huh. Interesting that it worked previously without opening the port, but suddenly broke.


Out of curiousity I checked my firewall logs for that port. Plenty logs of me going out, but none of them for my friends coming into my dedicated server.  Maybe a difference between P2P and dedicated server gaming? Anyway... Glad it's solved for you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...