Jump to content

enZombies - More Zombie Variations


ErrorNull

Recommended Posts

Bugs I got on the A20

Get this wile hordes going.
Error Could not load file ‘#Entities/Zombies?Zombies/zombie01Ragdoll.prefab’ for entity_class ‘khzCharlotte’
And
Businessman Boss will flood the console with red lines where you have to restart the server.
he was working in 19.
 

Edited by Scharie (see edit history)
Link to comment
Share on other sites

First I wanted to say great mod.  I just have enzombies installed with the loot mod. I do love the fact they all look like dead survivers.  Adds new look to the game.

 

For the regular zombies I was using the mod jaxteller718 reduce zombie hand reach.  This does not seem to effect your added zombies.  

 

I was wondering if there was a way to edit your mod so I can reduce the range of the zombie hand hit range?  I'm new to moding so any tips would be appreciated.

 

Thank you for your time.

Link to comment
Share on other sites

10 hours ago, Scharie said:

Bugs I got on the A20

Get this wile hordes going.
Error Could not load file ‘#Entities/Zombies?Zombies/zombie01Ragdoll.prefab’ for entity_class ‘khzCharlotte’
And
Businessman Boss will flood the console with red lines where you have to restart the server.
he was working in 19.
 

Maybe ErrorNull is a bit wrapped up with bits at the moment to provide an update. I am also using the enZombies and am glad you spotted these because they are something we all need to consider.

 

For now:

 

1. khz type of zombies

 

Replace at line 5901 and 6196
        <property name="Mesh" value="#Entities/Zombies?Zombies/zombie01Ragdoll.prefab" />

 

with

 

        <!--property name="Mesh" value="#Entities/Zombies?Zombies/zombie01Ragdoll.prefab" /-->

 

(We're just adding !-- at the beginning area and -- at the end)

 

in your entityclasses.xml file under 2 areas for 'khzTemplateMale1' and also 'aa_00'. aa_00 looks like a test entity but it shouldn't hurt game play. You never know who uses F6 to spawn things in though.

 

This will 'comment out' that entry for now and let this character fall back on the regular zombie template used for all zombies and should resolve the khzCharlotte and all other khz entity issues.

 

20211229131035_1.thumb.jpg.55f35ebbecb3b5ec8c907cf588f64749.jpg

 

20211229131107_1.thumb.jpg.96e33e7c56884e4a274ab684db00e8b4.jpg

 

2. Business Boss

 

Replace at line 5784:

 

<property name="Mesh" value="#Entities/Zombies?Zombies/zombieStandardSuitHDRagdoll.prefab"/>

 

with

 

<property name="Mesh" value="#Entities/Zombies?Prefabs/ZSuitRadiated.prefab"/>

 

It's the Radiated Businessman Zombie mesh for the model but will stop the critical issue for now.

 

20211229130934_1.thumb.jpg.27fbdd4fbdac3814d6c99c04d3e3aed2.jpg

 

20211229131008_1.thumb.jpg.635d331e033c1b188a07ee2c39204a17.jpg

Edited by arramus (see edit history)
  • Like 1
Link to comment
Share on other sites

meleeHandZombie01

36 minutes ago, kithtyr said:

First I wanted to say great mod.  I just have enzombies installed with the loot mod. I do love the fact they all look like dead survivers.  Adds new look to the game.

 

For the regular zombies I was using the mod jaxteller718 reduce zombie hand reach.  This does not seem to effect your added zombies.  

 

I was wondering if there was a way to edit your mod so I can reduce the range of the zombie hand hit range?  I'm new to moding so any tips would be appreciated.

 

Thank you for your time.

I'll make a couple of suggestions as I was still tinkering with the previous post and could check JaxTeller718-ZombieReach Mod as I also use it for players who have latency issues caused by distance.

 

The enZombies are linked back up the line to the same settings that Zombie Reach use through extensions. But, based on Mod load order and possible limits on those extensions, it may well have no impact as you are seeing.

 

First try load order. Rename enZombies mod to ZenZombies mod so it loads after the JaxTeller718-ZombieReach Mod and those reach settings can be cached first.

 

If that doesn't work, consider adding this to your Zombie Reach items.xml just below the bottom entries for meleeHandMaster. They will be identical but have meleeHandZombie01 instead as these are linked back to enZombies.

 

    <set xpath="/items/item[@name='meleeHandZombie01']/property[@class='Action0']/property[@name='Range']/@value">1.00</set>
    <set xpath="/items/item[@name='meleeHandZombie01']/effect_group[@name='meleeHandZombie01']/passive_effect[@name='DamageFalloffRange']/@value">1.05</set>

 

These suggestions may or may not work, and the next option would possibly be adding those reach settings manually (based on the default properties xml found in the default files for meleeHandMaster but updated to Zombie Reach values) to each and every individual enZombie as they have some very special unique features and effects which all adds to the enZombies fun.

Link to comment
Share on other sites

5 hours ago, arramus said:

Maybe ErrorNull is a bit wrapped up with bits at the moment to provide an update. I am also using the enZombies and am glad you spotted these because they are something we all need to consider.

 

For now:

 

1. khz type of zombies

 

Replace at line 5901 and 6196
        <property name="Mesh" value="#Entities/Zombies?Zombies/zombie01Ragdoll.prefab" />

 

with

 

        <!--property name="Mesh" value="#Entities/Zombies?Zombies/zombie01Ragdoll.prefab" /-->

 

(We're just adding !-- at the beginning area and -- at the end)

 

in your entityclasses.xml file under 2 areas for 'khzTemplateMale1' and also 'aa_00'. aa_00 looks like a test entity but it shouldn't hurt game play. You never know who uses F6 to spawn things in though.

 

This will 'comment out' that entry for now and let this character fall back on the regular zombie template used for all zombies and should resolve the khzCharlotte and all other khz entity issues.

 

20211229131035_1.thumb.jpg.55f35ebbecb3b5ec8c907cf588f64749.jpg

 

20211229131107_1.thumb.jpg.96e33e7c56884e4a274ab684db00e8b4.jpg

 

2. Business Boss

 

Replace at line 5784:

 

<property name="Mesh" value="#Entities/Zombies?Zombies/zombieStandardSuitHDRagdoll.prefab"/>

 

with

 

<property name="Mesh" value="#Entities/Zombies?Prefabs/ZSuitRadiated.prefab"/>

 

It's the Radiated Businessman Zombie mesh for the model but will stop the critical issue for now.

 

20211229130934_1.thumb.jpg.27fbdd4fbdac3814d6c99c04d3e3aed2.jpg

 

20211229131008_1.thumb.jpg.635d331e033c1b188a07ee2c39204a17.jpg

Thank you so much! If I spot anything else, I will post it

Link to comment
Share on other sites

15 hours ago, Scharie said:

Bugs I got on the A20

Get this wile hordes going.
Error Could not load file ‘#Entities/Zombies?Zombies/zombie01Ragdoll.prefab’ for entity_class ‘khzCharlotte’
And
Businessman Boss will flood the console with red lines where you have to restart the server.
he was working in 19.
 

Hi @Scharie - it looks like the devs removed the zombie challenge quests from alpha 20 for the time being, and also changed some coding for that mechanic. this resulted in errors for my custom challenge quests that were part of the enZombies mod when i created them in alpha 19:

 

- Goblin Raid

- Forest Goblin Raid

- Desert Goblin Raid

- Snow Goblin Raid

- Red Goblin Raid

- Wasteland Goblin Raid

- Business Meeting Gone Wrong

 

i haven't prioritized updating these alpha 19 challenge quests yet, but plan to for the next update. this is also why i haven't yet updated any code for the businessman boss, because he only spawns in the challenge quest called "Business Meeting Gone Wrong"... which i disabled along with all the other challenge quests. it's strange that this zombie spawsn for you in-game? until my next update, using the fix that @arramus suggested is the best.

 

5 hours ago, arramus said:

For now:

 

1. khz type of zombies

 

Replace at line 5901 and 6196
        <property name="Mesh" value="#Entities/Zombies?Zombies/zombie01Ragdoll.prefab" />

 

with

 

        <!--property name="Mesh" value="#Entities/Zombies?Zombies/zombie01Ragdoll.prefab" /-->

 

thanks @arramus for detailing this. i have now done the same change and it will be reflected in the next update. the mesh "zombie01Ragdoll.prefab" does not appear necessary for any of the uma archetypes at this point and i had already commented in out for all my main enZombies, but forgot to comment out this mesh for Khz's UMA zombies.

  • Like 1
Link to comment
Share on other sites

6 hours ago, arramus said:

If that doesn't work, consider adding this to your Zombie Reach items.xml just below the bottom entries for meleeHandMaster. They will be identical but have meleeHandZombie01 instead as these are linked back to enZombies.

 

    <set xpath="/items/item[@name='meleeHandZombie01']/property[@class='Action0']/property[@name='Range']/@value">1.00</set>
    <set xpath="/items/item[@name='meleeHandZombie01']/effect_group[@name='meleeHandZombie01']/passive_effect[@name='DamageFalloffRange']/@value">1.05</set>

 

These suggestions may or may not work, and the next option would possibly be adding those reach settings manually (based on the default properties xml found in the default files for meleeHandMaster but updated to Zombie Reach values) to each and every individual enZombie as they have some very special unique features and effects which all adds to the enZombies fun.

 

thanks for suggesting this @arramus , but unfortunately the above likely won't work. the way the hand/attack range settings work for all the enZombies is that they use the default "range" value inherited from the handitem called "meleeHandZombie01".... which actually inherits that value from "meleeHandMaster". this default range value is 1.65. however, many (but not all) of the enZombies have custom reach values that simply ignore this inherited default value. for example, the forest goblins are short and have a custom range = 1.2 and the male forest hikers wield torches and have a custom range = 2.2. so if you change the range value from within meleeHandZombie01 or meleeHandMaster, any enZombies with custom range values will disregard those values anyway and use the custom ones that are defined within items.xml of the enZombies mod. one solution, as you've alluded to, is to redefine the range value from within each custom handitem within the enZombies mod. 👍

 

this is not too tedious as you can go into the items.xml file, use a text editor to find all matches for the keyword name="Range" and replace it's associated value to whatever is desired. another solution is to use an xpath statement at the very bottom of the items.xml file, like after the closing </append> tag, that will alter any/all Range attributes (not just for meleeHandZombie01) to the desired value... for example:

 

<set xpath="/items/item/property[@class='Action0']/property[@name='Range']/@value">1.00</set>

 

i haven't tested this, but i believe it should have the intended result of the JaxTeller718-ZombieReach mod. i would love to know if that works.

Edited by ErrorNull (see edit history)
Link to comment
Share on other sites

On 12/27/2021 at 6:39 PM, mrgreaper said:

Yeah in normal play the micro freeze is ignorable, it does however become more annoying on a hoard night (blood moon) but we have managed it twice. I am hopeful that it can be solved before alpha 21 as it does get frustrating at times.

After a discussion our little group prefer to have the zombies and a little freeze now and again than go back to the default boring, repetitive, bland, zombies.

 

i got the chance to start a fresh new map today with your 2.60 mods package. i had to correct an error with "Daves" mod regarding the SET tag on line 44, but didn't seem too big of a deal. i then played in single player mode, played through a few quests.. and using DM mode quickly put myself to level 300 and jumped to day 14 horde night. what i can say is that the stuttering and freezing was very noticeable during the trader quests and during the horde night playthrough. ... to the point i was not happy with the performance. the stuttering would occur almost every 5 or so seconds as i explored inside a POI or while fighting zombies during the horde night.

 

if i were to remove all the mods within the 2.60 collection and just left in the enzombies, enZombiesAddonSnufkin, and enZombiesHarvest, the freezeups are infrequent and not that noticeable and performance is much better. i didn't get a chance to test the 2.60 mod package on a server with friends, but i'd suspect similar behavior. i'm thinking there is one or more mods in this collection that isn't working well with enZombies. when i get the chance, i'll sort through each mod to see which one(s) introduces the big decrease in performance.. and see if it can be fine-tuned to work better with enZombies. keep me posted any further issues you find. 👍

Link to comment
Share on other sites

2 hours ago, ErrorNull said:

 

i got the chance to start a fresh new map today with your 2.60 mods package. i had to correct an error with "Daves" mod regarding the SET tag on line 44, but didn't seem too big of a deal. i then played in single player mode, played through a few quests.. and using DM mode quickly put myself to level 300 and jumped to day 14 horde night. what i can say is that the stuttering and freezing was very noticeable during the trader quests and during the horde night playthrough. ... to the point i was not happy with the performance. the stuttering would occur almost every 5 or so seconds as i explored inside a POI or while fighting zombies during the horde night.

 

if i were to remove all the mods within the 2.60 collection and just left in the enzombies, enZombiesAddonSnufkin, and enZombiesHarvest, the freezeups are infrequent and not that noticeable and performance is much better. i didn't get a chance to test the 2.60 mod package on a server with friends, but i'd suspect similar behavior. i'm thinking there is one or more mods in this collection that isn't working well with enZombies. when i get the chance, i'll sort through each mod to see which one(s) introduces the big decrease in performance.. and see if it can be fine-tuned to work better with enZombies. keep me posted any further issues you find. 👍

2.60 is the old versio to be honest, https://drive.google.com/file/d/1HyHWZ44AVoJn1Eau7I9Xt0Y3yQmb-AdU/view?usp=sharing is the version we are using at mo (fixed my daves mod error, i had forgotten </set> like an idiot...and i was referencing using @class not @name...no idea why. I also merged a lot of the loot mods we had into the loot file of the daves mod which makes looting not have that pause where the computer works out what to put into it...in most cases. We also added two mods @arramussuggested but only server side not in the client side mod file yet (i know they dont have to go there, but i tend to like keeping it the same)....though one of those mods has been a tiny bit annoying us as its putting guards in nearly every drop...I must get around to editing that loot table file lol.
A modder called War3zuk mentioned the M1 Grande is in his mod so I may be adding that, may.... some mentioned its an overhaul mod and we like where we are at at the mo mod wise...but i do like that gun... so will post a 2.9 if i do change it.

Hoard night is the only time the micro freezes become more than an annoyance, but we have done a few with out wanting to remove the zombies...so not game killing just really really annoying

Link to comment
Share on other sites

@mrgreaper i checked out your latest download link. those are an interesting collection.. and a number of them are pretty cool. not sure if it's just me, but it seems that there's a bit more micro freezes when i spawn the horde nights inside a busy city intersection compared to an open wilderness - with the mod collection. i wonder if a few of the mods that add or make changes to blocks and POIs could be contributing. with or without your mod pack, i still do notice the microfreeze during horde night that seems to correspond whenever the 8th or so enZombie is spawns in. it would be great if this would be addressed by the devs at some point. meanwhile if you notice anything else with the enZombies mod, let me know.

Link to comment
Share on other sites

36 minutes ago, ErrorNull said:

@mrgreaper i checked out your latest download link. those are an interesting collection.. and a number of them are pretty cool. not sure if it's just me, but it seems that there's a bit more micro freezes when i spawn the horde nights inside a busy city intersection compared to an open wilderness - with the mod collection. i wonder if a few of the mods that add or make changes to blocks and POIs could be contributing. with or without your mod pack, i still do notice the microfreeze during horde night that seems to correspond whenever the 8th or so enZombie is spawns in. it would be great if this would be addressed by the devs at some point. meanwhile if you notice anything else with the enZombies mod, let me know.

We do have our base in a city (or large town....hard to tell lol) and hoard nights have been laggy...not enough for us to get rid of the cool zombies though. 
zz mod (cant think of the name and at work so cant check) does have custom pois in it (these were used when the map was generated in the client prior to being moved to the server) 
Yeah we almost have the mods down to how we want it, we did add a couple of adult paintings mods, but that was more to mess with one of the guys lol. We also implemented the fix @arramusmentioned further up for the boss zombie, though yet to meet him or have that crash :)

Would be nice if the devs weighed in on the issue, has to be some way to convert the zombies to the new format as apparently the crawler was the old format and is now the new one.  

Link to comment
Share on other sites

14 hours ago, NovaZone said:

experiencing the micro freeze as well with Version 2.4

hi @NovaZone , thanks for reporting. did you also first notice the micro freezes while exploring POIs, or during the bloodmoon horde? also, what mods are you using with enZombies? are the freeze ups very noticeable or not so much?

Link to comment
Share on other sites

@ErrorNull hello playing single player i notice the micro freeze when exploring the empty wilderness, horde night, and POI's (i don't have a powerful rig so i notice it all the time), i also get an error during sleeper spawns in POI's which i'm assuming is caused by the above post about the Businessman Boss (haven't tried to fix it yet). playing with 34 mods atm mostly UI mod's, JaxTeller's increased zombie spawn x2,  KhaineGB's Wandering Horde Frequency and Hornet. enZombies is pretty much my only zombie/animal modification other than the previously mentioned spawn increaser's and the hornet. nothing else seems to be touching entitygroups.xml or gamestages.xml but i'm not 100% sure so don't quote me on that lol. I'll do waay more extensive testing today and in the future (enZombies is just too good to let go of 😆)

Edited by NovaZone (see edit history)
  • Like 1
Link to comment
Share on other sites

4 hours ago, tombstone2 said:

Sorry if this has already been asked. What would I edit to make the zombies not get knocked back like 20 feet?

 

Go into PhysicsBodies.xml and edit/remove the line in there.

 

I'm having an issue where zombies just walk through 1x1 openings.

Half their body clips through the upper block and they just walk on through.

What value do I need to adjust to stop this from happening?

 

Thanks for a great mod :)

 

Edit: Just to clarify. I understand that zombies can crawl through 1x1 holes and that's fine. That's how it was in my prior alpha 20 game.

Right now they're just straight walking through the block with their torso completely upright, ignoring the rules entirely that they must be crawling in order to fix through 1x1 spaces.

Edited by Bazgrim (see edit history)
Link to comment
Share on other sites

23 minutes ago, Bazgrim said:

I'm having an issue where zombies just walk through 1x1 openings.

Half their body clips through the upper block and they just walk on through.

What value do I need to adjust to stop this from happening?

 

This may have something to do with the new ability of zombies to crawl through 1x1 holes which was introduced in Alpha 20. Naturally these UMA zombies are not officially supported anymore (and their support will be phased out further in future Alpha releases), so the issue may be simple as missing crawl animation, but the game knows they are capable to crawl through 1x1 hole, so it lets them do that anyway, which may result in such effect as you're describing when you see zombies walking through a wall with 1x1 hole in it. This is just a theory though, might be something completely different, but it may as well be something that cannot be fixed, because again UMA is not supported anymore.

Link to comment
Share on other sites

8 hours ago, tombstone2 said:

Ok so I tried editing this xml file and it either makes them super jiggly or fly around without moving.

It's always going to be a tricky one since there are only limited options available for tweaking the ragdoll effects. In A18 it was less pronounced but with A19 came an expanded ragdoll feature which exacerbated what we see now. It also feels like playing on a dedicated server further increases it from what I've experienced. We've tinkered with mass, weight, the physics you have edited, and anything else that seems to connect but without any real success. The only definitive solution is to set <property name="HasRagdoll" value="true"/> to "false" in the entityclasses.xml. They'll go through the motions of all other animations, but their ragdolls will be gone and their death animation will be like a suspended animation on an invisible crucifix.

  • Like 1
Link to comment
Share on other sites

Posted (edited)

hi @tombstone2 and @mr.devolver ... as arramus mentioned, unfortunately the floaty ragdoll behavior for any UMA zombies can't be toned down much... other than just disabling the "HasRagdoll" attribute... which results in that jesus death pose lol. the best i got was going into the physicsbodies.xml file and tweaking the "ragdollscale" and "ragdolloffset" values.. which decreased the floatiness just a little bit. this was what i did for enZombies v2.4. any other combination of values i tried just borked the whole thing.

 

in regards to walking through 1x1 meter blocks, yea.. the cause certainly appears like what you said mr.devolver. the UMA zombies are still following the same 'new' rules as the vanilla zombies.. in that they can crawl through 1m block spaces.. but the UMA zombies are just missing the programming code to initiate their existing crawling animations... so their upper bodies just appear inside the upper blocks. more reason to block off those holes!

Edited by ErrorNull (see edit history)
Link to comment
Share on other sites

9 minutes ago, ErrorNull said:

hi @tombstone2 and @mr.devolver ... as arramus mentioned, unfortunately the floaty ragdoll behavior for any UMA zombies can't be toned down much... other than just disabling the "HasRagdoll" attribute... which results in that jesus death pose lol. the best i got was going into the physicsbodies.xml file and tweaking the "ragdollscale" and "ragdolloffset" values.. which decreased the floatiness just a little bit. this was what i did for enZombies v2.4. any other combination of values i tried just borked the whole thing.

 

in regards to walking through 1x1 meter blocks, yea.. the cause certainly appears like what you said mr.devolver. the UMA zombies are still following the same 'new' rules as the vanilla zombies.. in that they can crawl through 1m block spaces.. but the UMA zombies are just missing the programming code to initiate their existing crawling animations... so their upper bodies just appear inside the upper blocks. more reason to block off those holes!

I think the reason why they fly away so fast, far and high has something to do with some values on melee weapons being too high for them to handle (keep in mind that weapons have been updated several times while UMA zombies haven't), can't recall exactly which values can affect this, but I'm pretty sure I had the same problem with my crowbar mod back in A19. The goal was to create a crowbar that would be strong enough to break into safes, doors easily as well as have a high chance to pop zombie heads open. In order to achieve those effects, I was messing with the values a lot and while I was doing that, some of the values made it so OP that zombies started flying very far and high. Keep in mind that I was testing it on regular zombies, not on these old UMA zombies, so in conclusion, I have this theory: How fast, far and high they fly away is affected by certain values on melee weapons and the only reason why regular zombies have that effect so subtle is because they might have much higher threshold for it to happen. If my theory is true, we may be unable to affect their behavior, it's probably something hardcoded in their controller, but we could modify the weapon values to match standards of UMA zombies, however doing that could make those weapons too weak against regular zombies. I'm thinking about a possible workaround, you could only apply this new value if the zombie that you attack is UMA based, this would be a requirement inside the xml, if it's possible to detect the UMA zombie type at all, that is...

Link to comment
Share on other sites

5 hours ago, mr.devolver said:

I think the reason why they fly away so fast, far and high has something to do with some values on melee weapons being too high for them to handle...

I agree with this and have seen it's not only limited to melee weapons but also projectiles and explosives. I am playing on a server where the weapon damage is clearly modded higher and a headshot using the pipe rifle is launching zombies high into the air and far away, whereas fist fights are comparatively gentle and their ragdoll is only 2-4 blocks. The server admin really likes this though and mentioned in an earlier post they do not want it removed.

 

ErrorNull will certainly be aware of this as when Version 1.0 was first launched a few images were shared of this effect using pipe grenades, rockets, and a combination of other armaments. They were launched so high that they would appear to hit ceiling height and disappear without falling back to the ground. But yes, if there is a way to implement a buff where the UMA type entities take the damage but see a large reduction in the associated ragdoll, it can be a workaround, and an optional choice for those who prefer it toned down a bit.

5 hours ago, ErrorNull said:

 so their upper bodies just appear inside the upper blocks. more reason to block off those holes!

Yes, players can either exploit this situation as they often get stuck, or adapt for the nuances of A20 and fill the gaps. It's still learning stage for sure.

Link to comment
Share on other sites

1 hour ago, dujinyuan said:

hey...eh... I'm going to search the room and this come into my sight...I don’t know what's wrong man...i can't move~~~Please take a look at it....

1.png

I tested spawning all of the entities in the image exactly as it says there just before each warning appeared and they could spawn without issue.
I wonder if you can share which building you entered and what other mods are being used and if there were any other warnings before these for other issues such as cntvehiclesedan type warnings.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...