Jump to content

KingGen - A Random World Generator for 7 Days to Die


KingSlayerGM

Recommended Posts

23 minutes ago, Dogmaguy said:

This POI list thing is starting to grind my gears...How do i create one? I just want to add 1 custom prefab. I HATE complex things...

You add the poi files of your custom poi to your game prefab folder then when you select generate list in kinggen you direct it to the game prefab folder then simply name the list. Remember where you save this list to. It will then generate a list then select custom list in kinggen and direct it to the list you just created.

Link to comment
Share on other sites

5 hours ago, stallionsden said:

You add the poi files of your custom poi to your game prefab folder then when you select generate list in kinggen you direct it to the game prefab folder then simply name the list. Remember where you save this list to. It will then generate a list then select custom list in kinggen and direct it to the list you just created.

I just want to apologize for my behavior sincerest apologies. You see i've been trying to generate a POI list for almost a week now. I have the custom prefab copied into my vanilla prefabs folder and coded into the game and now understand how to generate a world using KinGen but i have been unable to generate a POI list. I do exactly as you instructed it however it doesn't give me the option to save it where i want and instead it says "Save as type" i of course name it and after clicking the generate button it definitely looks like its undergoing something then it stops as if it finished. I don't know if im doing something wrong because to me this process doesn't seem at all complicated like i expected. its so weird.

Link to comment
Share on other sites

Posted (edited)

It's Ok, Dogmaguy - ... and sorry for me being long-winded here, but I've been in IT since 1960, and I know absolutely that not everyone instantly grasps what written instructions are trying to convey, and that is very apparent here:  it is the reason behind Tallman Brad's great instructional video's on using KingGen to make these maps, and we all owe him a debt of thanks!
Below is a blow-by-blow of the process to get that list made as simply as possible. In this case I recommend copying the game's Prefabs folder to (someplace) in case it all blows up.
 

1). Find the prefab - or prefabs folder that you want to add into the game.
2). Copy it into the (your drive letter)\Steam\steamapps\common\7 Days To Die\Data\Prefabs folder.

3). Start KingGen.exe
4). Click on "Advanced settings" - left side of the opening screen.
5). Note that "POIs list" will still say "vanilla"
6). Left-click on "Generate custom POIs list"


7). Browse to the (your drive letter)\Steam\steamapps\common\7 Days To Die\Data\Prefabs folder.
8). left-click on "Prefabs". This folder name will then be automatically placed in the bottom selection window.
9). Left-click on the "Select Folder" box at the bottom right of that screen.


10) That window will now change, and show all of the prefabs in the right window pane. At the bottom is a single line asking for a "File name" .  Make one up - put the .txt extension on the end of the name and then type it in (mine is simply pj_prefabs.txt). You do not need to "Save as type", as when you click "Save" at the bottom - it will save exactly what you typed.
11). The screen will change back to the main screen, and "vanilla" will still show in the POI's list box: Left-click on the down-arrow and select "custom list": The folder where you saved your txt file to - in this case, the Prefabs folder - will pop up and you can then browse to - and left-click on - the txt file which you just created a minute ago. It will appear in the line an the bottom.
12). Left-click on "Open", the window will close and the filename will now appear in the main window where "vanilla" was previously.
 

That's it!

Edited by paulj_3 (see edit history)
  • Thanks 1
Link to comment
Share on other sites

Posted (edited)

Hahahahaha!  I could only wish, KS . . . .   but naahh - I'm just a journeyman - a little cog - not even a strong programmer.  Technical writing just happens to be one of the problems in systems administrative environments.
What I do see here is that we have a lot of good people enjoying a good hobby - and helping each other when we see the need.  e.g. We now have "KingGen" to use in place of the defunct "Nitrogen", and you were the guy that jumped in to do that. On top of that - you are also supported by a list of top-name modders (they know who they are! ) in this forum, that have a   w a a a a y    superior knowledge of this hobby than I do.  

Teamwork!

Edited by paulj_3 (see edit history)
  • Like 2
Link to comment
Share on other sites

Posted (edited)

Assuming Windows 10, - to be trouble-free - make yourself the owner of the folder that KingGen.exe resides in, and ensure that you have Full Control of that folder. Your new map will appear in that same folder, under the name that you give the map as you begin to create

 

https://1drv.ms/u/s!AueVg7eVAeXMkxcGwF4_UjVLxL0w?e=qhTPAZ

 

 

Edited by paulj_3
Link is better than big images. . . . . . (see edit history)
Link to comment
Share on other sites

4 hours ago, Lsjreadingpa said:

I downloaded the latest version and when i press the generate button, this is what i get. It just hangs here.

 

Run as administrator, or give KingGen permissions to write a file.

Link to comment
Share on other sites

Hey running into some trouble generating a Wasteland only map that  doesn't but out the Travel to Trader starter quest line.  I've made about 5 wasteland only mpas which all bug out the starter quest as it will list "no trader" when at the travel to trader stage.  My guess this bugs out some game rule where that quest cannot send you to a trader in the wasteland.  This also bugs out the animal tracker skill every time (which I want to use).  I then tried to make the map mainly Wasteland by setting Wasteland biome to large everything else to none which generated a few maps that worked with regards to the starter ques and animal tracker skill but were like 10% Wasteland and 90% pine forest.

 

Just wondering if anyone has some thoughts or settings to get like a 90% Wasteland map or get the trader quest to work in 100% Wasteland? Thanks

Link to comment
Share on other sites

3 minutes ago, Arapho said:

Hey running into some trouble generating a Wasteland only map that  doesn't but out the Travel to Trader starter quest line.  I've made about 5 wasteland only mpas which all bug out the starter quest as it will list "no trader" when at the travel to trader stage.  My guess this bugs out some game rule where that quest cannot send you to a trader in the wasteland.  This also bugs out the animal tracker skill every time (which I want to use).  I then tried to make the map mainly Wasteland by setting Wasteland biome to large everything else to none which generated a few maps that worked with regards to the starter ques and animal tracker skill but were like 10% Wasteland and 90% pine forest.

 

Just wondering if anyone has some thoughts or settings to get like a 90% Wasteland map or get the trader quest to work in 100% Wasteland? Thanks

Does the generated world actually contain traders?

 

You can see in the preview. It's the light blue buildings

Link to comment
Share on other sites

Posted (edited)
6 hours ago, KingSlayerGM said:

 

Run as administrator, or give KingGen permissions to write a file.

 

Just an FYI, if you have KingGen put the generated worlds in its own folder it doesn't need any special permissions or admin mode any more than NitroGen ever did.

 

Edited by GlassDeviant (see edit history)
Link to comment
Share on other sites

5 hours ago, KingSlayerGM said:

Does the generated world actually contain traders?

 

You can see in the preview. It's the light blue buildings

 Yes, in the Wasteland only maps, there are traders even though the starter quest says No Trader but going to the nearest trader does not complete the quest.

Link to comment
Share on other sites

20 minutes ago, Arapho said:

 Yes, in the Wasteland only maps, there are traders even though the starter quest says No Trader but going to the nearest trader does not complete the quest.

So this is an issue of the game. KingGen just generates world files, but if the game is not happy with traders in the wasteland, then KingGen can't do anything about it.

Link to comment
Share on other sites

The starter quest will send you to the nearest trader in the forest biome. That's why you get the no trader glitch when there is no forest biome trader.

 

I believe you can edit that quest so that it can send you to a wasteland trader if it is important to you.

  • Like 3
Link to comment
Share on other sites

To get around this problem, which I also had, I drew a small pine forest area where I placed a custom city (with settings for increased traders). I did this near my manually configured spawn point to ensure that I'd be sent to that trader and not another 2k into the map. Originally the trader near by was sat in a wasteland area. 7dtd preferred that I went to one in a forest, 2k away. The small pine area solved the problem. This was only an issue as I wanted to start at a specific point and travel through the map on a pre determined route as part of the game play. 

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

9 minutes ago, Tallman Brad said:

To get around this problem, which I also had, I drew a small pine forest area where I placed a custom city (with settings for increased traders). I did this near my manually configured spawn point to ensure that I'd be sent to that trader and not another 2k into the map. Originally the trader near by was sat in a wasteland area. 7dtd preferred that I went to one in a forest, 2k away. The small pine area solved the problem. This was only an issue as I wanted to start at a specific point and travel through the map on a pre determined route as part of the game play. 

This makes a lot of sense thank you.  I'm going paint a small forest area over a city / trader.  I see there are nice tutorials on the first post just for this too.  Also thank you for everyone's thoughts and replies.

  • Like 2
Link to comment
Share on other sites

i need to add this to vanilla prefablist 

FLESHUS_greenhouse_01,RESIDENTIALNEW;RESIDENTIALOLD;RESIDENTIAL,2,-14,59,33,59,farm;smalltown;unique
FLESHUS_greenhouse_01,RESIDENTIALNEW;RESIDENTIALOLD;RESIDENTIAL,2,-14,59,33,59,farm;smalltown;unique
FLESHUS_greenhouse_01,RESIDENTIALNEW;RESIDENTIALOLD;RESIDENTIAL,2,-14,59,33,59,farm;smalltown;unique
FLESHUS_greenhouse_01,RESIDENTIALNEW;RESIDENTIALOLD;RESIDENTIAL,2,-14,59,33,59,farm;smalltown;unique
FLESHUS_watchtower_01,RESIDENTIALOLD,2,-1,17,46,17,alone;mountain;unique
FLESHUS_watchtower_01,RESIDENTIALOLD,2,-1,17,46,17,alone;mountain;unique
FLESHUS_watchtower_01,RESIDENTIALOLD,2,-1,17,46,17,alone;mountain;unique
FLESHUS_watchtower_01,RESIDENTIALOLD,2,-1,17,46,17,alone;mountain;unique
FLESHUS_watchtower_02,NONE,2,-11,25,45,34,alone;oldwest;mountain;unique
FLESHUS_watchtower_02,NONE,2,-11,25,45,34,alone;oldwest;mountain;unique
FLESHUS_watchtower_02,NONE,2,-11,25,45,34,alone;oldwest;mountain;unique
FLESHUS_watchtower_02,NONE,2,-11,25,45,34,alone;oldwest;mountain;unique
FLESHUS_serial_killer_01,RESIDENTIALNEW;RESIDENTIALOLD;RESIDENTIAL,3,-10,58,25,59,houses;smalltown;unique
FLESHUS_serial_killer_01,RESIDENTIALNEW;RESIDENTIALOLD;RESIDENTIAL,3,-10,58,25,59,houses;smalltown;unique
FLESHUS_serial_killer_01,RESIDENTIALNEW;RESIDENTIALOLD;RESIDENTIAL,3,-10,58,25,59,houses;smalltown;unique
FLESHUS_serial_killer_01,RESIDENTIALNEW;RESIDENTIALOLD;RESIDENTIAL,3,-10,58,25,59,houses;smalltown;unique

how can i because i tried custom list came up with errors 

Link to comment
Share on other sites

Hi there, sorry to have to post a bug report...

Version: KingGen v0.11.1 for 7 Days to Die A19.5
Platform: Linux 5.12.14 (Arch Linux x64)
Command(s) Tested (all run from the folder where the program downlaoded): ./KingGen <no args>, and ./KingGen gen KingGenTestMap 4096
Result(s) - ./KingGen <no args>:

X Error of failed request:  BadIDChoice (invalid resource ID chosen for this connection)
Major opcode of failed request:  1 (X_CreateWindow)
Resource id in failed request:  0x9800094
Serial number of failed request:  894
Current serial number in output stream:  896

- ./KingGen gen KingGenTestMap 4096:

KingGen v0.11.1 for 7 Days to Die A19.5
Generating heightmap.
Traceback (most recent call last):
File "king_gen.py", line 43, in <module>
File "king_gen.py", line 33, in main
File "ntime.py", line 11, in ntime
File "king_gen.py", line 24, in run
File "arguments.py", line 206, in parse_args
File "arguments.py", line 133, in gen_func
File "world.py", line 228, in generate
File "world.py", line 912, in init_heightmap
File "world.py", line 1006, in gen_heightmap
File "world.py", line 1121, in noise
File "pyfastnoisesimd/helpers.py", line 777, in genAsGrid
File "pyfastnoisesimd/helpers.py", line 33, in empty_aligned
numpy.core._exceptions.MemoryError: Unable to allocate 64.0 TiB for an array with shape (70368744177696,) and data type int8
[298398] Failed to execute script king_gen

All that generates is the output folder, and one file: KingGenConfig.txt...

  _  ___              _____
 | |/ (_)            / ____|
 | ' / _ _ __   __ _| |  __  ___ _ __
 |  < | | '_ \ / _` | | |_ |/ _ \ '_ \
 | . \| | | | | (_| | |__| |  __/ | | |
 |_|\_\_|_| |_|\__, |\_____|\___|_| |_|
                __/ |
               |___/
v0.11.1 - A19.5
7 Days to Die Random World Generator
Find out more at https://community.7daystodie.com/topic/23988-kinggen-a-random-world-generator-for-7-days-to-die/

SETTINGS:
border_size=medium
border_type=water
burnt_size=medium
cities_grid_size=medium
cities_level=60
cities_number=medium
cities_size=medium
default_biome=pine forest
desert_size=medium
heightmap_smoothing=none
mountains_size=medium
name=KingGenTestMap
output_folder=
png_heightmap=no
pois_list=vanilla
pois_number=medium
seed=EgeLBqrsTZ
size=4096
skip_preview=false
snow_level=false
snow_size=medium
spacing=medium
spawn_points=medium
terrain_roughness=medium
towns_grid_size=medium
towns_number=medium
towns_size=medium
traders_location=cities
traders_number=medium
villages_grid_size=medium
villages_number=medium
villages_size=medium
waste_size=medium
water_level=43
water_size=medium

Without any other output, I'm at a loss as to what could be the issue. Any, and all help will be appreciated.

Link to comment
Share on other sites

2 hours ago, DEAk0n said:

Hi there, sorry to have to post a bug report...

Version: KingGen v0.11.1 for 7 Days to Die A19.5
Platform: Linux 5.12.14 (Arch Linux x64)
Command(s) Tested (all run from the folder where the program downlaoded): ./KingGen <no args>, and ./KingGen gen KingGenTestMap 4096
Result(s) - ./KingGen <no args>:

X Error of failed request:  BadIDChoice (invalid resource ID chosen for this connection)
Major opcode of failed request:  1 (X_CreateWindow)
Resource id in failed request:  0x9800094
Serial number of failed request:  894
Current serial number in output stream:  896

- ./KingGen gen KingGenTestMap 4096:

KingGen v0.11.1 for 7 Days to Die A19.5
Generating heightmap.
Traceback (most recent call last):
File "king_gen.py", line 43, in <module>
File "king_gen.py", line 33, in main
File "ntime.py", line 11, in ntime
File "king_gen.py", line 24, in run
File "arguments.py", line 206, in parse_args
File "arguments.py", line 133, in gen_func
File "world.py", line 228, in generate
File "world.py", line 912, in init_heightmap
File "world.py", line 1006, in gen_heightmap
File "world.py", line 1121, in noise
File "pyfastnoisesimd/helpers.py", line 777, in genAsGrid
File "pyfastnoisesimd/helpers.py", line 33, in empty_aligned
numpy.core._exceptions.MemoryError: Unable to allocate 64.0 TiB for an array with shape (70368744177696,) and data type int8
[298398] Failed to execute script king_gen

All that generates is the output folder, and one file: KingGenConfig.txt...

  _  ___              _____
 | |/ (_)            / ____|
 | ' / _ _ __   __ _| |  __  ___ _ __
 |  < | | '_ \ / _` | | |_ |/ _ \ '_ \
 | . \| | | | | (_| | |__| |  __/ | | |
 |_|\_\_|_| |_|\__, |\_____|\___|_| |_|
                __/ |
               |___/
v0.11.1 - A19.5
7 Days to Die Random World Generator
Find out more at https://community.7daystodie.com/topic/23988-kinggen-a-random-world-generator-for-7-days-to-die/

SETTINGS:
border_size=medium
border_type=water
burnt_size=medium
cities_grid_size=medium
cities_level=60
cities_number=medium
cities_size=medium
default_biome=pine forest
desert_size=medium
heightmap_smoothing=none
mountains_size=medium
name=KingGenTestMap
output_folder=
png_heightmap=no
pois_list=vanilla
pois_number=medium
seed=EgeLBqrsTZ
size=4096
skip_preview=false
snow_level=false
snow_size=medium
spacing=medium
spawn_points=medium
terrain_roughness=medium
towns_grid_size=medium
towns_number=medium
towns_size=medium
traders_location=cities
traders_number=medium
villages_grid_size=medium
villages_number=medium
villages_size=medium
waste_size=medium
water_level=43
water_size=medium

Without any other output, I'm at a loss as to what could be the issue. Any, and all help will be appreciated.

When you use the CLI the size should be an integer between 4 an 16. Try that

Link to comment
Share on other sites

5 hours ago, Father said:

i need to add this to vanilla prefablist 

how can i because i tried custom list came up with errors 

Hi,

here are the steps to do it:

  • open KG
  • go to advanced settings tab
  • click on generate a new poi list
  • point KG to the vanilla prefabs folder of the game
  • select where to save the poi list file that will be created
  • open the newly generated file
  • paste your new lines
  • save the file
  • next time you run KG, select your custom list
  • make sure that before you play the generated world, you actually put your custom pois in the game prefabs folder

Cheers

  • Like 1
Link to comment
Share on other sites

2 hours ago, KingSlayerGM said:

When you use the CLI the size should be an integer between 4 an 16. Try that

 

Ok! Yes. That works as expected. Uhh, that also implies KingGen was trying to create a... 4096000 x 4096000 map. Wow... No wonder it wanted 64TiB of memory! Still, the GUI option is throwing the same error... I think I remember that's a known issue though...

  • Haha 1
Link to comment
Share on other sites

I've updated the description in the poi tutorial video to include better instructions (than I had) on making a custom POI list. I'll edit it again this morning to include the instructions you've just added Kingslayer. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...