Jump to content

Game just shuts down


Recommended Posts

I have been playing this game a long time.  Over 1400 hours. I have never had an issue at all.  Now since 19.4 the game just shuts off.  I can play a small amount of time and it just completely shuts down and stops running.  

  • Did you start a new game and re-create the issue? Yes I have
  • Have you validated your files through Steam? Yes I did
  • After validation, did you re-try with a brand new game? Yes I did

 

I have also uninstalled and reinstalled the game.  I have also uninstalled and reinstalled Steam.  I absolutely do not have any other issues with steam games or any other game.  I do not know what the issue is or why it started.  I am playing single player when this takes place. 

 

https://pastebin.com/BXG8PBun

Link to comment
Share on other sites

The log says you are out of memory. I think it is normal RAM (refering to heap allocation which I don't think is done in a graphics card, but I don't know enough about graphics cards to exclude VRAM with certainity).

 

If you have lots of other stuff running in the background while playing the game, turn it off.  If not, 16G is more than enough to play the game, so something must be really broken.

 

You should check the RAM usage of the game after starting it. Does it continually increase at a fast rate and crash once it hits 16G?

 

If not, check your graphics card VRAM. Alternatively if you have texture quality at "full", turn that down to "half". If it already is at half, turn down the resolution. Does that prevent the crashes?

 

Did you change the setting for virtual memory page cache lately? I think it was said that this should be set to the default, which is that windows manages the size of the page cache or bad things will happen.

 

Edited by meganoth (see edit history)
  • Like 1
Link to comment
Share on other sites

Still can be a memory issue, like stick going bad. A quick, easy way to rule in/out the game as the cause is to go back to 19.3 and play a map. As far as I've read, there is really not that much of a change from 19.3 to 19.4 that would affect memory. If you usually play random gen, start a new random gen map on 19.3 and see if you still crash. If you do, then running memtest would be the next step.

Edited by Star69 (see edit history)
  • Like 1
Link to comment
Share on other sites

Went back to 19.3.  Now when the game shows the hands in the beginning it shuts down no warning. 

I have ran a memory diagnostics check there is nothing wrong with the RAM.  RAM was at 6.8 gb last crash.

I have uninstalled all saved games and 7dtd.  Reinstalled 7dtd.

I have turned down all the graphics. 

I have turned off antivirus also.

I also have checked all drivers for GPU and updated.

I run Assassin's Creed Valhalla,  Battlefield V,  GTA V, and Call of Duty all on this system with no issues.  Usually at higher fps than 7dtd.

 

Nothing worked.  It does not even let me play the game at this point.  I had 3 saves with alpha 19.3 and have not been on since Feb.  I now can not play at all.

Link to comment
Share on other sites

Can you post the 19.3 log for comparison? Since February when you last played, can you think of any changes made to the system?

 

Hard to compare 7D2D to any of those other games due to the voxel nature of 7D2D's world. If you didn't get higher FPS in other 'normal' games, that would be odd in itself.

Link to comment
Share on other sites

It wouldn't hurt to make sure you have a clean install. Uninstall/reinstall does not remove everything.

 

First, delete your mods folder.

 

Second, click 7dtd in your steam games list. When the box pops up, do not click play. Click show launcher.

 

Go to tools and clean all files. Make sure to click the box that says clean ALL old maps, not just maps not played in the last 30 days.

 

Once you have cleaned through the launcher, verify the integrity of your files again.

 

Try a new game on your clean install and see if it works.

Link to comment
Share on other sites

4 hours ago, thegame2417 said:

Nothing worked.

Have you set your swapfile correctly, (mentioned as causing this problem three times now). It needs to be set to

automatic. Also in case of confusion, swapfile, pagefile, and virtual memory all mean the same thing.

Link to comment
Share on other sites

12 hours ago, Beelzybub said:

Have you set your swapfile correctly, (mentioned as causing this problem three times now). It needs to be set to

automatic. Also in case of confusion, swapfile, pagefile, and virtual memory all mean the same thing.

Yes, that's the most common issue I see when running into a problem like this. Pagefile lower than 8GB will cause the issue for sure, and larger static pagefiles have occasionally caused it as well.  In any modern Windows system the pagefile should be configured to System Managed, no matter how much physical RAM you have.

Link to comment
Share on other sites

HWinfo 64 can show virtual memory usage. I once had the problem that virtual memory was used to 99,7%, even though 20GB of RAM have been still free, with exactly the same result: various games just quit. Not just games, basically everything that needed more than few 100MBs of memory.

 

In my case a simple reboot fixed the virtual ram usage. Never found out what caused the high usage.

Edited by Liesel Weppen (see edit history)
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...