Jump to content

Glitched out of a friend's multiplayer private game, now I cannot join the game. nullreferenceexception object reference not set to an instance of an object joining host


Recommended Posts

In a multiplayer private game hosted on a PC. I'm playing on a mac. We reached day 51 and my came crashed. After restarting, I can't join the game anymore and am stuck in the loading screen after the world is created and the player is created with the error: nullreferenceexception object reference not set to an instance of an object joining host


What to do? I'm guessing my player exited the server but the server didn't save my exit position so now it can't spawn me into the world?


Oh we are playing the latest Alpha 19.3.


Any help would be great!


Log here: https://pastebin.com/MvQxLhsn

Link to comment
Share on other sites

2 hours ago, on.steroids said:

What to do?

I would try deleting my local cache of that server's game. Dunno where that is on a mac though. Maybe you can get there with the Finder

via:  Tools / Open savegame Folder. The folder will be named 004FCFD69C341840A92E143C4CF0240D

Link to comment
Share on other sites

I can clarify more.


I'm playing on my mac (PlayerName='justkp'), and the host is on a PC (PlayerName ='chefboyardie'). 


I've deleted my entire game, savegame folder, and world. And tried to reconnect to my friend hosting the game with no luck. So yes, the issue must be solved on my friend's PC side as he is hosting the game.


Here are his log files: 

earliest log --> https://pastebin.com/eTAGUs3f

attempting to teleport myself into game --> https://pastebin.com/PTMtAwxb



Thanks for the help so far!

Link to comment
Share on other sites

What happens when you try to teleport? Try "teleport yourplayername theirplayername" to teleport to your friend, or have your friend use the command to teleport you to him or her.


If you downloaded a new map and fresh player data from the server, and it's still broke, then your player data is likely corrupted. If teleporting

doesn't sort you out, I think the only thing that would help is if the host has a backup from before your crash.

Also I notice that Litenetlib is failing for you but I don't know how to troubleshoot that. Maybe @SylenThunder has an idea.

Are you connecting wireless?

Link to comment
Share on other sites

The litenetlib errors are just an end result of a general connection failure. I only saw it in the first log, and it is likely a result of the connection being dropped as a result of the error on the host.


The error on the host...

2021-02-20T22:53:05 140.691 WRN Spawned entity with wrong pos: [type=EntityPlayer, name=justkp, id=15764] id=15764 pos=(0.0, 0.0, 0.0)

This indicates that the player data file for this character is corrupted. To resolve it, the player data files on the server will need to be removed.


The host will need to go to the following folder...

C:\Users\Ardie Wen\AppData\Roaming\7DaysToDie\Saves\North Kiwuke Mountains\AERO\Players

Then they will need to delete the following files.




Then when you get logged in, you will get a new character, but your explored map will eventually sync to your client. They can give you admin to gift yourself exp to return to your previous level.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...