Jump to content

[Linux] Unable to load the game


fbrenha

Recommended Posts

Greetings,

This problem happened out of nowhere since I played this game just 2 days ago with no issues whatsoever and the computer hasnt been touched since.

So my problem is: I start the game on steam, I choose the "Play 7DTD" option as always, then a black screen appears like usual, the 7DTD pointer is loaded and then black screen until the system says this game isnt responding and asks me to wait or terminate the process.

I tried reinstalling on both my ssd drives and the hdd, same results. Restarting the computer didnt work either.

I've also tried the "Show game launcher" option on steam and i've tried launching without EAC, i've cleaned game data, tried Proton and i always get the same result.

These are my logs for this problem: https://pastebin.com/bCFDbetD

I'm puting the logs of when i played a couple days ago aswell just because: https://pastebin.com/tBxFY6si

I played like a couple hours so those logs might me a bit long.

 

Ty for your help in advance

 

Edit: I dont know what  i did but the game seems to work fine now lol, if you can delete this topic that'd be nice since i dont know if i can do it lol

Link to comment
Share on other sites

Your logfile stops just before steam is contacted, i.e. there should be a line "INF [Steamworks.NET] SteamAPI_Init() ok". Now logfiles can get cut short when the log-writing program hangs or crashes, also stuff might happen in parallel, so this isn't conclusive evidence.

 

Also in the log of the previous session there is a strange NullReferenceException at a time when you probably were selecting and starting an existing savegame. It seems you were afterwards creating and starting a new world.

 

Now what that might mean, well, no idea at the moment.

 

I have nearly the same setup, linux with radeon rx580, using vulkan at the moment, and yesterday at least it still worked.

 

One idea would be to start the game from the command line (first start steam, but don't use it to start the game). Instead enter the games install directory and execute 7dLauncher.x86_64. The command line may or may not show some messages (for example from the OS) that don't show up in the logfile.

 

 

 

 

Link to comment
Share on other sites

  • 8 months later...

I have noticed also, that you have:

OPENGL LOG: Creating OpenGL 4.6 graphics device ; Context level  <OpenGL 4.5> ; Context handle 61953408

 

I wonder what video card/driver do you use? Also it seems game expects OpenGL 4.6 graphic device/driver from message above,  but your machine can only do 4.5.

Perhaps update of game raised slightly system requirements of game.

And before someone blames anything on devs, it could be engine update(Unity) as part of update. So hard to predict what will fail, not only that, but 4.6 is pretty de-facto standard version for OpenGL.

If I am right, you will need some video card upgrade.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...