Jump to content

ERR [EAC] Protect: CERR NCSimple_deserializer (ch=0): UnknownNetPacketExecution: Unknown NetPackage ID: 255


Telerien
 Share

Recommended Posts

So, I just got a server for my friends and I and the next day I got to login and I'm greeted with ERR [EAC] Protect: CERR NCSimple_deserializer (ch=0): UnknownNetPacketExecution: Unknown NetPackage ID: 255.  I do some searching online and find no real solutions so I go through all the validation steps both client and server(Everyone else logs in fine. I then delete the game and all relevant folders (yes even the %Appdata%) and still nothing.  It let me login after the first fresh install but after nothing.  Done 2 more fresh installs since and still nothing.  Any insight? 

Link to comment
Share on other sites

Sadly not. These are all client logs, too much of them and none of them before the problem appeared. The first two logs seem to be proprietary logs of the server hoster with unknown meaning.

 

What is your setup exactly? From whom did you rent a server (or did you set it up yourself)?

 

I assume you have access to the 7D2D directory on the server. There should be a 7DaysToDieServer_Data directory in there and there should be output_log__... files in there just like in your client. Is that correct?

 

 

Link to comment
Share on other sites

15 hours ago, Telerien said:

I rent servers from hosthavok.   I went into the 7DaysToDieServer_Data directory and didn't see an output_log file, Could there be a file in the log viewer section? 

I don't know. That is something you have to ask your provider. You should have access to logfiles somehow.

 

 

Link to comment
Share on other sites

44 minutes ago, Star69 said:

I rent from Bluefang and their output_log file is log.txt and is in the main folder so keep looking around for text files.

They don't save the logs. Each time the server is started it wipes the old and starts a new one.

Link to comment
Share on other sites

  • 4 weeks later...

Currently getting this same issue. I've nuked and reinstalled the server, nuked and reinstalled my game client, cleared out %APPDATA%/7 Days to Die, and I'm about out of ideas. This is without EAC enabled.

 

Here's excerpts from the client and server logs - it won't let me attach text files apparently. From the looks I'd say it's a client issue - Server's just not getting information.

 

Client:

 

2021-02-19T16:43:37 12.620 INF Started thread ServerBrowserListUpdater
2021-02-19T16:43:40 14.745 INF Connect by IP
2021-02-19T16:43:40 14.749 INF Connecting to server 10.20.50.147:26900...
2021-02-19T16:43:40 14.749 INF NetPackageManager Init
2021-02-19T16:43:40 14.764 INF NET: LiteNetLib trying to connect to: 10.20.50.147:26900
2021-02-19T16:43:40 14.776 INF NET: LiteNetLib: Connected to server
2021-02-19T16:43:40 14.779 INF Exited thread ServerBrowserListUpdater
2021-02-19T16:43:40 14.781 INF Started thread NCS_Reader_0
2021-02-19T16:43:40 14.781 INF Started thread NCS_Writer_0
2021-02-19T16:43:40 14.801 INF Started thread NCS_Reader_1
2021-02-19T16:43:40 14.801 INF Started thread NCS_Writer_1
2021-02-19T16:43:40 14.805 ERR NCSimple_Deserializer (ch=0):
2021-02-19T16:43:40 14.805 EXC Unknown NetPackage ID: 255
UnknownNetPackageException: Unknown NetPackage ID: 255
  at NetPackageManager.getPackageInfoByType (System.Int32 _packageTypeId) [0x00019] in <e9521218400243e9ac8c145545b586cf>:0 
  at NetPackageManager.ParsePackage (PooledBinaryReader _reader, ClientInfo _sender) [0x00006] in <e9521218400243e9ac8c145545b586cf>:0 
  at NetConnectionSimple.taskDeserialize (ThreadManager+ThreadInfo _threadInfo) [0x001e5] in <e9521218400243e9ac8c145545b586cf>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
Logger:masterLogException(Exception)
Logger:Exception(Exception)
Log:Exception(Exception)
NetConnectionSimple:taskDeserialize(ThreadInfo)
ThreadManager:myThreadInvoke(Object)
System.Threading.ThreadHelper:ThreadStart_Context(Object)
System.Threading.ExecutionContext:RunInternal(ExecutionContext, ContextCallback, Object, Boolean)
System.Threading.ExecutionContext:Run(ExecutionContext, ContextCallback, Object, Boolean)
System.Threading.ExecutionContext:Run(ExecutionContext, ContextCallback, Object)
System.Threading.ThreadHelper:ThreadStart(Object)
 
(Filename: <e9521218400243e9ac8c145545b586cf> Line: 0)

2021-02-19T16:43:40 14.811 INF Exited thread NCS_Reader_0
2021-02-19T16:43:40 14.811 INF Exited thread NCS_Writer_0
2021-02-19T16:43:59 34.611 INF Exited thread NCS_Reader_1
2021-02-19T16:43:59 34.611 INF Exited thread NCS_Writer_1
2021-02-19T16:43:59 34.631 INF SaveAndCleanupWorld
2021-02-19T16:44:00 34.632 INF [Steamworks.NET] Stopping server
2021-02-19T16:44:00 34.632 INF [Steamworks.NET] Exiting Lobby
 

 

Server:

 

2021-02-19T22:43:40 2782.186 INF NET: LiteNetLib: Connect from: 10.15.0.77:59043
2021-02-19T22:43:40 2782.188 INF Started thread NCS_Reader_5_0
2021-02-19T22:43:40 2782.189 INF Started thread NCS_Writer_5_0
2021-02-19T22:43:40 2782.191 INF Started thread NCS_Reader_5_1
2021-02-19T22:43:40 2782.191 INF Started thread NCS_Writer_5_1
2021-02-19T22:43:40 2782.191 INF [NET] PlayerConnected EntityID=-1, PlayerID='', OwnerID='', PlayerName=''
2021-02-19T22:43:40 2782.193 INF NPCID.Write
2021-02-19T22:43:40 2782.683 INF Time: 41.66m FPS: 20.00 Heap: 1212.4MB Max: 1240.3MB Chunks: 0 CGO: 0 Ply: 0 Zom: 0 Ent: 0 (0) Items: 0 CO: 0 RSS: 2884.2MB
2021-02-19T22:44:00 2802.037 INF NET: LiteNetLib: Client disconnect from: 10.15.0.77:59043 (RemoteConnectionClose)
2021-02-19T22:44:00 2802.037 INF [NET] PlayerDisconnected EntityID=-1, PlayerID='', OwnerID='', PlayerName=''
2021-02-19T22:44:00 2802.037 INF Disconnected player not found in client list...
2021-02-19T22:44:00 2802.038 INF Player disconnected: EntityID=-1, PlayerID='', OwnerID='', PlayerName=''
2021-02-19T22:44:00 2802.038 INF Exited thread NCS_Reader_5_0
2021-02-19T22:44:00 2802.038 INF Exited thread NCS_Reader_5_1
2021-02-19T22:44:00 2802.038 INF Exited thread NCS_Writer_5_0
2021-02-19T22:44:00 2802.039 INF Exited thread NCS_Writer_5_1
2021-02-19T22:44:10 2812.699 INF Time: 42.16m FPS: 20.00 Heap: 1208.0MB Max: 1240.3MB Chunks: 0 CGO: 0 Ply: 0 Zom: 0 Ent: 0 (0) Items: 0 CO: 0 RSS: 2884.1MB
 

Link to comment
Share on other sites

On 2/19/2021 at 8:59 PM, Beelzybub said:

What's this? Do you have a whitelist or blacklist enabled?

I do not - I presume that was the server saying "I just had someone disconnect, but there was nobody connected that matched that". 

 

Apologies for the delay in getting back to this. I was able to resolve this by nuking and completely reinstalling the dedicated server. Still don't know what the problem was, but it works now.

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...