Jump to content

IndexOutOfRangeException after trying some Mods


Recommended Posts

Hello survivors,

i've been playing around with mods and now my client won't start anymore. -->  alpha 19(b4)

I get the same error message over and over again:

IndexOutOfRangeException: Index was outside the bounds of the array.

This message is repeated in an endless loop. So I cannot play at all. See screenshot.


I have already completely reinstalled and am now at a loss what to do to play again.

On the server (Linux > Alpha 19(b4)) other players in our LAN can play without any problems. Only I just can't.

In the attachment you find my last output log.

 

The only active Mods are:

  • GrassBlocks
  • HJ_ModernDoors

 

and it worked before trying other mods like:

  • SHERP
  • Stallionsdens One Book To Rule Them All
  • DayhawksJenDroid
  • Riles-SeatingPlus
  • Telrics Health Bars 2.0A19
  • TelricsSpidersA19
  • War3zuk Movie Posters PBH


I hope anyone can help me.

errormessage.png

output_log__2020-11-22__17-03-07.txt

Link to post
Share on other sites
48 minutes ago, dwarfmaster1974 said:

I have already completely reinstalled and am now at a loss what to do to play again.

You now have blocks with custom IDs on your map and/or items with custom IDs in any inventory.

Reinstalling won't help as it won't fix your "broken" savegame.

If the game is still playable, you probably can remove those items (e.g. dropping them and let them despawn). If they are still "pickable". Also if they had custom items and the mod was removed, they won't be visible any more and look like empty inventory slot (or invisible block).

 

If playing on a server, you should not use any mods, that are not also installed on the server, especially not mods that add custom items.

 

Quote

The only active Mods are:

  • GrassBlocks
  • HJ_ModernDoors

Both of them, just from the name, add custom blocks.

 

Quote

and it worked before trying other mods like

With what mods it worked is not the problem, the problem most likely is that you removed mods.

Also some mods are incompatible to each other. E.g. if two mods add custom items with the same id, that will cause conflicts.

Edited by Liesel Weppen (see edit history)
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...