Jump to content

Magolis Compo Pack (Current Thread) by Wolfbain5 and Stallionsden


Recommended Posts

Posted (edited)
22 minutes ago, Tahoenvy said:

Myself and Bluefang support have tried it everywhich way we can.  The RWGmixer.xml that comes with the modlet is broken and will not allow a world to be generated with the Compopack. 

Hi tahoenvy

 

Works for everyone else. Testers inc 

 

What version are you using.

 

Any mods or overhauls

 

Do you have an output.log. did you change anything in the modlet 

 

Did you start a new server fresh install and wiped 

 

Did you put it in your client side mods folder as well...

Edited by stallionsden (see edit history)
Link to post
Share on other sites

Are you supposed to copy and paste the RWGmixer info from yours into the original RWGmixer prior to installing because your RWG only shows Prefab information, nothing else about where to load in the world  Here was my process

I downloaded the Modlet, unpacked the Prefabs into the Prefab folder on my server

pulled the RWGMixer out of the Config folder and over wrote the RWGmixer on the server, then tried to load my world.  Would not launch.

Yes we loaded client side, no I didn't change anything else, yes it was a fresh install (this is on Bluefang servers.  

 

I opened your RWGmixer and noticed all it has in it are the Prefab names, nothing else.    I've attached the one that came with the download

rwgmixer.xml

 

I just went back and read your instructions for the modlet and it says just to drop the folder into the mods folder.  Is that how it works for a Server also?  I've never done that in the past, we had to actually unpack and overwrite the originals.

2. Simply then open the COMPOPACK A19 CP47 (RWG MODLET) folder and Drag the COMPOPACK A19 CP46 folder inside original folder into Mods folder (steam/steamapps/common/7 days to die/Mods)

Edited by Tahoenvy (see edit history)
Link to post
Share on other sites
Posted (edited)
6 hours ago, Tahoenvy said:

Are you supposed to copy and paste the RWGmixer info from yours into the original RWGmixer prior to installing because your RWG only shows Prefab information, nothing else about where to load in the world  Here was my process

I downloaded the Modlet, unpacked the Prefabs into the Prefab folder on my server

pulled the RWGMixer out of the Config folder and over wrote the RWGmixer on the server, then tried to load my world.  Would not launch.

Yes we loaded client side, no I didn't change anything else, yes it was a fresh install (this is on Bluefang servers.  

 

I opened your RWGmixer and noticed all it has in it are the Prefab names, nothing else.    I've attached the one that came with the download

rwgmixer.xml 127.1 kB · 0 downloads

 

I just went back and read your instructions for the modlet and it says just to drop the folder into the mods folder.  Is that how it works for a Server also?  I've never done that in the past, we had to actually unpack and overwrite the originals.

2. Simply then open the COMPOPACK A19 CP47 (RWG MODLET) folder and Drag the COMPOPACK A19 CP46 folder inside original folder into Mods folder (steam/steamapps/common/7 days to die/Mods)

It is a modlet. You put it in the mods folder then run game. The xmls state where they spawn. 

 

Yes for a server as well it requires a Mods folder and you add the modlet to the mods folder client side and server side. 

3 hours ago, Deacon of Undead said:

Question? Downloaded Nitrogen, ran a map, entered the game but no prefab at all are showing? Not sure what to do.

 

Hi Deacon of Undead

 

Did you add the 3 txt files to the nitrogen resource folder.  Did you select in the nitrogen prefab list  option - cp47 prefablist. 

 

Did you open the dl prefab folder select all and drag into the games prefab folder.

 

 

Edited by stallionsden (see edit history)
Link to post
Share on other sites

Hi! I'm using the modlet, and I've noticed that certain POIs seems to be spawning a lot more than they should, while others haven't spawned more than once over multiple world gens, or even none at all. For example, I frequently find the Apaxco prefab by Gouki 2-3 times per city, often within a block of each other, while an entire world may have one Book Stop prefab, if I'm lucky. The Hub51 multi-trader by War3zuk shows up all over the wilderness, 6 or more per world, but I haven't seen any of the other multi-traders, and checking world prefab files shows they haven't been generated in any of the 5 worlds I've made with this version of the compopack. I like HUB51, but some variety would be nice.  Similarly, I've found two instances of the Minimall prefab by Spider literally right next to each other in the same block, while other prefabs I like I'll be lucky to find even once. Is there some way I can change probabilities? I've tinkered with the modlet's rwgmixer file a bit to test things since noticing the lopsidedness, but it doesn't seem to make much difference. I noticed there's a note that says "uncomment prefablist if you wish more POIs to spawn," but I'm not sure where the referenced commented section is?

 

Any help you can give would be appreciated!

Link to post
Share on other sites
Posted (edited)
1 hour ago, Canaa said:

Hi! I'm using the modlet, and I've noticed that certain POIs seems to be spawning a lot more than they should, while others haven't spawned more than once over multiple world gens, or even none at all. For example, I frequently find the Apaxco prefab by Gouki 2-3 times per city, often within a block of each other, while an entire world may have one Book Stop prefab, if I'm lucky. The Hub51 multi-trader by War3zuk shows up all over the wilderness, 6 or more per world, but I haven't seen any of the other multi-traders, and checking world prefab files shows they haven't been generated in any of the 5 worlds I've made with this version of the compopack. I like HUB51, but some variety would be nice.  Similarly, I've found two instances of the Minimall prefab by Spider literally right next to each other in the same block, while other prefabs I like I'll be lucky to find even once. Is there some way I can change probabilities? I've tinkered with the modlet's rwgmixer file a bit to test things since noticing the lopsidedness, but it doesn't seem to make much difference. I noticed there's a note that says "uncomment prefablist if you wish more POIs to spawn," but I'm not sure where the referenced commented section is?

 

Any help you can give would be appreciated!

Hi @Canaa

 

First you can comment out the section in the rwgmixer under prefablist or simply delete. Leaving the 4k section and 8k section. 

 

Then when you spawn in a 4k or 8k world the prefabs are not also added thru the game as well so you would be getting double ups. I did forget to comment it out lol.

Edited by stallionsden (see edit history)
  • Thanks 1
Link to post
Share on other sites

Thanks @stallionsden! Your advice took care of the multitude of repeats, which left room for other things to spawn that hadn't been. Still not sure why the game was prioritizing certain things over others and just repeating them all the time, but whatever, this works!

Link to post
Share on other sites
Posted (edited)
15 minutes ago, Canaa said:

Thanks @stallionsden! Your advice took care of the multitude of repeats, which left room for other things to spawn that hadn't been. Still not sure why the game was prioritizing certain things over others and just repeating them all the time, but whatever, this works!

That is great to hear :-).

Yeh i have the prefablist section in there for those whom want lots of pois regardless of how many of each. But yeh i did mean to comment it out lol.
will fix that now for any one whom dl it for the first time or will want to dl it again to have that bit removed.

As for why lol I had added a 0.05 to all prefabs in that section. I dont know why tho random is random even on repeat lol 😛

 

 

Edited by stallionsden (see edit history)
Link to post
Share on other sites

UPDATE: CP 47 MODLET:

Commented out prefablist section in the rwgmixer in the modlet.  This causes many versions of a poi to spawn. Simply uncomment the <!-- at the start of the section and the --> at the end of the section to have many pois even if the same spawn.

Link to post
Share on other sites

Just tried a small NitroGen map with Compo Pack 47.  The city is deadly.  So many zombies on day one it was insane.  I was with two other people playing coop and they were giving up.  Is there a way to scale the zombie numbers?  I know many would love to fight or run away from hordes.  But when you spawn in the middle of the city, you are just out of luck.  One building had 20 zombie dogs run at you at ground level.  Bit much to try to kill.  Think it was the POI that had Welcome to Eden sign in front.

Link to post
Share on other sites
Posted (edited)
59 minutes ago, Lord Shakaka said:

Just tried a small NitroGen map with Compo Pack 47.  The city is deadly.  So many zombies on day one it was insane.  I was with two other people playing coop and they were giving up.  Is there a way to scale the zombie numbers?  I know many would love to fight or run away from hordes.  But when you spawn in the middle of the city, you are just out of luck.  One building had 20 zombie dogs run at you at ground level.  Bit much to try to kill.  Think it was the POI that had Welcome to Eden sign in front.

A city should be deadly tbh. If a z apocalypse happenned the cities would be filled...

 

Stay away from the big pois for starters.  

 

Level 1 should do smaller pois and quests from the trader whom will send you to pois for your game stage. 

 

Maybe spawn near a city or away from it also. 

 

 

Edited by stallionsden (see edit history)
Link to post
Share on other sites
1 hour ago, Lord Shakaka said:

Just tried a small NitroGen map with Compo Pack 47.  The city is deadly.  So many zombies on day one it was insane.  I was with two other people playing coop and they were giving up.  Is there a way to scale the zombie numbers?  I know many would love to fight or run away from hordes.  But when you spawn in the middle of the city, you are just out of luck.  One building had 20 zombie dogs run at you at ground level.  Bit much to try to kill.  Think it was the POI that had Welcome to Eden sign in front.

lol, that was a bad place to start, Eden Mall is a dungeon prefab. meant for hardcore players.

Link to post
Share on other sites

I don't know if this is a Nitrogen or a CompoPack question, so please bare (bear?) with me.  I'd like to know if there's a way to tell nitrogen that I want many of the POIs in the CompoPack to be placed in the map it generates.  For example, the 2nd to last map I generated had tons of the run down airport (one of my favorite POIs) but the most recent map I generated only had 1 of those POIs.  I guess I'd like the map to be generated with a uniform number of each of the POIs in the CompPack.

 

TIA

Edited by Alan Lau
clarification (see edit history)
Link to post
Share on other sites
6 minutes ago, Alan Lau said:

I don't know if this is a Nitrogen or a CompoPack question, so please bare (bear?) with me.  I'd like to know if there's a way to tell nitrogen that I want many of the POIs in the CompoPack to be placed in the map it generates.  For example, the 2nd to last map I generated had tons of the run down airport (one of my favorite POIs) but the most recent map I generated only had 1 of those POIs.  I guess I'd like the map to be generated with a uniform number of each of the POIs in the CompPack.

 

TIA

Hi @Alan Lau

in the nitrogen program you can try setting all the options in the pic supplied you can play around with and set max values (having a bigger world like 12k/14 k also gives more pois to spawn.
2021-01-11_09h48_43.jpg.3e7efe644038cd727d5e39bea575cae9.jpg

 

other then that it is a process of generating many maps and checking the world to see if it suits.

a sort of way is checking the prefabs.xml the game creates on world gen thru nitrogen to see what pois spawned. 

2021-01-11_09h51_46.jpg.d50492b3028ed0856d73fa0ce8132ad3.jpg

Link to post
Share on other sites

Thank you for all the hard work, its modders like you that make games great! I am having a small problem and I apologize in advance if it is a user error. I downloaded the file from github....when i try to unzip it, i get an error message that it cant open as archive. I have attached a picture of the error message. Thank you for the help its much appreciated.

7dtd github error.png

  • Thanks 1
Link to post
Share on other sites
58 minutes ago, Marcinkoman said:

Thank you for all the hard work, its modders like you that make games great! I am having a small problem and I apologize in advance if it is a user error. I downloaded the file from github....when i try to unzip it, i get an error message that it cant open as archive. I have attached a picture of the error message. Thank you for the help its much appreciated.

7dtd github error.png

Thank you appreciate the kind words. Magoli has done a wonderful job in keeping this pack going thru the many alpha releases. Also a credit to the many talented prefabbers out there whom have contributed.

 

Do you have winrar or what program are you using to open a rar file  

Edited by stallionsden (see edit history)
Link to post
Share on other sites
On 1/1/2021 at 11:04 AM, Tahoenvy said:

I'm having an issue with the modlet also.  I've loaded it on my Bluefang dedicated server and it won't create a world with the RWGMixer.xml.

It just hangs and hangs.  It will NOT create a world. No problem loading with original RWGMixer but that doesn't work with the POI's.  I think Bluefang support is sick of me.

Hey if your still having this problem I figured it out on my end. The rwg was having problems generating the town with the prefab xcostum_Big_Zed(by_Gobarg_Mana). It should work If you open up the rwgmixer and then comment out every instance of: 

<prefab name="xcostum_Big_Zed(by_Gobarg_Mana)" prob="0.05"/>

Mine worked just fine after that!!

 
Link to post
Share on other sites
2 hours ago, cjstorrs said:

Hey if your still having this problem I figured it out on my end. The rwg was having problems generating the town with the prefab xcostum_Big_Zed(by_Gobarg_Mana). It should work If you open up the rwgmixer and then comment out every instance of: 

<prefab name="xcostum_Big_Zed(by_Gobarg_Mana)" prob="0.05"/>

Mine worked just fine after that!!

 

That was a typo on my end it has been fixed up now in the latest dl.

Link to post
Share on other sites
On 1/9/2021 at 9:00 AM, stallionsden said:

A city should be deadly tbh. If a z apocalypse happenned the cities would be filled...

 

Stay away from the big pois for starters.  

 

Level 1 should do smaller pois and quests from the trader whom will send you to pois for your game stage. 

 

Maybe spawn near a city or away from it also. 

 

 

Yea I understand that.   Unfortunately at map start it spawned us in the city so it was just the luck of the draw.   I can see that Eden mall would be a tier 5 dungeon.  20 dogs on the ground floor seems excessive when they all can be triggers by one zombie.  Oh well,  I would have to try different maps since that coop spawn point basically means you have to try to sneak out of town just to start.  That is if you can find a path that doesn't have a ton of zombies on the outside of a POI.

Link to post
Share on other sites
2 hours ago, Lord Shakaka said:

Yea I understand that.   Unfortunately at map start it spawned us in the city so it was just the luck of the draw.   I can see that Eden mall would be a tier 5 dungeon.  20 dogs on the ground floor seems excessive when they all can be triggers by one zombie.  Oh well,  I would have to try different maps since that coop spawn point basically means you have to try to sneak out of town just to start.  That is if you can find a path that doesn't have a ton of zombies on the outside of a POI.

The coop spawn in nitro is random spot. I spawn sometimes near a city, sometimes in the forest,. Just dont try the random roof spawn one haha lol. That one is funny as..

Edited by stallionsden (see edit history)
Link to post
Share on other sites
17 minutes ago, stallionsden said:

The coop spawn in nitro is random spot. I spawn sometimes near a city, sometimes in the forest,. Just dont try the random roof spawn one haha lol. That one is funny as..

Yea I read the warning about the roof top.  LOL.  I may try it a few times solo for kicks.  Just not with a group that isn't experienced.

  • Haha 1
Link to post
Share on other sites
24 minutes ago, Lord Shakaka said:

Yea I read the warning about the roof top.  LOL.  I may try it a few times solo for kicks.  Just not with a group that isn't experienced.

Yeh haha best not for inexperienced ones lol.

Link to post
Share on other sites

I attempted to submit a POI, but the Discord link stated "invalid link". Side note - I want to ensure I am submitting them properly with the right settings. Is there a cheat sheet beyond the explanation in the Prefabs.txt file as it is slightly greek to me in regards to the direction and x,y,z coordinates. 

  • Like 1
Link to post
Share on other sites
1 hour ago, Ti2xGr said:

I attempted to submit a POI, but the Discord link stated "invalid link". Side note - I want to ensure I am submitting them properly with the right settings. Is there a cheat sheet beyond the explanation in the Prefabs.txt file as it is slightly greek to me in regards to the direction and x,y,z coordinates. 

Hi @Ti2xGr

 

Just tested the link it worked for me but try this one.

 

https://discord.gg/bc3kvZH

 

Oh awesome feel free to pm me if you have trouble still getting onto discord and can submit thru pm.  But hopefully the link will work 🙂 .

 

In the editor show facing (tools 2) which waybtyebarrow is pointing is the way your poi will face.

 

So what I do is go look in the direction I want the poi to face the road and take note of compass (nesw)  then I look at arrow and rotate til it points that way.  

 

Also in the editor the x,y,z is listed up right side next to tools menu.

 

Stallionsden 

Edited by stallionsden (see edit history)
  • Thanks 1
Link to post
Share on other sites

I've been using Nitrogen now for about a month and I can't figure out how to make a new map that includes vanilla (Alpha 19.3) POIs as well as PreFabs on the same map.  I would really appreciate any help anyone could offer.  Thanks in advance!

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...