Jump to content
DodgyWitch

My server disappeared from the server list

Recommended Posts

Hey everyone. Sorry to be the new jerk who's first post is a new topic with a plea for help, but...well I'm a new jerk who has need of help & I couldn't find this specific issue in any of the recent threads.

 

You see for the past few months, I've been running a very small dedicated server on the Linux box in my living room. It was pretty straightforward to set up, set up the firewall NAT ports, configure the serverconfig.xml etc & it has been running beautifully, right through the Experimental Alpha 19 updates & the Mario Blocks which showed up if I didn't wipe the world (loved colourful @%$*#!s by the way...a little sad to see them go), but just the last 2 days, none of my friends have been able to find my server in the server list & a direct IP connect fails.

 

I was thinking is was something I'd done (even though I hadn't done anything) & it's working for me locally, but when I tether my phone to my laptop to test, it fails. No server listing, direct IP timeout.

 

I've re-activated my old Minecraft server on the same box to test & it's working perfectly, so...I'm a little confused.

 

Has anyone else noticed that the Server Browser has a VERY short list these days? I've checked all my filters on the Server Browser & it's all "Any". I've restarted the server software & the hardware, but no dice.

 

Does anyone know if the Fun Pimps or Valve have done something with Server ports or the Server Browser?

 

Would love any help.

 

DodgyWitch

Share this post


Link to post
Share on other sites

I wonder, did you ever wipe the world/update the server to the latest version? I don't think servers running different versions than the client will show up in the list or be able to be connected to.

  • Like 1

Share this post


Link to post
Share on other sites

Might try flushing the cache as well. Something else to do is try a method other than your phone. Cellular data may not be able to manage the flood of dns requests that the server list uses. Try using a VPN that blocks the local network.

  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, DodgyWitch said:

none of my friends have been able to find my server in the server list & a direct IP connect fails.

Did they use the right ip? (the external ip, not the internal one)

Post your server log and your server config and we may figure it out.

Also, a log from a player that fails to connect may be helpful.

Reboot your router.

  • Like 1

Share this post


Link to post
Share on other sites

I actually have had the same thing happen to me. Running a dedicated on a Linux box, been doing it for a few years now. We've been pretty excited about the new alpha. 2 days ago my wife got stuck in the terrain, so she logged off and went to log back in and it wasn't listed. Been trying to figure out what happened, but haven't been able to see any problems with the server. Started a new instance and it worked fine, so it does not appear to be the install.

  • Like 1

Share this post


Link to post
Share on other sites

Hey team. Thanks for all the responses.

 

Yes - absolutely cleared the cache.

 

Yes - absolutely made sure the IP was correct (did it myself copying & pasting the IP to be certain).

 

Yes - definitely rebooted the router. Definitely monitored rejection & drop noticed in my router log.

 

I'm not a deeply experienced game server admin, but I spent 8 years as a Unix & web server admin & I'm still in the IT industry managing enterprise storage & enterprise apps & networking, so I know what I'm doing from the network & settings perspective which is why it freaked me the hell out when things wasn't working!

 

In the end, the server started working again in the last couple of days. I've made no changes to the server & no changes to my client end. So...yeah, either something to do with server population in Steam/FP or something to do with DNS/port access via my own ISP. Either way, painful, but at least all is well now.

 

Thanks again y'all.

 

💜

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...