Jump to content
Sign in to follow this  
LokoGumba

Update Dedicate Server (A19-b177)

Recommended Posts

Posted (edited)

 
good, I wanted to know if the 7Days to Die community could help me since I am new to this, I have a dedicated server and I would like to update it to the latest version of Alpha19 but I don't know how to do it, could someone hel
 

 

Good, I wanted to know if the 7Days to Die community could help me since I am new to this, I have a dedicated server and I would like to update it to the latest version of Alpha19 but I don't know how to do it, could someone help me?

 

Edited by LokoGumba (see edit history)

Share this post


Link to post
Share on other sites

Not if you are so stingy with details. Do you have a managed server (like bluefang) or a headless server in the cloud, or a dedicated server at home? What operating system runs on it?

 

  • Like 1

Share this post


Link to post
Share on other sites
On 8/5/2020 at 11:22 AM, meganoth said:

Not if you are so stingy with details. Do you have a managed server (like bluefang) or a headless server in the cloud, or a dedicated server at home? What operating system runs on it?

 

Not the original poster but I was trying to b177 from an earlier A19 build on a server at home with Steam CMD and couldn't figure out the command to do it.  I thought running the same command to install the server would also update it but I kept getting a 0x202 error.  After setting the install directory I ran:

  • app_update 294420 -beta latest_experimental

I hadn't done much with the earlier A19 server so I deleted the old server folder and ran the same command and it reinstalled to A19 b177 just fine.  I'm hoping to figure out how to update in the future without having to delete the existing server folder and reinstalling.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, MajorMakinBacon said:

Not the original poster but I was trying to b177 from an earlier A19 build on a server at home with Steam CMD and couldn't figure out the command to do it.  I thought running the same command to install the server would also update it but I kept getting a 0x202 error.  After setting the install directory I ran:

  • app_update 294420 -beta latest_experimental

I hadn't done much with the earlier A19 server so I deleted the old server folder and ran the same command and it reinstalled to A19 b177 just fine.  I'm hoping to figure out how to update in the future without having to delete the existing server folder and reinstalling.

Here is the relevant part of the readme I have on my server:

 

Steam/steamcmd
  > login anonymous
  > force_install_dir /home/days/clean
  > app_update 294420 validate        
or
  > app_update 294420 -beta latest_experimental validate
for experimental
  > quit

 

You should change the force_install_dir paramter naturally, but this is guaranteed to work, I always update this way. I would guess you might have forgotten to do the login the first time.

 

 

Edited by meganoth (see edit history)

Share this post


Link to post
Share on other sites

I was missing the "validate" piece.  I tried that and it worked without the error.  That will save me a lot of time in the future, thanks!

Share this post


Link to post
Share on other sites

I thought the validate was optional and just a verify pass to be be on the safe side. But I never tried without it so I might be wrong there.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...