Jump to content

Riles Vanilla Plus


Recommended Posts

Sounds perfect 👍🏻 keeps the player grinding and searching, will fit in our server perfectly. I sent you a pm, your welcome to pop by. Whens the release? Oh one of my players found an icon wrong or something, apparently rebar icon is wood frame although when placed it's rebar.

  • Like 1
Link to post
Share on other sites
29 minutes ago, TomGun42 said:

Sounds perfect 👍🏻 keeps the player grinding and searching, will fit in our server perfectly. I sent you a pm, your welcome to pop by. Whens the release? Oh one of my players found an icon wrong or something, apparently rebar icon is wood frame although when placed it's rebar.

Yeah, when you go to the multi-shape option to change shapes of the rebar frame, the rebar icons show as solid wood blocks of the same shape (Except ramp and square block, which are correct), but place and show in game as rebar frames.  Its not a huge thing, but can be a little disconcerting at first glance lol

  • Like 1
Link to post
Share on other sites
Just now, FighterAce124 said:

Yeah, when you go to the multi-shape option to change shapes of the rebar frame, the rebar icons show as solid wood blocks of the same shape (Except ramp and square block, which are correct), but place and show in game as rebar frames.  Its not a huge thing, but can be a little disconcerting at first glance lol

Yeah, the icons for the added shapes which don't exist can't be added in a server-side only mod. That's why the colour tint is there, to colour code wood frame / rebar frame / wet concrete etc.

 

Unfortunately for the shapes like window arches, the icon only exists in 'brick' form and there's no way to display it as a frame icon.

  • Thanks 1
Link to post
Share on other sites

Good Day Riles

Hope you are doing well

 

I have found another small issue with the new shapes .. On the Bars that we make in the inventory as wood  ( Center bars will not go diagonally ) .. had to go into CM and get the center bars from there, I use them on corners 90% of the time, depending on what I'm building.

Hopefully you can make out the corners .. I can get a better picture if needed.

Thanks again and as always Be Safe ... the Old Gamer .. 😌

7 Days to Die Screenshot 2020.10.01 - 14.33.43.83 (2).png

  • Like 1
Link to post
Share on other sites
19 hours ago, TomGun42 said:

Awesome work, whens release?

Right now! 🙂

 

Saminal is correct. I color coded existing icons in order to keep it server only. If I created an icon that matched the material for each shape, this would require everyone to download the mod in order to use it. And as Saminal noted, some of the blocks were only available in brick. To help, I ALSO had the material of the block a different color text than the shape.

 

 

6 hours ago, gpcstargate said:

( Center bars will not go diagonally )

I am doing well, thanks! I like the design and aesthetics of your base!  

 

When placing the block within a "Variant Helper" it causes issues with rotation of all the blocks within. SO, until something about that changes on the Dev end of things.... I got this for a workaround.... it isn't convenient, but it will allow you to do what you seek for now.

 

New Block:

Wood Rotating 45 Degrees: Bars

-You can choose between centered and side bars

-Upgrades normally like the rest of them

 

 

 

 

Edited by Riles
Update (see edit history)
Link to post
Share on other sites

Good day Riles

Thank you for the fix and thought, that is one thing _ I enjoy about 7d2d the building. 😊

 

As always Take Care and Be Safe ... the Old Gamer .. 😌

 

edit .. PS: is the .. Riles Deco Mod .. only available on Nexus?, if so no problem .. I can get it there. 🤔

Edited by gpcstargate
question added (see edit history)
  • Like 1
Link to post
Share on other sites
5 hours ago, TomGun42 said:

doesnt look like the polish works, coming up with red X thinking i havent go it, did same to me

Hmmm. It is working for me. I just tested it out on the stone axe, the red stone axe thing, hammer, and nailgun. If you have the other mod still applied, it might cancel out what I did. Also, be sure it isn't just the schematic you have in your inventory?

5 hours ago, gpcstargate said:

 Riles Deco Mod

Oh crap! I guess I forgot to put it over here. 😛 Thanks for catching that!

5 hours ago, TomGun42 said:

did same to me

OOOh, also, if you have any mods that edit any of the tools used for upgrading, there is a property that you need to add the polish material to for it to work. It is under Action1. 

 

<property name="Allowed_upgrade_items" value="resourceWood,resourceClayLump,resourceSnowBall,resourceScrapIron,resourceForgedIron,resourceForgedSteel,resourceConcreteMix,resourceCobblestones,ironDoor1_v1,vaultDoor01,scrapHatch_v1,vaultHatch_v1,resourceYuccaFibers,resourceCloth,resourceScrapPolymers,resourceNail,resourceSteelPolishR"/>

 

notice how at the end I added ,resourceSteelPolishR as that is the name of the polish I use.

 

Hope this helps?

 

 

  • Thanks 1
Link to post
Share on other sites
16 hours ago, Riles said:

Hmmm. It is working for me. I just tested it out on the stone axe, the red stone axe thing, hammer, and nailgun. If you have the other mod still applied, it might cancel out what I did. Also, be sure it isn't just the schematic you have in your inventory?

Oh crap! I guess I forgot to put it over here. 😛 Thanks for catching that!

OOOh, also, if you have any mods that edit any of the tools used for upgrading, there is a property that you need to add the polish material to for it to work. It is under Action1. 

 

<property name="Allowed_upgrade_items" value="resourceWood,resourceClayLump,resourceSnowBall,resourceScrapIron,resourceForgedIron,resourceForgedSteel,resourceConcreteMix,resourceCobblestones,ironDoor1_v1,vaultDoor01,scrapHatch_v1,vaultHatch_v1,resourceYuccaFibers,resourceCloth,resourceScrapPolymers,resourceNail,resourceSteelPolishR"/>

 

notice how at the end I added ,resourceSteelPolishR as that is the name of the polish I use.

 

Hope this helps?

 

 

cool, which xml is it?

Link to post
Share on other sites

Riles .. Just a quick thought .. Can you put a link to your others Mods on the forum ??

It would help players and users of your mods to find them ... It is just a thought 

 

Have a Great weekend and try to have some fun .. Take Care and Be Safe ... the Old Gamer .. 😌

  • Thanks 1
Link to post
Share on other sites
5 minutes ago, gpcstargate said:

Riles .. Just a quick thought .. Can you put a link to your others Mods on the forum ??

It would help players and users of your mods to find them ... It is just a thought 

 

Have a Great weekend and try to have some fun .. Take Care and Be Safe ... the Old Gamer .. 😌

Good Idea. I didn't realize I had more on nexus mod and not over here! 

  • Thanks 1
Link to post
Share on other sites

ok im trying to basically further tweak blocks and give them a little more oopphh. iI using the follow code to edit... trying with steel and then st steel... and yes im getting it wrong. This extra mod just has a "materials" xml in the mod, I downloaded it to increase msteel only but I thought I could have it gradual to st steel aswell.

 

<configs>

    <set xpath="/materials/material[@id='Msteel']/property[@name='MaxDamage'][@value='7000']/@value">10000</set>
    <set xpath="/materials/material[@id='MstainlessSteel']/property[@name='MaxDamage'][@value='10000']/@value">25000</set>
    <!--<set xpath="/materials/material[@id='Msteel']/property[@name='MaxDamage'][@value='7000']/@value">50000</set>
    <set xpath="/materials/material[@id='Msteel']/property[@name='MaxDamage'][@value='7000']/@value">50000</set> -->

</configs>

 

any help would be greatly apperciated

  • Confused 1
Link to post
Share on other sites
1 hour ago, TomGun42 said:

help

Hello @TomGun42

 

The code works. When editing the blocks, the changes will only apply to new blocks you place down, not existing ones. (I believe.) So, when applying a mod like this to a world, it will only apply when prefabs reset or unless you start it in a new world. Does this help?

 

I did load this up and it worked for me. If it still doesn't work for you on NEW blocks, could be conflicted with another mod.

Edited by Riles (see edit history)
Link to post
Share on other sites

Good Day Riles 

Just a Heads up .. I can not use v 1.06 in War3zuk Mod .. there is a conflict in the codes .. between what he is using and what you are using it seems.

 

I got an error message in the ( F1 ) when checking the load list .. I removed it and the error meesage isn't there anymore. (Techically 1.06 is the only New mod that I put into his game.)

Could have something to do with A19.2 b4 Stable

 

Take Care and Be Safe ... the Old Gamer .. 😌

 

7 Days to Die Screenshot 2020.10.26 - 13.01.07.72 (2).png

 

EDIT .. Ok .. somemore info ... 1.04 will work in the mod ... But when you maded all those groupings starting with 1.05 _ that is when the issue started ..

 

Tried 1.04 just now _ No Issues that I noticed right out of the gate, when checking ( F1 ).

Tired 1.05 also _ and got the same error issue in ( F1 ) ... so it must have something to do with grouping of the different groups as you did. 

 

So hope that helps and as I said before .. Take Care and Be Safe and have a good week ... the Old Gamer .. 😌 

 

PS: SO Far it seems to be fine in my other 7d2d games that I use it on ... working great on my Vanilla modded Game.

 

Edited by gpcstargate
ver and added comment with edit. (see edit history)
  • Thanks 1
Link to post
Share on other sites
On 10/28/2020 at 11:22 AM, gpcstargate said:

I can not use v 1.06 in War3zuk Mod ..

I will look into this! Thanks for sharing.

On 10/28/2020 at 11:22 AM, gpcstargate said:

War3zuk Mod

Ok, I see where the conflict is! The question is, are you still able to load the game even with that error? If you can, the game may still run as it should with the two mods on it. Otherwise, I could make a compatible version for ya.

Link to post
Share on other sites

Riles .. Thank you for the reply

 

It seemed to run and yes it did load ok ...

But I did not go any farther with game after I saw the error message after checking (F1) .. something I always do when running modded game just to be on the safe side ..  

I will reinstall 1.06 into game on Friday and see if it works and runs correctly and will let you know if all is good or not, either way.

 

Take Care and Be Safe ... the Old Gamer ..😌

Link to post
Share on other sites
22 hours ago, gpcstargate said:

reinstall 1.06 into game on Friday

Hello!

 

Just in case, I'm providing a compatible version to go with War3zuk's mod. This is as far as I know of what my mod disagrees with. If this works without errors, then I'll post this link on the original post.

 

EDIT: updated the compatible version.

Edited by Riles (see edit history)
  • Like 1
  • Thanks 1
Link to post
Share on other sites

Good Day again Riles 

 

Ok, I downloaded to new version and will install it and I will let you how it goes later 

 

Have a Good Day _ Be Safe and enjoy ... the Old Gamer .. 😌

 

....................................................................................................................................................................

 

Edit .. Installed updated mod and got an Error on load screen ... hit ESC .. to keep loading and got a second error as game was still loading .. Went into game and nonthing from the mod loaded .. checked a couple groups glass and frames .. all standard stuff.

1st picture .. is the first error 

2nd picture .. I took so you could read what the 2 errors were.

 

The Jukebox message .. is a standard error/conflict for any game that is using the jukebox mod, personal I wish it wasn't part of the mod.    ( I never use them )

 

Now .. I will say .. Try and Have a Great weekend and Take Care ... the Old Gamer .. 😌

 

7 Days to Die Screenshot 2020.10.30 - 12.48.52.83 (2).png

7 Days to Die Screenshot 2020.10.30 - 12.52.55.21 (3).png

 

UPDATE EDIT .. OK .. Installed just 1.06 back into game .. got the same error as Before as on Wednesday post ... BUT everything seems to be working .. the groups are there in the CM .. I looked at Glass and all the shapes are there .. looked at frames _ shapes are good and even made some 80 ladders and converted to 80 wood bars and installed _ then upgraded to steel.

Hopefully it is a simple fix ... Yellow error message don't bother me ....... Red error message _ well do bother me, just a me thing. But if I have play your mod that way .. so be it. I Enjoy your mod ... the Old Gamer .. 😌

 

PS: I almost forgot ... the Post from Wednesday .... The Game does not show error in Load screen, only after you are in game and check (F1)

Edited by gpcstargate
Update on Edits (see edit history)
  • Thanks 1
Link to post
Share on other sites

@gpcstargate Ooooh, plenty of details! Thanks!  Ok, oops on the compatibility error! I uh, believe I fixed that. I would only consider using this compatibility version IF you cannot upgrade the tube/tunnel blocks into titanium. Otherwise, that "red" error that shows up after the load screen and only if you check F1 will not be an issue. 🙂

 

But if you find you cannot upgrade the tube/tunnel blocks, here is a TAKE 2 on the combability version. 🙂 Thanks for your patience and help!

  • Thanks 1
Link to post
Share on other sites

Good Morning Riles .. or Great day

 

Take 2 worked like a charm .. No Load issues and no Red Messages ... You did good on the fixes.

 

Thank you so much for taking the Time and fixing it .. Have a GREAT Weekend and Enjoy, kick back and take it easy

Many thanks from ... the Old Gamer .. 😌 and 😘

 

7 Days to Die Screenshot 2020.10.31 - 10.50.28.64 (2).png

7 Days to Die Screenshot 2020.10.31 - 10.53.21.58 (2).png

Edited by gpcstargate (see edit history)
  • Thanks 1
Link to post
Share on other sites

Good day Riles .. everything is still good on the " Take 2 fix " Thank you.

 

Just wondering if you were going to link it to main page for other players??

I did forward the zip to a couple of friends that play his mod and it seems to be good for them also. ( But as we all know everyone system is a bit different )

 

Have a good week _ Take Care and Be Safe.   .......... Thank you again ... the Old Gamer .. 😌

  • Thanks 1
Link to post
Share on other sites
  • Riles changed the title to Riles Vanilla Plus

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...