Jump to content
Esporova

Prefab Menu NOT Working?

Recommended Posts

My prefab hot key “K” is not opening the prefab menu?  I am trying to clear a large area of land fast.

 

Does anyone have a fix, or know another way to open the prefab menu?


Alpha 19 (b157)

Share this post


Link to post
Share on other sites
1 minute ago, Esporova said:

My prefab hot key “K” is not opening the prefab menu?  I am trying to clear a large area of land fast.

 

Does anyone have a fix, or know another way to open the prefab menu?


Alpha 19 (b157)

They just disabled it in normal game mode in the latest build.  Only accessible via world/prefab editor now.

  • Sad 1

Share this post


Link to post
Share on other sites
3 minutes ago, Laz Man said:

They just disabled it in normal game mode in the latest build.  Only accessible via world/prefab editor now.

Oh, that’s terrible news.  It was one of my favorite features.  What is world/prefab editor and how do I use it? I’m unfamiliar with it.

Share this post


Link to post
Share on other sites
41 minutes ago, Esporova said:

Oh, that’s terrible news.  It was one of my favorite features.  What is world/prefab editor and how do I use it? I’m unfamiliar with it.

From the ingame menu, there is a option to access the prefab/world editors but they are primarily intended for manipulation of prefabs/worlds before they are used.  Not for editing existing world saves.

Share this post


Link to post
Share on other sites

Probably not. This was likely removed because it causes an issue for players when they hit the key playing the game, and don't know how to exit out of it.  I know I had this issue with a lot of people over the past few years.

 

If you are hosting a dedicated server, you can utilize similar functions via API tools.

Share this post


Link to post
Share on other sites

So its been disabled? I play mainly to build and this was a need function to do so and im not looking to build POIs i just want to enjoy a beautiful world and get my creativity flowing with some builds . Is there no way to re enable it? It was working just 2 days ago in my A19 game and i had to scrap a project i was working on because i had to delete a bunch of ground still half my build was done but could not finish without the menu.

Share this post


Link to post
Share on other sites
Posted (edited)

@Esporova

 

For those who used the k menu to clear land quickly, there is an alternative.  There is an item called a "Block Replacement Tool" in the creative/admin menu.  This tool looks like a wrench and can be used to replace highlighted sections (e.g. z key) with any block (e.g. air).  Left click with the tool to "Copy" and right click to "Replace." See attached screenshots.

 

 

A19.0_2020-07-08_13-49-02.jpg

A19.0_2020-07-08_13-48-48.jpg

Edited by Laz Man (see edit history)
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

@Laz Man

That's cool and all, but it doesn't clear grass or bushes from the flat land I am working on...which is the main reason I use the Prefab Menu.

Share this post


Link to post
Share on other sites

Sweetness. You're my hero Laz Man. Exactly what I needed.

Share this post


Link to post
Share on other sites
On 7/9/2020 at 8:34 AM, NinPC said:

@Laz Man

That's cool and all, but it doesn't clear grass or bushes from the flat land I am working on...which is the main reason I use the Prefab Menu.

It removed the grass for me when I used the replace with air option.

Share this post


Link to post
Share on other sites

The problem with the tool is u cant strike grass.  So if you want to remove grass you technically need to replace the block underneath it with air to get them to collapse..😂

Share this post


Link to post
Share on other sites

Another option, for those that use Botman. After marking the area, you can use /dig or /fill commands.

 

@Laz ManGood Info here. Thanks.

Share this post


Link to post
Share on other sites
On 7/12/2020 at 3:00 PM, Phredd said:

Another option, for those that use Botman. After marking the area, you can use /dig or /fill commands.

 

@Laz ManGood Info here. Thanks.

I’m getting unknown command with these

Share this post


Link to post
Share on other sites
5 hours ago, Pwnsaurusrex said:

I’m getting unknown command with these

Botman is well documented here. https://botman.nz/docs/commands/all-bot-commands

 

That is the most current command list. Search /mark and then /dig or /fill. Only time I've seen unknown command is if I typo'd the block name with these commands.

 

Hope that helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...