Jump to content
dIcapit8Or

My Dedicated 7DTD Server only shows my Local IP address

Recommended Posts

As the description says, i cant get my 7 days to die server to show my public IP, only the private. I've opened all the correct ports and such but it still will not work. Its getting on my nerves.

 

Because its only using my private IP address it makes it impossible for a PC outside my network to connect, i've been sitting with this for hours on end trying to find a solution on my own but havnt made much progress.

 

Thank you for your time, and if you have any tips or just a pure solution please help :)

Share this post


Link to post
Share on other sites

Read the sticky threads here in general support how to post logs.

 

Just guessing meanwhile you might not have all ports open. Read the FAQ which also can be found here. Usually people forget ports 26900-26903 UPD because many sources on the internet forgot to mention them or are ourdated

 

Share this post


Link to post
Share on other sites

Could have a double-nat also.  Had to say without any information on the configuration though.

Share this post


Link to post
Share on other sites
12 hours ago, SylenThunder said:

Could have a double-nat also.  Had to say without any information on the configuration though.

The server itself will never "show" the public ip if he is behind NAT.

 

In this case i assume, he doesn't have any port forwardings configured in his router.

Share this post


Link to post
Share on other sites
Posted (edited)

My in house 7DTD server always shows up on my server list with my internal address, 192.168.0.0 however everyone else that connects sees the external IP. All port forwarding and stuff is perfect, but all I see is internal so I chalk that up as normal.

 

If all your port forwards are correct you should be able to google 'what is my IP' and have your friends connect to your external IP. Also one of the last lines of the terminal when you start the server will say Server Made Public ###.###.###.### or something similar....yeah logs would help :)

Edited by Spiked_Coffee
Brain came back online (see edit history)

Share this post


Link to post
Share on other sites
14 hours ago, Liesel Weppen said:

The server itself will never "show" the public ip if he is behind NAT.

 

In this case i assume, he doesn't have any port forwardings configured in his router.

As i stated in the post, all the correct ports are configured and ready for use. The problem is, that my friends can not find the server, through Direct connect or in the server list. Connecting through steam doesnt work either.

 

Any ideas that does not involve this, as this is one of the things i can rule out safely

Share this post


Link to post
Share on other sites
1 minute ago, dIcapit8Or said:

Any ideas that does not involve this, as this is one of the things i can rule out safely

Yep. Read the @%$*#!ing first answer again carefully.

 

My car is broken, it sounds strange. What might be wrong? 🙄

 

Hell yeah, i wonder what kind of help some people expect if they don't provide any information on their problem, besides "it doesn't work"? And even further don't answer questions they have specifically askes about their problem?

 

Does your car stutter? Do you feel it has lost power? Is the fuel consumption increased?

- Yes, it sounds strange.... *doh*.

Share this post


Link to post
Share on other sites
3 hours ago, dIcapit8Or said:

As i stated in the post, all the correct ports are configured and ready for use. The problem is, that my friends can not find the server, through Direct connect or in the server list. Connecting through steam doesnt work either.

 

Any ideas that does not involve this, as this is one of the things i can rule out safely

Did you also open the ports on your server's firewall? There really isn't much to setting up a Dedicated server for 7 days to die. Port forwarding on router, static ip for your server (so your port forwarding is ensured to work), and firewall ports on your server. That's pretty much...it. As long as your serverconfig.xml has been setup correctly to match your ports and you have an actual world starting, you should see your public IP after your server has launched. The last four lines should be:

 

2020-06-23T08:11:28 129.592 INF StartGame done
2020-06-23T08:11:29 130.685 INF [Steamworks.NET] GameServer.Init successful
2020-06-23T08:11:29 130.689 INF [Steamworks.NET] Making server public
2020-06-23T08:11:30 131.248 INF [Steamworks.NET] GameServer.LogOn successful, SteamID=<steam id here>, public IP=<your public IP>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...