Jump to content
theCorb1nator

Alpha 18 - Dedicated Server - No Blood Moon/Horde Night on day 14

Recommended Posts

Hi,

 

Me and my friends have been playing on my hosted dedicated server. we got the blood moon on day 7 which featured Thunder followed by a wave of zombies and a very visible red moon. 


However today we played day 14 and nothing happened. and i mean nothing, there was no thunder, no red moon and no zombies spawned :( 

We tried logging out at around midnight on day 14 too, no luck

 

I have attached the logs for both client and server for Day 14 -> 15 

 

Please can you tell us why this happened, i am worried that the game is broken and there will be no more horde nights.

 

Server Info: 

Hosting Provider : Nitrado 

Game Version : A18.4(b4)

Player slots: 4


Thanks

server_output_log__2020-06-11__20-34-46.txt server_output_log__2020-06-11__21-56-24.txt client_ output_log__2020-06-11__20-37-06.txt client_output_log__2020-06-11__21-56-49.txt

Share this post


Link to post
Share on other sites

In your server log you can find the lines

2020-06-11T20:36:12 79.922 INF BloodMoon SetDay: day 14, last day 7, freq 7, range 0
2020-06-11T20:36:12 79.925 INF BloodMoon SetDay: day 7, last day 0, freq 7, range 0

They show what the server thinks is the next BloodMoon. Now when I look at my own logs on my server I sometimes see one, but most often two identical lines of this "SetDay". It seems the routine to set the day is often called twice. It might only be an indication that there is some code in need of cleanup but could also indicate a bug. Since you use mods those are also a likely source of the bug. (At a minimum it means TFP will ignore the bug report because they don't have the time to debug mods as well.)

 

In my server logs when I see two lines then they are always identical. In your case above the day is set correctly first but then reset to day 7. Therefore I would first start the server again (if it is still running, stop it first). Then search the log for the lines with "BloodMoon SetDay" and see if the lines are identical now and Bloodmoon is set correctly to day 21. If yes, all is well.

 

If not, edit serverconfig.xml and change the value for BloodMoonFrequency to 1. Restart the server, see if the day is set to today in the logs. If it is correct you can have your bloodmoon now and afterwards reset it to the old frequency. Check the logs again. SetDay should point to 21 now.

 

Share this post


Link to post
Share on other sites
On 6/12/2020 at 2:04 PM, meganoth said:

In your server log you can find the lines


2020-06-11T20:36:12 79.922 INF BloodMoon SetDay: day 14, last day 7, freq 7, range 0
2020-06-11T20:36:12 79.925 INF BloodMoon SetDay: day 7, last day 0, freq 7, range 0

They show what the server thinks is the next BloodMoon. Now when I look at my own logs on my server I sometimes see one, but most often two identical lines of this "SetDay". It seems the routine to set the day is often called twice. It might only be an indication that there is some code in need of cleanup but could also indicate a bug. Since you use mods those are also a likely source of the bug. (At a minimum it means TFP will ignore the bug report because they don't have the time to debug mods as well.)

 

In my server logs when I see two lines then they are always identical. In your case above the day is set correctly first but then reset to day 7. Therefore I would first start the server again (if it is still running, stop it first). Then search the log for the lines with "BloodMoon SetDay" and see if the lines are identical now and Bloodmoon is set correctly to day 21. If yes, all is well.

 

If not, edit serverconfig.xml and change the value for BloodMoonFrequency to 1. Restart the server, see if the day is set to today in the logs. If it is correct you can have your bloodmoon now and afterwards reset it to the old frequency. Check the logs again. SetDay should point to 21 now.

 

I did think that was odd, 

Thank you so much, your suggested fix of setting blood moon frequency worked :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...