Jump to content

Snukfin's Server Side Z(S)ombies


Recommended Posts

Havent used that, This is from the version I had running on the Launcher.... so 18.4 zombies just updated... using the code posted... Its defo the zombies cos i retested it & got the same error & particle error..... so something is missing in the new code

Link to post
Share on other sites
On 7/8/2020 at 11:08 AM, Slawa said:

Try this version:

https://bit.ly/2AFA1uf

 

They are much more present now

I get a warning all time after start:

WRN Unknown element found: DMT (file C:/Program Files (x86)/Steam/steamapps/common/7 Days To Die/7daystodie_Data/../Mods\Z2/ModInfo.xml, line 11)

and that it spams this:

 

(Filename: C:\buildslave\unity\build\Modules/Animation/Director/AnimatorControllerPlayable.cpp Line: 915)

Invalid Layer Index '1'

Any solution for this?

Link to post
Share on other sites
  • 2 weeks later...

so put this v2 version on my A19 hosted server and it runs fine. i can spawn them in on f6 no problem, they appear in the game in the wild no problem. they were running fine....right up until horde night when the red text null object reference error started scrolling up the screen and locked the server. so they nearly working but something is needed for horde night. maybe a v3 version coming soon??? love these zombies. btw I wont be doing the V3 as i have no clue. lol. but who ever fixed for v2 could revisit and see whats needed?

 

Edited by Drinka1ity (see edit history)
Link to post
Share on other sites
1 hour ago, Drinka1ity said:

so put this v2 version on my A19 hosted server and it runs fine. i can spawn them in on f6 no problem, they appear in the game in the wild no problem. they were running fine....right up until horde night when the red text null object reference error started scrolling up the screen and locked the server. so they nearly working but something is needed for horde night. maybe a v3 version coming soon??? love these zombies. btw I wont be doing the V3 as i have no clue. lol. but who ever fixed for v2 could revisit and see whats needed?

 

Sounds like you need to dig into the XML for Horde Night and fix the Spawn Script. It got overlooked and it should be an easy fix. IDK where that is yet though. Fun Pimps made it easy to edit but you have to poke around to figure out where they put everything

I've done several horde nights without any problems and after the third one I started to see lots of the custom zombies because our game stage got high enough

You might just need to SteamValidate your files. They get corrupted all the time.

Edited by Xeraphim (see edit history)
Link to post
Share on other sites

I have a updatded version for a19 b169. will upload it in 1h, if im home.

 

-deleted the Archon zombie, cause i cant get it to work.

-added a extra BabyJuggernaut, which spawns in the world

 

and a few changes to the Geist zombie :)

 

Edited by Slawa (see edit history)
Link to post
Share on other sites

Archon worked for me but not very often, didn't try to spawn it in. It just came on horde night a few times. I couldn't get the electrical noise from the wizard projectiles to stop without a restart though, probably a duration thing. I'm looking forward to seeing what you did

Link to post
Share on other sites
1 hour ago, Slawa said:

V2.1 - a19 b169

-Removed zombieArchon

-Added BabyJuggernaut

-Fixed the Juggernaut quest

-zombieGeist Projectiles overhaul

 

Juggernaut:

He has a debuff now, -50% runspeed if you wear a gun and +50% if your hands are empty (groupquest).

 

http://bit.ly/32CTWFC

image.thumb.png.429ed9d0f881182caa2e672d6a5e0cae.png

image.png.f99a6ad629a9c53cebe9981350f3daed.png

I don't know if it was intentionally set up like this.

I can see huge amount of custom zombies when blood moon comes. But if you try. You'll find the zombieBanshee affects the gaming experience too much.You can not even shoot or run.

At a very low stage of the game,we can't alive with so much custom zombies...I mean the prob was not set properly. 

Maybe when wo go to the 200-250 stage,We can fight them using enough traps and explosives.

Or maybe we need the b169 custom weapons...||admin gun...

Link to post
Share on other sites

yeay, finally working on my server, however the jug chainsaw seems to be coming out of hit foot... plus is it possible to add that they only appear when your game stage/lvl is over a certain number. New people joining my server get @%$*#! with them and its abit much. Plus if the person is reaches a certain lvl say lvl 50 - 55 can a message be sent to them saying something like "Hades is not happy with you, he has sent it demons to get you" or something like that

 

Other than that they are looking great

Link to post
Share on other sites

Hi there i love that you made these zombies work for alpha 19 , but is there any way to lower the damage they do ? For example both juggernaut and the baby one launches allot of rockets , is there a way to make them launch only 1 rocket ? Also i would like to lower the health because it take ages to kill them  :)

Link to post
Share on other sites
On 8/2/2020 at 5:38 PM, Timerman said:

Hi there i love that you made these zombies work for alpha 19 , but is there any way to lower the damage they do ? For example both juggernaut and the baby one launches allot of rockets , is there a way to make them launch only 1 rocket ? Also i would like to lower the health because it take ages to kill them  :)

Look in the config files at entities, you can find "maxhealth" and change it yourself

Link to post
Share on other sites

how to put the sound tic tac bomb like timer charger in a (ZombieBomber) terrorist zombie ?

 

i put that but only beep once in a while, i sow a server that beep every time zombie appers and dont stop that tic tac sound is it possible to repeat that sound until it die, and near dead tic tac goes faster ?

 

			<property name="SoundRandom" value="Sounds/Weapons/Thrown/Charge/charge_beep"/>
			<property name="SoundAlert" value="Sounds/Weapons/Thrown/Charge/charge_beep"/>
			<property name="SoundAttack" value="Sounds/Weapons/Thrown/Charge/charge_beep"/>
			<property name="SoundHurt" value="Sounds/Weapons/Thrown/Charge/charge_beep"/>
			<property name="SoundDeath" value="Sounds/Weapons/Thrown/Charge/charge_beep"/>
			<property name="SoundSense" value="Sounds/Weapons/Thrown/Charge/charge_beep"/>

 

Edited by ArNaLdInHo (see edit history)
Link to post
Share on other sites

@SlawaI'm speechless. You made them work on A19? I had never tried it too hard to be honest. I'm trilled to test them, and I really want to pass the ownership of the mod to you, if you don't mind. I won't have time to keep updating it and I'm glad that it can see a new life on the hands of another person.

  • Knuckle Rub 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...