Jump to content
Snufkin

Snukfin's Server Side Z(S)ombies

Recommended Posts

If you want a taste of what to expect.. Here is a clip from my impervious to vanilla zombies base.


Ridonkulous!

 

And I totally forgot about the research stations. I need to do that.

Share this post


Link to post
Share on other sites
On 3/14/2020 at 12:03 PM, Snufkin said:

We are on day 250, almost everyone is already pretty well stocked with weapons lvl 6. Only the Juggernaut requires a bit of planning before facing, that's why I made him quest-only.

Uh... I got the juggernaut without doing any quest. And he was a HUGE surprise.

Share this post


Link to post
Share on other sites
15 hours ago, ArNaLdInHo said:

what screen shots are those ? are not from this mod

Those are from the Research Station. You have to DL his MOD for it. Build it and the camera and the film. Equip camera, load camera with film. Take pics of Snuffles Custom Zombies. Go to research station (you built).

Share this post


Link to post
Share on other sites
5 hours ago, zewtastic said:

If you want a taste of what to expect.. Here is a clip from my impervious to vanilla zombies base.


Ridonkulous!

 

And I totally forgot about the research stations. I need to do that.

Try it. I don't know why it can't work in my server. I have deleted the research mod. 

Share this post


Link to post
Share on other sites
1 hour ago, ApocalypseQAQ said:

Try it. I don't know why it can't work in my server. I have deleted the research mod. 

I tried it but the picture must have been bad as it didn't give the right sound.

And frankly the film is WAY TOO $$$. Each shot costs a bottle of acid. And for just 25% dmg reduction, too costly. Especially if it fails to get a decent picture some of the time.

Share this post


Link to post
Share on other sites

Snufkin, is there any way to fix your custom zombies so they actually are affected by electric fences and are seen by turrets?

Share this post


Link to post
Share on other sites

Ok, what am I doing wrong?

I take the picture, get the correct click.

But when I use the research terminal it shows nothing.

What step am I missing?

Share this post


Link to post
Share on other sites

I just discovered this mod to use in my dedicated server,I put the two mods in my mod folder, changed the included xml name to entitygroups.xml and overwrote the original, started a new game, there were no zombies period (yes I checked the settings to make sure they were enabled) after not seeing any zombies, I put the original back and the vanilla zombies are back, am I doing something wrong here?

Share this post


Link to post
Share on other sites
9 hours ago, Kyopsis23 said:

I just discovered this mod to use in my dedicated server,I put the two mods in my mod folder, changed the included xml name to entitygroups.xml and overwrote the original, started a new game, there were no zombies period (yes I checked the settings to make sure they were enabled) after not seeing any zombies, I put the original back and the vanilla zombies are back, am I doing something wrong here?

This mod is for Alpha 18, but everything just updated to alpha 19. You'll want to run a18.4 if you want to use these guys before Snufkin updates them for a19.

Share this post


Link to post
Share on other sites
Posted (edited)

Please update to a19! I loved your mods!

You know these inside and out so you would be fastest at it.

(i created a profile here just so i could request your mod updated :))

Edited by Xeraphim (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

I know people are waiting for an A19 version, but sadly it seems that the UMA is broken for the AI entities this time. This, along with rumors that TFP may drop UMA entirely on the future makes harder to keep developing this mod. This was a nice ride, I'm sorry everyone.

Edited by Snufkin (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

does this mean you are not working on A19 version at all? rumors are not true until confirmed.

Share this post


Link to post
Share on other sites

Somewhat ported over. I am not experienced in modding 7d2d and things just came up that might prevent me from doing more with this. Most of the weapons work but the loot table needs fixed. Like I said I am not experienced in doing this. It's all guesswork to me.

CustomWeapons.zip

Share this post


Link to post
Share on other sites

Yeah, weapons will probably get ported, minus some problems on the hit detection of melee weapons. I wont port this mod but I MIGHT make a new one from scratch based this time on the meshes of the vanilla zombies.

Share this post


Link to post
Share on other sites
29 minutes ago, Snufkin said:

Yeah, weapons will probably get ported, minus some problems on the hit detection of melee weapons. I wont port this mod but I MIGHT make a new one from scratch based this time on the meshes of the vanilla zombies.

Please keep the lootbox system was a awesome addon. Thanks for updating your mods.

Share this post


Link to post
Share on other sites
14 hours ago, Snufkin said:

Yeah, weapons will probably get ported, minus some problems on the hit detection of melee weapons. I wont port this mod but I MIGHT make a new one from scratch based this time on the meshes of the vanilla zombies.

I've had the privilege, until their admin team decided to go taking a conversation out of context then changing the words entirely to invent a slanderous fraud as excuse to get rid of me because one of their local sociopaths happens to dislike me, of enjoying the work of an extremely talented duo of coders that has made a lot of deep mods to the game to create a very thorough revamp that adds a ton of playability to 7d2d.
Head over to primalragegaming.com, tell them Xeraphim sent you. You'll want to work with TheReaper and LordSlaughter, in the event they are even interested in working with you (they tend to be a bit fickle). Their list of custom zombies and custom debuffs was in the dozens before a19 and they probably intend to do that again.

Share this post


Link to post
Share on other sites
Posted (edited)

@Snufkins Are you building a version for Alpha 19 of your original Snufkins zombies.. ? Um loaded the version Slawa updated & they seem to work.. havent fully tested. I was sure they removed UMA abilities in alpha 19 but glad these still work & cant be updated somewhat :)

 

Getting this when spawning in a few of them...

 

2020-07-10T09:22:12 280.411 INF [Steamworks.NET] Lobby entered: 109775240988829964
NullReferenceException: Object reference not set to an instance of an object
  at EntityMoveHelper.UpdateMoveHelper () [0x00161] in <e120bb69ee234a65814c66f7495aa8c0>:0
  at EntityAlive.updateTasks () [0x000ff] in <e120bb69ee234a65814c66f7495aa8c0>:0
  at EntityAlive.OnUpdateLive () [0x00154] in <e120bb69ee234a65814c66f7495aa8c0>:0
  at EntityEnemy.OnUpdateLive () [0x00000] in <e120bb69ee234a65814c66f7495aa8c0>:0
  at EntityZombie.OnUpdateLive () [0x00000] in <e120bb69ee234a65814c66f7495aa8c0>:0
  at EntityAlive.OnUpdateEntity () [0x0001e] in <e120bb69ee234a65814c66f7495aa8c0>:0
  at World.TickEntity (Entity e, System.Single _partialTicks) [0x0015d] in <e120bb69ee234a65814c66f7495aa8c0>:0
  at World.TickEntitiesSlice (System.Int32 count) [0x00037] in <e120bb69ee234a65814c66f7495aa8c0>:0
  at World.TickEntitiesFlush () [0x0000c] in <e120bb69ee234a65814c66f7495aa8c0>:0
  at GameManager.UpdateTick () [0x00033] in <e120bb69ee234a65814c66f7495aa8c0>:0
  at GameManager.gmUpdate () [0x0029b] in <e120bb69ee234a65814c66f7495aa8c0>:0
  at GameManager.Update () [0x00000] in <e120bb69ee234a65814c66f7495aa8c0>:0

 

Particle System is trying to spawn on a mesh with zero surface area
 
(Filename: C:\buildslave\unity\build\Modules\ParticleSystem\Modules\ShapeModule.cpp Line: 1682)

 

Hopefully its not something huge.....

Edited by War3zuk (see edit history)

Share this post


Link to post
Share on other sites

dont use the research mod, it comes with his own entityclasses.xml and overrides the a19 customzombie mod

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...