Jump to content
Sign in to follow this  
Tahaan

The motion sensor does not trigger near the edges of the camera view.

Recommended Posts

Summary: Motion sensor camera view does not match the area in which it picks up motion

 

Game Version: Alpha 18.3 and 18.4 (Probably earlier too)

Platform: PC

OS/Version: Linux

CPU Model: i7 8750

System Memory: 24 GB

GPU Model and VRAM: GeForce GTX 1060 Mobile

Screen Resolution: 1920x1080

Video Settings: Custom with most settings to Ultra

Game mode: SP and Dedi

 

Did you wipe old saves? No

Did you start a new game? Yes

Did you validate your files? No

Are you using any mods? Yes

EAC on or off? on

 

Status: NEW

 

Bug Description: The motion sensor does not work near the edges of the camera view. This means you think it will pickup movement but it doesn't

 

If this explanation is not clear I can show a video recording of what it does.

 

Detailed steps to reproduce the bug:

 

1) Set up a motion sensor somewhere and configure it to turn on a light when you are in front of it.

2) Move around and check that it works.

3) Stand somwhere in the view of the motion sensor near the edge of the camera view.

 

Actual result: Motion sensor does not turn on

 

Expected result: Motion sensor should trigger for motion anywhere in the camera view.

 

 

Share this post


Link to post
Share on other sites

This is due to the distance from the camera and the slimming of the sight cone. Make sure that the sight cone is looking at the area you're concerned about.

 

Share this post


Link to post
Share on other sites

Clearly I am in the camera view. I recorded a video of this where the motion sensor doesn't see me less than 3 blocks away, soit can't possibly be distance related.

 

The problem is not that the trigger cone is narrower than the camera view. The problem is that there is no indication of what part of the camera view will be "seen" by the motion sensor.

Share this post


Link to post
Share on other sites
Posted (edited)

 

In the video I first show that the motion sensor does work by moving in and out of the area.

 

Then I open the sensor view while it is OFF, but notice that I am visible in the camera view. It should be on!

 

Edit: I notice the video is quite dark. But you can make out where I am standing to the right of the video. At 0:12 I open the camera view of the motion sensor. I am on the right, just slightly to the right of the middle of the right half of the view.

Edited by Tahaan (see edit history)

Share this post


Link to post
Share on other sites

That is an interesting observation and helpful to know especially if using sensors for traps. My take away is the detection zone is a lot smaller then what the camera can see. The devs probably have to narrow the view angle of the camera or increase the detection area. Which ever works. :)

Share this post


Link to post
Share on other sites

I would prefer just an overlay that tells you which part of the camera view is used by the sensor. Being able to see past the sides helps with setting it up.

Share this post


Link to post
Share on other sites
Posted (edited)

I'll bring it up and see what they say about adding the sight cone to the camera view.

 

Until then, just make sure you're aiming at your target and then checking the sight cone.

 

F8R6WTv.jpg

 

EEtynXo.jpg

 

Schwanz9000

Edited by schwanz9000 (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...