Jump to content

Dedicated Server not updating to 18.4


Recommended Posts

Note: This was solved. please see post #6 for the resolution.




A couple friends and I play on a dedicated server running on Linux, and have been playing on 18.3 for weeks. All of our PCs updated to 18.4, and I logged in and used steamcmd to update my server. While I am pretty confident I have done this properly (due to it updating instead of redownloading the entire game, and repeated runs of the update commands reporting that the app is already updated), I'm happy to provide output if you would like to check my work. I confimed that the serverconfig.xml file in the server directory still reflects my custom changes and server name.


When we go to join, the server browser still reports it is on 18.3. The same is listed when I start the dedicated server and look in the terminal output, it reports it is on 18.3.


Has the linux dedicated server not been updated yet? am I doing something wrong? (Hint: I was.)


The process I followed to update is as follows:

  1. Log in to the server through ssh
  2. navigate to the proper directory
  3. run 'steamcmd' , it updated.
  4. login to steam with 'login [uSERNAME]'
  5. Force the install directory with 'force_install_dir 7dtd_server' (Hint: This install directory did not match the exact file path of my 18.3 server)
  6. Update the app with 'app_update 294420'
  7. Quit steamcmd with 'quit'

I also attempted to update to the experimental build of the dedicated server, but it still reported it was on the latest version. I attempted to update with 'app_update 294420 -beta latest_experimental'


The guide I used to install my server initially is at: https://unixblogger.com/setup-7-days-to-die-server/ (Note: This guide indicates an inproper/out of date method of starting the server. I have corrected this by simply using the 'startserver.sh' script, and pointing to my serverconfig.xml file with './startserver.sh -configfile=serverconfig.xml'. )



Thanks for any help in advance!

Link to comment
Share on other sites

Just as a follow up, I have solved this issue. It was absolutely user error.


I had made an error when writing my steam update script, and it was using an install directory in a different path than intended. The different path was updating properly, and after figuring that out and adjusting my update script, I have successfully updated to 18.4.


Thanks for your help!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...