Jump to content
Sign in to follow this  
DoctorB0NG

Distant terrain incorrect -- renders differently up close

Recommended Posts

Hey all,

 

I'm running into a strange issue where distant terrain on the client side does not match the actual terrain upon moving closer. The result is sheer cliffs morphing into flat terrain and vice versa as users approach. There are 4 players on the server and they all experience the issue. Here are some screenshots to clarify:

 

https://imgur.com/vIoq3u0

https://imgur.com/vHxLZby

 

As I walk closer to the sheer cliff in the picture, it turns into the correct terrain in real-time.

 

I'm running a dedicated server on A18.4 (was originally spun up on 18.3) on Ubuntu 18.04. The server was installed using the install script from https://7dtd.illy.bz/. All 4 players who are experiencing the issue are running the game on Windows 10 1903 or 1909.

 

The issue appears to be the exact issue that @Hated describes in post #7 from the following thread: https://forums.7daystodie.com/forum/-7-days-to-die-pc/general-support/55768-mismatching-distant-terrain?54802-Mismatching-distant-terrain=

 

Unfortunately, there does not appear to be a 'hubcelldata' directory anymore in A18 so I'm at a loss. I've tried the following to correct the issue:

 

1) Delete client map data to force client to re-download from server

2) Delete server map file and force regeneration of map

3) Move contents of Region directory on server to a different location (don't do this one, it deletes all user's objects!)

4) Move all .map files in Player directory on server to a different location (don't do this one, it deletes all client's discovered portions of the map!)

 

Any advice is appreciated. Thanks!

Share this post


Link to post
Share on other sites

Distant terrain is pre-generated and does not get updated. So, for example, if you remove a building, and then walk away, when you get a certain distance away, you will see the building. You walk closer, and it vanishes. On my server, we gutted a settlement, removing buildings and adding our own. But from far off, you still see the buildings we removed. While this is not the direct cause of what you are observing, the fact that distant terrain is static is the root of the problem. It would be nice if there were some way to update it. I posted this as a bug report a while back and I think the response was that they were thinking about it. Maybe they will fix it in A19?

Share this post


Link to post
Share on other sites

This is an issue where you are using the same seed name from one version to another and the old save info is being overwritten on the new one. Using seed name 123 on A17 and then using it again in A18 would cause this. The RWG code has changed between versions, so the world generates differently. It "may" even be possible between A18.1 .2 .3 .4 depending on any changes. I highly suggest using the following naming convention so this doesn't happen. A18P4B4RWG01 I then use that as the Game Name AND the World Generation Seed. Cleaning out old maps regularly helps too.

 

 

Schwanz9000

 

Share this post


Link to post
Share on other sites
This is an issue where you are using the same seed name from one version to another and the old save info is being overwritten on the new one. Using seed name 123 on A17 and then using it again in A18 would cause this. The RWG code has changed between versions, so the world generates differently. It "may" even be possible between A18.1 .2 .3 .4 depending on any changes. I highly suggest using the following naming convention so this doesn't happen. A18P4B4RWG01 I then use that as the Game Name AND the World Generation Seed. Cleaning out old maps regularly helps too.

 

 

Schwanz9000

 

Is there a fix for this? Unfortunately we're already on day 68 and have quite a bit of time invested into this map.

Share this post


Link to post
Share on other sites

 

Is there a fix for this? Unfortunately we're already on day 68 and have quite a bit of time invested into this map.

 

Clear your local cache from the server. That will wipe your locally stored old data that is causing the issue.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...