Jump to content

Application not launching


Recommended Posts

Hey, I've played this game in the past on this PC, ran fine, though low FPS although it runs better now i'm unable to run it WITH EAC.


So I have the game through Steam, so when i go to launch it a window pops up saying:


"7 Days to die Launcher

Failed to execute: 740.

Press OK to ignore and risk data corruption.

Press Abort to kill the program"


Clicking OK makes the game say:"Running" through steam but nothing happens.

if i try to launch with the launcher through steam: turning off EAC runs the program nicely.


i've tried launching manually from the explorer and with administrator. also with steam as administrator, if EAC is on it won't run.


7dtd has work in the past, but i think it's because i install all of my games (through Steam not manually) on a different drive(E: drive not the C: Drive) and EAC isn't understanding it. some help here would be cool


Windows 10, updated.

Link to comment
Share on other sites

Nah, I run everything on a different drive. No issues.


Try re-installing EAC. It's in C:\Program Files\EasyAnticheat Run it from there, and you will be able to select 7 Days to Die, and then Repair. Then reboot your PC, and try again.

(I may be slightly off on the folder path. Pulling it from memory because I can't look at my PC from work atm.)

Link to comment
Share on other sites

ok, i will try that.


So i tried to run Shogun Total war 2 and got into a very similar problem, where the game starts up with initial loading screen and then shuts off. I think my issue is: I've been RE-installing all of my games onto the E: drive though the game has a registry possibly from the previous install on the C:drive?


I would like to know how to resolve this registry issue, like what files need to be deleted to ensure this is launched without the C:drive getting involved.



Edit: your solution did not work, I believe it has to do with me reinstalling the game onto the E:drive since "easyanticheat" thinks it's still on that default path.

Thank you though

Link to comment
Share on other sites

Most likely you just need to exclude the client from your Antivirus software. This error typically occurs because the client does not have the "credentials" to access a file or memory address, which is a direct result of the antivirus software either blocking it, or delaying actions due to scanning.


This is covered in the sticky FAQ here...

Why are you telling me to exclude the program from my Antivirus software?

[*=1]How to exclude the program from your Antivirus software.


It could also be due to running Steam as Admin, or a corrupt DirectX installation.



It does not likely have anything to do with installing the game on a different drive. I run Steam on a separate drive from my OS, and run the game client on another disk entirely.

Link to comment
Share on other sites

I have already made 7days to die, as well as the entirety of my steam folder exempted from my antivirus I can also play 7days perfectly without running EAC!

I tried running steam as the admin, but no longer do that


how can direct x be corrupt when no other games I play are affected?


I'm certain it's just a pathing error through EAC Steam starts up the game,


but steam gowes to run EAC which is on C:drive and EAC looks for the game on the C:drive? or at least a shortcut can't find the files and closes.


I originally had 7dtd installed on the C: but uninstalled it and later reinstalled it on my new E:

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

This topic is now closed to further replies.
  • Create New...