Jump to content

A19/A18 CreaturePacks - A community entity project


xyth

Recommended Posts

are there any zombies that are completely invisible with no target box? a player's base has one that we can't get rid of it seems like it's in the room we in but we can't find it i fired rifle all around the room nothing getting hit but it's hitting us

Link to comment
Share on other sites

Not intentionally.  I've seen that in some mods but not the creaturepacks.  Could be stuck in a wall but I never found the zombie either.  You can try using a killall command or leave the area an see if it resets.

Link to comment
Share on other sites

error when loading 

wrn xml patch for "entityclasses.xml" from mod "2-charactereffectspack" did not apply: <remove xpath="//entity_class[starts-with(@name, 'npc') and not ( starts-with(@name, 'npctrader') ) ]/property[starts-with(@name, 'soundattack')]"
2021-07-08 21:45:17 
wrn xml patch for "entityclasses.xml" from mod "2-charactereffectspack" did not apply: <remove xpath="//entity_class[starts-with(@name, 'npc') and not ( starts-with(@name, 'npctrader') ) ]/property[starts-with(@name, 'soundhurt')]"
2021-07-08 21:45:17 
wrn xml patch for "entityclasses.xml" from mod "2-charactereffectspack" did not apply: <remove xpath="//entity_class[starts-with(@name, 'npc') and not ( starts-with(@name, 'npctrader') ) ]/property[starts-with(@name, 'soundsense')]"
2021-07-08 21:45:17 
wrn xml patch for "entityclasses.xml" from mod "2-charactereffectspack" did not apply: <remove xpath="//entity_class[starts-with(@name, 'npc') and not ( starts-with(@name, 'npctrader') ) ]/property[starts-with(@name, 'soundalert')]"
2021-07-08 21:45:17 
wrn xml patch for "entityclasses.xml" from mod "2-charactereffectspack" did not apply: <remove xpath="//entity_class[starts-with(@name, 'npc') and not ( starts-with(@name, 'npctrader') ) ]/property[starts-with(@name, 'soundrandom')]"

 

Link to comment
Share on other sites

On 7/8/2021 at 9:48 PM, Father said:

error when loading 

wrn xml patch for "entityclasses.xml" from mod "2-charactereffectspack" did not apply: <remove xpath="//entity_class[starts-with(@name, 'npc') and not ( starts-with(@name, 'npctrader') ) ]/property[starts-with(@name, 'soundattack')]"
2021-07-08 21:45:17 
wrn xml patch for "entityclasses.xml" from mod "2-charactereffectspack" did not apply: <remove xpath="//entity_class[starts-with(@name, 'npc') and not ( starts-with(@name, 'npctrader') ) ]/property[starts-with(@name, 'soundhurt')]"
2021-07-08 21:45:17 
wrn xml patch for "entityclasses.xml" from mod "2-charactereffectspack" did not apply: <remove xpath="//entity_class[starts-with(@name, 'npc') and not ( starts-with(@name, 'npctrader') ) ]/property[starts-with(@name, 'soundsense')]"
2021-07-08 21:45:17 
wrn xml patch for "entityclasses.xml" from mod "2-charactereffectspack" did not apply: <remove xpath="//entity_class[starts-with(@name, 'npc') and not ( starts-with(@name, 'npctrader') ) ]/property[starts-with(@name, 'soundalert')]"
2021-07-08 21:45:17 
wrn xml patch for "entityclasses.xml" from mod "2-charactereffectspack" did not apply: <remove xpath="//entity_class[starts-with(@name, 'npc') and not ( starts-with(@name, 'npctrader') ) ]/property[starts-with(@name, 'soundrandom')]"

 

 

@xyth I think this is due to a mismatch in casing? For example, the property name is "SoundAttack" not "soundattack". (That's also the full name so I don't think you need the starts-with command.)

 

EDIT: Wait - I went to the Git repo and the casing is correct.

https://github.com/7D2D/A19Mods/blob/master/2-CharacterEffectsPack/Config/entityclasses.xml#L114

 

@Father Where did you get the pack? Is it possible there was some kind of casing conversion happening somewhere? Or perhaps you have an older version?

Edited by khzmusik
added link to XML file (see edit history)
Link to comment
Share on other sites

That is just a warning you can ignore.  The effects pack will say that if the NPC pack isn't also loaded.  I did push a fix for cannula zombie sounds recently and I have no idea if that site updates often.  Use the repo.

Link to comment
Share on other sites

IS there a way to disable the mech bees?

I've been trying to finish a quest in the shamway factory and they take off and disappear before I can get to the place where they spawn in at.

Link to comment
Share on other sites

You can easily remove them from the vulture group in entitygroups.xml

 

Open the entiyygroups.xml file in the mod using a text editor like Notepad++.  At the end of the file you will see these 3 lines:

<append xpath="/entitygroups/entitygroup[@name='VultureGroup']"><entity name="mechBee" /></append>

Delete those 3 lines and save the file.  Mech Bees will no longer spawn.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...